- updated from v0.10 to v0.11
- updated maintainership 0.11 2005-11-20 - Add extract_all method - Add merge_arrays method - inserts can now handle multiple elements as argument - absorb and key_absorb use the new multi-inserts - absorb and key_absorb now take any number of heaps as argument instead of absorbing exactly one. - Special characters in generated constant strings were incorrectly escaped (bugfix) - key_method doesn't return literal strings anymore in the "complex" case (also causes the above mentioned bug to never trigger) - make the internal _STRING and _LITERAL macros never see each others output (this is possibly a bugfix) Approved by: tobez
This commit is contained in:
parent
31714c2a37
commit
42cc30b381
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151647
4 changed files with 19 additions and 6 deletions
|
@ -6,13 +6,13 @@
|
|||
#
|
||||
|
||||
PORTNAME= Heap-Simple-Perl
|
||||
PORTVERSION= 0.10
|
||||
PORTVERSION= 0.11
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Heap
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= aaron@daltons.ca
|
||||
MAINTAINER= aaron@FreeBSD.org
|
||||
COMMENT= A pure perl implementation of the Heap::Simple interface
|
||||
|
||||
BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
|
||||
|
@ -24,8 +24,8 @@ MAN3= Heap::Simple::Perl.3
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} < 500600
|
||||
IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
|
||||
.if ${PERL_LEVEL} < 500800
|
||||
IGNORE= requires Perl5.8
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
MD5 (Heap-Simple-Perl-0.10.tar.gz) = 1a8947433fe6925161c2dcb2aa091bdb
|
||||
SIZE (Heap-Simple-Perl-0.10.tar.gz) = 25285
|
||||
MD5 (Heap-Simple-Perl-0.11.tar.gz) = 898458aab2a4eb67b4a199d13fc6e1cf
|
||||
SHA256 (Heap-Simple-Perl-0.11.tar.gz) = a5d31b3e77430ae4c5219ccb9ab761c1c6e9a65e0bfdaa8bdbfb4444587d4bbb
|
||||
SIZE (Heap-Simple-Perl-0.11.tar.gz) = 27985
|
||||
|
|
11
devel/p5-Heap-Simple-Perl/files/patch-Makefile
Normal file
11
devel/p5-Heap-Simple-Perl/files/patch-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.PL Wed Jul 27 15:21:08 2005
|
||||
+++ Makefile.PL Fri Nov 25 19:10:07 2005
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
# Allows to suppress all questions with -n
|
||||
use Getopt::Std;
|
||||
-our $opt_n;
|
||||
+our $opt_n = 1;
|
||||
getopts("n") || die "Usage: $0 [-n]\n";
|
||||
|
||||
my $benchmark = 0;
|
|
@ -27,6 +27,7 @@
|
|||
%%SITE_PERL%%/auto/Heap/Simple/Perl/insert.al
|
||||
%%SITE_PERL%%/auto/Heap/Simple/Perl/key.al
|
||||
%%SITE_PERL%%/auto/Heap/Simple/Perl/keys.al
|
||||
%%SITE_PERL%%/auto/Heap/Simple/Perl/merge_arrays.al
|
||||
%%SITE_PERL%%/auto/Heap/Simple/Perl/min_key.al
|
||||
%%SITE_PERL%%/auto/Heap/Simple/Perl/top.al
|
||||
%%SITE_PERL%%/auto/Heap/Simple/Perl/top_key.al
|
||||
|
|
Loading…
Reference in a new issue