- Update to 1.0.2
- Assign maintainership to the submitter PR: ports/126141 Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp>
This commit is contained in:
parent
e7ac4b124b
commit
42ce06e774
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=220646
5 changed files with 64 additions and 44 deletions
|
@ -6,29 +6,29 @@
|
|||
#
|
||||
|
||||
PORTNAME= dirmngr
|
||||
PORTVERSION= 1.0.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.0.2
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_GNUPG}
|
||||
MASTER_SITE_SUBDIR= dirmngr
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= umq@ueo.co.jp
|
||||
COMMENT= A client for managing and downloading certificate revocation lists
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libassuan.a:${PORTSDIR}/security/libassuan
|
||||
LIB_DEPENDS= gcrypt.15:${PORTSDIR}/security/libgcrypt \
|
||||
gpg-error.0:${PORTSDIR}/security/libgpg-error \
|
||||
iconv:${PORTSDIR}/converters/libiconv \
|
||||
ksba.17:${PORTSDIR}/security/libksba \
|
||||
pth:${PORTSDIR}/devel/pth
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_ICONV= yes
|
||||
USE_OPENLDAP= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
INFO= dirmngr
|
||||
MAN1= dirmngr-client.1 dirmngr.1
|
||||
|
||||
CONFIGURE_ARGS+= --docdir=${DOCSDIR}
|
||||
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
|
||||
|
||||
.if defined(WITHOUT_NLS)
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (dirmngr-1.0.1.tar.bz2) = 3b969ee763fa9160319abe3f24b5959d
|
||||
SHA256 (dirmngr-1.0.1.tar.bz2) = ae728c9109b7d29a8a5c66fad608d33680d68a93a2c2a535ff5d92df41fb31b0
|
||||
SIZE (dirmngr-1.0.1.tar.bz2) = 490079
|
||||
MD5 (dirmngr-1.0.2.tar.bz2) = 88d62a348903009cbc96212e4684c89c
|
||||
SHA256 (dirmngr-1.0.2.tar.bz2) = 26329d6c6151e6605dd14221b38c2b2f2aef161e6fdfc2036edf55d5dbcd5c35
|
||||
SIZE (dirmngr-1.0.2.tar.bz2) = 554067
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- jnlib/logging.c.orig Mon Nov 22 14:02:22 2004
|
||||
+++ jnlib/logging.c Fri Dec 17 13:03:13 2004
|
||||
@@ -35,6 +35,7 @@
|
||||
#include <time.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <sys/stat.h>
|
||||
#include <sys/un.h>
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
|
@ -1,27 +0,0 @@
|
|||
--- src/Makefile.in.orig Wed Jan 2 20:27:19 2008
|
||||
+++ src/Makefile.in Wed Jan 2 20:27:57 2008
|
||||
@@ -267,7 +267,7 @@
|
||||
validate.c validate.h exechelp.h exechelp.c get-path.c
|
||||
|
||||
dirmngr_LDADD = ../jnlib/libjnlib.a $(LIBOBJS) $(LIBASSUAN_PTH_LIBS) \
|
||||
- $(LIBGCRYPT_LIBS) $(KSBA_LIBS) $(PTH_LIBS) $(LIBINTL)
|
||||
+ $(LIBGCRYPT_LIBS) $(KSBA_LIBS) $(PTH_LIBS) $(LIBINTL) $(LIBICONV)
|
||||
|
||||
@HAVE_W32_SYSTEM_FALSE@ldap_url =
|
||||
@HAVE_W32_SYSTEM_TRUE@ldap_url = ldap-url.h ldap-url.c
|
||||
@@ -277,13 +277,13 @@
|
||||
dirmngr_ldap_CFLAGS = $(GPG_ERROR_CFLAGS)
|
||||
dirmngr_ldap_LDFLAGS =
|
||||
dirmngr_ldap_LDADD = $(ldap_ldadd) ../jnlib/libjnlib.a $(LIBOBJS) \
|
||||
- $(GPG_ERROR_LIBS) $(LDAPLIBS) $(LIBINTL)
|
||||
+ $(GPG_ERROR_LIBS) $(LDAPLIBS) $(LIBINTL) $(LIBICONV)
|
||||
|
||||
dirmngr_client_SOURCES = dirmngr-client.c i18n.h util.h b64enc.c \
|
||||
get-path.c no-libgcrypt.c no-libgcrypt.h
|
||||
|
||||
dirmngr_client_LDADD = ../jnlib/libjnlib.a $(LIBOBJS) $(LIBASSUAN_LIBS) \
|
||||
- $(GPG_ERROR_LIBS) $(LIBINTL)
|
||||
+ $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV)
|
||||
|
||||
all: all-am
|
||||
|
|
@ -1,4 +1,61 @@
|
|||
bin/dirmngr
|
||||
bin/dirmngr-client
|
||||
libexec/dirmngr_ldap
|
||||
%%DOCSDIR%%/examples/README
|
||||
%%DOCSDIR%%/examples/bnetza-10r-ocsp.signer
|
||||
%%DOCSDIR%%/examples/dirmngr.conf
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-001.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-002.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-003.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-004.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-005.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-006.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-007.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-008.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-009.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-010.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-011.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-012.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-013.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-014.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-015.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-016.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-017.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-018.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-019.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-020.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-021.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-022.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-023.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-024.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-025.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-026.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-027.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualSigOCSP2008-028.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualifiedSignatureCA2008-001.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualifiedSignatureCA2008-002.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualifiedSignatureCA2008-003.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualifiedSignatureCA2008-004.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualifiedSignatureCA2008-005.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/S-TRUSTQualifiedSignatureCA2008-006.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-1.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-10.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-11.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-12.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-2.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-3.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-4.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-5.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-6.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-7.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-8.crt
|
||||
%%DOCSDIR%%/examples/extra-certs/bnetza-10r-ocsp-9.crt
|
||||
%%DOCSDIR%%/examples/trusted-certs/README
|
||||
%%DOCSDIR%%/examples/trusted-certs/S-TRUSTQualifiedRootCA2008-001.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/trusted-certs/S-TRUSTQualifiedRootCA2008-002.final.v3.509.crt
|
||||
%%DOCSDIR%%/examples/trusted-certs/bnetza-10r-ca.crt
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/dirmngr.mo
|
||||
@dirrm %%DOCSDIR%%/examples/trusted-certs
|
||||
@dirrm %%DOCSDIR%%/examples/extra-certs
|
||||
@dirrm %%DOCSDIR%%/examples
|
||||
@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue