- Add more essential bugfixes
- Add perl-threaded-5.* to CONFLICTS [1] - Introduce PERL_VENDOR_PREFIX variable - Be really PREFIX-neutral [2} Submitted by: lth [1], rafan [2]
This commit is contained in:
parent
f03c844877
commit
42eabd7753
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=235438
18 changed files with 298 additions and 10 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= perl
|
||||
PORTVERSION= ${PERL_VERSION}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= lang devel perl5
|
||||
MASTER_SITES= CPAN \
|
||||
${MASTER_SITE_LOCAL:S/$/:local/} \
|
||||
|
@ -21,7 +21,7 @@ DIST_SUBDIR= perl
|
|||
MAINTAINER= skv@FreeBSD.org
|
||||
COMMENT= Practical Extraction and Report Language
|
||||
|
||||
CONFLICTS= perl-5.6.* perl-5.8.*
|
||||
CONFLICTS= perl-5.6.* perl-5.8.* perl-threaded-5.8.*
|
||||
|
||||
OPTIONS= DEBUGGING "Build with debugging support" off \
|
||||
GDBM "Build GDBM_File extension" off \
|
||||
|
@ -62,6 +62,16 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
|
|||
.include "Makefile.man"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PERL_VENDOR_PREFIX)
|
||||
CONFIGURE_ARGS+= \
|
||||
-Dvendorprefix=${PERL_VENDOR_PREFIX} \
|
||||
-Dvendorarch=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/${PERL_ARCH} \
|
||||
-Dvendorbin=${PERL_VENDOR_PREFIX}/bin \
|
||||
-Dvendorlib=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION} \
|
||||
-Dvendorman3dir=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/man/man3 \
|
||||
-Dvendorman1dir=${PERL_VENDOR_PREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
|
||||
PERL_VER=${PERL_VERSION} \
|
||||
PERL_ARCH=${PERL_ARCH} \
|
||||
|
@ -156,6 +166,8 @@ post-patch:
|
|||
${CP} ${WRKDIR}/use.perl ${PKGDEINSTALL}
|
||||
${SED} -i '' -e 's|%%PERL_PKGNAME%%|${PKGNAME}|g; s|%%PERL_VER%%|5.10|g;' \
|
||||
${BSDPAN_WRKSRC}/ExtUtils/*.pm
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
|
||||
.if defined(WITH_THREADS)
|
||||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
|
||||
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
|
||||
|
|
15
lang/perl5.10/files/patch-bug51636
Normal file
15
lang/perl5.10/files/patch-bug51636
Normal file
|
@ -0,0 +1,15 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=51636
|
||||
# http://perl5.git.perl.org/perl.git/commit/b63c7c552a2e9cf2b2c5eb492358b8567fd16179
|
||||
diff --git a/av.c b/av.c
|
||||
index e6c26bc..67ffad9 100644
|
||||
--- av.c
|
||||
+++ av.c
|
||||
@@ -437,7 +437,7 @@ Perl_av_clear(pTHX_ register AV *av)
|
||||
/* Give any tie a chance to cleanup first */
|
||||
if (SvRMAGICAL(av)) {
|
||||
const MAGIC* const mg = SvMAGIC(av);
|
||||
- if (PL_delaymagic && mg->mg_type == PERL_MAGIC_isa)
|
||||
+ if (PL_delaymagic && mg && mg->mg_type == PERL_MAGIC_isa)
|
||||
PL_delaymagic |= DM_ARRAY;
|
||||
else
|
||||
mg_clear((SV*)av);
|
23
lang/perl5.10/files/patch-bug64562
Normal file
23
lang/perl5.10/files/patch-bug64562
Normal file
|
@ -0,0 +1,23 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=64562
|
||||
# http://perl5.git.perl.org/perl.git/commitdiff/ee6d2783b2d78accfac54397826acf5f6e1715e1?hp=5a8cf367090fb5d83d8e8e0ae381a3525a215928
|
||||
diff --git a/op.c b/op.c
|
||||
index 517f648..89ed522 100644
|
||||
--- op.c
|
||||
+++ op.c
|
||||
@@ -6166,9 +6166,13 @@ Perl_newFORM(pTHX_ I32 floor, OP *o, OP *block)
|
||||
const line_t oldline = CopLINE(PL_curcop);
|
||||
if (PL_parser && PL_parser->copline != NOLINE)
|
||||
CopLINE_set(PL_curcop, PL_parser->copline);
|
||||
- Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
- o ? "Format %"SVf" redefined"
|
||||
- : "Format STDOUT redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ if (o) {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format %"SVf" redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ } else {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format STDOUT redefined");
|
||||
+ }
|
||||
CopLINE_set(PL_curcop, oldline);
|
||||
}
|
||||
SvREFCNT_dec(cv);
|
13
lang/perl5.10/files/patch-setpgrp
Normal file
13
lang/perl5.10/files/patch-setpgrp
Normal file
|
@ -0,0 +1,13 @@
|
|||
# http://perl5.git.perl.org/perl.git/commit/1f200948c4c45a9bc088451dd377e4ab8733c722
|
||||
diff --git a/pp_sys.c b/pp_sys.c
|
||||
index cfbf918..0d2c970 100644
|
||||
--- pp_sys.c
|
||||
+++ pp_sys.c
|
||||
@@ -4318,6 +4318,7 @@ PP(pp_setpgrp)
|
||||
if (MAXARG < 2) {
|
||||
pgrp = 0;
|
||||
pid = 0;
|
||||
+ XPUSHi(-1);
|
||||
}
|
||||
else {
|
||||
pgrp = POPi;
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= perl
|
||||
PORTVERSION= ${PERL_VERSION}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= lang devel perl5
|
||||
MASTER_SITES= CPAN \
|
||||
${MASTER_SITE_LOCAL:S/$/:local/} \
|
||||
|
@ -21,7 +21,7 @@ DIST_SUBDIR= perl
|
|||
MAINTAINER= skv@FreeBSD.org
|
||||
COMMENT= Practical Extraction and Report Language
|
||||
|
||||
CONFLICTS= perl-5.6.* perl-5.8.*
|
||||
CONFLICTS= perl-5.6.* perl-5.8.* perl-threaded-5.8.*
|
||||
|
||||
OPTIONS= DEBUGGING "Build with debugging support" off \
|
||||
GDBM "Build GDBM_File extension" off \
|
||||
|
@ -62,6 +62,16 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
|
|||
.include "Makefile.man"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PERL_VENDOR_PREFIX)
|
||||
CONFIGURE_ARGS+= \
|
||||
-Dvendorprefix=${PERL_VENDOR_PREFIX} \
|
||||
-Dvendorarch=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/${PERL_ARCH} \
|
||||
-Dvendorbin=${PERL_VENDOR_PREFIX}/bin \
|
||||
-Dvendorlib=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION} \
|
||||
-Dvendorman3dir=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/man/man3 \
|
||||
-Dvendorman1dir=${PERL_VENDOR_PREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
|
||||
PERL_VER=${PERL_VERSION} \
|
||||
PERL_ARCH=${PERL_ARCH} \
|
||||
|
@ -156,6 +166,8 @@ post-patch:
|
|||
${CP} ${WRKDIR}/use.perl ${PKGDEINSTALL}
|
||||
${SED} -i '' -e 's|%%PERL_PKGNAME%%|${PKGNAME}|g; s|%%PERL_VER%%|5.10|g;' \
|
||||
${BSDPAN_WRKSRC}/ExtUtils/*.pm
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
|
||||
.if defined(WITH_THREADS)
|
||||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
|
||||
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
|
||||
|
|
15
lang/perl5.12/files/patch-bug51636
Normal file
15
lang/perl5.12/files/patch-bug51636
Normal file
|
@ -0,0 +1,15 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=51636
|
||||
# http://perl5.git.perl.org/perl.git/commit/b63c7c552a2e9cf2b2c5eb492358b8567fd16179
|
||||
diff --git a/av.c b/av.c
|
||||
index e6c26bc..67ffad9 100644
|
||||
--- av.c
|
||||
+++ av.c
|
||||
@@ -437,7 +437,7 @@ Perl_av_clear(pTHX_ register AV *av)
|
||||
/* Give any tie a chance to cleanup first */
|
||||
if (SvRMAGICAL(av)) {
|
||||
const MAGIC* const mg = SvMAGIC(av);
|
||||
- if (PL_delaymagic && mg->mg_type == PERL_MAGIC_isa)
|
||||
+ if (PL_delaymagic && mg && mg->mg_type == PERL_MAGIC_isa)
|
||||
PL_delaymagic |= DM_ARRAY;
|
||||
else
|
||||
mg_clear((SV*)av);
|
23
lang/perl5.12/files/patch-bug64562
Normal file
23
lang/perl5.12/files/patch-bug64562
Normal file
|
@ -0,0 +1,23 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=64562
|
||||
# http://perl5.git.perl.org/perl.git/commitdiff/ee6d2783b2d78accfac54397826acf5f6e1715e1?hp=5a8cf367090fb5d83d8e8e0ae381a3525a215928
|
||||
diff --git a/op.c b/op.c
|
||||
index 517f648..89ed522 100644
|
||||
--- op.c
|
||||
+++ op.c
|
||||
@@ -6166,9 +6166,13 @@ Perl_newFORM(pTHX_ I32 floor, OP *o, OP *block)
|
||||
const line_t oldline = CopLINE(PL_curcop);
|
||||
if (PL_parser && PL_parser->copline != NOLINE)
|
||||
CopLINE_set(PL_curcop, PL_parser->copline);
|
||||
- Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
- o ? "Format %"SVf" redefined"
|
||||
- : "Format STDOUT redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ if (o) {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format %"SVf" redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ } else {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format STDOUT redefined");
|
||||
+ }
|
||||
CopLINE_set(PL_curcop, oldline);
|
||||
}
|
||||
SvREFCNT_dec(cv);
|
13
lang/perl5.12/files/patch-setpgrp
Normal file
13
lang/perl5.12/files/patch-setpgrp
Normal file
|
@ -0,0 +1,13 @@
|
|||
# http://perl5.git.perl.org/perl.git/commit/1f200948c4c45a9bc088451dd377e4ab8733c722
|
||||
diff --git a/pp_sys.c b/pp_sys.c
|
||||
index cfbf918..0d2c970 100644
|
||||
--- pp_sys.c
|
||||
+++ pp_sys.c
|
||||
@@ -4318,6 +4318,7 @@ PP(pp_setpgrp)
|
||||
if (MAXARG < 2) {
|
||||
pgrp = 0;
|
||||
pid = 0;
|
||||
+ XPUSHi(-1);
|
||||
}
|
||||
else {
|
||||
pgrp = POPi;
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= perl
|
||||
PORTVERSION= ${PERL_VERSION}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= lang devel perl5
|
||||
MASTER_SITES= CPAN \
|
||||
${MASTER_SITE_LOCAL:S/$/:local/} \
|
||||
|
@ -21,7 +21,7 @@ DIST_SUBDIR= perl
|
|||
MAINTAINER= skv@FreeBSD.org
|
||||
COMMENT= Practical Extraction and Report Language
|
||||
|
||||
CONFLICTS= perl-5.6.* perl-5.8.*
|
||||
CONFLICTS= perl-5.6.* perl-5.8.* perl-threaded-5.8.*
|
||||
|
||||
OPTIONS= DEBUGGING "Build with debugging support" off \
|
||||
GDBM "Build GDBM_File extension" off \
|
||||
|
@ -62,6 +62,16 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
|
|||
.include "Makefile.man"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PERL_VENDOR_PREFIX)
|
||||
CONFIGURE_ARGS+= \
|
||||
-Dvendorprefix=${PERL_VENDOR_PREFIX} \
|
||||
-Dvendorarch=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/${PERL_ARCH} \
|
||||
-Dvendorbin=${PERL_VENDOR_PREFIX}/bin \
|
||||
-Dvendorlib=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION} \
|
||||
-Dvendorman3dir=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/man/man3 \
|
||||
-Dvendorman1dir=${PERL_VENDOR_PREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
|
||||
PERL_VER=${PERL_VERSION} \
|
||||
PERL_ARCH=${PERL_ARCH} \
|
||||
|
@ -156,6 +166,8 @@ post-patch:
|
|||
${CP} ${WRKDIR}/use.perl ${PKGDEINSTALL}
|
||||
${SED} -i '' -e 's|%%PERL_PKGNAME%%|${PKGNAME}|g; s|%%PERL_VER%%|5.10|g;' \
|
||||
${BSDPAN_WRKSRC}/ExtUtils/*.pm
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
|
||||
.if defined(WITH_THREADS)
|
||||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
|
||||
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
|
||||
|
|
15
lang/perl5.14/files/patch-bug51636
Normal file
15
lang/perl5.14/files/patch-bug51636
Normal file
|
@ -0,0 +1,15 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=51636
|
||||
# http://perl5.git.perl.org/perl.git/commit/b63c7c552a2e9cf2b2c5eb492358b8567fd16179
|
||||
diff --git a/av.c b/av.c
|
||||
index e6c26bc..67ffad9 100644
|
||||
--- av.c
|
||||
+++ av.c
|
||||
@@ -437,7 +437,7 @@ Perl_av_clear(pTHX_ register AV *av)
|
||||
/* Give any tie a chance to cleanup first */
|
||||
if (SvRMAGICAL(av)) {
|
||||
const MAGIC* const mg = SvMAGIC(av);
|
||||
- if (PL_delaymagic && mg->mg_type == PERL_MAGIC_isa)
|
||||
+ if (PL_delaymagic && mg && mg->mg_type == PERL_MAGIC_isa)
|
||||
PL_delaymagic |= DM_ARRAY;
|
||||
else
|
||||
mg_clear((SV*)av);
|
23
lang/perl5.14/files/patch-bug64562
Normal file
23
lang/perl5.14/files/patch-bug64562
Normal file
|
@ -0,0 +1,23 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=64562
|
||||
# http://perl5.git.perl.org/perl.git/commitdiff/ee6d2783b2d78accfac54397826acf5f6e1715e1?hp=5a8cf367090fb5d83d8e8e0ae381a3525a215928
|
||||
diff --git a/op.c b/op.c
|
||||
index 517f648..89ed522 100644
|
||||
--- op.c
|
||||
+++ op.c
|
||||
@@ -6166,9 +6166,13 @@ Perl_newFORM(pTHX_ I32 floor, OP *o, OP *block)
|
||||
const line_t oldline = CopLINE(PL_curcop);
|
||||
if (PL_parser && PL_parser->copline != NOLINE)
|
||||
CopLINE_set(PL_curcop, PL_parser->copline);
|
||||
- Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
- o ? "Format %"SVf" redefined"
|
||||
- : "Format STDOUT redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ if (o) {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format %"SVf" redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ } else {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format STDOUT redefined");
|
||||
+ }
|
||||
CopLINE_set(PL_curcop, oldline);
|
||||
}
|
||||
SvREFCNT_dec(cv);
|
13
lang/perl5.14/files/patch-setpgrp
Normal file
13
lang/perl5.14/files/patch-setpgrp
Normal file
|
@ -0,0 +1,13 @@
|
|||
# http://perl5.git.perl.org/perl.git/commit/1f200948c4c45a9bc088451dd377e4ab8733c722
|
||||
diff --git a/pp_sys.c b/pp_sys.c
|
||||
index cfbf918..0d2c970 100644
|
||||
--- pp_sys.c
|
||||
+++ pp_sys.c
|
||||
@@ -4318,6 +4318,7 @@ PP(pp_setpgrp)
|
||||
if (MAXARG < 2) {
|
||||
pgrp = 0;
|
||||
pid = 0;
|
||||
+ XPUSHi(-1);
|
||||
}
|
||||
else {
|
||||
pgrp = POPi;
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= perl
|
||||
PORTVERSION= ${PERL_VERSION}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= lang devel perl5
|
||||
MASTER_SITES= CPAN \
|
||||
${MASTER_SITE_LOCAL:S/$/:local/} \
|
||||
|
@ -21,7 +21,7 @@ DIST_SUBDIR= perl
|
|||
MAINTAINER= skv@FreeBSD.org
|
||||
COMMENT= Practical Extraction and Report Language
|
||||
|
||||
CONFLICTS= perl-5.6.* perl-5.8.*
|
||||
CONFLICTS= perl-5.6.* perl-5.8.* perl-threaded-5.8.*
|
||||
|
||||
OPTIONS= DEBUGGING "Build with debugging support" off \
|
||||
GDBM "Build GDBM_File extension" off \
|
||||
|
@ -62,6 +62,16 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
|
|||
.include "Makefile.man"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PERL_VENDOR_PREFIX)
|
||||
CONFIGURE_ARGS+= \
|
||||
-Dvendorprefix=${PERL_VENDOR_PREFIX} \
|
||||
-Dvendorarch=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/${PERL_ARCH} \
|
||||
-Dvendorbin=${PERL_VENDOR_PREFIX}/bin \
|
||||
-Dvendorlib=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION} \
|
||||
-Dvendorman3dir=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/man/man3 \
|
||||
-Dvendorman1dir=${PERL_VENDOR_PREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
|
||||
PERL_VER=${PERL_VERSION} \
|
||||
PERL_ARCH=${PERL_ARCH} \
|
||||
|
@ -156,6 +166,8 @@ post-patch:
|
|||
${CP} ${WRKDIR}/use.perl ${PKGDEINSTALL}
|
||||
${SED} -i '' -e 's|%%PERL_PKGNAME%%|${PKGNAME}|g; s|%%PERL_VER%%|5.10|g;' \
|
||||
${BSDPAN_WRKSRC}/ExtUtils/*.pm
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
|
||||
.if defined(WITH_THREADS)
|
||||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
|
||||
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
|
||||
|
|
15
lang/perl5.16/files/patch-bug51636
Normal file
15
lang/perl5.16/files/patch-bug51636
Normal file
|
@ -0,0 +1,15 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=51636
|
||||
# http://perl5.git.perl.org/perl.git/commit/b63c7c552a2e9cf2b2c5eb492358b8567fd16179
|
||||
diff --git a/av.c b/av.c
|
||||
index e6c26bc..67ffad9 100644
|
||||
--- av.c
|
||||
+++ av.c
|
||||
@@ -437,7 +437,7 @@ Perl_av_clear(pTHX_ register AV *av)
|
||||
/* Give any tie a chance to cleanup first */
|
||||
if (SvRMAGICAL(av)) {
|
||||
const MAGIC* const mg = SvMAGIC(av);
|
||||
- if (PL_delaymagic && mg->mg_type == PERL_MAGIC_isa)
|
||||
+ if (PL_delaymagic && mg && mg->mg_type == PERL_MAGIC_isa)
|
||||
PL_delaymagic |= DM_ARRAY;
|
||||
else
|
||||
mg_clear((SV*)av);
|
23
lang/perl5.16/files/patch-bug64562
Normal file
23
lang/perl5.16/files/patch-bug64562
Normal file
|
@ -0,0 +1,23 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=64562
|
||||
# http://perl5.git.perl.org/perl.git/commitdiff/ee6d2783b2d78accfac54397826acf5f6e1715e1?hp=5a8cf367090fb5d83d8e8e0ae381a3525a215928
|
||||
diff --git a/op.c b/op.c
|
||||
index 517f648..89ed522 100644
|
||||
--- op.c
|
||||
+++ op.c
|
||||
@@ -6166,9 +6166,13 @@ Perl_newFORM(pTHX_ I32 floor, OP *o, OP *block)
|
||||
const line_t oldline = CopLINE(PL_curcop);
|
||||
if (PL_parser && PL_parser->copline != NOLINE)
|
||||
CopLINE_set(PL_curcop, PL_parser->copline);
|
||||
- Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
- o ? "Format %"SVf" redefined"
|
||||
- : "Format STDOUT redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ if (o) {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format %"SVf" redefined", SVfARG(cSVOPo->op_sv));
|
||||
+ } else {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format STDOUT redefined");
|
||||
+ }
|
||||
CopLINE_set(PL_curcop, oldline);
|
||||
}
|
||||
SvREFCNT_dec(cv);
|
13
lang/perl5.16/files/patch-setpgrp
Normal file
13
lang/perl5.16/files/patch-setpgrp
Normal file
|
@ -0,0 +1,13 @@
|
|||
# http://perl5.git.perl.org/perl.git/commit/1f200948c4c45a9bc088451dd377e4ab8733c722
|
||||
diff --git a/pp_sys.c b/pp_sys.c
|
||||
index cfbf918..0d2c970 100644
|
||||
--- pp_sys.c
|
||||
+++ pp_sys.c
|
||||
@@ -4318,6 +4318,7 @@ PP(pp_setpgrp)
|
||||
if (MAXARG < 2) {
|
||||
pgrp = 0;
|
||||
pid = 0;
|
||||
+ XPUSHi(-1);
|
||||
}
|
||||
else {
|
||||
pgrp = POPi;
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= perl
|
||||
PORTVERSION= ${PERL_VERSION}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= lang devel perl5
|
||||
MASTER_SITES= CPAN \
|
||||
${MASTER_SITE_LOCAL:S/$/:local/} \
|
||||
|
@ -25,7 +25,7 @@ PATCHFILES= defined-or-${PERL_VERSION}.bz2
|
|||
MAINTAINER= skv@FreeBSD.org
|
||||
COMMENT= Practical Extraction and Report Language
|
||||
|
||||
CONFLICTS= perl-5.6.* perl-5.10.*
|
||||
CONFLICTS= perl-5.6.* perl-5.10.* perl-threaded-5.10.*
|
||||
|
||||
OPTIONS= DEBUGGING "Build with debugging support" off \
|
||||
GDBM "Build GDBM_File extension" off \
|
||||
|
@ -66,6 +66,16 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
|
|||
.include "Makefile.man"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PERL_VENDOR_PREFIX)
|
||||
CONFIGURE_ARGS+= \
|
||||
-Dvendorprefix=${PERL_VENDOR_PREFIX} \
|
||||
-Dvendorarch=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/${PERL_ARCH} \
|
||||
-Dvendorbin=${PERL_VENDOR_PREFIX}/bin \
|
||||
-Dvendorlib=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION} \
|
||||
-Dvendorman3dir=${PERL_VENDOR_PREFIX}/lib/perl5/${PERL_VERSION}/man/man3 \
|
||||
-Dvendorman1dir=${PERL_VENDOR_PREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
|
||||
PERL_VER=${PERL_VERSION} \
|
||||
PERL_ARCH=${PERL_ARCH} \
|
||||
|
@ -162,6 +172,8 @@ post-patch:
|
|||
${CP} ${WRKDIR}/use.perl ${PKGDEINSTALL}
|
||||
${SED} -i '' -e 's|%%PERL_PKGNAME%%|${PKGNAME}|g; s|%%PERL_VER%%|5.8|g;' \
|
||||
${BSDPAN_WRKSRC}/ExtUtils/*.pm
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
|
||||
.if defined(WITH_THREADS)
|
||||
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
|
||||
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
|
||||
|
|
24
lang/perl5.8/files/patch-bug64562
Normal file
24
lang/perl5.8/files/patch-bug64562
Normal file
|
@ -0,0 +1,24 @@
|
|||
# http://rt.perl.org/rt3/Public/Bug/Display.html?id=64562
|
||||
# Adapted from:
|
||||
# http://perl5.git.perl.org/perl.git/commitdiff/ee6d2783b2d78accfac54397826acf5f6e1715e1?hp=5a8cf367090fb5d83d8e8e0ae381a3525a215928
|
||||
diff --git a/op.c b/op.c
|
||||
index 517f648..89ed522 100644
|
||||
--- op.c
|
||||
+++ op.c
|
||||
@@ -6166,9 +6166,13 @@ Perl_newFORM(pTHX_ I32 floor, OP *o, OP *block)
|
||||
const line_t oldline = CopLINE(PL_curcop);
|
||||
if (PL_copline != NOLINE)
|
||||
CopLINE_set(PL_curcop, PL_copline);
|
||||
- Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
- o ? "Format %"SVf" redefined"
|
||||
- : "Format STDOUT redefined", (void*)cSVOPo->op_sv);
|
||||
+ if (o) {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format %"SVf" redefined", (void*)cSVOPo->op_sv);
|
||||
+ } else {
|
||||
+ Perl_warner(aTHX_ packWARN(WARN_REDEFINE),
|
||||
+ "Format STDOUT redefined");
|
||||
+ }
|
||||
CopLINE_set(PL_curcop, oldline);
|
||||
}
|
||||
SvREFCNT_dec(cv);
|
Loading…
Reference in a new issue