Update to 0.1.9 which has gcc3.2 compatibility fixes.

Take maintainer.

PR:		48895
Submitted by:	Jens Rehsack <rehsack@liwing.de>
Approved by:	David MacKenzie <djm@djmnet.org> (previous maintainer)
This commit is contained in:
Christian Weisgerber 2003-03-05 15:39:44 +00:00
parent 170c5137fe
commit 4303e0b48e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76946
7 changed files with 21 additions and 90 deletions

View file

@ -6,12 +6,12 @@
#
PORTNAME= id3v2
PORTVERSION= 0.1.7
PORTVERSION= 0.1.9
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= id3v2
MAINTAINER= djm@pix.net
MAINTAINER= rehsack@liwing.de
COMMENT= Command line id3v2 tag editor
LIB_DEPENDS= id3-3.8.2:${PORTSDIR}/audio/id3lib \

View file

@ -1 +1 @@
MD5 (id3v2-0.1.7.tar.gz) = 825cf4baf60e2951b7826b947a8f52fa
MD5 (id3v2-0.1.9.tar.gz) = 544862d82224312595bf5a45422d1a49

View file

@ -0,0 +1,18 @@
--- Makefile.orig Sun Feb 23 19:55:25 2003
+++ Makefile Sun Feb 23 20:06:35 2003
@@ -5,11 +5,11 @@
LDFLAGS+= -L${PREFIX}/lib/
id3v2: convert.o list.o id3v2.o
- c++ ${LDFLAGS} -pedantic -Wall -lz -lid3 -g -o $@ id3v2.o list.o convert.o
+ ${CXX} ${LDFLAGS} -lz -lid3 -lgnugetopt -o $@ id3v2.o list.o convert.o
install: all
- install -c -s id3v2 ${PREFIX}/bin/id3v2
+ ${INSTALL} -c -s id3v2 ${PREFIX}/bin/id3v2
nroff -man id3v2.1 > ${PREFIX}/man/man1/id3v2.1
-clean:
- rm -f id3v2 core *.o
+.include <bsd.prog.mk>
+

View file

@ -1,21 +0,0 @@
--- Makefile.orig Tue Apr 16 04:35:31 2002
+++ Makefile Sun Dec 22 03:51:30 2002
@@ -1,10 +1,9 @@
-all: id3v2
+CC= ${CXX}
+PROG= id3v2
+SRCS= id3v2.cpp list.cpp convert.cpp
+CXXFLAGS+= -I${DESTDIR}${PREFIX}/include
+LDADD+= -L${DESTDIR}${PREFIX}/lib -lid3 -lz -lgnugetopt
+DPADD+= ${LIBZ}
+DPADD+= ${DESTDIR}${PREFIX}/lib/libid3.a
-id3v2: Makefile convert.cpp list.cpp id3v2.cpp convert.cpp
- g++ -lz -lid3 -g -o id3v2 id3v2.cpp list.cpp convert.cpp
-
-install: all
- cp id3v2 /usr/local/bin/
-
-clean:
- rm -f id3v2 core
+.include <bsd.prog.mk>

View file

@ -1,13 +0,0 @@
--- convert.cpp.orig Mon Nov 11 18:53:12 2002
+++ convert.cpp Mon Nov 11 18:54:36 2002
@@ -1,6 +1,8 @@
-#include <iostream.h>
+#include <iostream>
#include <id3/tag.h>
-#include <stdlib.h>
+#include <cstdlib>
+
+using namespace std;
void DeleteTag(int argc, char *argv[], int optind, int whichTags)
{

View file

@ -1,29 +0,0 @@
--- id3v2.cpp.orig Mon Nov 11 18:47:38 2002
+++ id3v2.cpp Mon Nov 11 18:53:32 2002
@@ -2,20 +2,21 @@
#include <config.h>
#endif
-#include <stdio.h>
-#include <iostream.h>
-#include <string.h>
+#include <cstdio>
+#include <iostream>
+#include <cstring>
#include <id3/tag.h>
#include <getopt.h>
-#include <stdlib.h>
+#include <cstdlib>
#include <id3/misc_support.h>
#include <sys/types.h>
#include <sys/stat.h>
-#include <unistd.h>
#define VERSION_NUMBER "$Revision: 1.7 $"
#define MAXNOFRAMES 1000
+
+using namespace std;
/* Write both tags by default */
flags_t UpdFlags = ID3TT_ALL;

View file

@ -1,24 +0,0 @@
--- list.cpp.orig Mon Nov 11 18:53:23 2002
+++ list.cpp Mon Nov 11 18:54:14 2002
@@ -17,15 +17,17 @@
#include <config.h>
#endif
-#include <iostream.h>
-#include <string.h>
+#include <iostream>
+#include <cstring>
#include <id3/tag.h>
#include <getopt.h>
-#include <stdlib.h>
-#include <stdio.h>
+#include <cstdlib>
+#include <cstdio>
#include <id3/misc_support.h>
#include "frametable.h"
#include "genre.h"
+
+using namespace std;
char *GetDescription(const ID3_FrameID eFrameID)
{