Patch configure instead of aclocal.m4 and set CONFIGURE_ENV instead of
patching configure.in to avoid USE_AUTOTOOLS
This commit is contained in:
parent
dcc338fc9c
commit
430a1f3415
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=369266
5 changed files with 34 additions and 76 deletions
|
@ -23,13 +23,11 @@ MPG321_RUN_DEPENDS_OFF= mpg123:${PORTSDIR}/audio/mpg123
|
|||
|
||||
USE_GNOME= gdkpixbuf
|
||||
USES= gettext libtool
|
||||
USE_AUTOTOOLS= autoconf213
|
||||
CONFIGURE_ENV+= USE_GNOME=""
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= ac_cv_path_GNOME_CONFIG=no
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lintl
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E -e \
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- aclocal.m4.orig Wed Jul 17 20:48:30 2002
|
||||
+++ aclocal.m4 Thu Jul 18 16:38:49 2002
|
||||
@@ -545,7 +545,7 @@
|
||||
rm -f conf.gdk_pixbuftest
|
||||
])
|
||||
|
||||
-# gettext.m4 serial 13 (gettext-0.11.1)
|
||||
+# gettext.m4 serial 14 (gettext-0.11.2)
|
||||
dnl Copyright (C) 1995-2002 Free Software Foundation, Inc.
|
||||
dnl This file is free software, distributed under the terms of the GNU
|
||||
dnl General Public License. As a special exception to the GNU General
|
||||
@@ -689,14 +689,13 @@
|
||||
dnl Now see whether libintl exists and does not depend on libiconv.
|
||||
AC_TRY_LINK([#include <libintl.h>
|
||||
extern int _nl_msg_cat_cntr;
|
||||
-extern int *_nl_domain_bindings;
|
||||
extern
|
||||
#ifdef __cplusplus
|
||||
"C"
|
||||
#endif
|
||||
const char *_nl_expand_alias ();],
|
||||
[bindtextdomain ("", "");
|
||||
-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
|
||||
+return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
|
||||
gt_cv_func_gnugettext_libintl=yes,
|
||||
gt_cv_func_gnugettext_libintl=no)
|
||||
dnl Now see whether libintl exists and depends on libiconv.
|
||||
@@ -704,14 +703,13 @@
|
||||
LIBS="$LIBS $LIBICONV"
|
||||
AC_TRY_LINK([#include <libintl.h>
|
||||
extern int _nl_msg_cat_cntr;
|
||||
-extern int *_nl_domain_bindings;
|
||||
extern
|
||||
#ifdef __cplusplus
|
||||
"C"
|
||||
#endif
|
||||
const char *_nl_expand_alias ();],
|
||||
[bindtextdomain ("", "");
|
||||
-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
|
||||
+return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
|
||||
[LIBINTL="$LIBINTL $LIBICONV"
|
||||
LTLIBINTL="$LTLIBINTL $LTLIBICONV"
|
||||
gt_cv_func_gnugettext_libintl=yes
|
31
audio/gqmpeg/files/patch-configure
Normal file
31
audio/gqmpeg/files/patch-configure
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- configure.orig 2003-02-02 05:27:15.000000000 +0100
|
||||
+++ configure 2014-09-25 17:43:37.000000000 +0200
|
||||
@@ -4027,10 +4027,9 @@
|
||||
#include "confdefs.h"
|
||||
#include <libintl.h>
|
||||
extern int _nl_msg_cat_cntr;
|
||||
-extern int *_nl_domain_bindings;
|
||||
int main() {
|
||||
bindtextdomain ("", "");
|
||||
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
|
||||
+return (int) gettext ("") + _nl_msg_cat_cntr
|
||||
; return 0; }
|
||||
EOF
|
||||
if { (eval echo configure:4037: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
@@ -4416,7 +4415,6 @@
|
||||
#include "confdefs.h"
|
||||
#include <libintl.h>
|
||||
extern int _nl_msg_cat_cntr;
|
||||
-extern int *_nl_domain_bindings;
|
||||
extern
|
||||
#ifdef __cplusplus
|
||||
"C"
|
||||
@@ -4424,7 +4422,7 @@
|
||||
const char *_nl_expand_alias ();
|
||||
int main() {
|
||||
bindtextdomain ("", "");
|
||||
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
|
||||
+return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_expand_alias (0)
|
||||
; return 0; }
|
||||
EOF
|
||||
if { (eval echo configure:4431: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.in.orig Fri Nov 9 14:42:36 2001
|
||||
+++ configure.in Sun Nov 11 22:13:39 2001
|
||||
@@ -83,7 +83,7 @@
|
||||
dnl CHECK_GNOME
|
||||
AC_PATH_PROG(GNOME_CONFIG,gnome-config,no)
|
||||
AM_CONDITIONAL(HAVE_GNOME, test $GNOME_CONFIG != no)
|
||||
- if test "$GNOME_CONFIG" = no; then
|
||||
+ if test "$GNOME_CONFIG" = no -o "$USE_GNOME" != yes; then
|
||||
AC_MSG_RESULT(GNOME icon and menu entry will NOT be installed)
|
||||
else
|
||||
AC_MSG_RESULT(will install a GNOME icon and menu entry)
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- po/Makefile.in.in.orig Wed Jul 24 16:24:35 2002
|
||||
+++ po/Makefile.in.in Wed Jul 24 16:25:07 2002
|
||||
@@ -21,7 +21,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
datadir = @datadir@
|
||||
-localedir = $(datadir)/locale
|
||||
+localedir = $(prefix)/share/locale
|
||||
gettextsrcdir = $(datadir)/gettext/po
|
||||
|
||||
INSTALL = @INSTALL@
|
Loading…
Reference in a new issue