Remove expired ports:

2019-05-30 math/gracetmpl: Long unmaintained abandonware; depends on stale numarray
2019-05-30 math/py-numarray: Obsoleted upstream in favor of NumPy
2019-05-30 net/neubot: neubot client has been retired upstream
This commit is contained in:
Rene Ladan 2019-05-30 21:39:16 +00:00
parent acf3eb7c44
commit 4353580e2f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=503088
22 changed files with 3 additions and 870 deletions

3
MOVED
View file

@ -12779,3 +12779,6 @@ graphics/cinepaint||2019-05-29|Has expired: Vulnerable since 2015, unmaintained
audio/specimen||2019-05-29|Has expired: Unmaintained, depends on expiring x11-toolkits/phat
devel/smack||2019-05-29|Has expired: Unmaintained, upstream disappeared, underlinks
x11-toolkits/phat||2019-05-29|Has expired: Unmaintained, upstream disappeared, underlinks
math/gracetmpl||2019-05-30|Has expired: Long unmaintained abandonware; depends on stale numarray
math/py-numarray|math/py-numpy|2019-05-30|Has expired: Obsoleted upstream in favor of NumPy
net/neubot||2019-05-30|Has expired: neubot client has been retired upstream

View file

@ -264,7 +264,6 @@
SUBDIR += gnuplot-tex-extras
SUBDIR += gotoblas
SUBDIR += grace
SUBDIR += gracetmpl
SUBDIR += graphthing
SUBDIR += gretl
SUBDIR += gri
@ -724,7 +723,6 @@
SUBDIR += py-networkx
SUBDIR += py-networkx1
SUBDIR += py-nevergrad
SUBDIR += py-numarray
SUBDIR += py-numeric
SUBDIR += py-numexpr
SUBDIR += py-numpy

View file

@ -1,55 +0,0 @@
# Created by: ijliao
# $FreeBSD$
PORTNAME= gracetmpl
PORTVERSION= 0.3.2
PORTREVISION= 7
CATEGORIES= math print
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Provide an easy way to use existing grace-files as a template
DEPRECATED= Long unmaintained abandonware; depends on stale numarray
EXPIRATION_DATE= 2019-05-30
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:math/py-numarray@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:math/py-numarray@${PY_FLAVOR}
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake python:2.7 tar:bzip2
USE_PYTHON= flavors
MAKE_ARGS= PREFIX="${PREFIX}" \
BIN_PREFIX="${PREFIX}/bin" \
LIB_PREFIX="${PREFIX}/lib" \
INC_PREFIX="${PREFIX}/include" \
DOC_PREFIX="${DOCSDIR}" \
AR="${AR}" \
CPP="${CXX} ${LDFLAGS}" \
CPPFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
CXX="${CXX}" \
PYTHON="${PYTHON_CMD}"
ALL_TARGET= all pythonwrap
INSTALL_TARGET= install
USE_GCC= yes
PLIST_SUB+= PYTHON_VER=${PYTHON_VER}
OPTIONS_DEFINE= DOCS
post-extract:
@${ECHO_CMD} -n > ${WRKSRC}/Makefile.defs
post-patch:
@${REINPLACE_CMD} -e 's|/gracetmpl\.a|/libgracetmpl.a|g' ${WRKSRC}/gracetmpl-config.in
post-install:
@(cd ${INSTALL_WRKSRC}/python; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py \
install --root=${STAGEDIR} --prefix=${PREFIX} -c -O1)
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/graceTMPL/graceTMPL.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/html/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (gracetmpl-0.3.2.tar.bz2) = 2a9cfee048a6d7bce545d9499047b2d9aa7b5fefd0e7d09f1518d7049c5b6bae
SIZE (gracetmpl-0.3.2.tar.bz2) = 898445

View file

@ -1,51 +0,0 @@
--- Makefile.orig 2004-09-27 03:59:48.000000000 -0400
+++ Makefile 2014-09-08 12:19:12.246360998 -0400
@@ -58,10 +58,10 @@
$(CPP) -o envtest envtest.o gracetmpl.o
install: all
- install -D -m 644 gracetmpl.h $(INC_PREFIX)/gracetmpl.h
- install -D -m 644 gracetmpl.a $(LIB_PREFIX)/gracetmpl.a
- install -D -m 755 gracetmpldemo $(BIN_PREFIX)/gracetmpldemo
- install -D -m 755 gracetmpl-config $(BIN_PREFIX)/gracetmpl-config
+ ${BSD_INSTALL_DATA} gracetmpl.h $(DESTDIR)$(INC_PREFIX)/gracetmpl.h
+ ${BSD_INSTALL_DATA} gracetmpl.a $(DESTDIR)$(LIB_PREFIX)/libgracetmpl.a
+ ${BSD_INSTALL_PROGRAM} gracetmpldemo $(DESTDIR)$(BIN_PREFIX)/gracetmpldemo
+ ${BSD_INSTALL_SCRIPT} gracetmpl-config $(DESTDIR)$(BIN_PREFIX)/gracetmpl-config
gracetmpl-config: gracetmpl-config.in Makefile.defs
sed -e 's!__PREFIX__!$(PREFIX)!g' \
@@ -78,16 +78,16 @@
rm -f *~ \#*\#
pythonwrap:
- @if python python/prereq.py 2>/dev/null; then \
- (cd python; make); \
+ @if $(PYTHON) python/prereq.py 2>/dev/null; then \
+ (cd python; $(MAKE)); \
else \
echo missing python numarray extension.; \
echo not building python stuff; \
fi
pythonwrap_install:
- @if python python/prereq.py 2>/dev/null; then \
- (cd python; make install); \
+ @if $(PYTHON) python/prereq.py 2>/dev/null; then \
+ (cd python; $(MAKE) install); \
else \
echo not installing python stuff; \
fi
@@ -121,10 +121,10 @@
rm -fr doc/html
test: gracetmpldemo pythonwrap
- @cd tests; make
+ @cd tests; $(MAKE)
testpics: gracetmpldemo pythonwrap
- @cd tests; make pics
+ @cd tests; $(MAKE) pics
web: doc
(cd doc/html; tar cvhzf ../../web-`date +%s`.tgz .)

View file

@ -1,25 +0,0 @@
--- gracetmpl.cpp.orig 2004-09-24 16:56:02.000000000 +0400
+++ gracetmpl.cpp
@@ -21,10 +21,12 @@
#include <vector>
#include <map>
#include <iostream>
+#include <cstring>
+#include <cstdlib>
extern "C" {
#include <math.h>
-#include <values.h>
+#include <float.h>
#include <ctype.h>
#include <time.h>
#include <sys/time.h>
@@ -981,7 +983,7 @@ string time2string (const string &format
gettimeofday(&tv,0);
size= (tm==0) ?
- strftime(buffer,999,format.c_str(),localtime(&tv.tv_sec)):
+ strftime(buffer,999,format.c_str(),localtime((const time_t *) &tv.tv_sec)):
strftime(buffer,999,format.c_str(),tm);
buffer[999]= 0;
return string(buffer);

View file

@ -1,16 +0,0 @@
--- gracetmpldemo.cpp.orig 2003-03-04 10:32:45 UTC
+++ gracetmpldemo.cpp
@@ -3,11 +3,13 @@ extern "C" {
#include <stdlib.h>
#include <stdio.h>
#include <getopt.h>
+#include <sys/syslimits.h>
}
#include <iostream>
#include <string>
#include <vector>
#include <map>
+#include <cstring>
#include "gracetmpl.h"

View file

@ -1,56 +0,0 @@
--- python/src/pygracetmpl.cc.orig Mon Sep 27 16:59:49 2004
+++ python/src/pygracetmpl.cc Sat Jun 18 00:44:43 2005
@@ -1,15 +1,15 @@
#include <gracetmpl.h>
+#include <string.h>
+#include <complex>
+#include <set>
+
/* python headers */
#include <Python.h>
/* numarray headers */
#include <numarray/numarray.h>
#include <numarray/arrayobject.h>
-#include <string.h>
-#include <complex>
-#include <set>
-
/********************************************************/
/******************* graceTMPL.data type ***************/
/********************************************************/
@@ -159,6 +159,7 @@
PyArrayObject *dataArray = 0;
GraceTMPL::Data *newData = 0;
graceTMPL_dataObject *dataObject = 0;
+ int cols, rows;
if (!PyArg_ParseTuple(args, "sO:graceTMPL.graph.addData(name, dataArray)",
&name, &oDataArray)){
@@ -178,12 +179,12 @@
"data array has to have at least dimension 2 in first axis");
return NULL;
}
- PyArray_INCREF(dataArray);
- int cols = dataArray->dimensions[0];
- int rows = dataArray->dimensions[1];
+ XXX_PyArray_INCREF(dataArray);
+ cols = dataArray->dimensions[0];
+ rows = dataArray->dimensions[1];
if(cols > 4)
cols = 4;
- double **data = new (double *)[cols];
+ double **data = new double *[cols];
for(int c = 0; c < cols; ++c){
data[c] = new double[rows];
for(int r = 0; r < rows; ++r)
@@ -191,7 +192,7 @@
c * dataArray->strides[0] +
r * dataArray->strides[1]);
}
- PyArray_XDECREF(dataArray);
+ XXX_PyArray_XDECREF(dataArray);
switch(cols){
case 2:
newData = new GraceTMPL::Data(std::string(name), rows,

View file

@ -1,22 +0,0 @@
The GraceTMPL classes provide an easy way to use existing grace-files as a
template to format any number of graphs in a predefined way and save them as
grace-files. This way you can apply the same graphical appearance to all of
your data. In case your preferences change, you just alter the template and
reformat your complete set of data within the shortest amount of time.
The capabilities of GraceTMPL include:
* The application using the GraceTMPL classes can define environment
variables for the sheet, each graph and each dataset. The variables can
be used in the template for dynamic string replacement. Even output
filenames can be templated using variable substitution.
* Datasets in the template file can be marked to be included in the
destination files for easy reference.
* Datasets can be tagged with arbitrary information strings to be
interpreted by the application using GraceTMPL. This way information can
be passed to the application on how to create the datasets and what kind
of information is intended by the template author.
* In case no template file is loaded by the application, GraceTMPL::Save
will output plain sets of data tables which can easily be imported by
XmGrace or other applications.
WWW: http://gracetmpl.sourceforge.net/

View file

@ -1,64 +0,0 @@
bin/gracetmpl-config
bin/gracetmpldemo
include/gracetmpl.h
%%PYTHON_INCLUDEDIR%%/graceTMPL/gracetmpl.h
lib/libgracetmpl.a
%%PYTHON_SITELIBDIR%%/graceTMPL/graceTMPL.so
%%PYTHON_SITELIBDIR%%/graceTMPL.pth
%%PYTHON_SITELIBDIR%%/graceTMPL/graceTMPL-0.3.2-py%%PYTHON_VER%%.egg-info
%%PORTDOCS%%%%DOCSDIR%%/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/annotations.html
%%PORTDOCS%%%%DOCSDIR%%/changes.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Data-members.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Data.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Data.png
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Environment-members.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Environment.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1EnvironmentUser-members.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1EnvironmentUser.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1EnvironmentUser.png
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Graph-members.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Graph.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Graph.png
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Save-members.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Save.html
%%PORTDOCS%%%%DOCSDIR%%/classGraceTMPL_1_1Save.png
%%PORTDOCS%%%%DOCSDIR%%/classes.html
%%PORTDOCS%%%%DOCSDIR%%/demo-annotated.jpg
%%PORTDOCS%%%%DOCSDIR%%/demo-output-big.jpg
%%PORTDOCS%%%%DOCSDIR%%/demo-template-big.jpg
%%PORTDOCS%%%%DOCSDIR%%/demo_outp_big.html
%%PORTDOCS%%%%DOCSDIR%%/demo_tmpl_big.html
%%PORTDOCS%%%%DOCSDIR%%/dictionary.html
%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/examples.html
%%PORTDOCS%%%%DOCSDIR%%/files.html
%%PORTDOCS%%%%DOCSDIR%%/functions.html
%%PORTDOCS%%%%DOCSDIR%%/functions_func.html
%%PORTDOCS%%%%DOCSDIR%%/functions_type.html
%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/gracetmpl_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/hierarchy.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/installation.html
%%PORTDOCS%%%%DOCSDIR%%/namespaceGraceTMPL.html
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers.html
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_enum.html
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_eval.html
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_func.html
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_type.html
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_vars.html
%%PORTDOCS%%%%DOCSDIR%%/namespaces.html
%%PORTDOCS%%%%DOCSDIR%%/pages.html
%%PORTDOCS%%%%DOCSDIR%%/structGraceTMPL_1_1Save_1_1CopySrc-members.html
%%PORTDOCS%%%%DOCSDIR%%/structGraceTMPL_1_1Save_1_1CopySrc.html
%%PORTDOCS%%%%DOCSDIR%%/structGraceTMPL_1_1Save_1_1Template-members.html
%%PORTDOCS%%%%DOCSDIR%%/structGraceTMPL_1_1Save_1_1Template.html
%%PORTDOCS%%%%DOCSDIR%%/test01.jpg
%%PORTDOCS%%%%DOCSDIR%%/test02.jpg
%%PORTDOCS%%%%DOCSDIR%%/test03.jpg
%%PORTDOCS%%%%DOCSDIR%%/test04.jpg
%%PORTDOCS%%%%DOCSDIR%%/test05.jpg
%%PORTDOCS%%%%DOCSDIR%%/tmpl_knowledge.html
%%PORTDOCS%%%%DOCSDIR%%/todo.html

View file

@ -1,46 +0,0 @@
# Created by: Hye-Shik Chang
# $FreeBSD$
PORTNAME= numarray
PORTVERSION= 1.5.2
PORTREVISION= 3
CATEGORIES= math python
MASTER_SITES= SF/numpy/Old%20Numarray/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Numeric array manipulation extension module for Python
LICENSE= BSD3CLAUSE
DEPRECATED= Obsoleted upstream in favor of NumPy
EXPIRATION_DATE= 2019-05-30
USES= python:2.7 shebangfix
SHEBANG_FILES= Examples/convolve/benchmark.py
USE_PYTHON= distutils autoplist
PORTDOCS= *
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
post-configure:
cd ${WRKSRC} && \
${PYTHON_CMD} generate.py && \
${PYTHON_CMD} Include/numarray/genapis.py
post-install:
@${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/numarray -name "*.so" -exec \
${STRIP_CMD} {} \;
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${TAR} -C ${WRKSRC}/Doc -cf- .|${TAR} -C ${STAGEDIR}${DOCSDIR} -xf-
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${TAR} -C ${WRKSRC}/Examples -cf- .|${TAR} -C ${STAGEDIR}${EXAMPLESDIR} -xf-
@${RM} -r ${STAGEDIR}${EXAMPLESDIR}/ufunc/build
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (numarray-1.5.2.tar.gz) = 6f6dc1a348c2fa32b2179717f3b3af4ddf60e9a3417739d325f344eb8f243174
SIZE (numarray-1.5.2.tar.gz) = 1196014

View file

@ -1,9 +0,0 @@
--- setup.py.orig 2005-11-17 23:12:49 UTC
+++ setup.py
@@ -227,6 +227,4 @@ def main():
# Do the installation.
#
if __name__ == "__main__":
- if "config" not in sys.argv and ("build" in sys.argv or "install" in sys.argv):
- sys.argv.insert(sys.argv.index("setup.py")+1, "config")
main()

View file

@ -1,9 +0,0 @@
Numarray is a reimplementation of the original Python Numeric array
module that provides Python with capbilities similar to Matlab, IDL,
Octave, APL and other array-based languages. This version is still
in its early stages and is not yet the official replacement for
Numeric though we hope it will be before long. It is not fully
backwards compatible with Numeric, particularly with regard to the
C API.
WWW: http://www.stsci.edu/resources/software_hardware/numarray

View file

@ -487,7 +487,6 @@
SUBDIR += netstrain
SUBDIR += nettest
SUBDIR += netwib
SUBDIR += neubot
SUBDIR += nfs-ganesha
SUBDIR += nfs-ganesha-kmod
SUBDIR += nfsshell

View file

@ -1,55 +0,0 @@
# Created by: thierry@pompo.net
# $FreeBSD$
PORTNAME= neubot
PORTVERSION= 0.4.16.9
PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://releases.neubot.org/_packages/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Measures neutrality of your network connection in the background
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
# Retiring the Neubot Client - See http://www.neubot.org/2019/01/retiring-neubot-client.html
DEPRECATED= Yes
EXPIRATION_DATE=2019-05-30
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
USES= python:2.7 shebangfix
SHEBANG_FILES= UNIX/bin/neubot
NO_BUILD= yes
NO_ARCH= yes
USERS= _neubot
GROUPS= _neubot
LSTATEDIR= /var
STATEDIR= ${LSTATEDIR}/${PORTNAME}
MAKE_ARGS= PYTHON=${PYTHON_CMD}
MAKE_ENV= LOCALSTATEDIR=${LSTATEDIR} MANDIR=${MANPREFIX}/man
USE_RC_SUBR= neubotd
INSTALLS_ICONS= yes
DOCS= AUTHORS BUGS ChangeLog PRIVACY README.rst TODO
SUB_FILES= pkg_message
SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
PKGMESSAGE= ${WRKDIR}/pkg_message
OPTIONS_DEFINE= DOCS
post-install:
${RM} -r ${STAGEDIR}${LSTATEDIR}
(cd ${STAGEDIR}${PREFIX} \
&& ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
-d ${PREFIX} -f ${DATADIR:S;${PREFIX}/;;})
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (neubot-0.4.16.9.tar.gz) = fd1ea78e8e164a01021477cef63dae59a666a922cc38c14e0e927709108657b6
SIZE (neubot-0.4.16.9.tar.gz) = 1160224

View file

@ -1,47 +0,0 @@
#! /bin/sh
#
# $FreeBSD$
#
# PROVIDE: neubotd
# REQUIRE: NETWORKING DAEMON
# KEYWORD: shutdown
# Add the following line to /etc/rc.conf to enable `neubotd':
#
# neubotd_enable="YES"
#
. /etc/rc.subr
name="neubotd"
rcvar=neubotd_enable
# read settings, set default values
load_rc_config "${name}"
: ${neubotd_enable="NO"}
required_files="%%PREFIX%%/bin/neubot"
pidfile="/var/run/${name}.pid"
long_name="neubot daemon."
neubotd_log="/var/log/${name}.log"
start_cmd=${name}_start
stop_cmd=${name}_stop
neubotd_start() {
[ -x %%PYTHON_CMD%% ] || (echo "%%PYTHON_CMD%% not found"; exit 1)
[ -f $pidfile ] && (echo "$name already running?"; exit 2)
echo "Starting $long_name"
%%PYTHON_CMD%% %%PREFIX%%/bin/neubot start > $neubotd_log && \
echo $$ > $pidfile
}
neubotd_stop() {
[ -f $pidfile ] || (echo "$name not running?"; exit 1)
echo "Stopping $long_name"
%%PYTHON_CMD%% %%PREFIX%%/bin/neubot stop > $neubotd_log && \
rm -f $pidfile
}
run_rc_command "$1"

View file

@ -1,11 +0,0 @@
--- Makefile.orig 2013-10-23 22:11:11 UTC
+++ Makefile
@@ -225,7 +225,7 @@ uninstall:
# using the compileall module.
#
_install_umask_ok:
- make -f Makefile _install INSTALL='install -o 0 -g 0'
+ make -f Makefile _install INSTALL='install'
$(PYTHON) -m compileall $(DESTDIR)$(DATADIR)/neubot
install:

View file

@ -1,12 +0,0 @@
==============================================================================
Please read the file %%DOCSDIR%%/PRIVACY before using this
program.
To start the daemon, add the following line to /etc/rc.conf:
neubotd_enable="YES"
When upgrading, don't forget to restart the daemon, in order to migrate its
database if needed.
==============================================================================

View file

@ -1,11 +0,0 @@
Neubot is a research project on network neutrality of the NEXA Center for
Internet & Society at Politecnico di Torino. The project is based on a
lightweight open-source program that interested users can download and install
on their computers. The program runs in background and periodically performs
transmission tests with some test servers and with other instances of the
program itself. These transmission tests probe the Internet using various
application level protocols. The program saves tests results locally and uploads
them on the project servers. The collected dataset contains samples from various
Providers and allows to monitor network neutrality.
WWW: http://www.neubot.org/

View file

@ -1,372 +0,0 @@
bin/neubot
etc/neubot/api
etc/neubot/users
etc/xdg/autostart/neubot.desktop
man/man1/neubot.1.gz
share/applications/neubot.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/PRIVACY
%%PORTDOCS%%%%DOCSDIR%%/README.rst
%%PORTDOCS%%%%DOCSDIR%%/TODO
share/icons/hicolor/scalable/apps/neubot.svg
%%DATADIR%%/mod_dash/__init__.py
%%DATADIR%%/mod_dash/__init__.pyc
%%DATADIR%%/mod_dash/client_negotiate.py
%%DATADIR%%/mod_dash/client_negotiate.pyc
%%DATADIR%%/mod_dash/client_smpl.py
%%DATADIR%%/mod_dash/client_smpl.pyc
%%DATADIR%%/mod_dash/main.py
%%DATADIR%%/mod_dash/main.pyc
%%DATADIR%%/mod_dash/neubot_module.py
%%DATADIR%%/mod_dash/neubot_module.pyc
%%DATADIR%%/mod_dash/server_glue.py
%%DATADIR%%/mod_dash/server_glue.pyc
%%DATADIR%%/mod_dash/server_negotiate.py
%%DATADIR%%/mod_dash/server_negotiate.pyc
%%DATADIR%%/mod_dash/server_smpl.py
%%DATADIR%%/mod_dash/server_smpl.pyc
%%DATADIR%%/neubot/__init__.py
%%DATADIR%%/neubot/__init__.pyc
%%DATADIR%%/neubot/agent.py
%%DATADIR%%/neubot/agent.pyc
%%DATADIR%%/neubot/api/__init__.py
%%DATADIR%%/neubot/api/__init__.pyc
%%DATADIR%%/neubot/api/client.py
%%DATADIR%%/neubot/api/client.pyc
%%DATADIR%%/neubot/api/server.py
%%DATADIR%%/neubot/api/server.pyc
%%DATADIR%%/neubot/api_data.py
%%DATADIR%%/neubot/api_data.pyc
%%DATADIR%%/neubot/api_results.py
%%DATADIR%%/neubot/api_results.pyc
%%DATADIR%%/neubot/api_server.py
%%DATADIR%%/neubot/api_server.pyc
%%DATADIR%%/neubot/backend.py
%%DATADIR%%/neubot/backend.pyc
%%DATADIR%%/neubot/backend_mlab.py
%%DATADIR%%/neubot/backend_mlab.pyc
%%DATADIR%%/neubot/backend_neubot.py
%%DATADIR%%/neubot/backend_neubot.pyc
%%DATADIR%%/neubot/backend_null.py
%%DATADIR%%/neubot/backend_null.pyc
%%DATADIR%%/neubot/backend_volatile.py
%%DATADIR%%/neubot/backend_volatile.pyc
%%DATADIR%%/neubot/background_api.py
%%DATADIR%%/neubot/background_api.pyc
%%DATADIR%%/neubot/background_rendezvous.py
%%DATADIR%%/neubot/background_rendezvous.pyc
%%DATADIR%%/neubot/background_win32.py
%%DATADIR%%/neubot/background_win32.pyc
%%DATADIR%%/neubot/bittorrent/__init__.py
%%DATADIR%%/neubot/bittorrent/__init__.pyc
%%DATADIR%%/neubot/bittorrent/bitfield.py
%%DATADIR%%/neubot/bittorrent/bitfield.pyc
%%DATADIR%%/neubot/bittorrent/btsched.py
%%DATADIR%%/neubot/bittorrent/btsched.pyc
%%DATADIR%%/neubot/bittorrent/client.py
%%DATADIR%%/neubot/bittorrent/client.pyc
%%DATADIR%%/neubot/bittorrent/config.py
%%DATADIR%%/neubot/bittorrent/config.pyc
%%DATADIR%%/neubot/bittorrent/estimate.py
%%DATADIR%%/neubot/bittorrent/estimate.pyc
%%DATADIR%%/neubot/bittorrent/peer.py
%%DATADIR%%/neubot/bittorrent/peer.pyc
%%DATADIR%%/neubot/bittorrent/server.py
%%DATADIR%%/neubot/bittorrent/server.pyc
%%DATADIR%%/neubot/bittorrent/stream.py
%%DATADIR%%/neubot/bittorrent/stream.pyc
%%DATADIR%%/neubot/brigade.py
%%DATADIR%%/neubot/brigade.pyc
%%DATADIR%%/neubot/browser.py
%%DATADIR%%/neubot/browser.pyc
%%DATADIR%%/neubot/browser_macos.py
%%DATADIR%%/neubot/browser_macos.pyc
%%DATADIR%%/neubot/browser_nt.py
%%DATADIR%%/neubot/browser_nt.pyc
%%DATADIR%%/neubot/browser_null.py
%%DATADIR%%/neubot/browser_null.pyc
%%DATADIR%%/neubot/bytegen_speedtest.py
%%DATADIR%%/neubot/bytegen_speedtest.pyc
%%DATADIR%%/neubot/compat.py
%%DATADIR%%/neubot/compat.pyc
%%DATADIR%%/neubot/config.py
%%DATADIR%%/neubot/config.pyc
%%DATADIR%%/neubot/config_api.py
%%DATADIR%%/neubot/config_api.pyc
%%DATADIR%%/neubot/connector.py
%%DATADIR%%/neubot/connector.pyc
%%DATADIR%%/neubot/database/__init__.py
%%DATADIR%%/neubot/database/__init__.pyc
%%DATADIR%%/neubot/database/_table_utils.py
%%DATADIR%%/neubot/database/_table_utils.pyc
%%DATADIR%%/neubot/database/main.py
%%DATADIR%%/neubot/database/main.pyc
%%DATADIR%%/neubot/database/migrate.py
%%DATADIR%%/neubot/database/migrate.pyc
%%DATADIR%%/neubot/database/migrate2.py
%%DATADIR%%/neubot/database/migrate2.pyc
%%DATADIR%%/neubot/database/table_bittorrent.py
%%DATADIR%%/neubot/database/table_bittorrent.pyc
%%DATADIR%%/neubot/database/table_config.py
%%DATADIR%%/neubot/database/table_config.pyc
%%DATADIR%%/neubot/database/table_geoloc.py
%%DATADIR%%/neubot/database/table_geoloc.pyc
%%DATADIR%%/neubot/database/table_log.py
%%DATADIR%%/neubot/database/table_log.pyc
%%DATADIR%%/neubot/database/table_raw.py
%%DATADIR%%/neubot/database/table_raw.pyc
%%DATADIR%%/neubot/database/table_speedtest.py
%%DATADIR%%/neubot/database/table_speedtest.pyc
%%DATADIR%%/neubot/database_xxx.py
%%DATADIR%%/neubot/database_xxx.pyc
%%DATADIR%%/neubot/debug/__init__.py
%%DATADIR%%/neubot/debug/__init__.pyc
%%DATADIR%%/neubot/debug/objgraph.py
%%DATADIR%%/neubot/debug/objgraph.pyc
%%DATADIR%%/neubot/defer.py
%%DATADIR%%/neubot/defer.pyc
%%DATADIR%%/neubot/handler.py
%%DATADIR%%/neubot/handler.pyc
%%DATADIR%%/neubot/http/__init__.py
%%DATADIR%%/neubot/http/__init__.pyc
%%DATADIR%%/neubot/http/client.py
%%DATADIR%%/neubot/http/client.pyc
%%DATADIR%%/neubot/http/message.py
%%DATADIR%%/neubot/http/message.pyc
%%DATADIR%%/neubot/http/server.py
%%DATADIR%%/neubot/http/server.pyc
%%DATADIR%%/neubot/http/ssi.py
%%DATADIR%%/neubot/http/ssi.pyc
%%DATADIR%%/neubot/http/stream.py
%%DATADIR%%/neubot/http/stream.pyc
%%DATADIR%%/neubot/http_clnt.py
%%DATADIR%%/neubot/http_clnt.pyc
%%DATADIR%%/neubot/http_utils.py
%%DATADIR%%/neubot/http_utils.pyc
%%DATADIR%%/neubot/listener.py
%%DATADIR%%/neubot/listener.pyc
%%DATADIR%%/neubot/log.py
%%DATADIR%%/neubot/log.pyc
%%DATADIR%%/neubot/log_api.py
%%DATADIR%%/neubot/log_api.pyc
%%DATADIR%%/neubot/main/__init__.py
%%DATADIR%%/neubot/main/__init__.pyc
%%DATADIR%%/neubot/main/browser.py
%%DATADIR%%/neubot/main/browser.pyc
%%DATADIR%%/neubot/main/common.py
%%DATADIR%%/neubot/main/common.pyc
%%DATADIR%%/neubot/main/module.py
%%DATADIR%%/neubot/main/module.pyc
%%DATADIR%%/neubot/main_common.py
%%DATADIR%%/neubot/main_common.pyc
%%DATADIR%%/neubot/main_macos.py
%%DATADIR%%/neubot/main_macos.pyc
%%DATADIR%%/neubot/main_win32.py
%%DATADIR%%/neubot/main_win32.pyc
%%DATADIR%%/neubot/marshal.py
%%DATADIR%%/neubot/marshal.pyc
%%DATADIR%%/neubot/negotiate/__init__.py
%%DATADIR%%/neubot/negotiate/__init__.pyc
%%DATADIR%%/neubot/negotiate/server.py
%%DATADIR%%/neubot/negotiate/server.pyc
%%DATADIR%%/neubot/negotiate/server_bittorrent.py
%%DATADIR%%/neubot/negotiate/server_bittorrent.pyc
%%DATADIR%%/neubot/negotiate/server_raw.py
%%DATADIR%%/neubot/negotiate/server_raw.pyc
%%DATADIR%%/neubot/negotiate/server_speedtest.py
%%DATADIR%%/neubot/negotiate/server_speedtest.pyc
%%DATADIR%%/neubot/net/CA.py
%%DATADIR%%/neubot/net/CA.pyc
%%DATADIR%%/neubot/net/__init__.py
%%DATADIR%%/neubot/net/__init__.pyc
%%DATADIR%%/neubot/net/poller.py
%%DATADIR%%/neubot/net/poller.pyc
%%DATADIR%%/neubot/net/stream.py
%%DATADIR%%/neubot/net/stream.pyc
%%DATADIR%%/neubot/notifier/__init__.py
%%DATADIR%%/neubot/notifier/__init__.pyc
%%DATADIR%%/neubot/notifier/macos.py
%%DATADIR%%/neubot/notifier/macos.pyc
%%DATADIR%%/neubot/notifier/unix.py
%%DATADIR%%/neubot/notifier/unix.pyc
%%DATADIR%%/neubot/notifier_browser.py
%%DATADIR%%/neubot/notifier_browser.pyc
%%DATADIR%%/neubot/notify.py
%%DATADIR%%/neubot/notify.pyc
%%DATADIR%%/neubot/percentile.py
%%DATADIR%%/neubot/percentile.pyc
%%DATADIR%%/neubot/pollable.py
%%DATADIR%%/neubot/pollable.pyc
%%DATADIR%%/neubot/poller.py
%%DATADIR%%/neubot/poller.pyc
%%DATADIR%%/neubot/privacy.py
%%DATADIR%%/neubot/privacy.pyc
%%DATADIR%%/neubot/raw.py
%%DATADIR%%/neubot/raw.pyc
%%DATADIR%%/neubot/raw_analyze.py
%%DATADIR%%/neubot/raw_analyze.pyc
%%DATADIR%%/neubot/raw_clnt.py
%%DATADIR%%/neubot/raw_clnt.pyc
%%DATADIR%%/neubot/raw_defs.py
%%DATADIR%%/neubot/raw_defs.pyc
%%DATADIR%%/neubot/raw_negotiate.py
%%DATADIR%%/neubot/raw_negotiate.pyc
%%DATADIR%%/neubot/raw_srvr.py
%%DATADIR%%/neubot/raw_srvr.pyc
%%DATADIR%%/neubot/raw_srvr_glue.py
%%DATADIR%%/neubot/raw_srvr_glue.pyc
%%DATADIR%%/neubot/rendezvous/__init__.py
%%DATADIR%%/neubot/rendezvous/__init__.pyc
%%DATADIR%%/neubot/rendezvous/compat.py
%%DATADIR%%/neubot/rendezvous/compat.pyc
%%DATADIR%%/neubot/rendezvous/geoip_wrapper.py
%%DATADIR%%/neubot/rendezvous/geoip_wrapper.pyc
%%DATADIR%%/neubot/rendezvous/server.py
%%DATADIR%%/neubot/rendezvous/server.pyc
%%DATADIR%%/neubot/resmon_linux.py
%%DATADIR%%/neubot/resmon_linux.pyc
%%DATADIR%%/neubot/runner_api.py
%%DATADIR%%/neubot/runner_api.pyc
%%DATADIR%%/neubot/runner_clnt.py
%%DATADIR%%/neubot/runner_clnt.pyc
%%DATADIR%%/neubot/runner_core.py
%%DATADIR%%/neubot/runner_core.pyc
%%DATADIR%%/neubot/runner_dload.py
%%DATADIR%%/neubot/runner_dload.pyc
%%DATADIR%%/neubot/runner_hosts.py
%%DATADIR%%/neubot/runner_hosts.pyc
%%DATADIR%%/neubot/runner_mlabns.py
%%DATADIR%%/neubot/runner_mlabns.pyc
%%DATADIR%%/neubot/runner_policy.py
%%DATADIR%%/neubot/runner_policy.pyc
%%DATADIR%%/neubot/runner_rendezvous.py
%%DATADIR%%/neubot/runner_rendezvous.pyc
%%DATADIR%%/neubot/runner_tests.py
%%DATADIR%%/neubot/runner_tests.pyc
%%DATADIR%%/neubot/runner_updates.py
%%DATADIR%%/neubot/runner_updates.pyc
%%DATADIR%%/neubot/server.py
%%DATADIR%%/neubot/server.pyc
%%DATADIR%%/neubot/simplejson/__init__.py
%%DATADIR%%/neubot/simplejson/__init__.pyc
%%DATADIR%%/neubot/simplejson/decoder.py
%%DATADIR%%/neubot/simplejson/decoder.pyc
%%DATADIR%%/neubot/simplejson/encoder.py
%%DATADIR%%/neubot/simplejson/encoder.pyc
%%DATADIR%%/neubot/simplejson/ordered_dict.py
%%DATADIR%%/neubot/simplejson/ordered_dict.pyc
%%DATADIR%%/neubot/simplejson/scanner.py
%%DATADIR%%/neubot/simplejson/scanner.pyc
%%DATADIR%%/neubot/six.py
%%DATADIR%%/neubot/six.pyc
%%DATADIR%%/neubot/speedtest/__init__.py
%%DATADIR%%/neubot/speedtest/__init__.pyc
%%DATADIR%%/neubot/speedtest/client.py
%%DATADIR%%/neubot/speedtest/client.pyc
%%DATADIR%%/neubot/speedtest/server.py
%%DATADIR%%/neubot/speedtest/server.pyc
%%DATADIR%%/neubot/speedtest/wrapper.py
%%DATADIR%%/neubot/speedtest/wrapper.pyc
%%DATADIR%%/neubot/sslstream.py
%%DATADIR%%/neubot/sslstream.pyc
%%DATADIR%%/neubot/state.py
%%DATADIR%%/neubot/state.pyc
%%DATADIR%%/neubot/stream.py
%%DATADIR%%/neubot/stream.pyc
%%DATADIR%%/neubot/system.py
%%DATADIR%%/neubot/system.pyc
%%DATADIR%%/neubot/system_posix.py
%%DATADIR%%/neubot/system_posix.pyc
%%DATADIR%%/neubot/system_win32.py
%%DATADIR%%/neubot/system_win32.pyc
%%DATADIR%%/neubot/updater/__init__.py
%%DATADIR%%/neubot/updater/__init__.pyc
%%DATADIR%%/neubot/updater/unix.py
%%DATADIR%%/neubot/updater/unix.pyc
%%DATADIR%%/neubot/updater_install.py
%%DATADIR%%/neubot/updater_install.pyc
%%DATADIR%%/neubot/updater_runner.py
%%DATADIR%%/neubot/updater_runner.pyc
%%DATADIR%%/neubot/updater_utils.py
%%DATADIR%%/neubot/updater_utils.pyc
%%DATADIR%%/neubot/updater_verify.py
%%DATADIR%%/neubot/updater_verify.pyc
%%DATADIR%%/neubot/updater_win32.py
%%DATADIR%%/neubot/updater_win32.pyc
%%DATADIR%%/neubot/utils.py
%%DATADIR%%/neubot/utils.pyc
%%DATADIR%%/neubot/utils_api.py
%%DATADIR%%/neubot/utils_api.pyc
%%DATADIR%%/neubot/utils_ctl.py
%%DATADIR%%/neubot/utils_ctl.pyc
%%DATADIR%%/neubot/utils_hier.py
%%DATADIR%%/neubot/utils_hier.pyc
%%DATADIR%%/neubot/utils_modules.py
%%DATADIR%%/neubot/utils_modules.pyc
%%DATADIR%%/neubot/utils_net.py
%%DATADIR%%/neubot/utils_net.pyc
%%DATADIR%%/neubot/utils_nt.py
%%DATADIR%%/neubot/utils_nt.pyc
%%DATADIR%%/neubot/utils_path.py
%%DATADIR%%/neubot/utils_path.pyc
%%DATADIR%%/neubot/utils_posix.py
%%DATADIR%%/neubot/utils_posix.pyc
%%DATADIR%%/neubot/utils_random.py
%%DATADIR%%/neubot/utils_random.pyc
%%DATADIR%%/neubot/utils_rc.py
%%DATADIR%%/neubot/utils_rc.pyc
%%DATADIR%%/neubot/utils_version.py
%%DATADIR%%/neubot/utils_version.pyc
%%DATADIR%%/neubot/viewer.py
%%DATADIR%%/neubot/viewer.pyc
%%DATADIR%%/neubot/viewer_webkit_gtk.py
%%DATADIR%%/neubot/viewer_webkit_gtk.pyc
%%DATADIR%%/neubot/web100.py
%%DATADIR%%/neubot/web100.pyc
%%DATADIR%%/neubot/www/css/jquery.jqplot.css
%%DATADIR%%/neubot/www/css/style.css
%%DATADIR%%/neubot/www/favicon.ico
%%DATADIR%%/neubot/www/footer.html
%%DATADIR%%/neubot/www/header.html
%%DATADIR%%/neubot/www/img/header-web.png
%%DATADIR%%/neubot/www/index.html
%%DATADIR%%/neubot/www/js/contrib.js
%%DATADIR%%/neubot/www/js/excanvas.min.js
%%DATADIR%%/neubot/www/js/i18n.js
%%DATADIR%%/neubot/www/js/index.js
%%DATADIR%%/neubot/www/js/jqplot.canvasAxisLabelRenderer.min.js
%%DATADIR%%/neubot/www/js/jqplot.canvasAxisTickRenderer.min.js
%%DATADIR%%/neubot/www/js/jqplot.canvasTextRenderer.min.js
%%DATADIR%%/neubot/www/js/jqplot.categoryAxisRenderer.min.js
%%DATADIR%%/neubot/www/js/jqplot.cursor.min.js
%%DATADIR%%/neubot/www/js/jqplot.dateAxisRenderer.min.js
%%DATADIR%%/neubot/www/js/jqplot.highlighter.min.js
%%DATADIR%%/neubot/www/js/jqplot.logAxisRenderer.min.js
%%DATADIR%%/neubot/www/js/jquery.jqplot.min.js
%%DATADIR%%/neubot/www/js/jquery.min.js
%%DATADIR%%/neubot/www/js/jquery.qtip.min.js
%%DATADIR%%/neubot/www/js/log.js
%%DATADIR%%/neubot/www/js/privacy.js
%%DATADIR%%/neubot/www/js/results.js
%%DATADIR%%/neubot/www/js/settings.js
%%DATADIR%%/neubot/www/js/state.js
%%DATADIR%%/neubot/www/js/update.js
%%DATADIR%%/neubot/www/js/utils.js
%%DATADIR%%/neubot/www/lang/en.js
%%DATADIR%%/neubot/www/lang/it.js
%%DATADIR%%/neubot/www/log.html
%%DATADIR%%/neubot/www/not_running.html
%%DATADIR%%/neubot/www/privacy.html
%%DATADIR%%/neubot/www/results.html
%%DATADIR%%/neubot/www/settings.html
%%DATADIR%%/neubot/www/test/bittorrent.html
%%DATADIR%%/neubot/www/test/bittorrent.json
%%DATADIR%%/neubot/www/test/dash.html
%%DATADIR%%/neubot/www/test/dash.json
%%DATADIR%%/neubot/www/test/raw.html
%%DATADIR%%/neubot/www/test/raw.json
%%DATADIR%%/neubot/www/test/speedtest.html
%%DATADIR%%/neubot/www/test/speedtest.json
%%DATADIR%%/neubot/www/update.html