Remove devel/hs-gtk2hs-buildtools, it does not build with recent GHC and breaks INDEX.

This commit is contained in:
Rene Ladan 2019-05-09 16:00:28 +00:00
parent 77a064f767
commit 4354ee5d87
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=501115
7 changed files with 1 additions and 75 deletions

1
MOVED
View file

@ -12766,3 +12766,4 @@ sysutils/sbsigntool||2019-05-09|Has expired: Broken for more than 6 months
www/py-cherrypy-old||2019-05-09|Has expired: Lates version is in tree and no dependent ports
games/warsow-data||2019-05-09|Removed, only useful for expired games/warsow
converters/hs-sandi||2019-05-09|Has expired: Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
devel/hs-gtk2hs-buildtools||2019-05-09|Removed, does not build with recent GHC and references deleted port

View file

@ -913,7 +913,6 @@
SUBDIR += hs-darcs
SUBDIR += hs-ghc-events
SUBDIR += hs-git-annex
SUBDIR += hs-gtk2hs-buildtools
SUBDIR += hs-haddock
SUBDIR += hs-happy
SUBDIR += hs-hasktags

View file

@ -1,21 +0,0 @@
# $FreeBSD$
PORTNAME= gtk2hs-buildtools
PORTVERSION= 0.13.4.0
PORTREVISION= 1
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Tools to build the Gtk2Hs suite of User Interface Libraries
LICENSE= GPLv2
BROKEN= Doesn't build with recent GHC
USE_CABAL= hashtables random
USE_ALEX= yes
USE_HAPPY= yes
EXECUTABLE= gtk2hsC2hs gtk2hsHookGenerator gtk2hsTypeGen
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1545833512
SHA256 (cabal/gtk2hs-buildtools-0.13.4.0.tar.gz) = 0f3e6ba90839efd43efe8cecbddb6478a55e2ce7788c57a0add4df477dede679
SIZE (cabal/gtk2hs-buildtools-0.13.4.0.tar.gz) = 177959

View file

@ -1,22 +0,0 @@
--- c2hs/c/CAST.hs.orig 2017-01-14 09:17:54 UTC
+++ c2hs/c/CAST.hs
@@ -1125,6 +1125,9 @@ instance Binary CStorageSpec where
put_ bh (CTypedef ae) = do
putByte bh 4
put_ bh ae
+ put_ bh (CThread af) = do
+ putByte bh 5
+ put_ bh af
get bh = do
h <- getByte bh
case h of
@@ -1143,6 +1146,9 @@ instance Binary CStorageSpec where
4 -> do
ae <- get bh
return (CTypedef ae)
+ 5 -> do
+ af <- get bh
+ return (CThread af)
instance Binary CTypeQual where
put_ bh (CConstQual aa) = do

View file

@ -1,20 +0,0 @@
Hide the scary c11 features from c2hs, which does not understand them:
c2hs: C header contains errors:
/usr/include/sys/_types.h:104: (column 61) [ERROR] >>> Syntax error !
The symbol `long' does not fit here.
*** Error code 1
--- c2hs/toplevel/C2HSConfig.hs.orig 2017-01-14 09:17:54 UTC
+++ c2hs/toplevel/C2HSConfig.hs
@@ -70,8 +70,8 @@ cpp = case os of
cppopts :: [String]
cppopts = case (os,cpp) of
("openbsd","cpp") -> ["-xc", "-w"]
- (_,"cpp") -> ["-x", "c", "-w"]
- (_,"gcc") -> ["-E", "-x", "c", "-w"]
+ (_,"cpp") -> ["-x", "c", "-w", "-std=c99", "-D_Nullable=", "-D_Nonnull="]
+ (_,"gcc") -> ["-E", "-x", "c", "-w", "-std=c99", "-D_Nullable", "-D_Nonnull="]
_ -> []
-- C preprocessor option for including only definitions (EXPORTED)

View file

@ -1,8 +0,0 @@
This package provides a set of helper programs necessary to build the
Gtk2Hs suite of libraries. These tools include a modified c2hs binding
tool that is used to generated FFI declarations, a tool to build a type
hiearchy that mirrors the C type hiearchy of GObjects found in glib, and
a generator for signal declarations that are used to call back from C to
Haskell. These tools are not needed to actually run Gtk2Hs programs.
WWW: http://projects.haskell.org/gtk2hs/