- Add rsyslog6*, the stable branch of rsyslog-6 at version 6.2.2
- Take maintainer PR: ports/169307 Approved by: pgollucci
This commit is contained in:
parent
517c7a6a7f
commit
4357b9a9c3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=302660
20 changed files with 696 additions and 0 deletions
|
@ -770,6 +770,15 @@
|
|||
SUBDIR += rsyslog5-relp
|
||||
SUBDIR += rsyslog5-rfc3195
|
||||
SUBDIR += rsyslog5-snmp
|
||||
SUBDIR += rsyslog6
|
||||
SUBDIR += rsyslog6-dbi
|
||||
SUBDIR += rsyslog6-gnutls
|
||||
SUBDIR += rsyslog6-gssapi
|
||||
SUBDIR += rsyslog6-mysql
|
||||
SUBDIR += rsyslog6-pgsql
|
||||
SUBDIR += rsyslog6-relp
|
||||
SUBDIR += rsyslog6-rfc3195
|
||||
SUBDIR += rsyslog6-snmp
|
||||
SUBDIR += rsyslog6-devel
|
||||
SUBDIR += rsyslog6-devel-dbi
|
||||
SUBDIR += rsyslog6-devel-gnutls
|
||||
|
|
24
sysutils/rsyslog6-dbi/Makefile
Normal file
24
sysutils/rsyslog6-dbi/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# New ports collection makefile for: rsyslog4-dbi
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
COMMENT= LibDBI output module for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= libdbi
|
||||
LIB_DEPENDS= dbi.1:${PORTSDIR}/databases/libdbi
|
||||
|
||||
CONFIGURE_ARGS+=--enable-libdbi
|
||||
|
||||
PLIST_FILES+= lib/rsyslog/omlibdbi.la \
|
||||
lib/rsyslog/omlibdbi.so
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/omlibdbi/.libs/omlibdbi.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/omlibdbi/omlibdbi.la ${PREFIX}/lib/rsyslog
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
27
sysutils/rsyslog6-gnutls/Makefile
Normal file
27
sysutils/rsyslog6-gnutls/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
#New ports collection makefile for: rsyslog4-gnutls
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTREVISION= 2
|
||||
|
||||
COMMENT= GNUTLS module for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= gnutls
|
||||
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls \
|
||||
gcrypt.18:${PORTSDIR}/security/libgcrypt
|
||||
|
||||
CONFIGURE_ARGS+=--enable-gnutls
|
||||
|
||||
PLIST_FILES+= lib/rsyslog/lmnsd_gtls.la \
|
||||
lib/rsyslog/lmnsd_gtls.so
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/runtime/.libs/lmnsd_gtls.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/runtime/lmnsd_gtls.la ${PREFIX}/lib/rsyslog
|
||||
.include "${MASTERDIR}/Makefile"
|
35
sysutils/rsyslog6-gssapi/Makefile
Normal file
35
sysutils/rsyslog6-gssapi/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: rsyslog4-gssapi
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
COMMENT= GSS API input/output module for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= gssapi
|
||||
|
||||
CONFIGURE_ARGS+=--enable-gssapi-krb5
|
||||
|
||||
PLIST_FILES+= lib/rsyslog/imgssapi.la \
|
||||
lib/rsyslog/imgssapi.so \
|
||||
lib/rsyslog/lmgssutil.la \
|
||||
lib/rsyslog/lmgssutil.so \
|
||||
lib/rsyslog/omgssapi.la \
|
||||
lib/rsyslog/omgssapi.so
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/omgssapi/.libs/omgssapi.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/omgssapi/omgssapi.la ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/imgssapi/.libs/imgssapi.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/imgssapi/imgssapi.la ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/.libs/lmgssutil.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/lmgssutil.la ${PREFIX}/lib/rsyslog
|
||||
.include "${MASTERDIR}/Makefile"
|
26
sysutils/rsyslog6-mysql/Makefile
Normal file
26
sysutils/rsyslog6-mysql/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: rsyslog4-mysql
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
COMMENT= MySQL output module for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= mysql
|
||||
USE_MYSQL= yes
|
||||
|
||||
CONFIGURE_ARGS+=--enable-mysql
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
|
||||
post-install:
|
||||
.ifndef NOPORTEXAMPLES
|
||||
@${INSTALL} -d ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
|
||||
.endif
|
||||
.include "${MASTERDIR}/Makefile"
|
4
sysutils/rsyslog6-mysql/pkg-plist
Normal file
4
sysutils/rsyslog6-mysql/pkg-plist
Normal file
|
@ -0,0 +1,4 @@
|
|||
lib/rsyslog/ommysql.la
|
||||
lib/rsyslog/ommysql.so
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
|
||||
%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
|
26
sysutils/rsyslog6-pgsql/Makefile
Normal file
26
sysutils/rsyslog6-pgsql/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: rsyslog4-pgsql
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
COMMENT= PostgreSQL output module for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= pgsql
|
||||
USE_PGSQL= yes
|
||||
|
||||
CONFIGURE_ARGS+=--enable-pgsql
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/ompgsql/.libs/ompgsql.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/ompgsql/ompgsql.la ${PREFIX}/lib/rsyslog
|
||||
post-install:
|
||||
.ifndef NOPORTEXAMPLES
|
||||
@${INSTALL} -d ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/plugins/ompgsql/createDB.sql ${EXAMPLESDIR}/pgsql_createDB.sql
|
||||
.endif
|
||||
.include "${MASTERDIR}/Makefile"
|
4
sysutils/rsyslog6-pgsql/pkg-plist
Normal file
4
sysutils/rsyslog6-pgsql/pkg-plist
Normal file
|
@ -0,0 +1,4 @@
|
|||
lib/rsyslog/ompgsql.la
|
||||
lib/rsyslog/ompgsql.so
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql_createDB.sql
|
||||
%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
|
32
sysutils/rsyslog6-relp/Makefile
Normal file
32
sysutils/rsyslog6-relp/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: rsyslog4-relp
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
COMMENT= RELP input/output module for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= relp
|
||||
LIB_DEPENDS= relp.0:${PORTSDIR}/devel/librelp
|
||||
|
||||
USE_PKGCONFIG= yes
|
||||
|
||||
CONFIGURE_ARGS+=--enable-relp
|
||||
|
||||
PLIST_FILES+= lib/rsyslog/imrelp.la \
|
||||
lib/rsyslog/imrelp.so \
|
||||
lib/rsyslog/omrelp.la \
|
||||
lib/rsyslog/omrelp.so
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/omrelp/.libs/omrelp.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/omrelp/omrelp.la ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/imrelp/.libs/imrelp.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/imrelp/imrelp.la ${PREFIX}/lib/rsyslog
|
||||
.include "${MASTERDIR}/Makefile"
|
26
sysutils/rsyslog6-rfc3195/Makefile
Normal file
26
sysutils/rsyslog6-rfc3195/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: rsyslog4-snmp
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
COMMENT= RFC3195 input support for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= rfc3195
|
||||
LIB_DEPENDS+= logging.0:${PORTSDIR}/devel/liblogging
|
||||
|
||||
USE_PKGCONFIG= yes
|
||||
|
||||
CONFIGURE_ARGS+=--enable-rfc3195
|
||||
|
||||
PLIST_FILES+= lib/rsyslog/im3195.la \
|
||||
lib/rsyslog/im3195.so
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/im3195/.libs/im3195.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/im3195/im3195.la ${PREFIX}/lib/rsyslog
|
||||
.include "${MASTERDIR}/Makefile"
|
24
sysutils/rsyslog6-snmp/Makefile
Normal file
24
sysutils/rsyslog6-snmp/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# New ports collection makefile for: rsyslog4-snmp
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
COMMENT= SNMP trap sender for rsyslog
|
||||
MASTERDIR= ${.CURDIR}/../rsyslog6
|
||||
|
||||
MNAME= snmp
|
||||
LIB_DEPENDS= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
|
||||
|
||||
CONFIGURE_ARGS+=--enable-snmp
|
||||
|
||||
PLIST_FILES+= lib/rsyslog/omsnmp.la \
|
||||
lib/rsyslog/omsnmp.so
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/plugins/omsnmp/.libs/omsnmp.so ${PREFIX}/lib/rsyslog
|
||||
@${INSTALL_DATA} \
|
||||
${WRKSRC}/plugins/omsnmp/omsnmp.la ${PREFIX}/lib/rsyslog
|
||||
.include "${MASTERDIR}/Makefile"
|
110
sysutils/rsyslog6/Makefile
Normal file
110
sysutils/rsyslog6/Makefile
Normal file
|
@ -0,0 +1,110 @@
|
|||
# New ports collection makefile for: rsyslog6-devel
|
||||
# Date created: 29 December 2008
|
||||
# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= rsyslog
|
||||
PORTVERSION= 6.2.2
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
|
||||
.ifdef MNAME
|
||||
PKGNAMESUFFIX?= -${MNAME}
|
||||
.endif
|
||||
|
||||
MAINTAINER= brd@FreeBSD.org
|
||||
COMMENT?= Syslogd supporting SQL, TCP, and TLS
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
LIB_DEPENDS+= ee:${PORTSDIR}/devel/libee \
|
||||
estr:${PORTSDIR}/devel/libestr \
|
||||
sysinfo:${PORTSDIR}/devel/libsysinfo
|
||||
|
||||
.ifdef MNAME
|
||||
RUN_DEPENDS= rsyslog>=${PORTVERSION}:${PORTSDIR}/sysutils/rsyslog6
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
LATEST_LINK= rsyslog6-${MNAME}
|
||||
.else
|
||||
LATEST_LINK= rsyslog6
|
||||
.endif
|
||||
|
||||
PORTSCOUT= limit:^6
|
||||
|
||||
.ifdef WITH_MYSQL_MICROSECONDS
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mysql-microseconds
|
||||
.endif
|
||||
|
||||
.ifdef WITH_SANE_HOSTNAME
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-sane-hostname
|
||||
.endif
|
||||
|
||||
CONFLICTS= rsyslog-[!6].[0-9]*
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.ifdef WITH_DEBUG
|
||||
CONFIGURE_ARGS+=--enable-rtinst --enable-debug
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
CPPFLAGS+=-march=i686
|
||||
.endif
|
||||
|
||||
CONFIGURE_ENV+= LIBESTR_CFLAGS="${CFLAGS}" LIBESTR_LIBS="${LDFLAGS} -lestr" LIBEE_CFLAGS="${CFLAGS}" LIBEE_LIBS="${LDFLAGS} -lee -lsysinfo -lkvm"
|
||||
CFLAGS+= ${CPPFLAGS}
|
||||
|
||||
.ifndef MNAME
|
||||
MAN8= rsyslogd.8
|
||||
MAN5= rsyslog.conf.5
|
||||
|
||||
USE_RC_SUBR= ${PORTNAME}d
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
CONFIGURE_ARGS+= --enable-imfile --enable-mail --enable-imtemplate --enable-testbench=no
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|/lib/rsyslog/|${PREFIX}/lib/rsyslog/|'\
|
||||
${WRKSRC}/tools/syslogd.c
|
||||
@${GREP} -rl '/etc/rsyslog.conf' ${WRKSRC}|${XARGS} ${REINPLACE_CMD} -e\
|
||||
's|/etc/rsyslog.conf|${PREFIX}/etc/rsyslog.conf|'
|
||||
@${REINPLACE_CMD} -e 's,/lib/rsyslog,${PREFIX}/lib/rsyslog,' ${WRKSRC}/tools/syslogd.c
|
||||
@${FIND} ${WRKSRC} -name '*.bak' -delete
|
||||
|
||||
post-install:
|
||||
.ifndef NOPORTDOCS
|
||||
@${INSTALL} -d ${DOCSDIR}/
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/*html ${DOCSDIR}/
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/*jpg ${DOCSDIR}/
|
||||
.endif
|
||||
.ifndef NOPORTEXAMPLES
|
||||
@${INSTALL} -d ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/rsyslog-example.conf ${EXAMPLESDIR}
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
.endif
|
||||
|
||||
.ifdef MNAME
|
||||
|
||||
.if ${MNAME} == "snmp" && ${ARCH} == "i386" && ${OSVERSION} >= 800000
|
||||
BROKEN= Does not link on i386: can't find symbol snmp_timeout in libnetsnmp
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --disable-rsyslogd --disable-klog
|
||||
|
||||
DESCR?= ${.CURDIR}/../rsyslog6/pkg-descr
|
||||
DISTINFO_FILE?= ${.CURDIR}/../rsyslog6/distinfo
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 700042
|
||||
USE_GCC= 4.2+
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
sysutils/rsyslog6/distinfo
Normal file
2
sysutils/rsyslog6/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (rsyslog-6.2.2.tar.gz) = c54b51f9f26d16e623d664c765268f3696721ceddfbee4e76b0dd89f04a6f471
|
||||
SIZE (rsyslog-6.2.2.tar.gz) = 2432745
|
56
sysutils/rsyslog6/files/extra-patch-mysql-microseconds
Normal file
56
sysutils/rsyslog6/files/extra-patch-mysql-microseconds
Normal file
|
@ -0,0 +1,56 @@
|
|||
--- ./runtime/datetime.c.orig 2010-05-04 18:57:25.588028725 -0400
|
||||
+++ ./runtime/datetime.c 2010-05-04 18:59:12.390680038 -0400
|
||||
@@ -644,18 +644,30 @@
|
||||
pBuf[1] = (ts->year / 100) % 10 + '0';
|
||||
pBuf[2] = (ts->year / 10) % 10 + '0';
|
||||
pBuf[3] = ts->year % 10 + '0';
|
||||
- pBuf[4] = (ts->month / 10) % 10 + '0';
|
||||
- pBuf[5] = ts->month % 10 + '0';
|
||||
- pBuf[6] = (ts->day / 10) % 10 + '0';
|
||||
- pBuf[7] = ts->day % 10 + '0';
|
||||
- pBuf[8] = (ts->hour / 10) % 10 + '0';
|
||||
- pBuf[9] = ts->hour % 10 + '0';
|
||||
- pBuf[10] = (ts->minute / 10) % 10 + '0';
|
||||
- pBuf[11] = ts->minute % 10 + '0';
|
||||
- pBuf[12] = (ts->second / 10) % 10 + '0';
|
||||
- pBuf[13] = ts->second % 10 + '0';
|
||||
- pBuf[14] = '\0';
|
||||
- return 15;
|
||||
+ pBuf[4] = '-';
|
||||
+ pBuf[5] = (ts->month / 10) % 10 + '0';
|
||||
+ pBuf[6] = ts->month % 10 + '0';
|
||||
+ pBuf[7] = '-';
|
||||
+ pBuf[8] = (ts->day / 10) % 10 + '0';
|
||||
+ pBuf[9] = ts->day % 10 + '0';
|
||||
+ pBuf[10] = ' ';
|
||||
+ pBuf[11] = (ts->hour / 10) % 10 + '0';
|
||||
+ pBuf[12] = ts->hour % 10 + '0';
|
||||
+ pBuf[13] = ':';
|
||||
+ pBuf[14] = (ts->minute / 10) % 10 + '0';
|
||||
+ pBuf[15] = ts->minute % 10 + '0';
|
||||
+ pBuf[16] = ':';
|
||||
+ pBuf[17] = (ts->second / 10) % 10 + '0';
|
||||
+ pBuf[18] = ts->second % 10 + '0';
|
||||
+ pBuf[19] = '.';
|
||||
+ pBuf[20] = (ts->secfrac / 100000) % 10 + '0';
|
||||
+ pBuf[21] = (ts->secfrac / 10000) % 10 + '0';
|
||||
+ pBuf[22] = (ts->secfrac / 1000) % 10 + '0';
|
||||
+ pBuf[23] = (ts->secfrac / 100) % 10 + '0';
|
||||
+ pBuf[24] = (ts->secfrac / 10) % 10 + '0';
|
||||
+ pBuf[25] = ts->secfrac % 10 + '0';
|
||||
+ pBuf[26] = '\0';
|
||||
+ return 26;
|
||||
|
||||
}
|
||||
|
||||
--- ./runtime/msg.c.orig 2010-05-04 19:00:20.241528788 -0400
|
||||
+++ ./runtime/msg.c 2010-05-04 19:00:06.136349680 -0400
|
||||
@@ -1293,7 +1293,7 @@
|
||||
case tplFmtMySQLDate:
|
||||
MsgLock(pM);
|
||||
if(pM->pszTIMESTAMP_MySQL == NULL) {
|
||||
- if((pM->pszTIMESTAMP_MySQL = MALLOC(15)) == NULL) {
|
||||
+ if((pM->pszTIMESTAMP_MySQL = MALLOC(26)) == NULL) {
|
||||
MsgUnlock(pM);
|
||||
return "";
|
||||
}
|
40
sysutils/rsyslog6/files/extra-patch-sane-hostname
Normal file
40
sysutils/rsyslog6/files/extra-patch-sane-hostname
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- ./tools/syslogd.c.orig 2010-05-04 19:02:05.548362478 -0400
|
||||
+++ ./tools/syslogd.c 2010-05-04 19:02:27.452450741 -0400
|
||||
@@ -2611,37 +2611,6 @@
|
||||
net.getLocalHostname(&LocalFQDNName);
|
||||
CHKmalloc(LocalHostName = (uchar*) strdup((char*)LocalFQDNName));
|
||||
glbl.SetLocalFQDNName(LocalFQDNName); /* set the FQDN before we modify it */
|
||||
- if((p = (uchar*)strchr((char*)LocalHostName, '.'))) {
|
||||
- *p++ = '\0';
|
||||
- LocalDomain = p;
|
||||
- } else {
|
||||
- LocalDomain = (uchar*)"";
|
||||
-
|
||||
- /* It's not clearly defined whether gethostname()
|
||||
- * should return the simple hostname or the fqdn. A
|
||||
- * good piece of software should be aware of both and
|
||||
- * we want to distribute good software. Joey
|
||||
- *
|
||||
- * Good software also always checks its return values...
|
||||
- * If syslogd starts up before DNS is up & /etc/hosts
|
||||
- * doesn't have LocalHostName listed, gethostbyname will
|
||||
- * return NULL.
|
||||
- */
|
||||
- /* TODO: gethostbyname() is not thread-safe, but replacing it is
|
||||
- * not urgent as we do not run on multiple threads here. rgerhards, 2007-09-25
|
||||
- */
|
||||
- hent = gethostbyname((char*)LocalHostName);
|
||||
- if(hent) {
|
||||
- free(LocalHostName);
|
||||
- CHKmalloc(LocalHostName = (uchar*)strdup(hent->h_name));
|
||||
-
|
||||
- if((p = (uchar*)strchr((char*)LocalHostName, '.')))
|
||||
- {
|
||||
- *p++ = '\0';
|
||||
- LocalDomain = p;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
|
||||
/* Convert to lower case to recognize the correct domain laterly */
|
||||
for(p = LocalDomain ; *p ; p++)
|
12
sysutils/rsyslog6/files/patch-plugins__imuxsock__imuxsock.c
Normal file
12
sysutils/rsyslog6/files/patch-plugins__imuxsock__imuxsock.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- ./plugins/imuxsock/imuxsock.c.orig 2011-09-15 06:01:15.000000000 +0000
|
||||
+++ ./plugins/imuxsock/imuxsock.c 2012-01-17 01:17:22.085759310 +0000
|
||||
@@ -727,9 +727,7 @@
|
||||
int iMaxLine;
|
||||
struct msghdr msgh;
|
||||
struct iovec msgiov;
|
||||
-# if HAVE_SCM_CREDENTIALS
|
||||
struct cmsghdr *cm;
|
||||
-# endif
|
||||
struct ucred *cred;
|
||||
struct timeval *ts;
|
||||
uchar bufRcv[4096+1];
|
30
sysutils/rsyslog6/files/pkg-message.in
Normal file
30
sysutils/rsyslog6/files/pkg-message.in
Normal file
|
@ -0,0 +1,30 @@
|
|||
===================================================================
|
||||
To start using rsyslogd(8), stop syslogd(8) if it's running and
|
||||
add the following lines to rc.conf(5):
|
||||
|
||||
syslogd_enable="NO"
|
||||
rsyslogd_enable="YES"
|
||||
|
||||
To avoid warnings about rsyslogd running in compatibility mode, add
|
||||
this:
|
||||
|
||||
rsyslogd_flags="-c5"
|
||||
|
||||
It's recommended to copy syslog.conf(5) to
|
||||
%%PREFIX%%/etc/rsyslog.conf and edit it there. Otherwise add
|
||||
this:
|
||||
|
||||
rsyslogd_config="/etc/syslog.conf"
|
||||
|
||||
Add the following (3) lines to the beginning of the config file, for
|
||||
basic functionality:
|
||||
|
||||
$ModLoad immark.so # provides --MARK-- message capability
|
||||
$ModLoad imuxsock.so # provides support for local system logging
|
||||
$ModLoad imklog.so # kernel logging
|
||||
|
||||
newsyslog(8) has the path of syslogd's pid file hardcoded. To
|
||||
make it work seamlessly with rsyslog, add this:
|
||||
|
||||
rsyslogd_pidfile="/var/run/syslog.pid"
|
||||
===================================================================
|
25
sysutils/rsyslog6/files/rsyslogd.in
Normal file
25
sysutils/rsyslog6/files/rsyslogd.in
Normal file
|
@ -0,0 +1,25 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
|
||||
# PROVIDE: rsyslogd
|
||||
# REQUIRE: mountcritremote cleanvar newsyslog ldconfig
|
||||
# BEFORE: SERVERS
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name=rsyslogd
|
||||
rcvar=rsyslogd_enable
|
||||
command="%%PREFIX%%/sbin/${name}"
|
||||
load_rc_config $name
|
||||
: ${rsyslogd_enable:="NO"}
|
||||
: ${rsyslogd_pidfile:="/var/run/rsyslogd.pid"}
|
||||
: ${rsyslogd_config:="%%PREFIX%%/etc/rsyslog.conf"}
|
||||
pidfile="${rsyslogd_pidfile}"
|
||||
command_args="-i ${pidfile} -f ${rsyslogd_config}"
|
||||
required_files="${rsyslogd_config}"
|
||||
extra_commands="reload"
|
||||
|
||||
run_rc_command "$1"
|
19
sysutils/rsyslog6/pkg-descr
Normal file
19
sysutils/rsyslog6/pkg-descr
Normal file
|
@ -0,0 +1,19 @@
|
|||
Rsyslog is an enhanced multi-threaded syslogd with a focus on
|
||||
security and reliability.
|
||||
|
||||
Among others, it offers support for on-demand disk buffering,
|
||||
reliable syslog over TCP, SSL, TLS and RELP, writing to databases
|
||||
(MySQL, PostgreSQL, Oracle, and many more), email alerting, fully
|
||||
configurable output formats (including high-precision timestamps),
|
||||
the ability to filter on any part of the syslog message, on-the-wire
|
||||
message compression, and the ability to convert text files to syslog.
|
||||
|
||||
It is a drop-in replacement for stock syslogd and able to work with
|
||||
the same configuration file syntax. Its advanced features make it
|
||||
suitable for enterprise-class, encryption protected syslog relay
|
||||
chains while at the same time being very easy to setup for the
|
||||
novice user.
|
||||
|
||||
Tracking v6-devel
|
||||
|
||||
WWW: http://www.rsyslog.com/
|
165
sysutils/rsyslog6/pkg-plist
Normal file
165
sysutils/rsyslog6/pkg-plist
Normal file
|
@ -0,0 +1,165 @@
|
|||
lib/rsyslog/imfile.la
|
||||
lib/rsyslog/imfile.so
|
||||
lib/rsyslog/imklog.la
|
||||
lib/rsyslog/imklog.so
|
||||
lib/rsyslog/immark.la
|
||||
lib/rsyslog/immark.so
|
||||
lib/rsyslog/imtcp.la
|
||||
lib/rsyslog/imtcp.so
|
||||
lib/rsyslog/imtemplate.la
|
||||
lib/rsyslog/imtemplate.so
|
||||
lib/rsyslog/imudp.la
|
||||
lib/rsyslog/imudp.so
|
||||
lib/rsyslog/imuxsock.la
|
||||
lib/rsyslog/imuxsock.so
|
||||
lib/rsyslog/lmnet.la
|
||||
lib/rsyslog/lmnet.so
|
||||
lib/rsyslog/lmnetstrms.la
|
||||
lib/rsyslog/lmnetstrms.so
|
||||
lib/rsyslog/lmnsd_ptcp.la
|
||||
lib/rsyslog/lmnsd_ptcp.so
|
||||
lib/rsyslog/lmregexp.la
|
||||
lib/rsyslog/lmregexp.so
|
||||
lib/rsyslog/lmstrmsrv.la
|
||||
lib/rsyslog/lmstrmsrv.so
|
||||
lib/rsyslog/lmtcpclt.la
|
||||
lib/rsyslog/lmtcpclt.so
|
||||
lib/rsyslog/lmtcpsrv.la
|
||||
lib/rsyslog/lmtcpsrv.so
|
||||
lib/rsyslog/lmzlibw.la
|
||||
lib/rsyslog/lmzlibw.so
|
||||
lib/rsyslog/ommail.la
|
||||
lib/rsyslog/ommail.so
|
||||
lib/rsyslog/omruleset.la
|
||||
lib/rsyslog/omruleset.so
|
||||
lib/rsyslog/omtesting.la
|
||||
lib/rsyslog/omtesting.so
|
||||
sbin/rsyslogd
|
||||
%%PORTDOCS%%%%DOCSDIR%%/bugs.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/build_from_repo.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/contributors.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/debug.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/dev_queue.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/droppriv.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/expression.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/features.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/generic_design.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/gssapi.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/history.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/how2help.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/im3195.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imfile.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imgssapi.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imklog.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/impstats.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imptcp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imrelp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imsolaris.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imtcp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/imuxsock.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/install.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ipv6.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/licensing.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/log_rotation_fix_size.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/manual.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mmnormalize.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mmsnmptrapd.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/modules.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/multi_ruleset.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/netstream.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ns_gtls.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ns_ptcp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omlibdbi.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ommail.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ommysql.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omoracle.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omrelp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omruleset.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omsnmp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omstdout.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omudpspoof.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/omuxsock.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/pmlastmsg.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/property_replacer.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/queueWorkerLogic.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/queueWorkerLogic_small.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/queues.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/queues_analogy.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rainerscript.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_actionexeconlywhenpreviousissuspended.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_actionresumeinterval.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_allowedsender.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_controlcharacterescapeprefix.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_debugprintcfsyslinehandlerlist.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_debugprintmodulelist.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_debugprinttemplatelist.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dircreatemode.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dirgroup.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dirowner.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dropmsgswithmaliciousdnsptrrecords.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_droptrailinglfonreception.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dynafilecachesize.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_escape8bitcharsonreceive.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_escapecontrolcharactersonreceive.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_failonchownfailure.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_filecreatemode.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_filegroup.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_fileowner.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_generateconfiggraph.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_gssforwardservicename.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_gsslistenservicename.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_gssmode.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_includeconfig.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_mainmsgqueuesize.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_markmessageperiod.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_moddir.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_modload.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_repeatedmsgreduction.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_resetconfigvariables.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_rulesetcreatemainqueue.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_rulesetparser.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_umask.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rscript_abnf.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_actions.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_examples.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_filter.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_global.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_modules.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_nomatch.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_output.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_templates.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_high_database_rate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_mysql.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_ng_comparison.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_packages.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_pgsql.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_php_syslog_ng.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_recording_pri.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_reliable_forwarding.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_secure_tls.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_stunnel.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_tls.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syslog_parsing.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syslog_protocol.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_100.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_ca.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_ca.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_client.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_errmsgs.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_machine.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_scenario.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_server.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_summary.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tls_cert_udp_relay.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/troubleshoot.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/v3compatibility.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/v4compatibility.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/v5compatibility.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/version_naming.html
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsyslog-example.conf
|
||||
%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrmtry lib/rsyslog
|
Loading…
Reference in a new issue