Initial import of PvmPov.

PvmPov is a distributing rendering package based on the popular POVRay raytracer
and the PVM library. I've tested it on cluster consisted several diskless
machines and it works really cool!

PR:		17572
Submitted by:	sobomax
This commit is contained in:
Maxim Sobolev 2000-05-29 08:47:48 +00:00
parent ecc5693eb8
commit 43d07d235f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=28923
8 changed files with 184 additions and 0 deletions

49
graphics/pvmpov/Makefile Normal file
View file

@ -0,0 +1,49 @@
# New ports collection makefile for: pvmpov
# Date created: 22 March 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= pvmpov
PORTVERSION= 3.1e.2
CATEGORIES= graphics
MASTER_SITES= http://www.luga.de/~flierl/pvmpov/
DISTNAME= ${PORTNAME}-3.1e2
EXTRACT_SUFX= .tgz
MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= nonexistent:${PORTSDIR}/graphics/povray31:configure \
aimk:${PORTSDIR}/net/pvm
RUN_DEPENDS= povray:${PORTSDIR}/graphics/povray31 \
pvmd:${PORTSDIR}/net/pvm
USE_XLIB= yes
WRKSRC= ${WRKDIR}/pvmpov3_1e_2
BUILDBASE= ${WRKSRC}/povray31/source/pvm
PVM_ROOT= ${LOCALBASE}/lib/pvm
pre-configure:
@ (cd ${PORTSDIR}/graphics/povray31/work && ${TAR} -c -f - povray31 ) \
| (cd ${WRKSRC} && ${TAR} --unlink -x -f -)
@ cd ${WRKSRC} && ${PATCH} -p0 -s < pvmpov.patch
@ ${PERL} -pi -e "s|%X11BASE%|${X11BASE}| ; s|%LOCALBASE%|${LOCALBASE}|" \
${BUILDBASE}/Makefile.aimk
do-build:
@ cd ${BUILDBASE} && \
${SETENV} PVM_ROOT=${PVM_ROOT} aimk newxwin
do-install:
@ ${MKDIR} ${PVM_ROOT}/bin/FREEBSD
@ ${MKDIR} ${PREFIX}/share/doc/pvmpov
@ ${INSTALL_PROGRAM} ${BUILDBASE}/FREEBSD/x-pvmpov ${PVM_ROOT}/bin/FREEBSD
@ ${LN} -sf ${PVM_ROOT}/bin/FREEBSD/x-pvmpov ${PREFIX}/bin/x-pvmpov
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/pvmpov
@ ${INSTALL_MAN} ${WRKSRC}/PVM* ${PREFIX}/share/doc/pvmpov
.endif
.include <bsd.port.mk>

1
graphics/pvmpov/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (pvmpov-3.1e2.tgz) = d2648d49bf0a500dc39cd9b2fb08e3dd

View file

@ -0,0 +1,28 @@
--- pvmpov.patch.orig Sun Sep 12 01:25:35 1999
+++ pvmpov.patch Wed Mar 22 12:37:19 2000
@@ -569,10 +569,10 @@
***************
*** 36,47 ****
- #define POV_RAY_VERSION "3.1e"
+ #define POV_RAY_VERSION "3.1g"
- #define DISTRIBUTION_MESSAGE_1 "This is an unofficial version compiled by:"
-! #define DISTRIBUTION_MESSAGE_2 "FILL IN NAME HERE........................."
+ #define DISTRIBUTION_MESSAGE_1 "This is an unofficial version compiled for"
+! #define DISTRIBUTION_MESSAGE_2 "FreeBSD, http://www.freebsd.org/"
#define DISTRIBUTION_MESSAGE_3 "The POV-Ray Team(tm) is not responsible for supporting this version."
/* Number of help pages (numbered 0 to MAX_HELP_PAGE). */
@@ -582,9 +582,9 @@
--- 39,50 ----
- #define POV_RAY_VERSION "3.1e"
+ #define POV_RAY_VERSION "3.1g"
- #define DISTRIBUTION_MESSAGE_1 "This is an unofficial version compiled by:"
+ #define DISTRIBUTION_MESSAGE_1 "This is an unofficial version compiled for"
! #define DISTRIBUTION_MESSAGE_2 "Jakob Flierl <flierl@luga.de> - PVMPOV Version 3.1e.2"
#define DISTRIBUTION_MESSAGE_3 "The POV-Ray Team(tm) is not responsible for supporting this version."

View file

@ -0,0 +1,77 @@
--- povray31/source/pvm/Makefile.aimk.orig Sun Sep 12 01:25:35 1999
+++ povray31/source/pvm/Makefile.aimk Wed Mar 22 13:17:46 2000
@@ -63,18 +63,18 @@
# Use libXXX.a if you want to force static linking of the libraries.
# Use -Llibdir -lXXX if you want to use shared libraries (if they are
# available). It doesn't matter if you only have libXXX.a libraries.
-PNGDIR = $(SRCDIR)/libpng
-LIBPNGINC = -I$(PNGDIR)
+PNGDIR =
+LIBPNGINC = -I%LOCALBASE%/include
#LIBPNGLIB = $(PNGDIR)/libpng.a
#LIBPNGINC = -I/usr/X11R6/include
-LIBPNGLIB = -L$(PNGDIR) -lpng
+LIBPNGLIB = -L%LOCALBASE%/lib -lpng
# LIBPNGLIB = -L/usr/lib -lpng
# LIBPNGLIB = -L/usr/X11R6/lib -lpng
# LIBPNGLIB =
-ZLIBDIR = $(SRCDIR)/zlib
-ZLIBINC = -I$(ZLIBDIR)
+ZLIBDIR =
+ZLIBINC =
#ZLIBLIB = $(ZLIBDIR)/libz.a
-ZLIBLIB = -L$(ZLIBDIR) -lz
+ZLIBLIB = -lz
#ZLIBLIB = -L/usr/local/lib -lz
@@ -92,7 +92,7 @@
#X11 = /usr/local/X11R6
#X11 = /usr/openwin # for some SunOS systems
#X11 = /usr/lpp/X11 # for some AIX systems
-X11 = /usr/X11R6
+X11 = %X11BASE%
# You probably won't need to change these if you have the X11 variable
# above set properly...
@@ -127,9 +127,8 @@
#
CC = gcc
OBJ = .o
-PVMINC = -I$(PVM_ROOT)/include
-PVMLIB = $(PVM_ROOT)/lib/$(PVM_ARCH)/libpvm3.a \
- $(PVM_ROOT)/lib/$(PVM_ARCH)/libgpvm3.a
+PVMINC = -I%LOCALBASE%/include
+PVMLIB = -L%LOCALBASE%/lib -lpvm3 -lgpvm3
#PVMLIB = /usr/lib/libpvm3.a \
# /usr/lib/libgpvm3.a
XDIR = $(HOME)/pvm3/bin/$(PVM_ARCH)
@@ -140,15 +139,15 @@
# some other possibilities for CFLAGS
#CFLAGS = -O2 -ansi -c -DCOMPILER_VER=\".`uname`.$(CC)\" \
- $(SRCINC) $(LIBPNGINC) $(ZLIBINC) $(XLIBINC)
+# $(SRCINC) $(LIBPNGINC) $(ZLIBINC) $(XLIBINC)
# HPUX compiler flags
#CFLAGS = +O2 -finline-functions -c -Aa -D_HPUX_SOURCE \
- -DCOMPILER_VER=\".`uname`.$(CC)\" \
- $(SRCINC) $(LIBPNGINC) $(ZLIBINC)
+# -DCOMPILER_VER=\".`uname`.$(CC)\" \
+# $(SRCINC) $(LIBPNGINC) $(ZLIBINC)
# ALPHA compiler flags
#CFLAGS = -O6 -ansi -finline-functions -c -Wall \
- -DCOMPILER_VER=\".`uname`.$(CC)\" \
- $(SRCINC) $(LIBPNGINC) $(ZLIBINC) $(XLIBINC)$(SRCINC)
+# -DCOMPILER_VER=\".`uname`.$(CC)\" \
+# $(SRCINC) $(LIBPNGINC) $(ZLIBINC) $(XLIBINC)$(SRCINC)
#
# and additional file needed for PVM
@@ -1079,7 +1078,6 @@
config.h \
$(SRCDIR)/frame.h \
$(SRCDIR)/optout.h \
- $(PNGDIR)/png.h \
$(SRCDIR)/png_pov.h \
$(SRCDIR)/point.h \
$(SRCDIR)/povproto.h \

View file

@ -0,0 +1,14 @@
--- povray31/source/pvm/pvm.h.orig Sun Sep 12 01:25:35 1999
+++ povray31/source/pvm/pvm.h Wed Mar 22 13:04:15 2000
@@ -23,9 +23,9 @@
* add it in permanently.
*/
-#include <features.h>
+/*#include <features.h>*/
-#if defined(SUN4SOL2) || defined(your_pvm_arch)
+#if defined(SUN4SOL2) || defined(__FreeBSD__)
#define NICE(x) nice(x)
extern int nice PARAMS((int prio));

View file

@ -0,0 +1 @@
Distributed rendering package for Persistence of Vision Ray Tracer

View file

@ -0,0 +1,5 @@
PVMPOV lets you unleash the power of your network connected computers with
POV-Ray. One master process distributes the rendering job over network and
collects the result from the POV-Ray slaves.
WWW: http://www.luga.de/~flierl/pvmpov/

View file

@ -0,0 +1,9 @@
bin/x-pvmpov
lib/pvm/bin/FREEBSD/x-pvmpov
share/doc/pvmpov/PVMPOV.Changelog
share/doc/pvmpov/PVMPOV.benchmark
share/doc/pvmpov/PVMPOV.example
share/doc/pvmpov/PVMPOV.general
share/doc/pvmpov/PVMPOV.install
share/doc/pvmpov/PVMPOV.radiosity
@dirrm share/doc/pvmpov