Fix build with OpenSSL 1.1.*

PR:		229019
Reported by:	brnrd
Obtained by:	Viktor Dukhovni <ietf-dane at dukhovni.org>
Reference:	https://lists.freebsd.org/pipermail/freebsd-python/2018-September/015429.html
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2018-09-24 11:14:18 +00:00
parent d690f81df4
commit 43ff95fcb6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=480594
3 changed files with 22 additions and 3 deletions

View file

@ -14,9 +14,6 @@ COMMENT= Crypto and SSL toolkit for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= Error: Syntax error in input(1).
BUILD_DEPENDS= swig3.0:devel/swig30
PYDISTUTILS_BUILDARGS= build_ext --include=${OPENSSLINC} --openssl=${OPENSSLBASE} --swig=${LOCALBASE}/bin/swig3.0

View file

@ -0,0 +1,11 @@
--- SWIG/_m2crypto.i.orig 2018-02-24 13:54:59 UTC
+++ SWIG/_m2crypto.i
@@ -57,7 +57,8 @@ static PyObject *x509_store_verify_cb_fu
#ifdef _WIN32
%include <windows.i>
#endif
+%include <openssl/e_os2.h>
%include <openssl/safestack.h>
/* Bring in LHASH_OF macro definition */
/* XXX Can't include lhash.h where LHASH_OF is defined, because it includes

View file

@ -0,0 +1,11 @@
--- setup.py.orig 2018-04-29 18:47:25 UTC
+++ setup.py
@@ -196,7 +196,7 @@ class _M2CryptoBuildExt(build_ext.build_
# swig seems to need the default header file directories
self.swig_opts.extend(['-I%s' % i for i in _get_additional_includes()])
- self.swig_opts.append('-includeall')
+ #self.swig_opts.append('-includeall')
self.swig_opts.append('-modern')
self.swig_opts.append('-builtin')