Upgrade to 5.0.0.
Note: to avoid conflicts with the other tidy-s, the previous names are kept.
This commit is contained in:
parent
ae2318a842
commit
445b90f015
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391007
5 changed files with 28 additions and 12 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= tidy-html5
|
||||
PORTVERSION= 4.9.36
|
||||
PORTVERSION= 5.0.0
|
||||
CATEGORIES= www
|
||||
|
||||
MAINTAINER= thierry@FreeBSD.org
|
||||
|
@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= htacg
|
||||
GH_PROJECT= ${PORTNAME}
|
||||
GH_TAGNAME= b65988c
|
||||
GH_TAGNAME= 1e70fc6
|
||||
|
||||
USES= cmake
|
||||
USE_GNOME= libxslt
|
||||
|
@ -27,6 +27,11 @@ PLIST_SUB= VER=${PORTVERSION}
|
|||
pre-configure:
|
||||
${REINPLACE_CMD} -e 's|build/cmake/||' ${WRKSRC}/test/testone.sh
|
||||
|
||||
post-install:
|
||||
# To avoid conflict ATM - to be removed later
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/tidy ${STAGEDIR}${PREFIX}/bin/tidy5
|
||||
${MV} ${STAGEDIR}${PREFIX}/lib/libtidy.so ${STAGEDIR}${PREFIX}/lib/libtidy5.so
|
||||
|
||||
regression-test:
|
||||
(cd ${WRKSRC}/test && ./testall.sh)
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (htacg-tidy-html5-4.9.36-b65988c_GH0.tar.gz) = dd4221eeb5bfcbd842126a583b0a27cc3a1550e59ddf2857caa44fdfced53792
|
||||
SIZE (htacg-tidy-html5-4.9.36-b65988c_GH0.tar.gz) = 680205
|
||||
SHA256 (htacg-tidy-html5-5.0.0-1e70fc6_GH0.tar.gz) = cf9bf72c49776c585ae85d4cea3dc5863c925852c69804c1189691e5751cd875
|
||||
SIZE (htacg-tidy-html5-5.0.0-1e70fc6_GH0.tar.gz) = 680570
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2015-05-20 18:09:57 UTC
|
||||
--- CMakeLists.txt.orig 2015-06-30 18:06:02 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -24,7 +24,7 @@ option( BUILD_SHARED_LIB "Set ON to buil
|
||||
@@ -42,7 +42,7 @@ option( BUILD_SHARED_LIB "Set OFF to NOT
|
||||
option( BUILD_TAB2SPACE "Set ON to build utility app, tab2space" OFF )
|
||||
option( BUILD_SAMPLE_CODE "Set ON to build the sample code" OFF )
|
||||
if (NOT MAN_INSTALL_DIR)
|
||||
|
|
11
www/tidy-html5/files/patch-test_testone.sh
Normal file
11
www/tidy-html5/files/patch-test_testone.sh
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- test/testone.sh.orig 2015-06-30 18:06:02 UTC
|
||||
+++ test/testone.sh
|
||||
@@ -19,7 +19,7 @@ set +f
|
||||
TESTNO=$1
|
||||
EXPECTED=$2
|
||||
#TIDY=../bin/tidy
|
||||
-TIDY=../build/cmake/tidy5
|
||||
+TIDY=../build/cmake/tidy
|
||||
if [ ! -f "$TIDY" ]; then
|
||||
echo "$BN: Can NOT locate binary '$TIDY'!"
|
||||
echo "$BN: Fix me with the correct location of the binary to run."
|
|
@ -1,10 +1,10 @@
|
|||
bin/tidy5
|
||||
include/buffio.h
|
||||
include/platform.h
|
||||
include/tidy.h
|
||||
include/tidybuffio.h
|
||||
include/tidyenum.h
|
||||
lib/libtidy5s.a
|
||||
include/tidyplatform.h
|
||||
lib/libtidy5.so
|
||||
lib/libtidy5.so.4
|
||||
lib/libtidy5.so.%%VER%%
|
||||
man/man1/tidy5.1.gz
|
||||
lib/libtidy.so.5
|
||||
lib/libtidy.so.%%VER%%
|
||||
lib/libtidys.a
|
||||
man/man1/tidy.1.gz
|
||||
|
|
Loading…
Reference in a new issue