www/chromium: update to 90.0.4430.93
MFH: 2021Q2 Security: https://vuxml.freebsd.org/freebsd/9fba80e0-a771-11eb-97a0-e09467587c17.html
This commit is contained in:
parent
fa9d483f12
commit
448693e731
5 changed files with 46 additions and 7 deletions
|
@ -1,7 +1,7 @@
|
|||
# Created by: Florent Thoumie <flz@FreeBSD.org>
|
||||
|
||||
PORTNAME= chromium
|
||||
PORTVERSION= 90.0.4430.85
|
||||
PORTVERSION= 90.0.4430.93
|
||||
CATEGORIES= www java
|
||||
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
|
||||
LOCAL/rene/chromium/:fonts
|
||||
|
@ -14,7 +14,6 @@ LICENSE= BSD3CLAUSE LGPL21 MPL11
|
|||
LICENSE_COMB= multi
|
||||
|
||||
BROKEN_FreeBSD_11_aarch64= components/safe_browsing_db/v4_rice.cc:120:18: use of overloaded operator '&' is ambiguous
|
||||
BROKEN_FreeBSD_11_i386= does not compile
|
||||
ONLY_FOR_ARCHS= aarch64 amd64 i386
|
||||
|
||||
BUILD_DEPENDS= bash:shells/bash \
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
TIMESTAMP = 1619007272
|
||||
SHA256 (chromium-90.0.4430.85.tar.xz) = 01c5594d4b7eaa67e00b4fa16ae0c9d35ec5917467abd387ba1b5cc332d44922
|
||||
SIZE (chromium-90.0.4430.85.tar.xz) = 917373872
|
||||
SHA256 (chromium-90.0.4430.85-testdata.tar.xz) = c2434c60103a0eff9cc449ddb7ddfd146560f0b6a7e8a8af9df728190fde9fda
|
||||
SIZE (chromium-90.0.4430.85-testdata.tar.xz) = 256581788
|
||||
TIMESTAMP = 1619508995
|
||||
SHA256 (chromium-90.0.4430.93.tar.xz) = 532ec75f4e08384fe2fb17b69af9210103379ee212dbf0bf081bdc5d4eca357e
|
||||
SIZE (chromium-90.0.4430.93.tar.xz) = 917357836
|
||||
SHA256 (chromium-90.0.4430.93-testdata.tar.xz) = fff80fe158223770d12a93ef67ca8690473c62e9b1997e59e991f32161659579
|
||||
SIZE (chromium-90.0.4430.93-testdata.tar.xz) = 256588960
|
||||
SHA256 (test_fonts-85.tar.xz) = f22b61b3639acb147c98ec2e2305d8b96f0b55c8c74c40e2ea696402fae8cef9
|
||||
SIZE (test_fonts-85.tar.xz) = 9511984
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
--- components/paint_preview/browser/paint_preview_client.cc.orig 2021-04-27 10:13:50 UTC
|
||||
+++ components/paint_preview/browser/paint_preview_client.cc
|
||||
@@ -302,8 +302,8 @@ void PaintPreviewClient::CapturePaintPreview(
|
||||
metadata->set_url(url.spec());
|
||||
metadata->set_version(kPaintPreviewVersion);
|
||||
auto* chromeVersion = metadata->mutable_chrome_version();
|
||||
- chromeVersion->set_major(CHROME_VERSION_MAJOR);
|
||||
- chromeVersion->set_minor(CHROME_VERSION_MINOR);
|
||||
+ chromeVersion->set_gmajor(CHROME_VERSION_MAJOR);
|
||||
+ chromeVersion->set_gminor(CHROME_VERSION_MINOR);
|
||||
chromeVersion->set_build(CHROME_VERSION_BUILD);
|
||||
chromeVersion->set_patch(CHROME_VERSION_PATCH);
|
||||
document_data.callback = std::move(callback);
|
|
@ -0,0 +1,13 @@
|
|||
--- components/paint_preview/common/proto/paint_preview.proto.orig 2021-04-27 07:39:47 UTC
|
||||
+++ components/paint_preview/common/proto/paint_preview.proto
|
||||
@@ -78,8 +78,8 @@ message PaintPreviewFrameProto {
|
||||
// Stores Chrome version.
|
||||
// NEXT_TAG = 5
|
||||
message ChromeVersionProto {
|
||||
- optional uint64 major = 1;
|
||||
- optional uint64 minor = 2;
|
||||
+ optional uint64 gmajor = 1;
|
||||
+ optional uint64 gminor = 2;
|
||||
optional uint64 build = 3;
|
||||
optional uint64 patch = 4;
|
||||
}
|
14
www/chromium/files/patch-mojo_core_channel.h
Normal file
14
www/chromium/files/patch-mojo_core_channel.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- mojo/core/channel.h.orig 2021-04-28 14:44:22 UTC
|
||||
+++ mojo/core/channel.h
|
||||
@@ -22,7 +22,11 @@
|
||||
namespace mojo {
|
||||
namespace core {
|
||||
|
||||
+#if defined(__i386__) && defined(OS_FREEBSD)
|
||||
+const size_t kChannelMessageAlignment = 4;
|
||||
+#else
|
||||
const size_t kChannelMessageAlignment = 8;
|
||||
+#endif
|
||||
|
||||
constexpr bool IsAlignedForChannelMessage(size_t n) {
|
||||
return n % kChannelMessageAlignment == 0;
|
Loading…
Reference in a new issue