math/py-CyLP: Add patch

This commit is contained in:
Yuri Victorovich 2023-12-20 11:23:06 -08:00
parent 50037fe84c
commit 4493b30696

View file

@ -0,0 +1,15 @@
--- pyproject.toml.orig 2023-11-01 20:21:56 UTC
+++ pyproject.toml
@@ -2,10 +2,10 @@
requires = [
'setuptools',
'wheel',
- 'Cython == 3.0.4',
+ 'Cython >= 3.0.4',
# https://numpy.org/devdocs/user/depending_on_numpy.html#build-time-dependency
# from https://github.com/scipy/oldest-supported-numpy/pull/78#issuecomment-1747936818:
- "oldest-supported-numpy; platform_python_implementation != 'PyPy'",
+ "numpy; platform_python_implementation != 'PyPy'",
"numpy; platform_python_implementation=='PyPy'"
]
build-backend = "setuptools.build_meta"