Add quick fix for fresh redis.

Also drop a note for UPDATING.

Feature safe:	yes
Pointy hat to:	osa
This commit is contained in:
Sergey A. Osokin 2011-11-23 11:56:53 +00:00
parent 59134b7c45
commit 449868b8a1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286303
2 changed files with 22 additions and 12 deletions

View file

@ -5,6 +5,16 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20111123:
AFFECTS: users of databases/redis
AUTHOR: osa@FreeBSD.org
The redis configuration file, redis.conf, have been changed, some options
removed in newer versions (>=2.4). In some cases, redis-server with
older configuration might does not run at startup.
If you run into startup problems, re-edit configuration file.
20111101:
AFFECTS: users of x11/kde4-workspace
AUTHOR: kde@FreeBSD.org

View file

@ -1,24 +1,24 @@
--- src/Makefile.orig 2011-09-14 10:32:32.000000000 +0400
+++ src/Makefile 2011-09-14 10:34:08.000000000 +0400
@@ -22,6 +22,9 @@
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
CCLINK?= -ldl -lnsl -lsocket -lm -lpthread
DEBUG?= -g -ggdb
--- src/Makefile.orig 2011-11-21 21:47:39.000000000 +0400
+++ src/Makefile 2011-11-23 06:29:54.000000000 +0400
@@ -28,6 +28,9 @@
CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
CCLINK?=-ldl -lnsl -lsocket -lm -lpthread
DEBUG?=-g -ggdb
+else ifeq ($(uname_S),FreeBSD)
+ CFLAGS?= $(CFLAGS)
+ CCLINK?= -pthread -lm
else
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
CCLINK?= -lm -pthread
@@ -32,9 +35,9 @@
CCLINK+= -ltcmalloc
CFLAGS+= -DUSE_TCMALLOC
CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
CCLINK?=-lm -pthread
@@ -52,9 +55,9 @@
ALLOC_FLAGS=-DUSE_JEMALLOC -I../deps/jemalloc/include
endif
-CCOPT= $(CFLAGS) $(ARCH) $(PROF)
+CCOPT= $(CFLAGS) $(PROF)
-PREFIX= /usr/local
+PREFIX?= $(PREFIX)
+PREFIX:= ${PREFIX}
INSTALL_BIN= $(PREFIX)/bin
INSTALL= cp -p