- Update to 3.51.26

- Fix pkg-plist when NOPORTDOCS is defined

PR:		ports/125547
Submitted by:	Sergey Prikhodko <sergey at network-asp.biz> (maintainer)
This commit is contained in:
Rong-En Fan 2008-07-17 14:23:36 +00:00
parent fcf29213d3
commit 44af92e3c0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=216954
9 changed files with 27 additions and 98 deletions

View file

@ -6,11 +6,11 @@
#
PORTNAME= mysql-connector-odbc
PORTVERSION= 3.51.12
PORTREVISION= 1
PORTVERSION= 3.51.26
DISTVERSIONSUFFIX= r1127
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MyODBC3
MASTER_SITE_SUBDIR= Connector-ODBC/3.51
PKGNAMESUFFIX= -${DRIVER_MANAGER}-mysql${MYSQL_VER}
MAINTAINER= sergey@network-asp.biz
@ -29,7 +29,8 @@ CONFIGURE_ARGS= --with-mysql-path=${LOCALBASE} --without-samples \
PLIST_SUB= VER=${PORTVERSION}
PORTDOCS= README
PORTDOCS= ChangeLog INSTALL LICENSE.exceptions LICENSE.gpl \
README README.debug
# MyODBC needs an ODBC driver manager to be installed, and it supports both
# iODBC and unixODBC.
@ -63,6 +64,13 @@ post-patch:
.if defined(ODBCVER)
@${REINPLACE_CMD} -e "s|ODBCVER 0x0250|ODBCVER ${ODBCVER}|" ${WRKSRC}/myodbc.h
.endif
@${REINPLACE_CMD} -e "s|^\(readmedir =\).*|\1 ${DOCSDIR}|" ${WRKSRC}/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e " \
/^ /s|install-readmeDATA||; \
/^install-data-am:/s|install-readmeDATA||; \
" ${WRKSRC}/Makefile.in
.endif
# XXX untested
.if defined(STATIC)
@ -70,10 +78,6 @@ CONFIGURE_ARGS+= --enable-shared=no --enable-static=yes
.endif
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.if !exists(${PREFIX}/lib/libmyodbc3.so.0)
@${LN} -s ${PREFIX}/lib/libmyodbc3-${PORTVERSION}.so ${PREFIX}/lib/libmyodbc3.so.0
.endif

View file

@ -1,3 +1,3 @@
MD5 (mysql-connector-odbc-3.51.12.tar.gz) = a484f590464fb823a8f821b2f1fd7fef
SHA256 (mysql-connector-odbc-3.51.12.tar.gz) = 7a9c19bd4ee140e7afe77fdcaecee53b4ce4bbbeb35a158c9548aa7ab9482c74
SIZE (mysql-connector-odbc-3.51.12.tar.gz) = 979942
MD5 (mysql-connector-odbc-3.51.26r1127.tar.gz) = ad2ac7a7dbef36f0d25bb1cdecc90389
SHA256 (mysql-connector-odbc-3.51.26r1127.tar.gz) = 78d6311946e92e72a40da6c6dfc06b0c4e7cb20d9431358351b2850c5e4a924a
SIZE (mysql-connector-odbc-3.51.26r1127.tar.gz) = 954125

View file

@ -1,11 +0,0 @@
--- driver/results.c.orig Sun Oct 9 22:33:40 2005
+++ driver/results.c Thu Oct 27 16:30:17 2005
@@ -558,7 +558,7 @@
SQLPOINTER CharacterAttributePtr,
SQLSMALLINT BufferLength,
SQLSMALLINT *StringLengthPtr,
- SQLPOINTER NumericAttributePtr )
+ SQLLEN *NumericAttributePtr )
#endif
{
return get_col_attr( StatementHandle,

View file

@ -1,6 +1,6 @@
--- configure.orig Sat Oct 29 20:43:26 2005
+++ configure Sat Oct 29 21:00:14 2005
@@ -1650,11 +1650,11 @@
--- configure.orig 2008-07-10 23:32:20.000000000 +0300
+++ configure 2008-07-10 23:33:51.000000000 +0300
@@ -1653,13 +1653,13 @@
# The aliases save the names the user supplied, while $host etc.
# will get canonicalized.
@ -8,12 +8,16 @@
- test "$program_prefix$program_suffix$program_transform_name" = \
- NONENONEs,x,x, &&
- program_prefix=${target_alias}-
-
-# When changing, also change VersionInfo.h and driver/myodbc3.def
-am__api_version="1.9"
+# test -n "$target_alias" &&
+# test "$program_prefix$program_suffix$program_transform_name" = \
+# NONENONEs,x,x, &&
+# program_prefix=${target_alias}-
+# am__api_version="1.9"
+#test -n "$target_alias" &&
+# test "$program_prefix$program_suffix$program_transform_name" = \
+# NONENONEs,x,x, &&
+# program_prefix=${target_alias}-
+#
+## When changing, also change VersionInfo.h and driver/myodbc3.def
+#am__api_version="1.9"
# Find a good install program. We prefer a C program (faster),
# so one script is as good as another. But avoid the broken or
# incompatible versions:

View file

@ -1,14 +0,0 @@
--- driver/connect.c.orig Sun Oct 9 22:33:40 2005
+++ driver/connect.c Thu Oct 27 16:44:37 2005
@@ -141,8 +141,10 @@
client_flag |= CLIENT_COMPRESS;
if (option_flag & FLAG_IGNORE_SPACE)
client_flag |= CLIENT_IGNORE_SPACE;
-
+
+#ifdef CLIENT_MULTI_RESULTS
client_flag |= CLIENT_MULTI_RESULTS;
+#endif
#ifdef __WIN__
if (option_flag & FLAG_NAMED_PIPE)
mysql_options(mysql,MYSQL_OPT_NAMED_PIPE,NullS);

View file

@ -1,15 +0,0 @@
--- driver/myodbc3.h.orig Sun Oct 9 22:33:40 2005
+++ driver/myodbc3.h Thu Oct 27 16:16:05 2005
@@ -101,7 +101,12 @@
#include <ltdl.h>
#include <sql.h>
#include <sqlext.h>
+
+# if defined(HAVE_IODBCINST_H)
+#include <iodbcinst.h>
+#elif defined(HAVE_ODBCINST_H)
#include <odbcinst.h>
+# endif
#ifndef SYSTEM_ODBC_INI
#define BOTH_ODBC_INI ODBC_BOTH_DSN

View file

@ -1,14 +0,0 @@
--- myodbcinst/myodbcinst.c.orig Mon Oct 10 05:49:47 2005
+++ myodbcinst/myodbcinst.c Thu Oct 27 16:33:29 2005
@@ -56,7 +56,11 @@
#include <ltdl.h>
#endif
+# if defined(HAVE_IODBCINST_H)
+#include <iodbcinst.h>
+#elif defined(HAVE_ODBCINST_H)
#include <odbcinst.h>
+# endif
#include "../util/MYODBCUtil.h"

View file

@ -1,11 +0,0 @@
--- util/MYODBCUtilReadDataSourceStr.c.orig Sun Oct 9 22:33:40 2005
+++ util/MYODBCUtilReadDataSourceStr.c Thu Oct 27 16:35:43 2005
@@ -20,7 +20,7 @@
#include "MYODBCUtil.h"
-#if defined(__APPLE__) || defined(WIN32) || defined(__sparc)
+#if defined(__APPLE__) || defined(WIN32) || defined(__sparc) || defined(__FreeBSD__)
char *strndup( const char *s, size_t n )
{
size_t nAvail;

View file

@ -1,14 +0,0 @@
--- util/MYODBCUtil.h.orig Sun Oct 9 22:33:40 2005
+++ util/MYODBCUtil.h Thu Oct 27 16:13:47 2005
@@ -40,7 +40,11 @@
#include <sqlext.h>
#endif
+# if defined(HAVE_IODBCINST_H)
+#include <iodbcinst.h>
+#elif defined(HAVE_ODBCINST_H)
#include <odbcinst.h>
+# endif
/*
Handle case on OSX where we want to use GetPrivateProfileString (because it