- Update to 2.1.1

- Patch to fix missing paren in src/filedir.c
- Patch for case insensitive hostname matching removed
  (now the default as of this version)

While I'm here:
- Respect hier(7): install examples into ${EXAMPLESDIR},
  docs into ${DOCSDIR}

PR:		61602
Submitted by:	maintainer
This commit is contained in:
Sergei Kolobov 2004-01-26 22:59:52 +00:00
parent 853399367b
commit 44f6e99f4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99236
8 changed files with 84 additions and 63 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= cfengine2
PORTVERSION= 2.1.0p1
PORTREVISION= 1
PORTVERSION= 2.1.1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iu.hio.no/pub/cfengine/ \
${MASTER_SITE_GNU}

View file

@ -1 +1 @@
MD5 (cfengine-2.1.0p1.tar.gz) = 3b2b132cb7d15f10818c0a05877d86da
MD5 (cfengine-2.1.1.tar.gz) = 71a91ec5283b45313b78fe00f8d1e042

View file

@ -1,33 +0,0 @@
--- src/cfagent.c.orig Fri Nov 28 16:14:34 2003
+++ src/cfagent.c Fri Nov 28 16:15:32 2003
@@ -615,7 +615,7 @@
{ struct Item *ip;
int n = 0;
-if (strstr(VSYSNAME.nodename,ToLowerStr(VDOMAIN)))
+if (strcasestr(VSYSNAME.nodename,VDOMAIN))
{
strcpy(VFQNAME,VSYSNAME.nodename);
--- src/cfservd.c.orig Fri Nov 28 16:14:49 2003
+++ src/cfservd.c Fri Nov 28 18:25:04 2003
@@ -423,7 +423,7 @@
i = 0;
-if (strstr(VSYSNAME.nodename,ToLowerStr(VDOMAIN)))
+if (strcasestr(VSYSNAME.nodename,VDOMAIN))
{
strncpy(VFQNAME,VSYSNAME.nodename,maxvarsize-1);
--- src/install.c.orig Fri Nov 28 16:14:39 2003
+++ src/install.c Fri Nov 28 16:21:06 2003
@@ -117,7 +117,7 @@
strcpy(VDOMAIN,value);
- if (!strstr(VSYSNAME.nodename,ToLowerStr(VDOMAIN)))
+ if (!strcasestr(VSYSNAME.nodename,VDOMAIN))
{
snprintf(VFQNAME,bufsize,"%s.%s",VSYSNAME.nodename,ToLowerStr(VDOMAIN));
strcpy(VUQNAME,VSYSNAME.nodename);

View file

@ -0,0 +1,11 @@
--- contrib/Makefile.in.orig Tue Jan 27 01:34:49 2004
+++ contrib/Makefile.in Tue Jan 27 01:35:03 2004
@@ -17,7 +17,7 @@
srcdir = @srcdir@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
-pkgdatadir = $(datadir)/@PACKAGE@
+pkgdatadir = $(prefix)/share/examples/cfengine2
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
top_builddir = ..

View file

@ -0,0 +1,24 @@
--- doc/Makefile.in.orig Sun Jan 11 17:16:59 2004
+++ doc/Makefile.in Tue Jan 27 01:31:55 2004
@@ -146,10 +146,10 @@
info_TEXINFOS = cfengine-Reference.texinfo cfengine-Tutorial.texinfo cfengine-Anomalies.texinfo
-docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
+docdir = $(prefix)/share/doc/cfengine2
doc_DATA =
# Info used in building and installing HTML files
-htmldir = $(pkgdatadir)/html
+htmldir = $(docdir)
htmlfiles = cfengine-Reference.html cfengine-Tutorial.html cfengine-Anomalies.html
html_DATA = $(htmlfiles)
@@ -161,7 +161,7 @@
# then uncomment the reference to ps2
psfiles = $(ps1) # $(ps2)
-psdir = $(pkgdatadir)/doc
+psdir = $(docdir)
ps_DATA = $(psfiles)
# Make sure these get distributed with everything else.

View file

@ -0,0 +1,11 @@
--- src/filedir.c.orig Mon Jan 19 19:22:26 2004
+++ src/filedir.c Mon Jan 19 19:22:39 2004
@@ -554,7 +554,7 @@
return;
}
#else
-if (((newperm & 07777) == (dstat->st_mode & 07777) && (action != touch)) /* file okay */
+if (((newperm & 07777) == (dstat->st_mode & 07777) && (action != touch))) /* file okay */
{
Debug("File okay, newperm = %o, stat = %o\n",(newperm & 07777),(dstat->st_mode & 07777));
fixmode = false;

View file

@ -0,0 +1,11 @@
--- inputs/Makefile.in.orig Tue Jan 27 01:33:35 2004
+++ inputs/Makefile.in Tue Jan 27 01:34:11 2004
@@ -17,7 +17,7 @@
srcdir = @srcdir@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
-pkgdatadir = $(datadir)/@PACKAGE@
+pkgdatadir = $(prefix)/share/examples/cfengine2
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
top_builddir = ..

View file

@ -7,30 +7,28 @@ sbin/cfkey
sbin/cfrun
sbin/cfservd
sbin/vicf
share/cfengine/cf.chflags.example
share/cfengine/cf.freebsd.example
share/cfengine/cf.ftp.example
share/cfengine/cf.groups.example
share/cfengine/cf.linux.example
share/cfengine/cf.main.example
share/cfengine/cf.motd.example
share/cfengine/cf.preconf.example
share/cfengine/cf.services.example
share/cfengine/cf.site.example
share/cfengine/cf.solaris.example
share/cfengine/cf.sun4.example
share/cfengine/cf.users.example
share/cfengine/cfagent.conf-advanced.example
share/cfengine/cfagent.conf.example
share/cfengine/cfengine.el
share/cfengine/cfrc.example
share/cfengine/cfrun.hosts.example
share/cfengine/cfservd.conf.example
share/cfengine/html/cfengine-Anomalies.html
share/cfengine/html/cfengine-Reference.html
share/cfengine/html/cfengine-Tutorial.html
share/cfengine/update.conf.example
@dirrm share/cfengine/html
@dirrm share/cfengine/doc
@dirrm share/cfengine
@dirrm doc/cfengine-2.1.0p1
%%EXAMPLESDIR%%/cf.chflags.example
%%EXAMPLESDIR%%/cf.freebsd.example
%%EXAMPLESDIR%%/cf.ftp.example
%%EXAMPLESDIR%%/cf.groups.example
%%EXAMPLESDIR%%/cf.linux.example
%%EXAMPLESDIR%%/cf.main.example
%%EXAMPLESDIR%%/cf.motd.example
%%EXAMPLESDIR%%/cf.preconf.example
%%EXAMPLESDIR%%/cf.services.example
%%EXAMPLESDIR%%/cf.site.example
%%EXAMPLESDIR%%/cf.solaris.example
%%EXAMPLESDIR%%/cf.sun4.example
%%EXAMPLESDIR%%/cf.users.example
%%EXAMPLESDIR%%/cfagent.conf-advanced.example
%%EXAMPLESDIR%%/cfagent.conf.example
%%EXAMPLESDIR%%/cfengine.el
%%EXAMPLESDIR%%/cfrc.example
%%EXAMPLESDIR%%/cfrun.hosts.example
%%EXAMPLESDIR%%/cfservd.conf.example
%%EXAMPLESDIR%%/update.conf.example
%%DOCSDIR%%/cfengine-Anomalies.html
%%DOCSDIR%%/cfengine-Reference.html
%%DOCSDIR%%/cfengine-Tutorial.html
@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%