Some makefile/install changes.

PR:		16572
Submitted by:	FUJISHIMA Satsuki <k5@cheerful.com>

Update to 1.0.8

PR:		17217
Submitted by:	Maxim Sobolev <sobomax@altavista.net>
This commit is contained in:
Chris Piazza 2000-03-06 22:16:57 +00:00
parent 065b75c49e
commit 45101f3259
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=26594
16 changed files with 248 additions and 208 deletions

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: SDL
# Version required: 1.0.4
# Version required: 1.0.8
# Date created: 8 August 1999
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
DISTNAME= SDL-1.0.4
PKGNAME= sdl-1.0.4
DISTNAME= SDL-1.0.8
PKGNAME= sdl-1.0.8
CATEGORIES= devel
MASTER_SITES= http://www.devolution.com/~slouken/SDL/release/
@ -30,12 +30,13 @@ CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads \
post-install:
@ ${MKDIR} ${PREFIX}/share/examples/SDL
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/SDL
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL
.endfor
@ cd ${WRKSRC}/docs; tar cf - `/bin/ls | ${GREP} -v Makefile` | \
@ cd ${WRKSRC}/docs; tar cf - `${ECHO} [^M]*` | \
(cd ${PREFIX}/share/doc/SDL; ${TAR} --unlink -xf - )
.endif

View file

@ -1 +1 @@
MD5 (SDL-1.0.4.tar.gz) = b90f4c9de63b4b3b82f65b6fe04fc76b
MD5 (SDL-1.0.8.tar.gz) = c58bcf59d41181c492a06cd10ce97a6a

View file

@ -1,15 +1,18 @@
--- configure.orig Tue Feb 8 03:53:58 2000
+++ configure Tue Feb 8 11:31:03 2000
@@ -3016,7 +3016,7 @@
echo "$ac_t""yes" 1>&6
CFLAGS="$CFLAGS -DESD_SUPPORT $ESD_CFLAGS"
- SYSTEM_LIBS="$SYSTEM_LIBS -lesd"
+ SYSTEM_LIBS="$SYSTEM_LIBS $ESD_LIBS"
else
echo "$ac_t""no" 1>&6
@@ -4326,7 +4326,7 @@
--- configure.orig Sat Mar 4 04:58:00 2000
+++ configure Mon Mar 6 13:40:33 2000
@@ -604,9 +604,9 @@
# libtool versioning
LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
-LT_CURRENT=`expr $SDL_MICRO_VERSION - $SDL_INTERFACE_AGE`
+LT_CURRENT=$SDL_INTERFACE_AGE
LT_REVISION=$SDL_INTERFACE_AGE
-LT_AGE=`expr $SDL_BINARY_AGE - $SDL_INTERFACE_AGE`
+LT_AGE=$SDL_INTERFACE_AGE
@@ -4324,7 +4324,7 @@
ac_save_libs="$LIBS"
case "$target" in
*-*-freebsd*)
@ -18,7 +21,7 @@
;;
*-*-openbsd*)
pthread_lib="-lc_r"
@@ -4366,7 +4366,7 @@
@@ -4364,7 +4364,7 @@
echo "$ac_t""$use_pthreads" 1>&6
if test x$use_pthreads = xyes; then
CFLAGS="$CFLAGS -D_REENTRANT -DSDL_USE_PTHREADS"
@ -27,40 +30,11 @@
SDL_LIBS="$SDL_LIBS $pthread_lib"
fi
fi
@@ -4955,6 +4955,7 @@
@@ -4953,6 +4953,7 @@
;;
*-*-freebsd*)
ARCH=freebsd
+ CheckNASM
+ CheckNASM
CheckESD
CheckX11
CheckPTHREAD
@@ -5038,6 +5039,28 @@
__EOF__
cat >>$new <$old
+
+ echo "Copying src/audio/linux/SDL_dspaudio.h -> src/audio/SDL_dspaudio.h"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.h"
+ new="$srcdir/src/audio/SDL_dspaudio.h"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
+
+ echo "Copying src/audio/linux/SDL_dspaudio.c -> src/audio/SDL_dspaudio.c"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.c"
+ new="$srcdir/src/audio/SDL_dspaudio.c"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
fi
# Set up files for the cdrom library
if test x$enable_cdrom = xyes; then

View file

@ -32,9 +32,6 @@ lib/libSDLmain.a
@exec /sbin/ldconfig -m %B
@unexec /sbin/ldconfig -R
share/aclocal/sdl.m4
share/doc/SDL/.codeblock
share/doc/SDL/.header
share/doc/SDL/.macros
share/doc/SDL/BUGS
share/doc/SDL/COPYING
share/doc/SDL/CREDITS
@ -64,9 +61,47 @@ share/doc/SDL/video/examples.html
share/doc/SDL/video/funclist.html
share/doc/SDL/video/functions.html
share/doc/SDL/video/index.html
share/examples/SDL/COPYING
share/examples/SDL/Makefile.am
share/examples/SDL/Makefile.in
share/examples/SDL/README
share/examples/SDL/acinclude.m4
share/examples/SDL/aclocal.m4
share/examples/SDL/autogen.sh
share/examples/SDL/checkkeys.c
share/examples/SDL/config.guess
share/examples/SDL/config.sub
share/examples/SDL/configure
share/examples/SDL/configure.in
share/examples/SDL/graywin.c
share/examples/SDL/icon.bmp
share/examples/SDL/install-sh
share/examples/SDL/loopwave.c
share/examples/SDL/missing
share/examples/SDL/mkinstalldirs
share/examples/SDL/picture.xbm
share/examples/SDL/sample.bmp
share/examples/SDL/sample.wav
share/examples/SDL/testalpha.c
share/examples/SDL/testbitmap.c
share/examples/SDL/testcdrom.c
share/examples/SDL/testerror.c
share/examples/SDL/testhread.c
share/examples/SDL/testkeys.c
share/examples/SDL/testlock.c
share/examples/SDL/testsprite.c
share/examples/SDL/testtimer.c
share/examples/SDL/testtypes.c
share/examples/SDL/testver.c
share/examples/SDL/testvidinfo.c
share/examples/SDL/testwin.c
share/examples/SDL/testwm.c
share/examples/SDL/threadwin.c
@dirrm share/examples/SDL
@dirrm share/doc/SDL/video
@dirrm share/doc/SDL/time
@dirrm share/doc/SDL/threads
@dirrm share/doc/SDL/opengl
@dirrm share/doc/SDL/images
@dirrm share/doc/SDL/events
@dirrm share/doc/SDL/cdrom

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: SDL
# Version required: 1.0.4
# Version required: 1.0.8
# Date created: 8 August 1999
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
DISTNAME= SDL-1.0.4
PKGNAME= sdl-1.0.4
DISTNAME= SDL-1.0.8
PKGNAME= sdl-1.0.8
CATEGORIES= devel
MASTER_SITES= http://www.devolution.com/~slouken/SDL/release/
@ -30,12 +30,13 @@ CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads \
post-install:
@ ${MKDIR} ${PREFIX}/share/examples/SDL
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/SDL
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL
.endfor
@ cd ${WRKSRC}/docs; tar cf - `/bin/ls | ${GREP} -v Makefile` | \
@ cd ${WRKSRC}/docs; tar cf - `${ECHO} [^M]*` | \
(cd ${PREFIX}/share/doc/SDL; ${TAR} --unlink -xf - )
.endif

View file

@ -1 +1 @@
MD5 (SDL-1.0.4.tar.gz) = b90f4c9de63b4b3b82f65b6fe04fc76b
MD5 (SDL-1.0.8.tar.gz) = c58bcf59d41181c492a06cd10ce97a6a

View file

@ -1,15 +1,18 @@
--- configure.orig Tue Feb 8 03:53:58 2000
+++ configure Tue Feb 8 11:31:03 2000
@@ -3016,7 +3016,7 @@
echo "$ac_t""yes" 1>&6
CFLAGS="$CFLAGS -DESD_SUPPORT $ESD_CFLAGS"
- SYSTEM_LIBS="$SYSTEM_LIBS -lesd"
+ SYSTEM_LIBS="$SYSTEM_LIBS $ESD_LIBS"
else
echo "$ac_t""no" 1>&6
@@ -4326,7 +4326,7 @@
--- configure.orig Sat Mar 4 04:58:00 2000
+++ configure Mon Mar 6 13:40:33 2000
@@ -604,9 +604,9 @@
# libtool versioning
LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
-LT_CURRENT=`expr $SDL_MICRO_VERSION - $SDL_INTERFACE_AGE`
+LT_CURRENT=$SDL_INTERFACE_AGE
LT_REVISION=$SDL_INTERFACE_AGE
-LT_AGE=`expr $SDL_BINARY_AGE - $SDL_INTERFACE_AGE`
+LT_AGE=$SDL_INTERFACE_AGE
@@ -4324,7 +4324,7 @@
ac_save_libs="$LIBS"
case "$target" in
*-*-freebsd*)
@ -18,7 +21,7 @@
;;
*-*-openbsd*)
pthread_lib="-lc_r"
@@ -4366,7 +4366,7 @@
@@ -4364,7 +4364,7 @@
echo "$ac_t""$use_pthreads" 1>&6
if test x$use_pthreads = xyes; then
CFLAGS="$CFLAGS -D_REENTRANT -DSDL_USE_PTHREADS"
@ -27,40 +30,11 @@
SDL_LIBS="$SDL_LIBS $pthread_lib"
fi
fi
@@ -4955,6 +4955,7 @@
@@ -4953,6 +4953,7 @@
;;
*-*-freebsd*)
ARCH=freebsd
+ CheckNASM
+ CheckNASM
CheckESD
CheckX11
CheckPTHREAD
@@ -5038,6 +5039,28 @@
__EOF__
cat >>$new <$old
+
+ echo "Copying src/audio/linux/SDL_dspaudio.h -> src/audio/SDL_dspaudio.h"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.h"
+ new="$srcdir/src/audio/SDL_dspaudio.h"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
+
+ echo "Copying src/audio/linux/SDL_dspaudio.c -> src/audio/SDL_dspaudio.c"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.c"
+ new="$srcdir/src/audio/SDL_dspaudio.c"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
fi
# Set up files for the cdrom library
if test x$enable_cdrom = xyes; then

View file

@ -32,9 +32,6 @@ lib/libSDLmain.a
@exec /sbin/ldconfig -m %B
@unexec /sbin/ldconfig -R
share/aclocal/sdl.m4
share/doc/SDL/.codeblock
share/doc/SDL/.header
share/doc/SDL/.macros
share/doc/SDL/BUGS
share/doc/SDL/COPYING
share/doc/SDL/CREDITS
@ -64,9 +61,47 @@ share/doc/SDL/video/examples.html
share/doc/SDL/video/funclist.html
share/doc/SDL/video/functions.html
share/doc/SDL/video/index.html
share/examples/SDL/COPYING
share/examples/SDL/Makefile.am
share/examples/SDL/Makefile.in
share/examples/SDL/README
share/examples/SDL/acinclude.m4
share/examples/SDL/aclocal.m4
share/examples/SDL/autogen.sh
share/examples/SDL/checkkeys.c
share/examples/SDL/config.guess
share/examples/SDL/config.sub
share/examples/SDL/configure
share/examples/SDL/configure.in
share/examples/SDL/graywin.c
share/examples/SDL/icon.bmp
share/examples/SDL/install-sh
share/examples/SDL/loopwave.c
share/examples/SDL/missing
share/examples/SDL/mkinstalldirs
share/examples/SDL/picture.xbm
share/examples/SDL/sample.bmp
share/examples/SDL/sample.wav
share/examples/SDL/testalpha.c
share/examples/SDL/testbitmap.c
share/examples/SDL/testcdrom.c
share/examples/SDL/testerror.c
share/examples/SDL/testhread.c
share/examples/SDL/testkeys.c
share/examples/SDL/testlock.c
share/examples/SDL/testsprite.c
share/examples/SDL/testtimer.c
share/examples/SDL/testtypes.c
share/examples/SDL/testver.c
share/examples/SDL/testvidinfo.c
share/examples/SDL/testwin.c
share/examples/SDL/testwm.c
share/examples/SDL/threadwin.c
@dirrm share/examples/SDL
@dirrm share/doc/SDL/video
@dirrm share/doc/SDL/time
@dirrm share/doc/SDL/threads
@dirrm share/doc/SDL/opengl
@dirrm share/doc/SDL/images
@dirrm share/doc/SDL/events
@dirrm share/doc/SDL/cdrom

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: SDL
# Version required: 1.0.4
# Version required: 1.0.8
# Date created: 8 August 1999
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
DISTNAME= SDL-1.0.4
PKGNAME= sdl-1.0.4
DISTNAME= SDL-1.0.8
PKGNAME= sdl-1.0.8
CATEGORIES= devel
MASTER_SITES= http://www.devolution.com/~slouken/SDL/release/
@ -30,12 +30,13 @@ CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads \
post-install:
@ ${MKDIR} ${PREFIX}/share/examples/SDL
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/SDL
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL
.endfor
@ cd ${WRKSRC}/docs; tar cf - `/bin/ls | ${GREP} -v Makefile` | \
@ cd ${WRKSRC}/docs; tar cf - `${ECHO} [^M]*` | \
(cd ${PREFIX}/share/doc/SDL; ${TAR} --unlink -xf - )
.endif

View file

@ -1 +1 @@
MD5 (SDL-1.0.4.tar.gz) = b90f4c9de63b4b3b82f65b6fe04fc76b
MD5 (SDL-1.0.8.tar.gz) = c58bcf59d41181c492a06cd10ce97a6a

View file

@ -1,15 +1,18 @@
--- configure.orig Tue Feb 8 03:53:58 2000
+++ configure Tue Feb 8 11:31:03 2000
@@ -3016,7 +3016,7 @@
echo "$ac_t""yes" 1>&6
CFLAGS="$CFLAGS -DESD_SUPPORT $ESD_CFLAGS"
- SYSTEM_LIBS="$SYSTEM_LIBS -lesd"
+ SYSTEM_LIBS="$SYSTEM_LIBS $ESD_LIBS"
else
echo "$ac_t""no" 1>&6
@@ -4326,7 +4326,7 @@
--- configure.orig Sat Mar 4 04:58:00 2000
+++ configure Mon Mar 6 13:40:33 2000
@@ -604,9 +604,9 @@
# libtool versioning
LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
-LT_CURRENT=`expr $SDL_MICRO_VERSION - $SDL_INTERFACE_AGE`
+LT_CURRENT=$SDL_INTERFACE_AGE
LT_REVISION=$SDL_INTERFACE_AGE
-LT_AGE=`expr $SDL_BINARY_AGE - $SDL_INTERFACE_AGE`
+LT_AGE=$SDL_INTERFACE_AGE
@@ -4324,7 +4324,7 @@
ac_save_libs="$LIBS"
case "$target" in
*-*-freebsd*)
@ -18,7 +21,7 @@
;;
*-*-openbsd*)
pthread_lib="-lc_r"
@@ -4366,7 +4366,7 @@
@@ -4364,7 +4364,7 @@
echo "$ac_t""$use_pthreads" 1>&6
if test x$use_pthreads = xyes; then
CFLAGS="$CFLAGS -D_REENTRANT -DSDL_USE_PTHREADS"
@ -27,40 +30,11 @@
SDL_LIBS="$SDL_LIBS $pthread_lib"
fi
fi
@@ -4955,6 +4955,7 @@
@@ -4953,6 +4953,7 @@
;;
*-*-freebsd*)
ARCH=freebsd
+ CheckNASM
+ CheckNASM
CheckESD
CheckX11
CheckPTHREAD
@@ -5038,6 +5039,28 @@
__EOF__
cat >>$new <$old
+
+ echo "Copying src/audio/linux/SDL_dspaudio.h -> src/audio/SDL_dspaudio.h"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.h"
+ new="$srcdir/src/audio/SDL_dspaudio.h"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
+
+ echo "Copying src/audio/linux/SDL_dspaudio.c -> src/audio/SDL_dspaudio.c"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.c"
+ new="$srcdir/src/audio/SDL_dspaudio.c"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
fi
# Set up files for the cdrom library
if test x$enable_cdrom = xyes; then

View file

@ -32,9 +32,6 @@ lib/libSDLmain.a
@exec /sbin/ldconfig -m %B
@unexec /sbin/ldconfig -R
share/aclocal/sdl.m4
share/doc/SDL/.codeblock
share/doc/SDL/.header
share/doc/SDL/.macros
share/doc/SDL/BUGS
share/doc/SDL/COPYING
share/doc/SDL/CREDITS
@ -64,9 +61,47 @@ share/doc/SDL/video/examples.html
share/doc/SDL/video/funclist.html
share/doc/SDL/video/functions.html
share/doc/SDL/video/index.html
share/examples/SDL/COPYING
share/examples/SDL/Makefile.am
share/examples/SDL/Makefile.in
share/examples/SDL/README
share/examples/SDL/acinclude.m4
share/examples/SDL/aclocal.m4
share/examples/SDL/autogen.sh
share/examples/SDL/checkkeys.c
share/examples/SDL/config.guess
share/examples/SDL/config.sub
share/examples/SDL/configure
share/examples/SDL/configure.in
share/examples/SDL/graywin.c
share/examples/SDL/icon.bmp
share/examples/SDL/install-sh
share/examples/SDL/loopwave.c
share/examples/SDL/missing
share/examples/SDL/mkinstalldirs
share/examples/SDL/picture.xbm
share/examples/SDL/sample.bmp
share/examples/SDL/sample.wav
share/examples/SDL/testalpha.c
share/examples/SDL/testbitmap.c
share/examples/SDL/testcdrom.c
share/examples/SDL/testerror.c
share/examples/SDL/testhread.c
share/examples/SDL/testkeys.c
share/examples/SDL/testlock.c
share/examples/SDL/testsprite.c
share/examples/SDL/testtimer.c
share/examples/SDL/testtypes.c
share/examples/SDL/testver.c
share/examples/SDL/testvidinfo.c
share/examples/SDL/testwin.c
share/examples/SDL/testwm.c
share/examples/SDL/threadwin.c
@dirrm share/examples/SDL
@dirrm share/doc/SDL/video
@dirrm share/doc/SDL/time
@dirrm share/doc/SDL/threads
@dirrm share/doc/SDL/opengl
@dirrm share/doc/SDL/images
@dirrm share/doc/SDL/events
@dirrm share/doc/SDL/cdrom

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: SDL
# Version required: 1.0.4
# Version required: 1.0.8
# Date created: 8 August 1999
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
DISTNAME= SDL-1.0.4
PKGNAME= sdl-1.0.4
DISTNAME= SDL-1.0.8
PKGNAME= sdl-1.0.8
CATEGORIES= devel
MASTER_SITES= http://www.devolution.com/~slouken/SDL/release/
@ -30,12 +30,13 @@ CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads \
post-install:
@ ${MKDIR} ${PREFIX}/share/examples/SDL
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/SDL
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL
.endfor
@ cd ${WRKSRC}/docs; tar cf - `/bin/ls | ${GREP} -v Makefile` | \
@ cd ${WRKSRC}/docs; tar cf - `${ECHO} [^M]*` | \
(cd ${PREFIX}/share/doc/SDL; ${TAR} --unlink -xf - )
.endif

View file

@ -1 +1 @@
MD5 (SDL-1.0.4.tar.gz) = b90f4c9de63b4b3b82f65b6fe04fc76b
MD5 (SDL-1.0.8.tar.gz) = c58bcf59d41181c492a06cd10ce97a6a

View file

@ -1,15 +1,18 @@
--- configure.orig Tue Feb 8 03:53:58 2000
+++ configure Tue Feb 8 11:31:03 2000
@@ -3016,7 +3016,7 @@
echo "$ac_t""yes" 1>&6
CFLAGS="$CFLAGS -DESD_SUPPORT $ESD_CFLAGS"
- SYSTEM_LIBS="$SYSTEM_LIBS -lesd"
+ SYSTEM_LIBS="$SYSTEM_LIBS $ESD_LIBS"
else
echo "$ac_t""no" 1>&6
@@ -4326,7 +4326,7 @@
--- configure.orig Sat Mar 4 04:58:00 2000
+++ configure Mon Mar 6 13:40:33 2000
@@ -604,9 +604,9 @@
# libtool versioning
LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
-LT_CURRENT=`expr $SDL_MICRO_VERSION - $SDL_INTERFACE_AGE`
+LT_CURRENT=$SDL_INTERFACE_AGE
LT_REVISION=$SDL_INTERFACE_AGE
-LT_AGE=`expr $SDL_BINARY_AGE - $SDL_INTERFACE_AGE`
+LT_AGE=$SDL_INTERFACE_AGE
@@ -4324,7 +4324,7 @@
ac_save_libs="$LIBS"
case "$target" in
*-*-freebsd*)
@ -18,7 +21,7 @@
;;
*-*-openbsd*)
pthread_lib="-lc_r"
@@ -4366,7 +4366,7 @@
@@ -4364,7 +4364,7 @@
echo "$ac_t""$use_pthreads" 1>&6
if test x$use_pthreads = xyes; then
CFLAGS="$CFLAGS -D_REENTRANT -DSDL_USE_PTHREADS"
@ -27,40 +30,11 @@
SDL_LIBS="$SDL_LIBS $pthread_lib"
fi
fi
@@ -4955,6 +4955,7 @@
@@ -4953,6 +4953,7 @@
;;
*-*-freebsd*)
ARCH=freebsd
+ CheckNASM
+ CheckNASM
CheckESD
CheckX11
CheckPTHREAD
@@ -5038,6 +5039,28 @@
__EOF__
cat >>$new <$old
+
+ echo "Copying src/audio/linux/SDL_dspaudio.h -> src/audio/SDL_dspaudio.h"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.h"
+ new="$srcdir/src/audio/SDL_dspaudio.h"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
+
+ echo "Copying src/audio/linux/SDL_dspaudio.c -> src/audio/SDL_dspaudio.c"
+ old="$srcdir/src/audio/linux/SDL_dspaudio.c"
+ new="$srcdir/src/audio/SDL_dspaudio.c"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+
fi
# Set up files for the cdrom library
if test x$enable_cdrom = xyes; then

View file

@ -32,9 +32,6 @@ lib/libSDLmain.a
@exec /sbin/ldconfig -m %B
@unexec /sbin/ldconfig -R
share/aclocal/sdl.m4
share/doc/SDL/.codeblock
share/doc/SDL/.header
share/doc/SDL/.macros
share/doc/SDL/BUGS
share/doc/SDL/COPYING
share/doc/SDL/CREDITS
@ -64,9 +61,47 @@ share/doc/SDL/video/examples.html
share/doc/SDL/video/funclist.html
share/doc/SDL/video/functions.html
share/doc/SDL/video/index.html
share/examples/SDL/COPYING
share/examples/SDL/Makefile.am
share/examples/SDL/Makefile.in
share/examples/SDL/README
share/examples/SDL/acinclude.m4
share/examples/SDL/aclocal.m4
share/examples/SDL/autogen.sh
share/examples/SDL/checkkeys.c
share/examples/SDL/config.guess
share/examples/SDL/config.sub
share/examples/SDL/configure
share/examples/SDL/configure.in
share/examples/SDL/graywin.c
share/examples/SDL/icon.bmp
share/examples/SDL/install-sh
share/examples/SDL/loopwave.c
share/examples/SDL/missing
share/examples/SDL/mkinstalldirs
share/examples/SDL/picture.xbm
share/examples/SDL/sample.bmp
share/examples/SDL/sample.wav
share/examples/SDL/testalpha.c
share/examples/SDL/testbitmap.c
share/examples/SDL/testcdrom.c
share/examples/SDL/testerror.c
share/examples/SDL/testhread.c
share/examples/SDL/testkeys.c
share/examples/SDL/testlock.c
share/examples/SDL/testsprite.c
share/examples/SDL/testtimer.c
share/examples/SDL/testtypes.c
share/examples/SDL/testver.c
share/examples/SDL/testvidinfo.c
share/examples/SDL/testwin.c
share/examples/SDL/testwm.c
share/examples/SDL/threadwin.c
@dirrm share/examples/SDL
@dirrm share/doc/SDL/video
@dirrm share/doc/SDL/time
@dirrm share/doc/SDL/threads
@dirrm share/doc/SDL/opengl
@dirrm share/doc/SDL/images
@dirrm share/doc/SDL/events
@dirrm share/doc/SDL/cdrom