- Use USES=dos2unix and remove CRLF in patch file

- Use USES=tar:tgz
- Use COPYTREE_SHARE instead of CP -R
- Simplify Makefile
- Bump PORTREVISION for package change
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2015-04-05 18:25:56 +00:00
parent c48f4a821b
commit 4533380fe7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383341
2 changed files with 15 additions and 19 deletions

View file

@ -3,13 +3,12 @@
PORTNAME= rdbc1
PORTVERSION= 001103
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= databases ruby
MASTER_SITES= http://homepage3.nifty.com/guion/SOFT/RDBC/ \
ftp://ftp.dinoex.de/pub/approved/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
@ -18,25 +17,22 @@ COMMENT= Ruby Database Connectivity
RUN_DEPENDS= rubygem-pg>=0:${PORTSDIR}/databases/rubygem-pg
USE_RUBY= yes
USES= dos2unix tar:tgz
DOS2UNIX_FILES= ora_rdbc1.rb pg_rdbc1.rb rdbc1.rb sample/test1.rb
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/*.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
cd ${WRKSRC}/doc/en/ && ${COPYTREE_SHARE} . ${STAGEDIR}${RUBY_MODDOCDIR}/
cd ${WRKSRC}/doc/ja/ && ${COPYTREE_SHARE} . ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.endif
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
${CP} -R ${WRKSRC}/doc/en/* ${STAGEDIR}${RUBY_MODDOCDIR}/
${CP} -R ${WRKSRC}/doc/ja/* ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
.endif
.include <bsd.port.mk>

View file

@ -1,11 +1,11 @@
--- pg_rdbc1.rb.orig Fri May 26 03:24:12 2000
+++ pg_rdbc1.rb Mon Mar 19 17:44:34 2001
@@ -11,7 +11,7 @@
require "rdbc1.rb"
module PG_RDBC1
- require "../postgres/postgres.so"
+ require "postgres"
include RDBC1
# Driver Creator will inherite me.
require "rdbc1.rb"
module PG_RDBC1
- require "../postgres/postgres.so"
+ require "postgres"
include RDBC1
# Driver Creator will inherite me.