o unbreak Alpha and prepare for other 64-bit platforms.
o add WITH_VORBIS and fix WITH_GSM. PR: 31413 Submitted by: Christian Weisgerber <naddy@mips.inka.de>, Dan Nelson <dnelson@allantgroup.com> (maintainer)
This commit is contained in:
parent
bcfaae4672
commit
457a95e101
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=49092
3 changed files with 54 additions and 7 deletions
|
@ -7,20 +7,32 @@
|
|||
|
||||
PORTNAME= sox
|
||||
PORTVERSION= 12.17.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= sox
|
||||
|
||||
MAINTAINER= dnelson@emsphone.com
|
||||
MAINTAINER= dnelson@emsphone.com
|
||||
|
||||
MAN1= sox.1 play.1 soxexam.1
|
||||
MLINKS= play.1 rec.1
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-fast-ulaw --enable-fast-alaw
|
||||
MAN1= sox.1 play.1 soxexam.1
|
||||
MLINKS= play.1 rec.1
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-fast-ulaw --enable-fast-alaw
|
||||
|
||||
.if defined(WITH_GSM)
|
||||
CONFIGURE_ARGS+= --with-gsmlib=${PREFIX}/lib --with-gsminc=${PREFIX}/include
|
||||
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
|
||||
CONFIGURE_ARGS+= --with-gsmlib=${LOCALBASE}/lib \
|
||||
--with-gsminc=${LOCALBASE}/include
|
||||
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-gsminc=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_VORBIS)
|
||||
CONFIGURE_ARGS+= --with-ogg-vorbisinc=${LOCALBASE}/include \
|
||||
--with-ogg-vorbislib=${LOCALBASE}/lib
|
||||
LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-ogg-vorbisinc=no
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
15
audio/sox/files/patch-ad
Normal file
15
audio/sox/files/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ima_rw.c.orig Sun Oct 21 00:11:17 2001
|
||||
+++ ima_rw.c Sun Oct 21 00:11:25 2001
|
||||
@@ -23,8 +23,8 @@
|
||||
#include <math.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
-#include "ima_rw.h"
|
||||
#include "st.h"
|
||||
+#include "ima_rw.h"
|
||||
|
||||
/*
|
||||
*
|
20
audio/sox/files/patch-ae
Normal file
20
audio/sox/files/patch-ae
Normal file
|
@ -0,0 +1,20 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- st.h.orig Sun Oct 21 00:13:45 2001
|
||||
+++ st.h Sun Oct 21 00:13:56 2001
|
||||
@@ -33,14 +33,9 @@
|
||||
#define st_free free
|
||||
|
||||
/* FIXME: Move to separate header */
|
||||
-#ifdef __alpha__
|
||||
#include <sys/types.h> /* To get defines for 32-bit integers */
|
||||
#define LONG int32_t
|
||||
#define ULONG u_int32_t
|
||||
-#else
|
||||
-#define LONG long
|
||||
-#define ULONG unsigned long
|
||||
-#endif
|
||||
|
||||
#define MAXLONG 0x7fffffffL
|
||||
#define MAXULONG 0xffffffffL
|
Loading…
Reference in a new issue