graphics/luminance: Update to 2.5.1

Release announcement:
	http://qtpfsgui.sourceforge.net/?p=335

PR:		221058
Submitted by:	goffredo@gmail.com (original version)
Approved by:	h2+fbsdports@fsfe.org (maintainer, timeout)
This commit is contained in:
Tobias C. Berner 2019-03-30 19:30:08 +00:00
parent 40a2f95af2
commit 457c582ab4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=497333
4 changed files with 68 additions and 128 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= luminance-hdr
DISTVERSION= 2.4.0
PORTREVISION= 30
DISTVERSION= 2.5.1
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
PKGNAMESUFFIX= -qt5
@ -14,32 +13,28 @@ COMMENT= Complete open source solution for HDR photography
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libfftw3f.so:math/fftw3-float \
libexiv2.so:graphics/exiv2 \
libIlmImf.so:graphics/openexr \
LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libHalf.so:graphics/ilmbase \
libtiff.so:graphics/tiff \
libgsl.so:math/gsl \
libraw_r.so:graphics/libraw \
libboost_system.so:devel/boost-libs
libfftw3f.so:math/fftw3-float \
libgsl.so:math/gsl \
libexiv2.so:graphics/exiv2 \
liblcms2.so:graphics/lcms2 \
libpng16.so:graphics/png \
libIlmImf.so:graphics/openexr \
libboost_date_time.so:devel/boost-libs
USES= cmake jpeg pkgconfig qt:5 tar:bzip2
USE_QT= concurrent gui printsupport sql webkit xml \
buildtools_build linguist_build qmake_build \
imageformats_run
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE=yes
USES= cmake desktop-file-utils jpeg pkgconfig qt:5 tar:bzip2
USE_QT= concurrent core declarative gui location network printsupport \
sql svg webchannel webengine widgets xml \
buildtools_build linguisttools_build qmake_build
CONFLICTS_INSTALL= luminance-hdr-[0-9]*
OPTIONS_DEFINE= DOCS
post-patch:
# Remove the non-required dependency on Qt5 Declarative. This can be dropped
# once www/qt5-webengine lands in the portstree and this port can be updated to
# a version >= 2.5.0.
@${REINPLACE_CMD} -e '/Qt5Declarative/d' \
${WRKSRC}/CMakeLists.txt
# Do not install yet another copy of GPL (we use license framework instead)
# and fix installation path for docs (but not for internal help files)
@${REINPLACE_CMD} -e '/LICENSE/d ; \
@ -50,13 +45,4 @@ post-patch:
s,share/doc/luminance-hdr,share/licenses/${PKGNAME},' \
${WRKSRC}/src/UI/UMessageBox.cpp
# Allow builds from release distfile to display correct git hash in "About"
# dialog window
@${REINPLACE_CMD} -e \
's,@GIT_SHA1@,be5409f2ed028b0a509d3f4cd44a970a09d2ef6c,' \
${WRKSRC}/src/Common/GitSHA1.cpp.in
pre-install:
QT_BINDIR_REL=bin
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (luminance-hdr-2.4.0.tar.bz2) = 14014eadab099944f051dd99447f6f47d455ffb0e4e0272d93a8e71fd96ad401
SIZE (luminance-hdr-2.4.0.tar.bz2) = 10507522
TIMESTAMP = 1553968553
SHA256 (luminance-hdr-2.5.1.tar.bz2) = a8986e0afba434a2e9da7e8aed19cdb763fedc8de2655bdb496c4ee9d3f41696
SIZE (luminance-hdr-2.5.1.tar.bz2) = 10238826

View file

@ -1,87 +0,0 @@
This is a bug fix commit required to make the port work correctly with Qt 5.3.
commit 07e36ef892343b01bf13545866823e6a55044382
Author: Davide Anastasia <davide.anastasia@gmail.com>
Date: Mon Sep 29 08:06:15 2014 +0100
Fix QPrinter support
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -18,19 +18,20 @@ include(cmake/Internationalization.cmake)
# to always look for includes there:
#set(CMAKE_INCLUDE_CURRENT_DIR ON)
-find_package(Qt5Core)
-find_package(Qt5Concurrent)
-find_package(Qt5Widgets)
-find_package(Qt5Gui)
-find_package(Qt5Declarative)
-find_package(Qt5WebKit)
-find_package(Qt5WebKitWidgets)
-find_package(Qt5Xml)
-find_package(Qt5Sql)
-find_package(Qt5Network)
-find_package(Qt5LinguistTools)
+find_package(Qt5Core REQUIRED)
+find_package(Qt5Concurrent REQUIRED)
+find_package(Qt5Widgets REQUIRED)
+find_package(Qt5Gui REQUIRED)
+find_package(Qt5Declarative REQUIRED)
+find_package(Qt5WebKit REQUIRED)
+find_package(Qt5WebKitWidgets REQUIRED)
+find_package(Qt5Xml REQUIRED)
+find_package(Qt5Sql REQUIRED)
+find_package(Qt5Network REQUIRED)
+find_package(Qt5LinguistTools REQUIRED)
+find_package(Qt5PrintSupport REQUIRED)
IF(WIN32)
- find_package(Qt5WinExtras)
+ find_package(Qt5WinExtras)
ENDIF()
# Include the qtmain lib if we are on the windows platform
--- src/HelpBrowser/CMakeLists.txt
+++ src/HelpBrowser/CMakeLists.txt
@@ -27,9 +27,8 @@ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
QT5_WRAP_CPP(FILES_MOC ${FILES_H})
QT5_WRAP_UI(FILES_UI_H ${FILES_UI})
-
ADD_LIBRARY(helpbrowser ${FILES_H} ${FILES_CPP} ${FILES_MOC} ${FILES_UI_H} ${FILES_HXX})
-qt5_use_modules(helpbrowser Core Concurrent Gui Widgets Xml WebKit WebKitWidgets)
+qt5_use_modules(helpbrowser Core Concurrent Gui Widgets Xml WebKit WebKitWidgets PrintSupport)
SET(FILES_TO_TRANSLATE ${FILES_TO_TRANSLATE} ${FILES_CPP} ${FILES_H} ${FILES_UI} ${FILES_HXX} PARENT_SCOPE)
SET(LUMINANCE_MODULES_GUI ${LUMINANCE_MODULES_GUI} helpbrowser PARENT_SCOPE)
--- src/HelpBrowser/helpbrowser.cpp
+++ src/HelpBrowser/helpbrowser.cpp
@@ -30,6 +30,7 @@ for which a new license (GPL+exception) is in place.
#include "ui_HelpBrowser.h"
#include "ui_HelpSideBar.h"
+#include <QDebug>
#include <QAction>
#include <QBuffer>
#include <QDir>
@@ -45,8 +46,6 @@ for which a new license (GPL+exception) is in place.
#include <QModelIndex>
#include <QModelIndexList>
#include <QPainter>
-#include <QPrinter>
-#include <QPrintDialog>
#include <QProcess>
#include <QPushButton>
#include <QString>
@@ -56,7 +55,10 @@ for which a new license (GPL+exception) is in place.
#include <QXmlDefaultHandler>
#include <QDesktopServices>
-#include <QDebug>
+#include <QtPrintSupport/QPrinter>
+#include <QtPrintSupport/QPrintDialog>
+
+
#include "Common/global.h"
#include "HelpBrowser/schelptreemodel.h"

View file

@ -1,10 +1,35 @@
bin/luminance-hdr
bin/luminance-hdr-cli
share/appdata/luminance-hdr.appdata.xml
share/applications/luminance-hdr.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/Changelog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.md
share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/hdrhtml/hdrhtml_c_b2.csv
%%DATADIR%%/hdrhtml/hdrhtml_c_b3.csv
%%DATADIR%%/hdrhtml/hdrhtml_c_b4.csv
%%DATADIR%%/hdrhtml/hdrhtml_c_b5.csv
%%DATADIR%%/hdrhtml/hdrhtml_default_templ/hdrhtml_image_templ.html
%%DATADIR%%/hdrhtml/hdrhtml_default_templ/hdrhtml_page_templ.html
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/hdr_viewer.css
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/hdr_viewer.js
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/information-red.png
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/information.png
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/loading-spinner.gif
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/mootools-1.2.4.js
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/mouse2touch.js
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/slider-black.png
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/slider-red.png
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_assets/slider-white.png
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_image_templ.html
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_image_templ_slider-above.html
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_page_templ.html
%%DATADIR%%/hdrhtml/hdrhtml_hdrlabs_templ/hdrhtml_page_templ_short.html
%%DATADIR%%/hdrhtml/hdrhtml_t_b2.csv
%%DATADIR%%/hdrhtml/hdrhtml_t_b3.csv
%%DATADIR%%/hdrhtml/hdrhtml_t_b4.csv
%%DATADIR%%/hdrhtml/hdrhtml_t_b5.csv
%%DATADIR%%/help/en/README
%%DATADIR%%/help/en/additional.html
%%DATADIR%%/help/en/basics.html
@ -26,26 +51,36 @@ share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/help/en/faq.html
%%DATADIR%%/help/en/features.html
%%DATADIR%%/help/en/hints.html
%%DATADIR%%/help/en/images/EditingTools-0.jpeg
%%DATADIR%%/help/en/images/EditingTools-1.jpeg
%%DATADIR%%/help/en/images/EditingTools-2.jpeg
%%DATADIR%%/help/en/images/Ghost-0.jpeg
%%DATADIR%%/help/en/images/NoGhost-0.jpeg
%%DATADIR%%/help/en/images/batch-hdr.png
%%DATADIR%%/help/en/images/batch-tmo.png
%%DATADIR%%/help/en/images/color_management.png
%%DATADIR%%/help/en/images/copy-exif.png
%%DATADIR%%/help/en/images/cropping_frame.png
%%DATADIR%%/help/en/images/edit_menu.png
%%DATADIR%%/help/en/images/editingtools-1.png
%%DATADIR%%/help/en/images/editingtools-2.png
%%DATADIR%%/help/en/images/editingtools-3.png
%%DATADIR%%/help/en/images/editingtools-4.png
%%DATADIR%%/help/en/images/editingtools-5.png
%%DATADIR%%/help/en/images/editingtools-6.png
%%DATADIR%%/help/en/images/hdrwizard.png
%%DATADIR%%/help/en/images/mainwin.png
%%DATADIR%%/help/en/images/not-translated-menu-item.png
%%DATADIR%%/help/en/images/preferences-menu.png
%%DATADIR%%/help/en/images/preferences.png
%%DATADIR%%/help/en/images/prefs-cms.png
%%DATADIR%%/help/en/images/prefs-ext.png
%%DATADIR%%/help/en/images/prefs-fast-export.png
%%DATADIR%%/help/en/images/prefs-hdr.png
%%DATADIR%%/help/en/images/prefs-raw-color.png
%%DATADIR%%/help/en/images/prefs-raw-corrections.png
%%DATADIR%%/help/en/images/prefs-raw-general.png
%%DATADIR%%/help/en/images/prefs-raw.png
%%DATADIR%%/help/en/images/prefs-tm.png
%%DATADIR%%/help/en/images/prefs-ui.png
%%DATADIR%%/help/en/images/projectiveTransformationDialog.png
%%DATADIR%%/help/en/images/resize.png
%%DATADIR%%/help/en/images/tonemappingpanel.png
%%DATADIR%%/help/en/images/translated-menu-item.png
%%DATADIR%%/help/en/index.html
%%DATADIR%%/help/en/manual.html
@ -53,6 +88,7 @@ share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/help/en/news.html
%%DATADIR%%/help/en/prefs.html
%%DATADIR%%/help/en/prefs_cms.html
%%DATADIR%%/help/en/prefs_fast_export.html
%%DATADIR%%/help/en/prefs_hdr.html
%%DATADIR%%/help/en/prefs_rawconversion.html
%%DATADIR%%/help/en/prefs_tonemapping.html
@ -61,9 +97,17 @@ share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/help/en/projective_transformation.html
%%DATADIR%%/help/en/style.css
%%DATADIR%%/help/en/tmap_ref.html
%%DATADIR%%/help/en/tmap_ref_ashikhmin.html
%%DATADIR%%/help/en/tmap_ref_drago.html
%%DATADIR%%/help/en/tmap_ref_durand.html
%%DATADIR%%/help/en/tmap_ref_fattal.html
%%DATADIR%%/help/en/tmap_ref_ferradans.html
%%DATADIR%%/help/en/tmap_ref_mai.html
%%DATADIR%%/help/en/tmap_ref_mantiuk06.html
%%DATADIR%%/help/en/tmap_ref_mantiuk08.html
%%DATADIR%%/help/en/tmap_ref_pattanaik.html
%%DATADIR%%/help/en/tmap_ref_reinhard02.html
%%DATADIR%%/help/en/tmap_ref_reinhard05.html
%%DATADIR%%/help/en/tonemapping.html
%%DATADIR%%/help/en/tonemapping_batch.html
%%DATADIR%%/help/en/tonemapping_cli.html
@ -78,14 +122,10 @@ share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/i18n/lang_hu.qm
%%DATADIR%%/i18n/lang_id.qm
%%DATADIR%%/i18n/lang_it.qm
%%DATADIR%%/i18n/lang_nl.qm
%%DATADIR%%/i18n/lang_pl.qm
%%DATADIR%%/i18n/lang_pt_BR.qm
%%DATADIR%%/i18n/lang_ro.qm
%%DATADIR%%/i18n/lang_ru.qm
%%DATADIR%%/i18n/lang_tr.qm
%%DATADIR%%/i18n/lang_zh.qm
%%DATADIR%%/i18n/qt_fi.qm
%%DATADIR%%/i18n/qt_it.qm
%%DATADIR%%/i18n/qt_ro.qm
%%DATADIR%%/i18n/qt_tr.qm
%%DATADIR%%/i18n/qt_zh.qm