Add meqcc 1.4, MrElusive's QuakeC compiler.
This commit is contained in:
parent
f7ab4556e7
commit
458f7331db
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=126577
8 changed files with 109 additions and 0 deletions
|
@ -284,6 +284,7 @@
|
|||
SUBDIR += mangband
|
||||
SUBDIR += marathon-evil
|
||||
SUBDIR += marbles
|
||||
SUBDIR += meqcc
|
||||
SUBDIR += merlin
|
||||
SUBDIR += mindfocus
|
||||
SUBDIR += mindguard
|
||||
|
|
39
games/meqcc/Makefile
Normal file
39
games/meqcc/Makefile
Normal file
|
@ -0,0 +1,39 @@
|
|||
# New ports collection makefile for: meQCC
|
||||
# Date created: 16 Jan 2005
|
||||
# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= meqcc
|
||||
PORTVERSION= 1.4
|
||||
CATEGORIES= games devel
|
||||
MASTER_SITES= http://wiki.quakesrc.org/files/ \
|
||||
http://freebsd.nsu.ru/distfiles/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}src
|
||||
|
||||
MAINTAINER= danfe@FreeBSD.org
|
||||
COMMENT= MrElusive's QuakeC compiler
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_ZIP= yes
|
||||
|
||||
MAKEFILE= ${WRKSRC}/linux.mak
|
||||
|
||||
post-extract:
|
||||
@${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|h|mak|txt)" -print0 | \
|
||||
${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
|
||||
@${REINPLACE_CMD} -e 's/<io\.h>/<unistd\.h>/' ${WRKSRC}/cmdlib.c \
|
||||
${WRKSRC}/qcc.c ${WRKSRC}/l_log.c
|
||||
@${REINPLACE_CMD} -e '/<conio\.h>/d' ${WRKSRC}/l_log.c
|
||||
@${REINPLACE_CMD} -e 's/unsigned long t/time_t t/' ${WRKSRC}/l_precomp.c
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/qcc ${PREFIX}/bin/${PORTNAME}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/[^g]*.txt ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
games/meqcc/distinfo
Normal file
2
games/meqcc/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (meqcc14src.zip) = e0189332470ca4d53d34964b03faec62
|
||||
SIZE (meqcc14src.zip) = 100418
|
11
games/meqcc/files/patch-cmdlib.c
Normal file
11
games/meqcc/files/patch-cmdlib.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- cmdlib.c.orig Sat Jan 15 20:08:10 2005
|
||||
+++ cmdlib.c Sat Jan 15 20:03:02 2005
|
||||
@@ -141,6 +141,8 @@
|
||||
================
|
||||
*/
|
||||
// MrE:
|
||||
+long int tell (int);
|
||||
+
|
||||
long int filelength (int handle)
|
||||
{
|
||||
/*
|
24
games/meqcc/files/patch-l_memory.c
Normal file
24
games/meqcc/files/patch-l_memory.c
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- l_memory.c.orig Sat Jan 15 20:19:09 2005
|
||||
+++ l_memory.c Sat Jan 15 20:19:04 2005
|
||||
@@ -10,11 +10,12 @@
|
||||
// Tab Size: 3
|
||||
//===========================================================================
|
||||
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
#include "qcc.h"
|
||||
#include "l_log.h"
|
||||
|
||||
|
||||
+#if 0
|
||||
/*
|
||||
=================
|
||||
MemorySize
|
||||
@@ -31,6 +32,7 @@
|
||||
#endif
|
||||
#endif
|
||||
} //end of the function MemorySize
|
||||
+#endif
|
||||
|
||||
/*
|
||||
=================
|
20
games/meqcc/files/patch-linux.mak
Normal file
20
games/meqcc/files/patch-linux.mak
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- linux.mak.orig Sat Jan 15 19:59:27 2005
|
||||
+++ linux.mak Sat Jan 15 19:59:20 2005
|
||||
@@ -1,5 +1,4 @@
|
||||
-# for Linux/DJGPP
|
||||
-CFLAGS = -g -O2 -Wall
|
||||
+CFLAGS += -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp
|
||||
|
||||
EXES = qcc
|
||||
|
||||
@@ -21,8 +20,8 @@
|
||||
clean:
|
||||
rm -f *.o *~ $(EXES)
|
||||
|
||||
-.c.o: ; gcc -c $(CFLAGS) -o $@ $*.c
|
||||
+.c.o: ; $(CC) -c $(CFLAGS) -o $@ $*.c
|
||||
|
||||
QCCFILES = qcc.o pr_lex.o pr_comp.o cmdlib.o l_log.o l_memory.o l_script.o l_precomp.o
|
||||
qcc : $(QCCFILES)
|
||||
- gcc -o qcc $(QCCFILES)
|
||||
+ $(CC) -o qcc $(QCCFILES)
|
7
games/meqcc/pkg-descr
Normal file
7
games/meqcc/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
This is a modification to the Quake-C compiler from id Software. It allows
|
||||
for creating a `progs.dat' which cannot be decompiled to Quake-C source code.
|
||||
As an added bonus a `progs.dat' which cannot be decompiled is a lot smaller.
|
||||
The compiler also has a C compatible precompiler. A description of the
|
||||
precompiler directives can be found in a regular C manual.
|
||||
|
||||
WWW: http://wiki.quakesrc.org/index.php/meQCC
|
5
games/meqcc/pkg-plist
Normal file
5
games/meqcc/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
bin/meqcc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/meqcc.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/qcc.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/readme.txt
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue