Add gkrellm-gtodo, a GkrellM2 plugin that tracks tasks and to-do items. It also

supports deadline reminder alarms, tracking of time spent on individual
tasks, and task-diary (sort of) through task comments.

PR:		ports/66045
Submitted by:	Tobias Roth <ports@fsck.ch>
This commit is contained in:
Pav Lucistnik 2004-05-02 21:39:29 +00:00
parent 9c7873a965
commit 45cff1ac26
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108214
5 changed files with 72 additions and 0 deletions

View file

@ -35,6 +35,7 @@
SUBDIR += gdesklets-starterbar
SUBDIR += gemcal
SUBDIR += genius
SUBDIR += gkrellm-gtodo
SUBDIR += glabels
SUBDIR += gmcal
SUBDIR += gnomeblog

View file

@ -0,0 +1,33 @@
# New ports collection makefile for: gkrellm-gtodo
# Date created: Wed Apr 28 08:31:22 CEST 2004
# Whom: Tobias Roth <ports@fsck.ch>
#
# $FreeBSD$
#
PORTNAME= gtodo
PORTVERSION= 0.2.5.a
CATEGORIES= deskutils
MASTER_SITES= http://voidtrance.home.comcast.net/software/files/gtodo/ \
http://depot.fsck.ch/mirror/distfiles/
PKGNAMEPREFIX= gkrellm-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-0.2.5a
MAINTAINER= ports@fsck.ch
COMMENT= GKrellM2 plugin that tracks tasks and to-do items
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
PLIST_FILES= libexec/gkrellm2/plugins/gkrellm-gtodo.so
WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PKGNAMEPREFIX}${PORTNAME}.so \
${PREFIX}/libexec/gkrellm2/plugins/
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
MD5 (gkrellm-gtodo-0.2.5a.tar.gz) = 6d00732619d2b0cc1191cc8f3979d644
SIZE (gkrellm-gtodo-0.2.5a.tar.gz) = 58891

View file

@ -0,0 +1,30 @@
--- Makefile.orig Wed Apr 28 08:51:42 2004
+++ Makefile Wed Apr 28 09:15:38 2004
@@ -11,15 +11,15 @@
USER_INSTALL_PATH ?= $(HOME)/.gkrellm2/plugins
## executables
-CC = gcc
+CC ?= gcc
RM = rm -f
INSTALL ?= install -m 755
## Compiler and Linker flags
## Theoretically, you should not need to change these
## but if the make does not work look into it
-CFLAGS = -fPIC -Wall -I. $(shell pkg-config gtk+-2.0 --cflags)
-LIBFLAGS = -shared $(shell pkg-config gtk+-2.0 --libs)
+CFLAGS += -fPIC -Wall -I. `pkg-config gtk+-2.0 --cflags`
+LIBFLAGS = -shared `pkg-config gtk+-2.0 --libs`
## Set all the locale converstion stuff
## if necessary
@@ -29,7 +29,7 @@
CFLAGS += -DENABLE_NLS -DLOCALEDIR=\"$(LOCALEDIR)\"
export enable_nls
endif
-CFLAGS += -DPACKAGE="\"$(PACKAGE)\""
+#CFLAGS += -DPACKAGE="\"$(PACKAGE)\""
export PACKAGE LOCALEDIR
## File name and target definitions

View file

@ -0,0 +1,6 @@
This is a GkrellM2 plugin that tracks tasks and to-do items. It also
supports deadline reminder alarms, tracking of time spent on individual
tasks, and task-diary (sort of) through task comments.
Author: Dimitar Haralanov <fulcrumusa@netscape.net>
WWW: http://voidtrance.home.comcast.net/software/