[maintainer update]: security/samba-vscan fix atoll problem on 4.X
- Fix atoll problem with FreeBSD 4.X. PR: ports/90645 Submitted by: Jean Milanez Melo <jmelo@freebsdbrasil.com.br>
This commit is contained in:
parent
daf77eba94
commit
45e3e7a3a4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151627
2 changed files with 17 additions and 1 deletions
|
@ -28,6 +28,12 @@ ETCDIR= ${PREFIX}/etc/samba-vscan
|
|||
PKGMESSAGE= ${WRKDIR}/pkg-message
|
||||
VSCAN_SAMBA_PORT?=samba3
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
EXTRA_PATCHES=${FILESDIR}/extra_patch-*
|
||||
.endif
|
||||
|
||||
.if ${VSCAN_SAMBA_PORT} == "samba3"
|
||||
PLIST_SUB= VFSDIR=lib/samba/vfs
|
||||
.else
|
||||
|
@ -58,4 +64,4 @@ post-install:
|
|||
@${SED} "s|%%PREFIX%%|${PREFIX}|g;" ${.CURDIR}/pkg-message > ${PKGMESSAGE}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
10
security/samba-vscan/files/extra_patch-vscan-parameter.c
Normal file
10
security/samba-vscan/files/extra_patch-vscan-parameter.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- global/vscan-parameter.c.orig Mon Dec 12 01:36:54 2005
|
||||
+++ global/vscan-parameter.c Mon Dec 12 01:36:54 2005
|
||||
@@ -162,6 +162,7 @@
|
||||
*/
|
||||
/* FIXME: changed atoi to atoll, but atoll might not be available
|
||||
on all platforms! */
|
||||
+ #define atoll(a) strtoll((a), (char **)NULL, 10)
|
||||
vscan_config->common.max_size = atoll(value);
|
||||
DEBUG(3, ("max file size is: %lld\n", (long long)vscan_config->common.max_size));
|
||||
|
Loading…
Reference in a new issue