multimedia/sabbu: link using ffmpeg0
- Link using ffmpeg0 Approved by: portmgr (bapt, implicit)
This commit is contained in:
parent
ddef80a87d
commit
460d6992fe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=329854
3 changed files with 29 additions and 7 deletions
|
@ -2,14 +2,14 @@
|
|||
|
||||
PORTNAME= sabbu
|
||||
PORTVERSION= 0.3.0
|
||||
PORTREVISION= 13
|
||||
PORTREVISION= 14
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Sabbu%20${PORTVERSION}
|
||||
|
||||
MAINTAINER= dinoex@FreeBSD.org
|
||||
COMMENT= Program used to time subtitles
|
||||
|
||||
LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg \
|
||||
LIB_DEPENDS= libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0 \
|
||||
sndfile:${PORTSDIR}/audio/libsndfile
|
||||
|
||||
NO_STAGE= yes
|
||||
|
@ -20,8 +20,8 @@ USE_GMAKE= yes
|
|||
GNU_CONFIGURE= yes
|
||||
|
||||
USE_GNOME= gtk20
|
||||
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lswscale
|
||||
CFLAGS+= -I${LOCALBASE}/include/ffmpeg0 ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib/ffmpeg0 -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lswscale0
|
||||
|
||||
OPTIONS_DEFINE= GTKSPELL
|
||||
OPTIONS_DEFAULT=GTKSPELL
|
||||
|
@ -47,4 +47,12 @@ LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
|
|||
BROKEN= Does not configure on powerpc
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's,ffmpeg/avformat,libavformat/avformat,g' \
|
||||
-e 's,lavcodec,lavcodec0,g' \
|
||||
-e 's,lavformat,lavformat0,g' \
|
||||
-e 's,lavswscale,lavswscale0,g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
13
multimedia/sabbu/files/patch-Source-Makefile.in
Normal file
13
multimedia/sabbu/files/patch-Source-Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Source/Makefile.in.orig 2013-10-08 23:05:45.410158951 -0300
|
||||
+++ Source/Makefile.in 2013-10-08 23:09:15.165157059 -0300
|
||||
@@ -100,8 +100,8 @@
|
||||
DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
|
||||
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
||||
am__depfiles_maybe = depfiles
|
||||
-CXXCOMPILE = $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
|
||||
- $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
+CXXCOMPILE = $(CXX) $(DEFS) $(AM_CXXFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) \
|
||||
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(CXXFLAGS)
|
||||
CXXLD = $(CXX)
|
||||
CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) \
|
||||
-o $@
|
|
@ -1,12 +1,13 @@
|
|||
--- Source/video.h.orig Thu Jul 14 17:52:07 2005
|
||||
+++ Source/video.h Sun Jun 17 08:57:32 2007
|
||||
--- Source/video.h.orig 2005-07-14 12:52:07.000000000 -0300
|
||||
+++ Source/video.h 2013-10-08 23:10:25.214159730 -0300
|
||||
@@ -23,11 +23,13 @@
|
||||
};
|
||||
|
||||
#else
|
||||
+extern "C" {
|
||||
#ifndef _WINDOWS
|
||||
#include <ffmpeg/avformat.h>
|
||||
-#include <ffmpeg/avformat.h>
|
||||
+#include <libavformat/avformat.h>
|
||||
#else
|
||||
#include "video_ffmpeg.h"
|
||||
#endif
|
||||
|
|
Loading…
Reference in a new issue