- Add LICENSE_FILE

- Switch to options helpers
- Regenerate patches with `make makepatch`
This commit is contained in:
Dmitry Marakasov 2015-10-14 23:51:17 +00:00
parent 54138bd6c3
commit 4675e5abe8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=399315
4 changed files with 15 additions and 10 deletions

View file

@ -16,6 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fast program for analysing WWW logfiles
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/Licence.txt
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
libpng.so:${PORTSDIR}/graphics/png
@ -41,8 +42,12 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/lang/* ${STAGEDIR}${DATADIR}/lang
${MKDIR} ${STAGEDIR}${IMGDIR}
${INSTALL_DATA} ${WRKSRC}/images/* ${STAGEDIR}${IMGDIR}
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.cfg ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/anlgform.html ${STAGEDIR}${EXAMPLESDIR}

View file

@ -1,5 +1,5 @@
--- analog.cfg.orig Sun Mar 23 13:56:53 2003
+++ analog.cfg Sun May 11 09:25:33 2003
--- analog.cfg.orig 2004-12-19 13:51:22 UTC
+++ analog.cfg
@@ -10,7 +10,8 @@
#
# If you need a LOGFORMAT command (most people don't -- try it without first!),

View file

@ -1,5 +1,5 @@
--- src/Makefile.orig Sun Dec 19 05:51:30 2004
+++ src/Makefile Sun Jan 9 12:50:26 2005
--- src/Makefile.orig 2004-12-19 13:51:30 UTC
+++ src/Makefile
@@ -2,16 +2,23 @@
# Please read docs/Readme.html, or http://www.analog.cx/
# This is a general Unix-like Makefile: Makefiles for other OS's can be found
@ -26,7 +26,7 @@
# ... -DNOOPEN -DNOFOLLOW -DNOALARM -DNOGRAPHICS -DNOGMTIME ...
# ... -DEBCDIC -DUSE_PLAIN_SETJMP ...
# ... -DHAVE_GD -DHAVE_ZLIB -DHAVE_BZLIB -DHAVE_PCRE ...
@@ -31,6 +38,12 @@
@@ -31,6 +38,12 @@ DEFS = # any combination of -DN
OS = UNIX # Operating system: UNIX, DOS, WIN32, MAC, OS2, OSX, VMS
# RISCOS, BEOS, NEXTSTEP, MPEIX, BS2000, AS400, OS390
LIBS = -lm # extra libraries needed; most platforms (but not OS X or BeOS)

View file

@ -1,6 +1,6 @@
--- src/tree.c.orig 2004-12-19 08:51:31.000000000 -0500
+++ src/tree.c 2011-08-01 12:49:29.176805068 -0400
@@ -769,11 +769,13 @@
--- src/tree.c.orig 2004-12-19 13:51:31 UTC
+++ src/tree.c
@@ -769,11 +769,13 @@ void Bnextname(char **name, char **namee
if (((*name = strstr(whole, "Mosaic")) != NULL && (len = 6)) ||
((*name = strstr(whole, "mosaic")) != NULL && (len = 6)) ||
((*name = strstr(whole, "Konqueror")) != NULL && (len = 9)) ||
@ -14,7 +14,7 @@
((*name = strstr(whole, "Camino")) != NULL && (len = 6)) ||
((*name = strstr(whole, "Safari")) != NULL && (len = 6)) ||
((*name = strstr(whole, "WebTV")) != NULL && (len = 5)) ||
@@ -871,7 +873,17 @@
@@ -871,7 +873,17 @@ void Pnextname(char **name, char **namee
else
*name = "Windows:Unknown Windows";
}
@ -33,7 +33,7 @@
*name = "Windows:Unknown Windows";
else
*name = "Windows:Windows NT";
@@ -904,8 +916,16 @@
@@ -904,8 +916,16 @@ void Pnextname(char **name, char **namee
*name = "Macintosh";
else if (strstr(whole, "Linux") != NULL || strstr(whole, "linux") != NULL)
*name = "Unix:Linux";