- Update to 1.8.4

PR:		ports/91556
Submitted by:	Alexander Wittig <alexander@wittig.name>
This commit is contained in:
Pav Lucistnik 2006-01-14 13:25:43 +00:00
parent 9a98e29af8
commit 468362a5b7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=153456
7 changed files with 700 additions and 476 deletions

View file

@ -136,7 +136,7 @@ _RUBY_SITEDIR!= ${_RUBY_CONFIG} 'puts C["sitedir"]'
RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
.if defined(RUBY_VER) && ${RUBY_VER} == 1.8
RUBY_VERSION?= 1.8.2
RUBY_VERSION?= 1.8.4
#RUBY_DISTVERSION?= ${RUBY_VERSION}
#RUBY_PATCHFILES?= ruby-${RUBY_DISTVERSION}-yyyy.mm.dd.diff.bz2

View file

@ -7,20 +7,12 @@
PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR_RUBY}
DISTFILES= ${RUBY_DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= ruby
PATCH_SITES= ${MASTER_SITE_RUBY}
#PATCH_SITE_SUBDIR= snapshots
PATCH_SITE_SUBDIR= 1.8
PATCHFILES= ${RUBY_PATCHFILES}
#PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= An object-oriented interpreted scripting language
@ -34,7 +26,6 @@ PLIST_SUB+= ONIGURUMA=""
PLIST_SUB+= ONIGURUMA="@comment "
.endif
#USE_BZIP2= yes
USE_OPENSSL= yes
RUBY_VER= 1.8
@ -43,12 +34,12 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
#USE_AUTOCONF= yes # does not work with 2.13; requires 2.53 or later
USE_REINPLACE= yes
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--enable-shared
--enable-shared \
--with-openssl-include=${PREFIX}/include
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LIBS="${PTHREAD_LIBS}"
@ -60,18 +51,15 @@ STRIP= # none
INSTALLS_SHLIB= yes
MAN1= ${RUBY_NAME}.1
LATEST_LINK= ruby-devel
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502102
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
.endif
.if ${ARCH} == "ia64"
BROKEN= "Segfault during build on ia64"
.endif
MAKE_ARGS= -j3
# Uncomment if it still segfaults with 1.8.4
#.if ${ARCH} == "ia64"
#BROKEN= "Segfault during build on ia64"
#.endif
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
@ -137,10 +125,10 @@ post-patch:
${REINPLACE_CMD} -e 's|-l$$pthread_lib|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
.for d in Win32API win32ole
${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm iconv tcltklib tk
.for d in gdbm iconv tk
${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
@ -176,6 +164,8 @@ post-install:
${SETENV} LC_TIME=C /bin/date > ${RUBY_SITERIDIR}/created.rid
.if !defined(NOPORTDOCS)
${CP} -R ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/
${MKDIR} ${RUBY_EXAMPLESDIR}/bigdecimal
${INSTALL_DATA} ${WRKSRC}/ext/bigdecimal/sample/*.rb ${RUBY_EXAMPLESDIR}/bigdecimal
${MKDIR} ${RUBY_EXAMPLESDIR}/curses
${INSTALL_DATA} ${WRKSRC}/ext/curses/hello.rb ${WRKSRC}/ext/curses/rain.rb ${WRKSRC}/ext/curses/view.rb ${RUBY_EXAMPLESDIR}/curses
${MKDIR} ${RUBY_EXAMPLESDIR}/dl

View file

@ -1,6 +1,3 @@
MD5 (ruby/ruby-1.8.2.tar.gz) = 8ffc79d96f336b80f2690a17601dea9b
SHA256 (ruby/ruby-1.8.2.tar.gz) = 34cf95791323c96dc92c672c16daaef69f00a0ba69e1c43bab893ae38b7eeb3e
SIZE (ruby/ruby-1.8.2.tar.gz) = 3627349
MD5 (ruby/1.8.2-patch1.gz) = 4f32bae4546421a20a9211253da103d3
SHA256 (ruby/1.8.2-patch1.gz) = d9d85c4bba4d2cba4c065c4fa58da7e3071137c1a0958cbb085e5b6749cf5a08
SIZE (ruby/1.8.2-patch1.gz) = 1347
MD5 (ruby/ruby-1.8.4.tar.gz) = bd8c2e593e1fa4b01fd98eaf016329bb
SHA256 (ruby/ruby-1.8.4.tar.gz) = 71432841b3965b7ab2d83f0dc7c3049195ea4e9267a8dc2d825a8a0466982930
SIZE (ruby/ruby-1.8.4.tar.gz) = 4312965

View file

@ -1,19 +0,0 @@
--- ext/dl/extconf.rb.orig Mon Oct 21 23:52:24 2002
+++ ext/dl/extconf.rb Sun Jul 20 00:55:25 2003
@@ -183,6 +183,16 @@
]
create_makefile('dl')
+
+if (Config::CONFIG['CC'] =~ /gcc/) && (Config::CONFIG['arch'] =~ /i.86/)
+ open('Makefile', 'r+') {|f|
+ s = f.read
+ f.rewind
+ f.print s.gsub(/^(CFLAGS\s*=.*\s)-m(cpu|arch)=\S+/, "\\1")
+ f.truncate f.tell
+ }
+end
+
rescue SystemExit
# do nothing
end

View file

@ -1,25 +0,0 @@
--- ext/extmk.rb 6 Feb 2005 15:13:50 -0000 1.44.2.8
+++ ext/extmk.rb 2 Mar 2005 10:53:20 -0000 1.44.2.9
@@ -157,6 +157,10 @@ def parse_args()
grep(/\A-(?!-).*#{'%c' % flag}/i) { return true }
false
end
+ def $mflags.defined?(var)
+ grep(/\A#{var}=(.*)/) {return $1}
+ false
+ end
if $mflags.set?(?n)
$dryrun = true
@@ -165,7 +169,10 @@ def parse_args()
end
$continue = $mflags.set?(?k)
- $mflags |= ["DESTDIR=#{$destdir}"]
+ if !$destdir.to_s.empty?
+ $destdir = File.expand_path($destdir)
+ $mflags.defined?("DESTDIR") or $mflags << "DESTDIR=#{$destdir}"
+ end
end
parse_args()

View file

@ -0,0 +1,11 @@
--- lib/mkmf.rb.orig Mon Nov 28 01:22:53 2005
+++ lib/mkmf.rb Thu Jan 12 01:35:31 2006
@@ -1153,7 +1153,7 @@
mfile.print <<-SITEINSTALL
-site-install: site-install-so site-install-rb
+site-install: site-install-so site-install-rb install
site-install-so: install-so
site-install-rb: install-rb

File diff suppressed because it is too large Load diff