Add ptl. PTL (Portable Thread Library) is an implementation of user

level multi-thread library based on POSIX 1003.1c API.
This commit is contained in:
Akinori MUSHA 2001-04-07 19:38:07 +00:00
parent 61ea4aa6e3
commit 46aa7c0001
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41044
8 changed files with 130 additions and 0 deletions

View file

@ -359,6 +359,7 @@
SUBDIR += projectcenter.app
SUBDIR += pth
SUBDIR += pth-devel
SUBDIR += ptl
SUBDIR += py-coro
SUBDIR += py-functional
SUBDIR += py-game

47
devel/ptl/Makefile Normal file
View file

@ -0,0 +1,47 @@
# New ports collection makefile for: PTL
# Date created: 8 April 2001
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= ptl
PORTVERSION= 2.1.8
CATEGORIES= devel
MASTER_SITES= ftp://ftp.media.osaka-cu.ac.jp/pub/%SUBDIR%/ \
ftp://ftp.ics.es.osaka-u.ac.jp/pub/mirrors/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME:U}/${PORTNAME:U}2
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
MAKE_ARGS= prefix="${PREFIX}"
INSTALLS_SHLIB= yes
DOCS= COPYING ChangeLog FAQ NEWS \
PROBLEMS README README.PDB README.jp \
WISHLIST doc/manual.ps.gz
post-patch:
${PERL} -i -pe 's/-O[2-6]/${CFLAGS}/g' \
${WRKSRC}/Util/Makefile.in \
${WRKSRC}/Util/configure \
${WRKSRC}/libaltsys/utils/configure
post-install:
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/${PORTNAME:U}
cd ${PREFIX} && ( \
find ${PORTNAME:U} -type f -o -type l | sort; \
find ${PORTNAME:U} -type d | sort -r | ${SED} 's/^/@dirrm /'; \
) >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/doc/PTL.info* ${PREFIX}/info/
.for f in ${DOCS}
${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
.endfor
.endif
.include <bsd.port.mk>

1
devel/ptl/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (PTL-2.1.8.tar.gz) = 4c367786201c3a12ae687d1aaa3ef517

View file

@ -0,0 +1,27 @@
--- Makefile.orig Sat Sep 23 07:05:15 2000
+++ Makefile Sun Apr 8 02:47:24 2001
@@ -7,13 +7,13 @@
#
# Install directory
-prefix = /usr/local
+prefix ?= /usr/local
exec_prefix = $(prefix)
# Directory to install ptlgcc
dest_bindir = $(exec_prefix)/bin
# Directory to install libPTL.a and libPTL.so
-dest_libdir = $(exec_prefix)/PTL/lib
+dest_libdir = $(exec_prefix)/lib
# Directory to install include files
# This directory must NOT be /usr/local/include
dest_includedir = $(exec_prefix)/PTL/include
@@ -27,7 +27,7 @@
# make distclean Cleanup PTL (A.*)
#
-AUTOCONFBINDIR = /usr/local/bin
+AUTOCONFBINDIR = $(exec_prefix)/bin
ARCHPROG = ./Util/config.guess
SHELL = /bin/sh
# Exported variable CC will confuse configure script ...

View file

@ -0,0 +1,11 @@
--- Util/Makefile.in.orig Sun Apr 8 03:00:36 2001
+++ Util/Makefile.in Sun Apr 8 03:21:21 2001
@@ -117,7 +117,7 @@
STATIC_LIBRARY = libPTL.a
PROFLIBRARY = libPTL_p.a
SHARED_LIBRARY = libPTL.so
-SLIBVER = 2.0
+SLIBVER = 2
ALTSYS_LINK = -L$(altsysdir) -laltsys `cat $(altsysdir)/linker_opt`

1
devel/ptl/pkg-comment Normal file
View file

@ -0,0 +1 @@
A user level multi-thread library based on POSIX 1003.1c API

18
devel/ptl/pkg-descr Normal file
View file

@ -0,0 +1,18 @@
PTL -- Portable Thread Library
PTL is an implementation of a user level multi-thread library based on
POSIX 1003.1c API. You can create and control multiple threads
(control flow) in one UNIX process using PTL.
For example, PTL can be used for following purposes.
- Network server/client program
- Concurrent processing
- Simulating distributed or parallel algorithms
- Study of multi thread programming
This library is based on the standard "POSIX 1003.1c" and works on BSD
UNIX (architecture-independent!)
WWW: http://www.media.osaka-cu.ac.jp/~k-abe/PTL/
Author: Kota ABE <k-abe@media.osaka-cu.ac.jp>

24
devel/ptl/pkg-plist Normal file
View file

@ -0,0 +1,24 @@
bin/ptlgcc
bin/ptlg++
lib/libPTL.a
lib/libPTL.so
lib/libPTL.so.2
%%PORTDOCS%%@unexec install-info --delete %D/info/PTL.info %D/info/dir
%%PORTDOCS%%info/PTL.info
%%PORTDOCS%%info/PTL.info-1
%%PORTDOCS%%info/PTL.info-2
%%PORTDOCS%%info/PTL.info-3
%%PORTDOCS%%info/PTL.info-4
%%PORTDOCS%%@exec install-info %D/info/PTL.info %D/info/dir
%%PORTDOCS%%share/doc/ptl/COPYING
%%PORTDOCS%%share/doc/ptl/ChangeLog
%%PORTDOCS%%share/doc/ptl/FAQ
%%PORTDOCS%%share/doc/ptl/NEWS
%%PORTDOCS%%share/doc/ptl/PROBLEMS
%%PORTDOCS%%share/doc/ptl/README
%%PORTDOCS%%share/doc/ptl/README.PDB
%%PORTDOCS%%share/doc/ptl/README.jp
%%PORTDOCS%%share/doc/ptl/WISHLIST
%%PORTDOCS%%share/doc/ptl/manual.ps.gz
%%PORTDOCS%%@dirrm share/doc/ptl
@comment PTL/* is environment dependent and thus added dynamically hereinafter: