vietnamese/x-unikey: Fix build with Clang 6

data.cpp💯15: error: constant expression evaluates to -72 which cannot be narrowed to type 'unsigned char' [-Wc++11-narrowing]
{{'A','a','<B8>','<B8>','<B5>','<B5>','<B6>','<B6>','<B7>','<B7>','<B9>','<B9>',      // 0: a
                 ^~~~~~

http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/vi-x-unikey-1.0.4.log

- While here prevent build from asking an interactive question
  during the install phase
This commit is contained in:
Tobias Kortkamp 2018-08-25 14:22:46 +00:00
parent 336eab338e
commit 46d328db5c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478043
2 changed files with 14 additions and 1 deletions

View file

@ -9,10 +9,13 @@ MASTER_SITES= SF/unikey/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Vietnamese input method for X
USES= tar:bzip2
USES= compiler tar:bzip2
USE_XORG= x11
GNU_CONFIGURE= yes
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-c++11-narrowing
PLIST_FILES= bin/unikey bin/ukxim
.include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
Do not ask an interactive question during the install phase.
--- src/xim/install.sh.orig 2018-08-25 14:18:57 UTC
+++ src/xim/install.sh
@@ -1,4 +1,5 @@
#!/bin/sh
+exit 0
echo
echo "To use UniKey, certain environment variables must be set."
echo "Do you want to set these variables in /etc/profile? (y/N)"