- Unbreak by updating to version 1.4.3
- Drop now unneeded dependency to deskutils/kdepim3
This commit is contained in:
parent
2f6c228b00
commit
46d9d5084a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164340
18 changed files with 254 additions and 116 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= kmess
|
||||
PORTVERSION= 1.4.2
|
||||
PORTVERSION= 1.4.3
|
||||
CATEGORIES= net-im kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -14,22 +14,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= MSN Messenger Client for KDE3
|
||||
|
||||
LIB_DEPENDS= mimelib.1:${PORTSDIR}/deskutils/kdepim3
|
||||
|
||||
BROKEN= Does not compile
|
||||
EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-configure
|
||||
|
||||
USE_KDELIBS_VER=3
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GMAKE= yes
|
||||
|
||||
pre-patch:
|
||||
${REINPLACE_CMD} -e '23s/^$$/#include <unistd.h>/' \
|
||||
${WRKSRC}/kmess/kmessview.cpp
|
||||
${REINPLACE_CMD} -e '20s/^$$/#include <ctype.h>/' \
|
||||
${WRKSRC}/kmess/network/mimemessage.h
|
||||
${REINPLACE_CMD} -e '35s|^$$|#include <netinet/in.h>|' \
|
||||
${WRKSRC}/kmess/network/msnconnection.h
|
||||
${REINPLACE_CMD} -e 's/-pedantic //g; s/-O2//g; \
|
||||
s/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
|
||||
post-patch:
|
||||
@${TOUCH} ${WRKSRC}/config.h.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (kmess-1.4.2.tar.gz) = e3d368ffbce6ee629e900d4a1134752e
|
||||
SHA256 (kmess-1.4.2.tar.gz) = 864dae86f5fc4a2d40698b382b4f6642c5d0e3d111a3c4732374dc7226f942d6
|
||||
SIZE (kmess-1.4.2.tar.gz) = 2336147
|
||||
MD5 (kmess-1.4.3.tar.gz) = 88c73b2223cbb0dc2b79023188fba64a
|
||||
SHA256 (kmess-1.4.3.tar.gz) = f571847704618c2d364dee731a8d3a5a59ff423b77e52160cb147ebec8ffd526
|
||||
SIZE (kmess-1.4.3.tar.gz) = 1869940
|
||||
|
|
11
net-im/kmess-kde4/files/patch-kmess-Makefile.in
Normal file
11
net-im/kmess-kde4/files/patch-kmess-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kmess/Makefile.in.orig Sun Jun 4 16:44:43 2006
|
||||
+++ kmess/Makefile.in Sun Jun 4 16:45:06 2006
|
||||
@@ -470,7 +470,7 @@
|
||||
|
||||
# the library search path.
|
||||
# the -lpthread is required for Autopackage/BinReloc
|
||||
-kmess_LDFLAGS = $(KDE_RPATH) $(all_libraries) -lpthread
|
||||
+kmess_LDFLAGS = $(KDE_RPATH) $(all_libraries)
|
||||
AM_CXXFLAGS = -ggdb
|
||||
#>- all: all-recursive
|
||||
#>+ 1
|
11
net-im/kmess-kde4/files/patch-kmess-crypt-bithelp.h
Normal file
11
net-im/kmess-kde4/files/patch-kmess-crypt-bithelp.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kmess/crypt/bithelp.h.orig Sun Jun 4 13:38:04 2006
|
||||
+++ kmess/crypt/bithelp.h Sun Jun 4 13:39:09 2006
|
||||
@@ -20,8 +20,6 @@
|
||||
#ifndef G10_BITHELP_H
|
||||
#define G10_BITHELP_H
|
||||
|
||||
-#include <stdint.h>
|
||||
-
|
||||
/****************
|
||||
* Rotate the 32 bit unsigned integer X by N bits left/right
|
||||
*/
|
13
net-im/kmess-kde4/files/patch-kmess-crypt-globalstuff.h
Normal file
13
net-im/kmess-kde4/files/patch-kmess-crypt-globalstuff.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- kmess/crypt/globalstuff.h.orig Fri May 21 04:00:44 2004
|
||||
+++ kmess/crypt/globalstuff.h Sun Jun 4 13:48:21 2006
|
||||
@@ -16,9 +16,9 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <string>
|
||||
#include <sstream>
|
||||
-#include <stdint.h>
|
||||
|
||||
/** convert something to string using ostringstream */
|
||||
template <class T> inline
|
11
net-im/kmess-kde4/files/patch-kmess-kmessview.cpp
Normal file
11
net-im/kmess-kde4/files/patch-kmess-kmessview.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kmess/kmessview.cpp.orig Sun Jun 4 15:13:33 2006
|
||||
+++ kmess/kmessview.cpp Sun Jun 4 15:14:27 2006
|
||||
@@ -1058,7 +1058,7 @@
|
||||
{
|
||||
Contact *contact = getContactByItem( contactListView_->currentItem() );
|
||||
Group *oldGroup = getGroupByItem( contactListView_->currentItem() );
|
||||
- QString oldGroupId = (oldGroup != 0 ? oldGroup->getId() : "0");
|
||||
+ QString oldGroupId = (oldGroup != 0 ? oldGroup->getId() : QString::fromLatin1("0"));
|
||||
|
||||
if(contact != 0)
|
||||
{
|
10
net-im/kmess-kde4/files/patch-kmess-kmessview.h
Normal file
10
net-im/kmess-kde4/files/patch-kmess-kmessview.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- kmess/kmessview.h.orig Sun Jun 4 15:46:03 2006
|
||||
+++ kmess/kmessview.h Sun Jun 4 15:59:14 2006
|
||||
@@ -187,6 +187,7 @@
|
||||
private:
|
||||
KMessView *kmessView_;
|
||||
};
|
||||
+ friend class ToolTip;
|
||||
|
||||
// Reference to the current tooltip
|
||||
ToolTip *toolTip_;
|
|
@ -0,0 +1,11 @@
|
|||
--- kmess/network/applications/p2papplication.cpp.orig Sun Jun 4 15:00:05 2006
|
||||
+++ kmess/network/applications/p2papplication.cpp Sun Jun 4 15:00:44 2006
|
||||
@@ -2056,7 +2056,7 @@
|
||||
// Get message content and Content-Type
|
||||
bool gotTransferInvitation = (invitationContentType_ == "application/x-msnmsgr-transreqbody");
|
||||
QString content = message.getFields();
|
||||
- QString contentType = (gotTransferInvitation ? "application/x-msnmsgr-transrespbody" : invitationContentType_);
|
||||
+ QString contentType = (gotTransferInvitation ? QString::fromLatin1("application/x-msnmsgr-transrespbody") : invitationContentType_);
|
||||
|
||||
QString myHandle = CurrentAccount::instance()->getHandle();
|
||||
|
|
@ -1,51 +1,25 @@
|
|||
bin/kmess
|
||||
share/applications/kde/kmess.desktop
|
||||
share/apps/kmess/emoticons/airplane.png
|
||||
share/apps/kmess/emoticons/automobile.png
|
||||
share/apps/kmess/emoticons/baringteeth.png
|
||||
share/apps/kmess/emoticons/bowl.png
|
||||
share/apps/kmess/emoticons/brb.png
|
||||
share/apps/kmess/emoticons/cigarette.png
|
||||
share/apps/kmess/emoticons/computer.png
|
||||
share/apps/kmess/emoticons/eyeroll.png
|
||||
share/apps/kmess/emoticons/fingerscrossed.png
|
||||
share/apps/kmess/emoticons/gameconsole.png
|
||||
share/apps/kmess/emoticons/highfive.png
|
||||
share/apps/kmess/emoticons/huh.png
|
||||
share/apps/kmess/emoticons/island.png
|
||||
share/apps/kmess/emoticons/lightning.png
|
||||
share/apps/kmess/emoticons/mobilephone.png
|
||||
share/apps/kmess/emoticons/money.png
|
||||
share/apps/kmess/emoticons/nerd.png
|
||||
share/apps/kmess/emoticons/party.png
|
||||
share/apps/kmess/emoticons/pizza.png
|
||||
share/apps/kmess/emoticons/plate.png
|
||||
share/apps/kmess/emoticons/sarcastic.png
|
||||
share/apps/kmess/emoticons/secret.png
|
||||
share/apps/kmess/emoticons/sheep.png
|
||||
share/apps/kmess/emoticons/sick.png
|
||||
share/apps/kmess/emoticons/sleepy.png
|
||||
share/apps/kmess/emoticons/snail.png
|
||||
share/apps/kmess/emoticons/soccer.png
|
||||
share/apps/kmess/emoticons/sshh.png
|
||||
share/apps/kmess/emoticons/storm.png
|
||||
share/apps/kmess/emoticons/thinking.png
|
||||
share/apps/kmess/emoticons/turtle.png
|
||||
share/apps/kmess/emoticons/umbrella.png
|
||||
share/apps/kmess/emoticons/unhappy.png
|
||||
share/apps/kmess/emoticons/angel.png
|
||||
share/apps/kmess/emoticons/angry.png
|
||||
share/apps/kmess/emoticons/arrogant.png
|
||||
share/apps/kmess/emoticons/asl.png
|
||||
share/apps/kmess/emoticons/automobile.png
|
||||
share/apps/kmess/emoticons/bad.png
|
||||
share/apps/kmess/emoticons/baringteeth.png
|
||||
share/apps/kmess/emoticons/bat.png
|
||||
share/apps/kmess/emoticons/beer.png
|
||||
share/apps/kmess/emoticons/bowl.png
|
||||
share/apps/kmess/emoticons/boy.png
|
||||
share/apps/kmess/emoticons/brb.png
|
||||
share/apps/kmess/emoticons/cake.png
|
||||
share/apps/kmess/emoticons/camera.png
|
||||
share/apps/kmess/emoticons/cat.png
|
||||
share/apps/kmess/emoticons/cigarette.png
|
||||
share/apps/kmess/emoticons/clock.png
|
||||
share/apps/kmess/emoticons/cocktail.png
|
||||
share/apps/kmess/emoticons/computer.png
|
||||
share/apps/kmess/emoticons/confused.png
|
||||
share/apps/kmess/emoticons/cry.png
|
||||
share/apps/kmess/emoticons/cup.png
|
||||
|
@ -55,38 +29,64 @@ share/apps/kmess/emoticons/dude_hug.png
|
|||
share/apps/kmess/emoticons/embarrassed.png
|
||||
share/apps/kmess/emoticons/emoticonrc
|
||||
share/apps/kmess/emoticons/envelope.png
|
||||
share/apps/kmess/emoticons/eyeroll.png
|
||||
share/apps/kmess/emoticons/film.png
|
||||
share/apps/kmess/emoticons/fingerscrossed.png
|
||||
share/apps/kmess/emoticons/gameconsole.png
|
||||
share/apps/kmess/emoticons/girl.png
|
||||
share/apps/kmess/emoticons/girl_hug.png
|
||||
share/apps/kmess/emoticons/handcuffs.png
|
||||
share/apps/kmess/emoticons/highfive.png
|
||||
share/apps/kmess/emoticons/huh.png
|
||||
share/apps/kmess/emoticons/island.png
|
||||
share/apps/kmess/emoticons/kiss.png
|
||||
share/apps/kmess/emoticons/lightbulb.png
|
||||
share/apps/kmess/emoticons/lightning.png
|
||||
share/apps/kmess/emoticons/love.png
|
||||
share/apps/kmess/emoticons/megasmile.png
|
||||
share/apps/kmess/emoticons/messenger.png
|
||||
share/apps/kmess/emoticons/mobilephone.png
|
||||
share/apps/kmess/emoticons/money.png
|
||||
share/apps/kmess/emoticons/moon.png
|
||||
share/apps/kmess/emoticons/nerd.png
|
||||
share/apps/kmess/emoticons/note.png
|
||||
share/apps/kmess/emoticons/omg.png
|
||||
share/apps/kmess/emoticons/party.png
|
||||
share/apps/kmess/emoticons/phone.png
|
||||
share/apps/kmess/emoticons/pizza.png
|
||||
share/apps/kmess/emoticons/plate.png
|
||||
share/apps/kmess/emoticons/present.png
|
||||
share/apps/kmess/emoticons/rainbow.png
|
||||
share/apps/kmess/emoticons/regular.png
|
||||
share/apps/kmess/emoticons/rose.png
|
||||
share/apps/kmess/emoticons/sad.png
|
||||
share/apps/kmess/emoticons/sarcastic.png
|
||||
share/apps/kmess/emoticons/secret.png
|
||||
share/apps/kmess/emoticons/shade.png
|
||||
share/apps/kmess/emoticons/sheep.png
|
||||
share/apps/kmess/emoticons/sick.png
|
||||
share/apps/kmess/emoticons/sleepy.png
|
||||
share/apps/kmess/emoticons/snail.png
|
||||
share/apps/kmess/emoticons/soccer.png
|
||||
share/apps/kmess/emoticons/sorry.png
|
||||
share/apps/kmess/emoticons/sshh.png
|
||||
share/apps/kmess/emoticons/star.png
|
||||
share/apps/kmess/emoticons/storm.png
|
||||
share/apps/kmess/emoticons/sun.png
|
||||
share/apps/kmess/emoticons/teeth.png
|
||||
share/apps/kmess/emoticons/thinking.png
|
||||
share/apps/kmess/emoticons/thumbs_down.png
|
||||
share/apps/kmess/emoticons/thumbs_up.png
|
||||
share/apps/kmess/emoticons/tongue.png
|
||||
share/apps/kmess/emoticons/turtle.png
|
||||
share/apps/kmess/emoticons/ugly.png
|
||||
share/apps/kmess/emoticons/umbrella.png
|
||||
share/apps/kmess/emoticons/unhappy.png
|
||||
share/apps/kmess/emoticons/unlove.png
|
||||
share/apps/kmess/emoticons/wilted_rose.png
|
||||
share/apps/kmess/emoticons/wink.png
|
||||
share/apps/kmess/eventsrc
|
||||
share/apps/kmess/pics/kmesspic.png
|
||||
share/apps/kmess/icons/hicolor/16x16/apps/gnomemeeting.png
|
||||
share/apps/kmess/pics/away.png
|
||||
share/apps/kmess/pics/background.png
|
||||
share/apps/kmess/pics/berightback.png
|
||||
|
@ -96,6 +96,7 @@ share/apps/kmess/pics/email.png
|
|||
share/apps/kmess/pics/emoticons.png
|
||||
share/apps/kmess/pics/invisible.png
|
||||
share/apps/kmess/pics/kmesslogo.png
|
||||
share/apps/kmess/pics/kmesspic.png
|
||||
share/apps/kmess/pics/lunch.png
|
||||
share/apps/kmess/pics/offline.png
|
||||
share/apps/kmess/pics/online.png
|
||||
|
@ -118,16 +119,15 @@ share/doc/HTML/en/kmess/kmesspopupbaloon.png
|
|||
share/doc/HTML/en/kmess/kmessrightclickmenucontact.png
|
||||
share/doc/HTML/en/kmess/kmessstartupscreen.png
|
||||
share/doc/HTML/en/kmess/kmesstimestamp.png
|
||||
share/apps/kmess/icons/hicolor/16x16/apps/gnomemeeting.png
|
||||
share/icons/hicolor/128x128/apps/kmess.png
|
||||
share/icons/hicolor/16x16/apps/kmess.png
|
||||
share/icons/hicolor/22x22/apps/kmess.png
|
||||
share/icons/hicolor/32x32/apps/kmess.png
|
||||
share/icons/hicolor/48x48/apps/kmess.png
|
||||
share/icons/locolor/16x16/apps/kmess.png
|
||||
share/icons/locolor/32x32/apps/kmess.png
|
||||
share/icons/hicolor/128x128/apps/kmess.png
|
||||
share/icons/hicolor/22x22/apps/kmess.png
|
||||
share/icons/hicolor/64x64/apps/kmess.png
|
||||
share/icons/locolor/16x16/apps/kmess.png
|
||||
share/icons/locolor/22x22/apps/kmess.png
|
||||
share/icons/locolor/32x32/apps/kmess.png
|
||||
share/locale/ar/LC_MESSAGES/kmess.mo
|
||||
share/locale/ca/LC_MESSAGES/kmess.mo
|
||||
share/locale/de/LC_MESSAGES/kmess.mo
|
||||
|
@ -140,21 +140,31 @@ share/locale/ko/LC_MESSAGES/kmess.mo
|
|||
share/locale/nb/LC_MESSAGES/kmess.mo
|
||||
share/locale/nl/LC_MESSAGES/kmess.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/kmess.mo
|
||||
share/locale/sv/LC_MESSAGES/kmess.mo
|
||||
share/locale/sl/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/kmess.mo
|
||||
share/locale/sv/LC_MESSAGES/kmess.mo
|
||||
share/locale/th/LC_MESSAGES/kmess.mo
|
||||
share/locale/tr/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_CN.GB18030/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_CN.GB2312/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/kmess.mo
|
||||
share/sounds/kmess_chat.ogg
|
||||
share/sounds/kmess_logoff.ogg
|
||||
share/sounds/kmess_logon.ogg
|
||||
share/sounds/kmess_msg.ogg
|
||||
@dirrmtry share/locale/zh_TW/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_TW
|
||||
@dirrmtry share/locale/zh_CN/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_CN.GB18030/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_CN.GB18030
|
||||
@dirrmtry share/locale/zh_CN
|
||||
@dirrmtry share/locale/sl/LC_MESSAGES
|
||||
@dirrmtry share/locale/sl
|
||||
@dirrmtry share/locale/ko/LC_MESSAGES
|
||||
@dirrmtry share/locale/ko
|
||||
@dirrmtry share/locale/ca/LC_MESSAGES
|
||||
@dirrmtry share/locale/ca
|
||||
@dirrm share/doc/HTML/en/kmess
|
||||
@dirrm share/locale/zh_CN.GB18030/LC_MESSAGES
|
||||
@dirrm share/locale/zh_CN.GB18030
|
||||
@dirrm share/apps/kmess/pics
|
||||
@dirrm share/apps/kmess/icons/hicolor/16x16/apps
|
||||
@dirrm share/apps/kmess/icons/hicolor/16x16
|
||||
|
@ -162,3 +172,4 @@ share/sounds/kmess_msg.ogg
|
|||
@dirrm share/apps/kmess/icons
|
||||
@dirrm share/apps/kmess/emoticons
|
||||
@dirrm share/apps/kmess
|
||||
@dirrmtry share/applications/kde
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= kmess
|
||||
PORTVERSION= 1.4.2
|
||||
PORTVERSION= 1.4.3
|
||||
CATEGORIES= net-im kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -14,22 +14,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= MSN Messenger Client for KDE3
|
||||
|
||||
LIB_DEPENDS= mimelib.1:${PORTSDIR}/deskutils/kdepim3
|
||||
|
||||
BROKEN= Does not compile
|
||||
EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-configure
|
||||
|
||||
USE_KDELIBS_VER=3
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GMAKE= yes
|
||||
|
||||
pre-patch:
|
||||
${REINPLACE_CMD} -e '23s/^$$/#include <unistd.h>/' \
|
||||
${WRKSRC}/kmess/kmessview.cpp
|
||||
${REINPLACE_CMD} -e '20s/^$$/#include <ctype.h>/' \
|
||||
${WRKSRC}/kmess/network/mimemessage.h
|
||||
${REINPLACE_CMD} -e '35s|^$$|#include <netinet/in.h>|' \
|
||||
${WRKSRC}/kmess/network/msnconnection.h
|
||||
${REINPLACE_CMD} -e 's/-pedantic //g; s/-O2//g; \
|
||||
s/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
|
||||
post-patch:
|
||||
@${TOUCH} ${WRKSRC}/config.h.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (kmess-1.4.2.tar.gz) = e3d368ffbce6ee629e900d4a1134752e
|
||||
SHA256 (kmess-1.4.2.tar.gz) = 864dae86f5fc4a2d40698b382b4f6642c5d0e3d111a3c4732374dc7226f942d6
|
||||
SIZE (kmess-1.4.2.tar.gz) = 2336147
|
||||
MD5 (kmess-1.4.3.tar.gz) = 88c73b2223cbb0dc2b79023188fba64a
|
||||
SHA256 (kmess-1.4.3.tar.gz) = f571847704618c2d364dee731a8d3a5a59ff423b77e52160cb147ebec8ffd526
|
||||
SIZE (kmess-1.4.3.tar.gz) = 1869940
|
||||
|
|
11
net-im/kmess/files/patch-kmess-Makefile.in
Normal file
11
net-im/kmess/files/patch-kmess-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kmess/Makefile.in.orig Sun Jun 4 16:44:43 2006
|
||||
+++ kmess/Makefile.in Sun Jun 4 16:45:06 2006
|
||||
@@ -470,7 +470,7 @@
|
||||
|
||||
# the library search path.
|
||||
# the -lpthread is required for Autopackage/BinReloc
|
||||
-kmess_LDFLAGS = $(KDE_RPATH) $(all_libraries) -lpthread
|
||||
+kmess_LDFLAGS = $(KDE_RPATH) $(all_libraries)
|
||||
AM_CXXFLAGS = -ggdb
|
||||
#>- all: all-recursive
|
||||
#>+ 1
|
11
net-im/kmess/files/patch-kmess-crypt-bithelp.h
Normal file
11
net-im/kmess/files/patch-kmess-crypt-bithelp.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kmess/crypt/bithelp.h.orig Sun Jun 4 13:38:04 2006
|
||||
+++ kmess/crypt/bithelp.h Sun Jun 4 13:39:09 2006
|
||||
@@ -20,8 +20,6 @@
|
||||
#ifndef G10_BITHELP_H
|
||||
#define G10_BITHELP_H
|
||||
|
||||
-#include <stdint.h>
|
||||
-
|
||||
/****************
|
||||
* Rotate the 32 bit unsigned integer X by N bits left/right
|
||||
*/
|
13
net-im/kmess/files/patch-kmess-crypt-globalstuff.h
Normal file
13
net-im/kmess/files/patch-kmess-crypt-globalstuff.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- kmess/crypt/globalstuff.h.orig Fri May 21 04:00:44 2004
|
||||
+++ kmess/crypt/globalstuff.h Sun Jun 4 13:48:21 2006
|
||||
@@ -16,9 +16,9 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <string>
|
||||
#include <sstream>
|
||||
-#include <stdint.h>
|
||||
|
||||
/** convert something to string using ostringstream */
|
||||
template <class T> inline
|
11
net-im/kmess/files/patch-kmess-kmessview.cpp
Normal file
11
net-im/kmess/files/patch-kmess-kmessview.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kmess/kmessview.cpp.orig Sun Jun 4 15:13:33 2006
|
||||
+++ kmess/kmessview.cpp Sun Jun 4 15:14:27 2006
|
||||
@@ -1058,7 +1058,7 @@
|
||||
{
|
||||
Contact *contact = getContactByItem( contactListView_->currentItem() );
|
||||
Group *oldGroup = getGroupByItem( contactListView_->currentItem() );
|
||||
- QString oldGroupId = (oldGroup != 0 ? oldGroup->getId() : "0");
|
||||
+ QString oldGroupId = (oldGroup != 0 ? oldGroup->getId() : QString::fromLatin1("0"));
|
||||
|
||||
if(contact != 0)
|
||||
{
|
10
net-im/kmess/files/patch-kmess-kmessview.h
Normal file
10
net-im/kmess/files/patch-kmess-kmessview.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- kmess/kmessview.h.orig Sun Jun 4 15:46:03 2006
|
||||
+++ kmess/kmessview.h Sun Jun 4 15:59:14 2006
|
||||
@@ -187,6 +187,7 @@
|
||||
private:
|
||||
KMessView *kmessView_;
|
||||
};
|
||||
+ friend class ToolTip;
|
||||
|
||||
// Reference to the current tooltip
|
||||
ToolTip *toolTip_;
|
|
@ -0,0 +1,11 @@
|
|||
--- kmess/network/applications/p2papplication.cpp.orig Sun Jun 4 15:00:05 2006
|
||||
+++ kmess/network/applications/p2papplication.cpp Sun Jun 4 15:00:44 2006
|
||||
@@ -2056,7 +2056,7 @@
|
||||
// Get message content and Content-Type
|
||||
bool gotTransferInvitation = (invitationContentType_ == "application/x-msnmsgr-transreqbody");
|
||||
QString content = message.getFields();
|
||||
- QString contentType = (gotTransferInvitation ? "application/x-msnmsgr-transrespbody" : invitationContentType_);
|
||||
+ QString contentType = (gotTransferInvitation ? QString::fromLatin1("application/x-msnmsgr-transrespbody") : invitationContentType_);
|
||||
|
||||
QString myHandle = CurrentAccount::instance()->getHandle();
|
||||
|
|
@ -1,51 +1,25 @@
|
|||
bin/kmess
|
||||
share/applications/kde/kmess.desktop
|
||||
share/apps/kmess/emoticons/airplane.png
|
||||
share/apps/kmess/emoticons/automobile.png
|
||||
share/apps/kmess/emoticons/baringteeth.png
|
||||
share/apps/kmess/emoticons/bowl.png
|
||||
share/apps/kmess/emoticons/brb.png
|
||||
share/apps/kmess/emoticons/cigarette.png
|
||||
share/apps/kmess/emoticons/computer.png
|
||||
share/apps/kmess/emoticons/eyeroll.png
|
||||
share/apps/kmess/emoticons/fingerscrossed.png
|
||||
share/apps/kmess/emoticons/gameconsole.png
|
||||
share/apps/kmess/emoticons/highfive.png
|
||||
share/apps/kmess/emoticons/huh.png
|
||||
share/apps/kmess/emoticons/island.png
|
||||
share/apps/kmess/emoticons/lightning.png
|
||||
share/apps/kmess/emoticons/mobilephone.png
|
||||
share/apps/kmess/emoticons/money.png
|
||||
share/apps/kmess/emoticons/nerd.png
|
||||
share/apps/kmess/emoticons/party.png
|
||||
share/apps/kmess/emoticons/pizza.png
|
||||
share/apps/kmess/emoticons/plate.png
|
||||
share/apps/kmess/emoticons/sarcastic.png
|
||||
share/apps/kmess/emoticons/secret.png
|
||||
share/apps/kmess/emoticons/sheep.png
|
||||
share/apps/kmess/emoticons/sick.png
|
||||
share/apps/kmess/emoticons/sleepy.png
|
||||
share/apps/kmess/emoticons/snail.png
|
||||
share/apps/kmess/emoticons/soccer.png
|
||||
share/apps/kmess/emoticons/sshh.png
|
||||
share/apps/kmess/emoticons/storm.png
|
||||
share/apps/kmess/emoticons/thinking.png
|
||||
share/apps/kmess/emoticons/turtle.png
|
||||
share/apps/kmess/emoticons/umbrella.png
|
||||
share/apps/kmess/emoticons/unhappy.png
|
||||
share/apps/kmess/emoticons/angel.png
|
||||
share/apps/kmess/emoticons/angry.png
|
||||
share/apps/kmess/emoticons/arrogant.png
|
||||
share/apps/kmess/emoticons/asl.png
|
||||
share/apps/kmess/emoticons/automobile.png
|
||||
share/apps/kmess/emoticons/bad.png
|
||||
share/apps/kmess/emoticons/baringteeth.png
|
||||
share/apps/kmess/emoticons/bat.png
|
||||
share/apps/kmess/emoticons/beer.png
|
||||
share/apps/kmess/emoticons/bowl.png
|
||||
share/apps/kmess/emoticons/boy.png
|
||||
share/apps/kmess/emoticons/brb.png
|
||||
share/apps/kmess/emoticons/cake.png
|
||||
share/apps/kmess/emoticons/camera.png
|
||||
share/apps/kmess/emoticons/cat.png
|
||||
share/apps/kmess/emoticons/cigarette.png
|
||||
share/apps/kmess/emoticons/clock.png
|
||||
share/apps/kmess/emoticons/cocktail.png
|
||||
share/apps/kmess/emoticons/computer.png
|
||||
share/apps/kmess/emoticons/confused.png
|
||||
share/apps/kmess/emoticons/cry.png
|
||||
share/apps/kmess/emoticons/cup.png
|
||||
|
@ -55,38 +29,64 @@ share/apps/kmess/emoticons/dude_hug.png
|
|||
share/apps/kmess/emoticons/embarrassed.png
|
||||
share/apps/kmess/emoticons/emoticonrc
|
||||
share/apps/kmess/emoticons/envelope.png
|
||||
share/apps/kmess/emoticons/eyeroll.png
|
||||
share/apps/kmess/emoticons/film.png
|
||||
share/apps/kmess/emoticons/fingerscrossed.png
|
||||
share/apps/kmess/emoticons/gameconsole.png
|
||||
share/apps/kmess/emoticons/girl.png
|
||||
share/apps/kmess/emoticons/girl_hug.png
|
||||
share/apps/kmess/emoticons/handcuffs.png
|
||||
share/apps/kmess/emoticons/highfive.png
|
||||
share/apps/kmess/emoticons/huh.png
|
||||
share/apps/kmess/emoticons/island.png
|
||||
share/apps/kmess/emoticons/kiss.png
|
||||
share/apps/kmess/emoticons/lightbulb.png
|
||||
share/apps/kmess/emoticons/lightning.png
|
||||
share/apps/kmess/emoticons/love.png
|
||||
share/apps/kmess/emoticons/megasmile.png
|
||||
share/apps/kmess/emoticons/messenger.png
|
||||
share/apps/kmess/emoticons/mobilephone.png
|
||||
share/apps/kmess/emoticons/money.png
|
||||
share/apps/kmess/emoticons/moon.png
|
||||
share/apps/kmess/emoticons/nerd.png
|
||||
share/apps/kmess/emoticons/note.png
|
||||
share/apps/kmess/emoticons/omg.png
|
||||
share/apps/kmess/emoticons/party.png
|
||||
share/apps/kmess/emoticons/phone.png
|
||||
share/apps/kmess/emoticons/pizza.png
|
||||
share/apps/kmess/emoticons/plate.png
|
||||
share/apps/kmess/emoticons/present.png
|
||||
share/apps/kmess/emoticons/rainbow.png
|
||||
share/apps/kmess/emoticons/regular.png
|
||||
share/apps/kmess/emoticons/rose.png
|
||||
share/apps/kmess/emoticons/sad.png
|
||||
share/apps/kmess/emoticons/sarcastic.png
|
||||
share/apps/kmess/emoticons/secret.png
|
||||
share/apps/kmess/emoticons/shade.png
|
||||
share/apps/kmess/emoticons/sheep.png
|
||||
share/apps/kmess/emoticons/sick.png
|
||||
share/apps/kmess/emoticons/sleepy.png
|
||||
share/apps/kmess/emoticons/snail.png
|
||||
share/apps/kmess/emoticons/soccer.png
|
||||
share/apps/kmess/emoticons/sorry.png
|
||||
share/apps/kmess/emoticons/sshh.png
|
||||
share/apps/kmess/emoticons/star.png
|
||||
share/apps/kmess/emoticons/storm.png
|
||||
share/apps/kmess/emoticons/sun.png
|
||||
share/apps/kmess/emoticons/teeth.png
|
||||
share/apps/kmess/emoticons/thinking.png
|
||||
share/apps/kmess/emoticons/thumbs_down.png
|
||||
share/apps/kmess/emoticons/thumbs_up.png
|
||||
share/apps/kmess/emoticons/tongue.png
|
||||
share/apps/kmess/emoticons/turtle.png
|
||||
share/apps/kmess/emoticons/ugly.png
|
||||
share/apps/kmess/emoticons/umbrella.png
|
||||
share/apps/kmess/emoticons/unhappy.png
|
||||
share/apps/kmess/emoticons/unlove.png
|
||||
share/apps/kmess/emoticons/wilted_rose.png
|
||||
share/apps/kmess/emoticons/wink.png
|
||||
share/apps/kmess/eventsrc
|
||||
share/apps/kmess/pics/kmesspic.png
|
||||
share/apps/kmess/icons/hicolor/16x16/apps/gnomemeeting.png
|
||||
share/apps/kmess/pics/away.png
|
||||
share/apps/kmess/pics/background.png
|
||||
share/apps/kmess/pics/berightback.png
|
||||
|
@ -96,6 +96,7 @@ share/apps/kmess/pics/email.png
|
|||
share/apps/kmess/pics/emoticons.png
|
||||
share/apps/kmess/pics/invisible.png
|
||||
share/apps/kmess/pics/kmesslogo.png
|
||||
share/apps/kmess/pics/kmesspic.png
|
||||
share/apps/kmess/pics/lunch.png
|
||||
share/apps/kmess/pics/offline.png
|
||||
share/apps/kmess/pics/online.png
|
||||
|
@ -118,16 +119,15 @@ share/doc/HTML/en/kmess/kmesspopupbaloon.png
|
|||
share/doc/HTML/en/kmess/kmessrightclickmenucontact.png
|
||||
share/doc/HTML/en/kmess/kmessstartupscreen.png
|
||||
share/doc/HTML/en/kmess/kmesstimestamp.png
|
||||
share/apps/kmess/icons/hicolor/16x16/apps/gnomemeeting.png
|
||||
share/icons/hicolor/128x128/apps/kmess.png
|
||||
share/icons/hicolor/16x16/apps/kmess.png
|
||||
share/icons/hicolor/22x22/apps/kmess.png
|
||||
share/icons/hicolor/32x32/apps/kmess.png
|
||||
share/icons/hicolor/48x48/apps/kmess.png
|
||||
share/icons/locolor/16x16/apps/kmess.png
|
||||
share/icons/locolor/32x32/apps/kmess.png
|
||||
share/icons/hicolor/128x128/apps/kmess.png
|
||||
share/icons/hicolor/22x22/apps/kmess.png
|
||||
share/icons/hicolor/64x64/apps/kmess.png
|
||||
share/icons/locolor/16x16/apps/kmess.png
|
||||
share/icons/locolor/22x22/apps/kmess.png
|
||||
share/icons/locolor/32x32/apps/kmess.png
|
||||
share/locale/ar/LC_MESSAGES/kmess.mo
|
||||
share/locale/ca/LC_MESSAGES/kmess.mo
|
||||
share/locale/de/LC_MESSAGES/kmess.mo
|
||||
|
@ -140,21 +140,31 @@ share/locale/ko/LC_MESSAGES/kmess.mo
|
|||
share/locale/nb/LC_MESSAGES/kmess.mo
|
||||
share/locale/nl/LC_MESSAGES/kmess.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/kmess.mo
|
||||
share/locale/sv/LC_MESSAGES/kmess.mo
|
||||
share/locale/sl/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/kmess.mo
|
||||
share/locale/sv/LC_MESSAGES/kmess.mo
|
||||
share/locale/th/LC_MESSAGES/kmess.mo
|
||||
share/locale/tr/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_CN.GB18030/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_CN.GB2312/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/kmess.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/kmess.mo
|
||||
share/sounds/kmess_chat.ogg
|
||||
share/sounds/kmess_logoff.ogg
|
||||
share/sounds/kmess_logon.ogg
|
||||
share/sounds/kmess_msg.ogg
|
||||
@dirrmtry share/locale/zh_TW/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_TW
|
||||
@dirrmtry share/locale/zh_CN/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_CN.GB18030/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_CN.GB18030
|
||||
@dirrmtry share/locale/zh_CN
|
||||
@dirrmtry share/locale/sl/LC_MESSAGES
|
||||
@dirrmtry share/locale/sl
|
||||
@dirrmtry share/locale/ko/LC_MESSAGES
|
||||
@dirrmtry share/locale/ko
|
||||
@dirrmtry share/locale/ca/LC_MESSAGES
|
||||
@dirrmtry share/locale/ca
|
||||
@dirrm share/doc/HTML/en/kmess
|
||||
@dirrm share/locale/zh_CN.GB18030/LC_MESSAGES
|
||||
@dirrm share/locale/zh_CN.GB18030
|
||||
@dirrm share/apps/kmess/pics
|
||||
@dirrm share/apps/kmess/icons/hicolor/16x16/apps
|
||||
@dirrm share/apps/kmess/icons/hicolor/16x16
|
||||
|
@ -162,3 +172,4 @@ share/sounds/kmess_msg.ogg
|
|||
@dirrm share/apps/kmess/icons
|
||||
@dirrm share/apps/kmess/emoticons
|
||||
@dirrm share/apps/kmess
|
||||
@dirrmtry share/applications/kde
|
||||
|
|
Loading…
Reference in a new issue