Update svxlink/qtel to latest release
This commit is contained in:
parent
ba0339b25a
commit
4742634d66
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=412692
21 changed files with 74 additions and 173 deletions
|
@ -1,8 +1,8 @@
|
|||
bin/qtel
|
||||
include/svxlink/AsyncQtApplication.h
|
||||
%%STATIC%%lib/libasyncqt.a
|
||||
lib/libasyncqt.so.1.3.1
|
||||
lib/libasyncqt.so.1.3
|
||||
lib/libasyncqt.so.1.4.0
|
||||
lib/libasyncqt.so.1.4
|
||||
lib/libasyncqt.so
|
||||
share/applications/qtel.desktop
|
||||
share/qtel/translations/qtel_sv.qm
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME?= svxlink
|
||||
PORTVERSION= 14.08.2
|
||||
PORTVERSION= 15.11
|
||||
CATEGORIES= comms hamradio
|
||||
|
||||
MAINTAINER= hamradio@FreeBSD.org
|
||||
|
@ -24,7 +24,7 @@ USE_GITHUB= yes
|
|||
GH_ACCOUNT= sm0svx
|
||||
GH_PROJECT= svxlink
|
||||
|
||||
USES= compiler:c++11-lib cmake tcl
|
||||
USES= cmake tcl
|
||||
CMAKE_SOURCE_PATH= ${WRKSRC}/src
|
||||
CMAKE_ARGS+= -DMAN_INSTALL_DIR:FILEPATH=${MANDIRS} \
|
||||
-DLOCAL_STATE_DIR=/var
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (sm0svx-svxlink-14.08.2_GH0.tar.gz) = fe420a035cce6a293b1e46dcba98e79a089548bb5d9329a9f79f0e51054f8ce2
|
||||
SIZE (sm0svx-svxlink-14.08.2_GH0.tar.gz) = 1507462
|
||||
SHA256 (sm0svx-svxlink-15.11_GH0.tar.gz) = 17bd8a1174c70e990b676210e6edb373732d284aed55c5a82bc378a1d69cecf2
|
||||
SIZE (sm0svx-svxlink-15.11_GH0.tar.gz) = 1528034
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/async/audio/AsyncAudioDeviceOSS.cpp.orig 2014-04-09 22:38:17.000000000 -0700
|
||||
+++ src/async/audio/AsyncAudioDeviceOSS.cpp 2014-04-09 22:38:29.000000000 -0700
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <sys/soundcard.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <unistd.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
#include <cassert>
|
||||
#include <cstring>
|
|
@ -1,11 +0,0 @@
|
|||
--- src/echolib/EchoLinkDirectoryCon.cpp.orig 2014-04-09 23:13:08.000000000 -0700
|
||||
+++ src/echolib/EchoLinkDirectoryCon.cpp 2014-04-09 23:13:15.000000000 -0700
|
||||
@@ -204,7 +204,7 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- errno = ECOMM;
|
||||
+ errno = EIO;
|
||||
return -1;
|
||||
}
|
||||
}
|
|
@ -1,12 +0,0 @@
|
|||
--- src/echolib/EchoLinkDispatcher.h.orig 2014-04-10 02:13:14.000000000 -0700
|
||||
+++ src/echolib/EchoLinkDispatcher.h 2014-04-10 02:22:41.000000000 -0700
|
||||
@@ -215,7 +215,8 @@
|
||||
return a1 < a2;
|
||||
}
|
||||
};
|
||||
- typedef std::map<Async::IpAddress, ConData, ipaddr_lt> ConMap;
|
||||
+ //typedef std::map<Async::IpAddress, ConData, ipaddr_lt> ConMap;
|
||||
+ typedef std::map<Async::IpAddress, ConData> ConMap;
|
||||
|
||||
static const int DEFAULT_PORT_BASE = 5198;
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- src/locationinfo/LocationInfo.cpp.orig 2014-04-09 23:26:23.000000000 -0700
|
||||
+++ src/locationinfo/LocationInfo.cpp 2014-04-09 23:26:32.000000000 -0700
|
||||
@@ -480,7 +480,7 @@
|
||||
}
|
||||
|
||||
double tmp = sqrt(2.0 * loc_cfg.height * sqrt((loc_cfg.power / 10.0) *
|
||||
- pow10(loc_cfg.gain / 10.0) / 2)) * range_factor;
|
||||
+ pow(10, loc_cfg.gain / 10.0) / 2)) * range_factor;
|
||||
|
||||
return lrintf(tmp);
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- src/CMakeLists.txt.orig 2014-08-02 12:45:56.000000000 -0700
|
||||
+++ src/CMakeLists.txt 2015-01-05 21:58:48.000000000 -0800
|
||||
@@ -37,6 +37,7 @@
|
||||
--- src/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -37,6 +37,7 @@ set(RUNTIME_OUTPUT_DIRECTORY ${PROJECT_B
|
||||
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/Modules/")
|
||||
|
||||
# Optional parts
|
||||
|
@ -8,7 +8,7 @@
|
|||
option(USE_QT "Build Qt applications and libs" ON)
|
||||
option(BUILD_STATIC_LIBS "Build static libraries in addition to dynamic" OFF)
|
||||
|
||||
@@ -46,12 +47,6 @@
|
||||
@@ -46,12 +47,6 @@ if(NOT DEFINED INTERNAL_SAMPLE_RATE)
|
||||
endif(NOT DEFINED INTERNAL_SAMPLE_RATE)
|
||||
add_definitions(-DINTERNAL_SAMPLE_RATE=${INTERNAL_SAMPLE_RATE})
|
||||
|
||||
|
@ -21,8 +21,8 @@
|
|||
# Warnings should be enabled for GCC. Also turning off the NDEBUG flag
|
||||
# since that remove asserts.
|
||||
if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
|
||||
@@ -83,6 +78,15 @@
|
||||
set(INCLUDE_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/include)
|
||||
@@ -87,6 +82,15 @@ if(NOT DEFINED INCLUDE_INSTALL_DIR)
|
||||
set(INCLUDE_INSTALL_DIR ${CMAKE_INSTALL_FULL_INCLUDEDIR})
|
||||
endif(NOT DEFINED INCLUDE_INSTALL_DIR)
|
||||
|
||||
+# Set up include directories
|
||||
|
@ -36,8 +36,8 @@
|
|||
+
|
||||
# Where to install libraries
|
||||
if(NOT DEFINED LIB_INSTALL_DIR)
|
||||
set(LIB_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
|
||||
@@ -312,10 +316,12 @@
|
||||
#set(LIB_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
|
||||
@@ -324,10 +328,12 @@ include(FindCHOWN)
|
||||
|
||||
# Add directories to build
|
||||
add_subdirectory(async)
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/async/CMakeLists.txt.orig 2015-01-05 20:59:17.000000000 -0800
|
||||
+++ src/async/CMakeLists.txt 2015-01-05 20:59:44.000000000 -0800
|
||||
--- src/async/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/async/CMakeLists.txt
|
||||
@@ -1,7 +1,9 @@
|
||||
+if(NOT QT_ONLY)
|
||||
add_subdirectory(core)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/async/qt/CMakeLists.txt.orig 2014-08-02 12:45:56.000000000 -0700
|
||||
+++ src/async/qt/CMakeLists.txt 2015-01-05 21:42:06.000000000 -0800
|
||||
@@ -6,7 +6,12 @@
|
||||
--- src/async/qt/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/async/qt/CMakeLists.txt
|
||||
@@ -6,7 +6,12 @@ set(LIBSRC AsyncQtApplication.cpp AsyncQ
|
||||
|
||||
set(QTHEADERS AsyncQtApplication.h AsyncQtTimer.h AsyncQtDnsLookupWorker.h)
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/doc/CMakeLists.txt.orig 2015-01-05 21:49:06.000000000 -0800
|
||||
+++ src/doc/CMakeLists.txt 2015-01-05 21:49:20.000000000 -0800
|
||||
--- src/doc/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/doc/CMakeLists.txt
|
||||
@@ -2,6 +2,7 @@
|
||||
add_custom_target(doc)
|
||||
|
||||
|
@ -8,9 +8,9 @@
|
|||
find_package(Doxygen)
|
||||
if(DOXYGEN_FOUND)
|
||||
configure_file(doxygen.echolib.in doxygen.echolib @ONLY)
|
||||
@@ -32,5 +33,6 @@
|
||||
"echolib;async"
|
||||
)
|
||||
@@ -36,5 +37,6 @@ else(DOXYGEN_FOUND)
|
||||
message("-- It is an optional dependency and SvxLink will build without")
|
||||
message("-- it. Not needed for normal use.")
|
||||
endif(DOXYGEN_FOUND)
|
||||
+endif(NOT QT_ONLY)
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/doc/man/CMakeLists.txt.orig 2014-08-02 12:45:56.000000000 -0700
|
||||
+++ src/doc/man/CMakeLists.txt 2015-01-05 21:07:04.000000000 -0800
|
||||
--- src/doc/man/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/doc/man/CMakeLists.txt
|
||||
@@ -1,9 +1,16 @@
|
||||
# Set up which man pages to build and install
|
||||
+if(QT_ONLY)
|
||||
|
@ -8,13 +8,30 @@
|
|||
set(MAN_PAGES svxlink.1 remotetrx.1 siglevdetcal.1 svxlink.conf.5
|
||||
ModuleHelp.conf.5 remotetrx.conf.5 ModuleParrot.conf.5 ModuleEchoLink.conf.5
|
||||
ModuleTclVoiceMail.conf.5 ModuleDtmfRepeater.conf.5
|
||||
- ModulePropagationMonitor.conf.5 ModuleSelCallEnc.conf.5 qtel.1
|
||||
+ ModulePropagationMonitor.conf.5 ModuleSelCallEnc.conf.5
|
||||
- ModulePropagationMonitor.conf.5 ModuleSelCallEnc.conf.5 qtel.1 devcal.1
|
||||
+ ModulePropagationMonitor.conf.5 ModuleSelCallEnc.conf.5 devcal.1
|
||||
)
|
||||
+if(USE_QT)
|
||||
+ set(MAN_PAGES ${MAN_PAGES} qtel.1)
|
||||
+endif(USE_QT)
|
||||
+endif(QT_ONLY)
|
||||
|
||||
# Search for gzip program. Error out if not found.
|
||||
# Search for the gzip and groff programs. Error out if not found.
|
||||
include(FindGZIP)
|
||||
@@ -29,11 +36,11 @@ if(GROFF_TOOL AND GZIP_TOOL)
|
||||
DESTINATION ${MAN_INSTALL_DIR}/man${sec}
|
||||
OPTIONAL
|
||||
)
|
||||
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${man}.html
|
||||
- DESTINATION ${DOC_INSTALL_DIR}/man/man${sec}
|
||||
- OPTIONAL
|
||||
- )
|
||||
- set(TARGETS ${TARGETS} ${man}.gz ${man}.html)
|
||||
+ #install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${man}.html
|
||||
+ # DESTINATION ${DOC_INSTALL_DIR}/man/man${sec}
|
||||
+ # OPTIONAL
|
||||
+ #)
|
||||
+ set(TARGETS ${TARGETS} ${man}.gz)
|
||||
endforeach(man)
|
||||
|
||||
# Add a custom target to trigger the build of the man pages
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/locationinfo/LocationInfo.h.orig 2016-02-23 13:03:56.000000000 +0100
|
||||
+++ src/locationinfo/LocationInfo.h 2016-02-23 13:07:13.000000000 +0100
|
||||
@@ -38,7 +38,7 @@
|
||||
#include <string>
|
||||
#include <vector>
|
||||
#include <list>
|
||||
-
|
||||
+#include <sys/time.h> // for struct timeval
|
||||
|
||||
/****************************************************************************
|
||||
*
|
|
@ -1,6 +1,6 @@
|
|||
--- src/qtel/CMakeLists.txt.orig 2014-08-02 12:45:56.000000000 -0700
|
||||
+++ src/qtel/CMakeLists.txt 2015-01-05 21:46:43.000000000 -0800
|
||||
@@ -16,7 +16,14 @@
|
||||
--- src/qtel/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/qtel/CMakeLists.txt
|
||||
@@ -16,7 +16,14 @@ set(FORMS MainWindowBase.ui ComDialogBas
|
||||
set(RESOURCES qtel.qrc)
|
||||
|
||||
# Libraries
|
||||
|
|
|
@ -0,0 +1,9 @@
|
|||
--- src/svxlink/devcal/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/svxlink/devcal/CMakeLists.txt
|
||||
@@ -18,3 +18,6 @@ set_target_properties(devcal PROPERTIES
|
||||
#set_target_properties(noisegen PROPERTIES
|
||||
# RUNTIME_OUTPUT_DIRECTORY ${RUNTIME_OUTPUT_DIRECTORY}
|
||||
#)
|
||||
+
|
||||
+# Install targets
|
||||
+install(TARGETS devcal DESTINATION ${BIN_INSTALL_DIR})
|
|
@ -1,6 +1,6 @@
|
|||
--- ./src/svxlink/svxlink/CMakeLists.txt.orig 2015-01-05 18:06:11.000000000 -0800
|
||||
+++ ./src/svxlink/svxlink/CMakeLists.txt 2015-01-05 18:06:33.000000000 -0800
|
||||
@@ -24,9 +24,9 @@
|
||||
--- src/svxlink/svxlink/CMakeLists.txt.orig 2015-11-22 16:03:59 UTC
|
||||
+++ src/svxlink/svxlink/CMakeLists.txt
|
||||
@@ -31,9 +31,9 @@ include_directories(${GCRYPT_INCLUDE_DIR
|
||||
add_definitions(${GCRYPT_DEFINITIONS})
|
||||
|
||||
# Find the dl library
|
|
@ -1,13 +0,0 @@
|
|||
--- src/svxlink/trx/NetTrxMsg.h.orig 2014-04-09 23:51:14.000000000 -0700
|
||||
+++ src/svxlink/trx/NetTrxMsg.h 2014-04-09 23:51:53.000000000 -0700
|
||||
@@ -176,8 +176,8 @@
|
||||
MsgProtoVer(void)
|
||||
: Msg(TYPE, sizeof(MsgProtoVer)), m_major(MAJOR),
|
||||
m_minor(MINOR) {}
|
||||
- uint16_t major(void) const { return m_major; }
|
||||
- uint16_t minor(void) const { return m_minor; }
|
||||
+ uint16_t FBSD_major(void) const { return m_major; }
|
||||
+ uint16_t FBSD_minor(void) const { return m_minor; }
|
||||
|
||||
private:
|
||||
uint16_t m_major;
|
|
@ -1,24 +0,0 @@
|
|||
--- src/svxlink/trx/NetTrxTcpClient.cpp.orig 2014-04-09 23:51:30.000000000 -0700
|
||||
+++ src/svxlink/trx/NetTrxTcpClient.cpp 2014-04-09 23:52:13.000000000 -0700
|
||||
@@ -328,8 +328,8 @@
|
||||
{
|
||||
MsgProtoVer *ver_msg = reinterpret_cast<MsgProtoVer *>(msg);
|
||||
if ((msg->size() != sizeof(MsgProtoVer)) ||
|
||||
- (ver_msg->major() != MsgProtoVer::MAJOR) ||
|
||||
- (ver_msg->minor() != MsgProtoVer::MINOR))
|
||||
+ (ver_msg->FBSD_major() != MsgProtoVer::MAJOR) ||
|
||||
+ (ver_msg->FBSD_minor() != MsgProtoVer::MINOR))
|
||||
{
|
||||
cerr << "*** ERROR: Incompatible protocol version. Disconnecting from "
|
||||
<< remoteHost().toString() << ":" << remotePort() << "...\n";
|
||||
@@ -337,8 +337,8 @@
|
||||
return;
|
||||
}
|
||||
cout << remoteHost().toString() << ":" << remotePort()
|
||||
- << ": RemoteTrx protocol version " << ver_msg->major() << "."
|
||||
- << ver_msg->minor() << endl;
|
||||
+ << ": RemoteTrx protocol version " << ver_msg->FBSD_major() << "."
|
||||
+ << ver_msg->FBSD_minor() << endl;
|
||||
state = STATE_AUTH_WAIT;
|
||||
}
|
||||
else
|
|
@ -1,19 +0,0 @@
|
|||
--- src/svxlink/trx/SwDtmfDecoder.cpp.orig 2014-04-09 23:44:56.000000000 -0700
|
||||
+++ src/svxlink/trx/SwDtmfDecoder.cpp 2014-04-09 23:47:28.000000000 -0700
|
||||
@@ -175,14 +175,14 @@
|
||||
{
|
||||
int cfg_fwd_twist = atoi(value.c_str());
|
||||
if (cfg_fwd_twist >= 0)
|
||||
- normal_twist = exp10f(cfg_fwd_twist/10.0f);
|
||||
+ normal_twist = powf(10,cfg_fwd_twist/10.0f);
|
||||
}
|
||||
|
||||
if (cfg().getValue(name(), "DTMF_MAX_REV_TWIST", value))
|
||||
{
|
||||
int cfg_rev_twist = atoi(value.c_str());
|
||||
if (cfg_rev_twist >= 0)
|
||||
- reverse_twist = exp10f(cfg_rev_twist/10.0f);
|
||||
+ reverse_twist = powf(10,cfg_rev_twist/10.0f);
|
||||
}
|
||||
|
||||
return true;
|
|
@ -1,20 +0,0 @@
|
|||
--- src/svxlink/trx/ToneDetector.cpp.orig 2014-04-09 23:45:04.000000000 -0700
|
||||
+++ src/svxlink/trx/ToneDetector.cpp 2014-04-09 23:47:33.000000000 -0700
|
||||
@@ -335,7 +335,7 @@
|
||||
{
|
||||
if (thresh > 0.0f)
|
||||
{
|
||||
- det_par->peak_thresh = exp10f(thresh/10.0f);
|
||||
+ det_par->peak_thresh = powf(10, thresh/10.0f);
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -348,7 +348,7 @@
|
||||
{
|
||||
if (thresh > 0.0f)
|
||||
{
|
||||
- undet_par->peak_thresh = exp10f(thresh/10.0f);
|
||||
+ undet_par->peak_thresh = powf(10, thresh/10.0f);
|
||||
}
|
||||
else
|
||||
{
|
|
@ -1,3 +1,4 @@
|
|||
bin/devcal
|
||||
bin/svxlink
|
||||
bin/remotetrx
|
||||
bin/siglevdetcal
|
||||
|
@ -64,14 +65,18 @@ include/svxlink/EchoLinkDispatcher.h
|
|||
include/svxlink/EchoLinkQso.h
|
||||
include/svxlink/EchoLinkStationData.h
|
||||
include/svxlink/EchoLinkProxy.h
|
||||
lib/libasynccore.so.1.3.1
|
||||
lib/libasynccore.so.1.3
|
||||
include/svxlink/AsyncAudioGenerator.h
|
||||
include/svxlink/AsyncAudioNoiseAdder.h
|
||||
include/svxlink/AsyncPty.h
|
||||
include/svxlink/AsyncPtyStreamBuf.h
|
||||
lib/libasynccore.so.1.4.0
|
||||
lib/libasynccore.so.1.4
|
||||
lib/libasynccore.so
|
||||
lib/libasynccpp.so.1.3.1
|
||||
lib/libasynccpp.so.1.3
|
||||
lib/libasynccpp.so.1.4.0
|
||||
lib/libasynccpp.so.1.4
|
||||
lib/libasynccpp.so
|
||||
lib/libasyncaudio.so.1.3.1
|
||||
lib/libasyncaudio.so.1.3
|
||||
lib/libasyncaudio.so.1.4.0
|
||||
lib/libasyncaudio.so.1.4
|
||||
lib/libasyncaudio.so
|
||||
lib/svxlink/ModuleHelp.so
|
||||
lib/svxlink/ModuleParrot.so
|
||||
|
@ -79,7 +84,7 @@ lib/svxlink/ModuleEchoLink.so
|
|||
lib/svxlink/ModuleTcl.so
|
||||
lib/svxlink/ModuleDtmfRepeater.so
|
||||
lib/svxlink/ModuleMetarInfo.so
|
||||
lib/libecholib.so.1.3.1
|
||||
lib/libecholib.so.1.3.2
|
||||
lib/libecholib.so.1.3
|
||||
lib/libecholib.so
|
||||
%%STATIC%%lib/libasyncaudio.a
|
||||
|
@ -107,6 +112,7 @@ lib/libecholib.so
|
|||
%%DATADIR%%/modules.d/ModuleTclVoiceMail.tcl
|
||||
%%DATADIR%%/modules.d/ModulePropagationMonitor.tcl
|
||||
%%DATADIR%%/modules.d/ModuleSelCallEnc.tcl
|
||||
man/man1/devcal.1.gz
|
||||
man/man1/svxlink.1.gz
|
||||
man/man1/remotetrx.1.gz
|
||||
man/man1/siglevdetcal.1.gz
|
||||
|
|
Loading…
Reference in a new issue