1: Stagify.

2: use @sample on pkg-plist.
3: bump version.
This commit is contained in:
Vanilla I. Shu 2014-06-09 16:21:35 +00:00
parent e02b236f9d
commit 4744048656
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=357181
3 changed files with 41 additions and 21 deletions

View file

@ -3,6 +3,7 @@
PORTNAME= sntop
PORTVERSION= 1.4.3
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF
@ -16,21 +17,17 @@ PORTDOCS= COPYING CREDITS ChangeLog INSTALL README TODO
EXAMPLES= alarm.sh sntoprc.EXAMPLE
SUB_FILES= pkg-message
MAN1= sntop.1
NO_STAGE= yes
post-install:
@${STRIP_CMD} ${PREFIX}/bin/sntop
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sntop
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
@${MKDIR} ${EXAMPLESDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for example in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${example} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/${example} ${STAGEDIR}${EXAMPLESDIR}
.endfor
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -1,6 +1,6 @@
--- Makefile.in.orig Sun Nov 11 22:54:15 2001
+++ Makefile.in Sat Apr 6 23:49:08 2002
@@ -36,7 +36,7 @@
--- Makefile.in.orig 2001-11-12 05:54:15.000000000 +0800
+++ Makefile.in 2014-06-10 00:19:16.894102010 +0800
@@ -36,7 +36,7 @@ DOWENEEDGETOPT = @LIBOBJS@
MANDIR = @mandir@/man1
SNTOPRC = $(ETCDIR)/sntoprc
CC = @CC@
@ -9,28 +9,50 @@
proper: clean sntop
@@ -65,12 +65,12 @@
@@ -56,34 +56,33 @@ clean:
-rm getopt_long.o
install: sntop
- @if [ -d $(INSTDIR) ]; \
+ @if [ -d $(DESTDIR)$(INSTDIR) ]; \
then \
- cp sntop $(INSTDIR); \
- chmod 755 $(INSTDIR)/sntop; \
+ cp sntop $(DESTDIR)$(INSTDIR); \
+ chmod 755 $(DESTDIR)$(INSTDIR)/sntop; \
else \
echo "sntop: $(INSTDIR) does not exist"; false; \
fi
@if [ -d $(ETCDIR) ]; \
- @if [ -d $(ETCDIR) ]; \
+ @if [ -d $(DESTDIR)$(ETCDIR) ]; \
then \
- if [ ! -f $(ETCDIR)/sntoprc ]; \
+ if [ ! -f $(ETCDIR)/sntoprc.sample ]; \
+ if [ ! -f $(DESTDIR)$(ETCDIR)/sntoprc.sample ]; \
then \
- cp sntoprc.EXAMPLE $(ETCDIR)/sntoprc; \
- chmod 644 $(ETCDIR)/sntoprc; \
+ cp sntoprc.EXAMPLE $(ETCDIR)/sntoprc.sample; \
+ chmod 644 $(ETCDIR)/sntoprc.sample; \
+ cp sntoprc.EXAMPLE $(DESTDIR)$(ETCDIR)/sntoprc.sample; \
+ chmod 644 $(DESTDIR)$(ETCDIR)/sntoprc.sample; \
fi; \
- echo "sntop: Sample config exists at $(ETCDIR)/sntoprc"; \
+ echo "sntop: Sample config exists at $(ETCDIR)/sntoprc.sample"; \
else \
echo "sntop: $(ETCDIR) does not exist"; false; \
fi
@@ -78,7 +78,6 @@
- @if [ -d $(MANDIR) ]; \
+ @if [ -d $(DESTDIR)$(MANDIR) ]; \
then \
cp sntop.1 $(MANDIR); \
chmod 644 $(MANDIR)/sntop.1; \
- cp sntop.1 $(MANDIR); \
- chmod 644 $(MANDIR)/sntop.1; \
- gzip -9 $(MANDIR)/sntop.1; \
+ cp sntop.1 $(DESTDIR)$(MANDIR); \
+ chmod 644 $(DESTDIR)$(MANDIR)/sntop.1; \
echo "sntop: Man file installed in $(MANDIR)"; \
else \
echo "sntop: $(MANDIR) does not exist, not installing man file"; \
fi
- @if [ -f $(INSTDIR)/sntop ]; \
+ @if [ -f $(DESTDIR)$(INSTDIR)/sntop ]; \
then \
echo "sntop: Executable installed in $(INSTDIR)"; \
else \

View file

@ -1,5 +1,6 @@
bin/sntop
etc/sntoprc.sample
@sample etc/sntoprc.sample
man/man1/sntop.1.gz
%%EXAMPLESDIR%%/alarm.sh
%%EXAMPLESDIR%%/sntoprc.EXAMPLE
@dirrm %%EXAMPLESDIR%%