Update to 1.3.0
Changes: https://github.com/rubygems/rubygems-mirror/blob/master/CHANGELOG.rdoc https://github.com/rubygems/rubygems-mirror/commits/master
This commit is contained in:
parent
5156337cd9
commit
477daa57a9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482075
3 changed files with 7 additions and 27 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= rubygems-mirror
|
||||
PORTVERSION= 1.2.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.3.0
|
||||
CATEGORIES= devel rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -14,8 +13,9 @@ LICENSE= MIT
|
|||
|
||||
RUN_DEPENDS= rubygem-net-http-persistent>=2.9:www/rubygem-net-http-persistent
|
||||
|
||||
NO_ARCH= yes
|
||||
USE_RUBY= yes
|
||||
USES= gem
|
||||
USE_RUBY= yes
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1525985916
|
||||
SHA256 (rubygem/rubygems-mirror-1.2.0.gem) = 48f29d1ac5acb296a24b7d70034b12400374cf98cb1a4e8c63cdd6b4e6eca605
|
||||
SIZE (rubygem/rubygems-mirror-1.2.0.gem) = 11776
|
||||
TIMESTAMP = 1539374846
|
||||
SHA256 (rubygem/rubygems-mirror-1.3.0.gem) = fd3496a1bed5f19be639aae650162a8be32f5c5518dd27956216e6d275931416
|
||||
SIZE (rubygem/rubygems-mirror-1.3.0.gem) = 11776
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
Obtained from: https://github.com/rubygems/rubygems-mirror/commit/292a6b283b5ea96c20ed30b27526def4b142a866
|
||||
|
||||
--- lib/rubygems/mirror/fetcher.rb.orig 2018-06-02 12:50:03 UTC
|
||||
+++ lib/rubygems/mirror/fetcher.rb
|
||||
@@ -6,7 +6,14 @@ class Gem::Mirror::Fetcher
|
||||
class Error < StandardError; end
|
||||
|
||||
def initialize(opts = {})
|
||||
- @http = Net::HTTP::Persistent.new(self.class.name, :ENV)
|
||||
+ @http =
|
||||
+ if defined?(Net::HTTP::Persistent::DEFAULT_POOL_SIZE)
|
||||
+ Net::HTTP::Persistent.new(name: self.class.name, proxy: :ENV)
|
||||
+ else
|
||||
+ # net-http-persistent < 3.0
|
||||
+ Net::HTTP::Persistent.new(self.class.name, :ENV)
|
||||
+ end
|
||||
+
|
||||
@opts = opts
|
||||
|
||||
# default opts
|
Loading…
Reference in a new issue