This program remotely kills trino nodes on version 1.07b2+f3 and below.

It abuses the careless coding in trinoo nodes and causes them to exit.
This commit is contained in:
David E. O'Brien 2000-02-14 03:46:32 +00:00
parent ea1a4b4c7e
commit 47878a089b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25809
6 changed files with 49 additions and 0 deletions

View file

@ -0,0 +1,30 @@
# ex:ts=8
# Ports collection makefile for: trinokiller
# Version required: 1.0
# Date created: Sun Feb 12, 2000
# Whom: David O'Brien (obrien@NUXI.com)
#
# $FreeBSD$
#
DISTNAME= trinokiller
PKGNAME= trinokiller-1.0
CATEGORIES= security
MASTER_SITES= http://www.afro-productions.com/
EXTRACT_SUFX= .c
MAINTAINER= obrien@FreeBSD.org
NO_WRKSUBDIR= yes
do-extract:
@${MKDIR} ${WRKDIR}
@${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${DISTNAME} ${DISTNAME}.c)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/sbin
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (trinokiller.c) = 3aa49c480158e8c78199f25a5660cc79

View file

@ -0,0 +1,10 @@
--- trinokiller.c.orig Sun Feb 13 19:41:24 2000
+++ trinokiller.c Sun Feb 13 19:41:48 2000
@@ -12,6 +12,7 @@
*
*/
+#include <sys/types.h>
#include <stdlib.h>
#include <stdio.h>
#include <sys/socket.h>

View file

@ -0,0 +1 @@
remotely kill trino nodes

View file

@ -0,0 +1,6 @@
This program remotely kills trino nodes on version 1.07b2+f3 and below.
It abuses the careless coding in trinoo nodes and causes them to exit. It
requires that you either know the node password or think it's the default
password.
WWW: http://www.afro-productions.com/utils.html

View file

@ -0,0 +1 @@
sbin/trinokiller