upgrade to 1.3.0

PR:		40424
Submitted by:	maintainer
This commit is contained in:
Ying-Chieh Liao 2002-07-11 16:51:06 +00:00
parent 46c48ab102
commit 47c68887b2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62820
15 changed files with 24 additions and 198 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= openvpn
PORTVERSION= 1.2.1
PORTVERSION= 1.3.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -34,6 +34,7 @@ post-install:
@${MKDIR} ${DOCSDIR}/${dirs}
@${INSTALL_DATA} ${WRKSRC}/${dirs}/* ${DOCSDIR}/${dirs}
.endfor
@${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (openvpn-1.2.1.tar.gz) = 9a41f775bb5045d225483c8a2a9b0ad0
MD5 (openvpn-1.3.0.tar.gz) = f82482f0ec8d9091876bd86133a8ff2f

View file

@ -1,11 +0,0 @@
--- error.c.orig Mon Jun 24 02:27:37 2002
+++ error.c Mon Jun 24 02:28:05 2002
@@ -215,7 +215,7 @@
#if defined(HAVE_OPENLOG) && defined(HAVE_SYSLOG)
if (daemon (cd != NULL, 0) < 0)
msg (M_ERR, "daemon() failed");
- openlog ("openvpn", LOG_PID, 0);
+ openlog ("openvpn", LOG_PID, LOG_DAEMON);
#else
msg (M_WARN, "Warning: this operating system lacks daemon logging features, therefore when I become a daemon, I won't be able to log status or error messages");
if (daemon (cd != NULL, 0) < 0)

View file

@ -1,53 +0,0 @@
--- tun.c.orig Sun Jun 23 23:43:57 2002
+++ tun.c Sun Jun 23 23:45:54 2002
@@ -76,7 +76,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "linux ifconfig failed");
+ msg (M_ERR, "Linux ifconfig failed");
#elif defined(TARGET_SOLARIS)
@@ -90,7 +90,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "solaris ifconfig failed");
+ msg (M_ERR, "Solaris ifconfig failed");
#elif defined(TARGET_OPENBSD)
@@ -118,7 +118,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "openbsd ifconfig failed");
+ msg (M_ERR, "OpenBSD ifconfig failed");
#elif defined(TARGET_DARWIN)
@@ -144,7 +144,22 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "darwin ifconfig failed");
+ msg (M_ERR, "Darwin ifconfig failed");
+
+#elif defined(TARGET_FREEBSD)
+ /* example: ifconfig tun2 10.2.0.2 10.2.0.1 mtu 1450 netmask 255.255.255.255 up */
+ snprintf (command_line, sizeof (command_line),
+ IFCONFIG_PATH " %s %s %s mtu %d netmask 255.255.255.255 up",
+ dev,
+ ifconfig_local,
+ ifconfig_remote,
+ tun_mtu
+ );
+ msg (M_INFO, "%s", command_line);
+ if (openvpn_system (command_line) != 0)
+ msg (M_ERR, "FreeBSD ifconfig failed");
+
+
#else
msg (M_FATAL, "Sorry, but I don't know how to do 'ifconfig' commands on this operating system. You should ifconfig your tun/tap device manually or use an --up script.");

View file

@ -0,0 +1,5 @@
### ---------------------------------------------------------------------- ###
### To retain backwards compatibility of OpenVPN 1.3.0 with OpenVPN peers ###
### that run older versions (back to 1.1.0), you will have to set the MTU ###
### explicitly by command line options since OpenVPN 1.3.0. ###
### ---------------------------------------------------------------------- ###

View file

@ -6,7 +6,7 @@
#
PORTNAME= openvpn
PORTVERSION= 1.2.1
PORTVERSION= 1.3.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -34,6 +34,7 @@ post-install:
@${MKDIR} ${DOCSDIR}/${dirs}
@${INSTALL_DATA} ${WRKSRC}/${dirs}/* ${DOCSDIR}/${dirs}
.endfor
@${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (openvpn-1.2.1.tar.gz) = 9a41f775bb5045d225483c8a2a9b0ad0
MD5 (openvpn-1.3.0.tar.gz) = f82482f0ec8d9091876bd86133a8ff2f

View file

@ -1,11 +0,0 @@
--- error.c.orig Mon Jun 24 02:27:37 2002
+++ error.c Mon Jun 24 02:28:05 2002
@@ -215,7 +215,7 @@
#if defined(HAVE_OPENLOG) && defined(HAVE_SYSLOG)
if (daemon (cd != NULL, 0) < 0)
msg (M_ERR, "daemon() failed");
- openlog ("openvpn", LOG_PID, 0);
+ openlog ("openvpn", LOG_PID, LOG_DAEMON);
#else
msg (M_WARN, "Warning: this operating system lacks daemon logging features, therefore when I become a daemon, I won't be able to log status or error messages");
if (daemon (cd != NULL, 0) < 0)

View file

@ -1,53 +0,0 @@
--- tun.c.orig Sun Jun 23 23:43:57 2002
+++ tun.c Sun Jun 23 23:45:54 2002
@@ -76,7 +76,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "linux ifconfig failed");
+ msg (M_ERR, "Linux ifconfig failed");
#elif defined(TARGET_SOLARIS)
@@ -90,7 +90,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "solaris ifconfig failed");
+ msg (M_ERR, "Solaris ifconfig failed");
#elif defined(TARGET_OPENBSD)
@@ -118,7 +118,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "openbsd ifconfig failed");
+ msg (M_ERR, "OpenBSD ifconfig failed");
#elif defined(TARGET_DARWIN)
@@ -144,7 +144,22 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "darwin ifconfig failed");
+ msg (M_ERR, "Darwin ifconfig failed");
+
+#elif defined(TARGET_FREEBSD)
+ /* example: ifconfig tun2 10.2.0.2 10.2.0.1 mtu 1450 netmask 255.255.255.255 up */
+ snprintf (command_line, sizeof (command_line),
+ IFCONFIG_PATH " %s %s %s mtu %d netmask 255.255.255.255 up",
+ dev,
+ ifconfig_local,
+ ifconfig_remote,
+ tun_mtu
+ );
+ msg (M_INFO, "%s", command_line);
+ if (openvpn_system (command_line) != 0)
+ msg (M_ERR, "FreeBSD ifconfig failed");
+
+
#else
msg (M_FATAL, "Sorry, but I don't know how to do 'ifconfig' commands on this operating system. You should ifconfig your tun/tap device manually or use an --up script.");

View file

@ -0,0 +1,5 @@
### ---------------------------------------------------------------------- ###
### To retain backwards compatibility of OpenVPN 1.3.0 with OpenVPN peers ###
### that run older versions (back to 1.1.0), you will have to set the MTU ###
### explicitly by command line options since OpenVPN 1.3.0. ###
### ---------------------------------------------------------------------- ###

View file

@ -6,7 +6,7 @@
#
PORTNAME= openvpn
PORTVERSION= 1.2.1
PORTVERSION= 1.3.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -34,6 +34,7 @@ post-install:
@${MKDIR} ${DOCSDIR}/${dirs}
@${INSTALL_DATA} ${WRKSRC}/${dirs}/* ${DOCSDIR}/${dirs}
.endfor
@${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (openvpn-1.2.1.tar.gz) = 9a41f775bb5045d225483c8a2a9b0ad0
MD5 (openvpn-1.3.0.tar.gz) = f82482f0ec8d9091876bd86133a8ff2f

View file

@ -1,11 +0,0 @@
--- error.c.orig Mon Jun 24 02:27:37 2002
+++ error.c Mon Jun 24 02:28:05 2002
@@ -215,7 +215,7 @@
#if defined(HAVE_OPENLOG) && defined(HAVE_SYSLOG)
if (daemon (cd != NULL, 0) < 0)
msg (M_ERR, "daemon() failed");
- openlog ("openvpn", LOG_PID, 0);
+ openlog ("openvpn", LOG_PID, LOG_DAEMON);
#else
msg (M_WARN, "Warning: this operating system lacks daemon logging features, therefore when I become a daemon, I won't be able to log status or error messages");
if (daemon (cd != NULL, 0) < 0)

View file

@ -1,53 +0,0 @@
--- tun.c.orig Sun Jun 23 23:43:57 2002
+++ tun.c Sun Jun 23 23:45:54 2002
@@ -76,7 +76,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "linux ifconfig failed");
+ msg (M_ERR, "Linux ifconfig failed");
#elif defined(TARGET_SOLARIS)
@@ -90,7 +90,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "solaris ifconfig failed");
+ msg (M_ERR, "Solaris ifconfig failed");
#elif defined(TARGET_OPENBSD)
@@ -118,7 +118,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "openbsd ifconfig failed");
+ msg (M_ERR, "OpenBSD ifconfig failed");
#elif defined(TARGET_DARWIN)
@@ -144,7 +144,22 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "darwin ifconfig failed");
+ msg (M_ERR, "Darwin ifconfig failed");
+
+#elif defined(TARGET_FREEBSD)
+ /* example: ifconfig tun2 10.2.0.2 10.2.0.1 mtu 1450 netmask 255.255.255.255 up */
+ snprintf (command_line, sizeof (command_line),
+ IFCONFIG_PATH " %s %s %s mtu %d netmask 255.255.255.255 up",
+ dev,
+ ifconfig_local,
+ ifconfig_remote,
+ tun_mtu
+ );
+ msg (M_INFO, "%s", command_line);
+ if (openvpn_system (command_line) != 0)
+ msg (M_ERR, "FreeBSD ifconfig failed");
+
+
#else
msg (M_FATAL, "Sorry, but I don't know how to do 'ifconfig' commands on this operating system. You should ifconfig your tun/tap device manually or use an --up script.");

View file

@ -0,0 +1,5 @@
### ---------------------------------------------------------------------- ###
### To retain backwards compatibility of OpenVPN 1.3.0 with OpenVPN peers ###
### that run older versions (back to 1.1.0), you will have to set the MTU ###
### explicitly by command line options since OpenVPN 1.3.0. ###
### ---------------------------------------------------------------------- ###