net/gnome-nettool: Update to 42.0
This commit is contained in:
parent
2612817fd0
commit
47de15c587
6 changed files with 75 additions and 21 deletions
|
@ -1,11 +1,10 @@
|
|||
# Created by: Adam Weinberger <adamw@FreeBSD.org>
|
||||
|
||||
PORTNAME= gnome-nettool
|
||||
PORTVERSION= 3.8.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 42.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net gnome
|
||||
MASTER_SITES= GNOME
|
||||
MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
|
||||
DIST_SUBDIR= gnome3
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
@ -15,12 +14,10 @@ BUILD_DEPENDS= itstool:textproc/itstool
|
|||
LIB_DEPENDS= libgtop-2.0.so:devel/libgtop
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/dig:dns/bind-tools
|
||||
|
||||
USES= gettext gmake gnome meson pathfix pkgconfig python:3.8+ tar:xz
|
||||
USE_GNOME= gtk30 intlhack libxml2:build
|
||||
USES= gettext gmake gnome libtool localbase:ldflags pathfix pkgconfig \
|
||||
tar:xz
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
GLIB_SCHEMAS= org.gnome.gnome-nettool.gschema.xml
|
||||
|
||||
BINARY_ALIAS= python3=${PYTHON_CMD}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (gnome3/gnome-nettool-3.8.1.tar.xz) = f0a4510d9fe5eae4c91b63ade9848992b2795108e76eff7f51dc3decf7df2cb1
|
||||
SIZE (gnome3/gnome-nettool-3.8.1.tar.xz) = 589024
|
||||
TIMESTAMP = 1653086843
|
||||
SHA256 (gnome3/gnome-nettool-42.0.tar.xz) = a54f29eef2038aee69551c8b19ca4f758e5eb9e2090a4bc6b5633dff0188751f
|
||||
SIZE (gnome3/gnome-nettool-42.0.tar.xz) = 422880
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- src/info.c.orig 2013-05-31 00:00:21 UTC
|
||||
--- src/info.c.orig 2022-04-06 01:52:01 UTC
|
||||
+++ src/info.c
|
||||
@@ -20,6 +20,10 @@
|
||||
#include <gtk/gtk.h>
|
||||
|
@ -28,8 +28,8 @@
|
|||
+ { N_("Modem Interface"), INFO_INTERFACE_PPP, "16_ppp.xpm", "tun", NULL },
|
||||
{ N_("Parallel Line Interface"), INFO_INTERFACE_PLIP, "16_plip.xpm", "plip", NULL },
|
||||
{ N_("Infrared Interface"), INFO_INTERFACE_IRLAN, "irda-16.png", "irlan", NULL },
|
||||
{ N_("Loopback Interface"), INFO_INTERFACE_LO, "16_loopback.xpm", "lo", NULL },
|
||||
@@ -131,9 +139,35 @@ info_get_interface_from_dev_name (const gchar *dev_nam
|
||||
{ N_("Infiniband Interface"), INFO_INTERFACE_IB, "network.png", "ib", NULL },
|
||||
@@ -132,9 +140,35 @@ info_get_interface_from_dev_name (const gchar *dev_nam
|
||||
{
|
||||
gint i;
|
||||
gchar *path;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/netstat.c.orig 2012-01-03 10:38:09.000000000 +0100
|
||||
+++ src/netstat.c 2015-08-28 16:21:17.101757000 +0200
|
||||
@@ -114,7 +114,7 @@ netstat_get_active_option (Netinfo * net
|
||||
--- src/netstat.c.orig 2022-04-06 01:52:01 UTC
|
||||
+++ src/netstat.c
|
||||
@@ -114,7 +114,7 @@ netstat_get_active_option (Netinfo * netinfo)
|
||||
g_return_val_if_fail (netinfo != NULL, NULL);
|
||||
|
||||
if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (netinfo->routing))) {
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/nettool.c.orig 2012-01-03 10:38:09.000000000 +0100
|
||||
+++ src/nettool.c 2015-08-28 16:28:52.904785000 +0200
|
||||
--- src/nettool.c.orig 2022-04-06 01:52:01 UTC
|
||||
+++ src/nettool.c
|
||||
@@ -28,7 +28,6 @@
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
|
@ -8,7 +8,7 @@
|
|||
#include <signal.h>
|
||||
#include <errno.h>
|
||||
#include <sys/wait.h>
|
||||
@@ -410,6 +409,10 @@ netinfo_io_text_buffer_dialog (GIOChanne
|
||||
@@ -410,6 +409,10 @@ netinfo_io_text_buffer_dialog (GIOChannel * channel,
|
||||
len, NULL);
|
||||
}
|
||||
|
||||
|
@ -19,7 +19,7 @@
|
|||
} else if (status == G_IO_STATUS_AGAIN) {
|
||||
char buf[1];
|
||||
|
||||
@@ -421,6 +424,11 @@ netinfo_io_text_buffer_dialog (GIOChanne
|
||||
@@ -421,6 +424,11 @@ netinfo_io_text_buffer_dialog (GIOChannel * channel,
|
||||
}
|
||||
g_string_append_c (netinfo->command_output, buf[0]);
|
||||
}
|
||||
|
@ -31,7 +31,7 @@
|
|||
} else if (status == G_IO_STATUS_EOF) {
|
||||
|
||||
} else if (status == G_IO_STATUS_ERROR) {
|
||||
@@ -438,15 +446,16 @@ netinfo_io_text_buffer_dialog (GIOChanne
|
||||
@@ -438,15 +446,16 @@ netinfo_io_text_buffer_dialog (GIOChannel * channel,
|
||||
|
||||
} else {
|
||||
g_warning ("Error: %s\n", err->message);
|
||||
|
|
|
@ -57,12 +57,54 @@ share/help/es/gnome-nettool/index.page
|
|||
share/help/es/gnome-nettool/introduction.page
|
||||
share/help/es/gnome-nettool/ip-information.page
|
||||
share/help/es/gnome-nettool/network-connectivity.page
|
||||
share/help/eu/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/eu/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/eu/gnome-nettool/index.page
|
||||
share/help/eu/gnome-nettool/introduction.page
|
||||
share/help/eu/gnome-nettool/ip-information.page
|
||||
share/help/eu/gnome-nettool/network-connectivity.page
|
||||
share/help/fr/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/fr/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/fr/gnome-nettool/index.page
|
||||
share/help/fr/gnome-nettool/introduction.page
|
||||
share/help/fr/gnome-nettool/ip-information.page
|
||||
share/help/fr/gnome-nettool/network-connectivity.page
|
||||
share/help/fur/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/fur/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/fur/gnome-nettool/index.page
|
||||
share/help/fur/gnome-nettool/introduction.page
|
||||
share/help/fur/gnome-nettool/ip-information.page
|
||||
share/help/fur/gnome-nettool/network-connectivity.page
|
||||
share/help/gl/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/gl/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/gl/gnome-nettool/index.page
|
||||
share/help/gl/gnome-nettool/introduction.page
|
||||
share/help/gl/gnome-nettool/ip-information.page
|
||||
share/help/gl/gnome-nettool/network-connectivity.page
|
||||
share/help/hu/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/hu/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/hu/gnome-nettool/index.page
|
||||
share/help/hu/gnome-nettool/introduction.page
|
||||
share/help/hu/gnome-nettool/ip-information.page
|
||||
share/help/hu/gnome-nettool/network-connectivity.page
|
||||
share/help/id/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/id/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/id/gnome-nettool/index.page
|
||||
share/help/id/gnome-nettool/introduction.page
|
||||
share/help/id/gnome-nettool/ip-information.page
|
||||
share/help/id/gnome-nettool/network-connectivity.page
|
||||
share/help/it/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/it/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/it/gnome-nettool/index.page
|
||||
share/help/it/gnome-nettool/introduction.page
|
||||
share/help/it/gnome-nettool/ip-information.page
|
||||
share/help/it/gnome-nettool/network-connectivity.page
|
||||
share/help/ko/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/ko/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/ko/gnome-nettool/index.page
|
||||
share/help/ko/gnome-nettool/introduction.page
|
||||
share/help/ko/gnome-nettool/ip-information.page
|
||||
share/help/ko/gnome-nettool/network-connectivity.page
|
||||
share/help/oc/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/oc/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/oc/gnome-nettool/index.page
|
||||
|
@ -75,6 +117,12 @@ share/help/pa/gnome-nettool/index.page
|
|||
share/help/pa/gnome-nettool/introduction.page
|
||||
share/help/pa/gnome-nettool/ip-information.page
|
||||
share/help/pa/gnome-nettool/network-connectivity.page
|
||||
share/help/pl/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/pl/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/pl/gnome-nettool/index.page
|
||||
share/help/pl/gnome-nettool/introduction.page
|
||||
share/help/pl/gnome-nettool/ip-information.page
|
||||
share/help/pl/gnome-nettool/network-connectivity.page
|
||||
share/help/pt_BR/gnome-nettool/figures/gnome-nettool-trail.png
|
||||
share/help/pt_BR/gnome-nettool/figures/gnome-nettool.png
|
||||
share/help/pt_BR/gnome-nettool/index.page
|
||||
|
@ -115,6 +163,7 @@ share/icons/hicolor/16x16/apps/gnome-nettool.png
|
|||
share/icons/hicolor/22x22/apps/gnome-nettool.png
|
||||
share/icons/hicolor/24x24/apps/gnome-nettool.png
|
||||
share/icons/hicolor/32x32/apps/gnome-nettool.png
|
||||
share/icons/hicolor/scalable/apps/gnome-nettool-symbolic.svg
|
||||
share/icons/hicolor/scalable/apps/gnome-nettool.svg
|
||||
share/locale/af/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ar/LC_MESSAGES/gnome-nettool.mo
|
||||
|
@ -129,6 +178,7 @@ share/locale/br/LC_MESSAGES/gnome-nettool.mo
|
|||
share/locale/bs/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ca/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ca@valencia/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ckb/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/cs/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/cy/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/da/LC_MESSAGES/gnome-nettool.mo
|
||||
|
@ -145,7 +195,9 @@ share/locale/eu/LC_MESSAGES/gnome-nettool.mo
|
|||
share/locale/fa/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/fi/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/fr/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/fur/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ga/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/gd/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/gl/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/gu/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/he/LC_MESSAGES/gnome-nettool.mo
|
||||
|
@ -153,13 +205,16 @@ share/locale/hi/LC_MESSAGES/gnome-nettool.mo
|
|||
share/locale/hr/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/hu/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/id/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/is/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/it/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ja/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ka/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/kk/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/km/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/kn/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ko/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/ku/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/lo/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/lt/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/lv/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/mai/LC_MESSAGES/gnome-nettool.mo
|
||||
|
@ -205,3 +260,4 @@ share/locale/xh/LC_MESSAGES/gnome-nettool.mo
|
|||
share/locale/zh_CN/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/zh_HK/LC_MESSAGES/gnome-nettool.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
|
||||
share/metainfo/gnome-nettool.appdata.xml
|
||||
|
|
Loading…
Reference in a new issue