Add projectionlib 3.7, a C++ wrapper for the USGS GCTP projection
library. PR: 26928 Submitted by: Randall Hopper <aa8vb@nc.rr.com>
This commit is contained in:
parent
f5af0463e4
commit
47f8960c39
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43351
18 changed files with 224 additions and 0 deletions
|
@ -126,6 +126,7 @@
|
|||
SUBDIR += pinfo
|
||||
SUBDIR += pkg_tarup
|
||||
SUBDIR += porteasy
|
||||
SUBDIR += projectionlib
|
||||
SUBDIR += proxyper
|
||||
SUBDIR += py-distutils
|
||||
SUBDIR += pybliographer
|
||||
|
|
30
misc/projectionlib/Makefile
Normal file
30
misc/projectionlib/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# New ports collection makefile for: ProjectionLib library from VTP
|
||||
# Date created: 26 Apr 2001
|
||||
# Whom: Randall Hopper <aa8vb@nc.rr.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= projectionlib
|
||||
PORTVERSION= 3.7
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ftp://ftpmcmc.er.usgs.gov/release/viewers/dlgv32/source/
|
||||
DISTNAME= Dlgv32v37
|
||||
|
||||
MAINTAINER= aa8vb@nc.rr.com
|
||||
|
||||
LIB_DEPENDS= gctpc.1:${PORTSDIR}/misc/gctpc
|
||||
|
||||
EXTRACT_CMD= unzip -a
|
||||
|
||||
WRKSRC= ${WRKDIR}/dlgv32/ProjectionLib
|
||||
|
||||
USE_ZIP= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
MAKEFILE= ${FILESDIR}/Makefile
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/include/ProjectionLib
|
||||
${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/ProjectionLib
|
||||
|
||||
.include <bsd.port.mk>
|
1
misc/projectionlib/distinfo
Normal file
1
misc/projectionlib/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (Dlgv32v37.zip) = 067dcd5a9b7be359b3275cf16d45ab17
|
11
misc/projectionlib/files/Makefile
Normal file
11
misc/projectionlib/files/Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
# $FreeBSD$
|
||||
|
||||
LIB= projection
|
||||
SRCS!= echo ${.CURDIR}/*.cpp
|
||||
CXXFLAGS+= -I${LOCALBASE}/include
|
||||
SHLIB_MAJOR= 1
|
||||
SHLIB_MINOR= 0
|
||||
LIBDIR= ${PREFIX}/lib
|
||||
NOPROFILE= true
|
||||
|
||||
.include <bsd.lib.mk>
|
11
misc/projectionlib/files/patch-aa
Normal file
11
misc/projectionlib/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/AlaskaConformalProjection.cpp AlaskaConformalProjection.cpp
|
||||
--- ORIG/AlaskaConformalProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ AlaskaConformalProjection.cpp Fri Apr 27 19:07:38 2001
|
||||
@@ -8,6 +8,7 @@
|
||||
#include "AlaskaConformalProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctpc.h"
|
||||
#include "gctpc/gctp.h"
|
17
misc/projectionlib/files/patch-ab
Normal file
17
misc/projectionlib/files/patch-ab
Normal file
|
@ -0,0 +1,17 @@
|
|||
diff -ruN ORIG/AzimuthalProjection.cpp AzimuthalProjection.cpp
|
||||
--- ORIG/AzimuthalProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ AzimuthalProjection.cpp Fri Apr 27 19:07:35 2001
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "AzimuthalProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctpc.h"
|
||||
#include "gctpc/proj.h"
|
||||
@@ -257,4 +258,4 @@
|
||||
{
|
||||
return true;
|
||||
}
|
||||
-}
|
||||
+}
|
11
misc/projectionlib/files/patch-ac
Normal file
11
misc/projectionlib/files/patch-ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/ConicProjection.cpp ConicProjection.cpp
|
||||
--- ORIG/ConicProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ ConicProjection.cpp Fri Apr 27 19:07:21 2001
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "ConicProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctpc.h"
|
||||
#include "gctpc/proj.h"
|
11
misc/projectionlib/files/patch-ad
Normal file
11
misc/projectionlib/files/patch-ad
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/HotineObliqueMercatorProjection.cpp HotineObliqueMercatorProjection.cpp
|
||||
--- ORIG/HotineObliqueMercatorProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ HotineObliqueMercatorProjection.cpp Fri Apr 27 19:07:19 2001
|
||||
@@ -5,6 +5,7 @@
|
||||
//////////////////////////////////////////////////////////////////////
|
||||
|
||||
#include "HotineObliqueMercatorProjection.h"
|
||||
+#include <stdio.h>
|
||||
|
||||
//////////////////////////////////////////////////////////////////////
|
||||
// Construction/Destruction
|
17
misc/projectionlib/files/patch-ae
Normal file
17
misc/projectionlib/files/patch-ae
Normal file
|
@ -0,0 +1,17 @@
|
|||
diff -ruN ORIG/MercatorProjection.cpp MercatorProjection.cpp
|
||||
--- ORIG/MercatorProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ MercatorProjection.cpp Fri Apr 27 19:07:15 2001
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "MercatorProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctpc.h"
|
||||
#include "gctpc/proj.h"
|
||||
@@ -240,4 +241,4 @@
|
||||
}
|
||||
|
||||
return ( latitude >= -86.0 && latitude <= 86.0 );
|
||||
-}
|
||||
+}
|
11
misc/projectionlib/files/patch-af
Normal file
11
misc/projectionlib/files/patch-af
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/PolarStereographicProjection.cpp PolarStereographicProjection.cpp
|
||||
--- ORIG/PolarStereographicProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ PolarStereographicProjection.cpp Fri Apr 27 19:07:11 2001
|
||||
@@ -4,6 +4,7 @@
|
||||
// Started: 2/26/98
|
||||
|
||||
#include "PolarStereographicProjection.h"
|
||||
+#include <stdio.h>
|
||||
|
||||
PolarStereographicProjection::PolarStereographicProjection( double longPole, double trueScale,
|
||||
double sMajor, double sMinor,
|
18
misc/projectionlib/files/patch-ag
Normal file
18
misc/projectionlib/files/patch-ag
Normal file
|
@ -0,0 +1,18 @@
|
|||
diff -ruN ORIG/Projection.cpp Projection.cpp
|
||||
--- ORIG/Projection.cpp Fri May 5 07:24:56 2000
|
||||
+++ Projection.cpp Fri Apr 27 19:07:08 2001
|
||||
@@ -9,6 +9,8 @@
|
||||
#include "GeographicProjection.h"
|
||||
#include "gctpc/untfz.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
+
|
||||
#ifndef NULL
|
||||
#define NULL 0
|
||||
#endif
|
||||
@@ -238,4 +240,4 @@
|
||||
longitude /= factor;
|
||||
|
||||
return bResult;
|
||||
-}
|
||||
+}
|
11
misc/projectionlib/files/patch-ah
Normal file
11
misc/projectionlib/files/patch-ah
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/PseudocylindricalProjection.cpp PseudocylindricalProjection.cpp
|
||||
--- ORIG/PseudocylindricalProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ PseudocylindricalProjection.cpp Fri Apr 27 19:07:04 2001
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "PseudocylindricalProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctpc.h"
|
||||
#include "gctpc/proj.h"
|
11
misc/projectionlib/files/patch-ai
Normal file
11
misc/projectionlib/files/patch-ai
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/StatePlaneProjection.cpp StatePlaneProjection.cpp
|
||||
--- ORIG/StatePlaneProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ StatePlaneProjection.cpp Fri Apr 27 19:06:46 2001
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "StatePlaneProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctp.h"
|
||||
#include "gctpc/gctpc.h"
|
11
misc/projectionlib/files/patch-aj
Normal file
11
misc/projectionlib/files/patch-aj
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/TransverseMercatorProjection.cpp TransverseMercatorProjection.cpp
|
||||
--- ORIG/TransverseMercatorProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ TransverseMercatorProjection.cpp Fri Apr 27 19:07:00 2001
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "TransverseMercatorProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctpc.h"
|
||||
#include "gctpc/gctp.h"
|
11
misc/projectionlib/files/patch-ak
Normal file
11
misc/projectionlib/files/patch-ak
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -ruN ORIG/UTMProjection.cpp UTMProjection.cpp
|
||||
--- ORIG/UTMProjection.cpp Fri May 5 07:24:56 2000
|
||||
+++ UTMProjection.cpp Fri Apr 27 19:06:57 2001
|
||||
@@ -7,6 +7,7 @@
|
||||
#include "UTMProjection.h"
|
||||
#include "DatumConvertor.h"
|
||||
|
||||
+#include <stdio.h>
|
||||
// GCTPC includes
|
||||
#include "gctpc/gctpc.h"
|
||||
#include "gctpc/gctp.h"
|
1
misc/projectionlib/pkg-comment
Normal file
1
misc/projectionlib/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A C++ wrapper for the USGS GCTP projection library
|
6
misc/projectionlib/pkg-descr
Normal file
6
misc/projectionlib/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
C++ wrapper for the USGS GCTP projection library.
|
||||
|
||||
This library is delivered as part of the USGS dlgv32 application used
|
||||
for viewing Digital Line Graph products.
|
||||
|
||||
WWW: http://mcmcweb.er.usgs.gov/viewers/dlg_view.html
|
34
misc/projectionlib/pkg-plist
Normal file
34
misc/projectionlib/pkg-plist
Normal file
|
@ -0,0 +1,34 @@
|
|||
include/ProjectionLib/AlaskaConformalProjection.h
|
||||
include/ProjectionLib/AlbersConicProjection.h
|
||||
include/ProjectionLib/AzimuthalEquidistantProjection.h
|
||||
include/ProjectionLib/AzimuthalProjection.h
|
||||
include/ProjectionLib/ConicProjection.h
|
||||
include/ProjectionLib/DatumConvertor.h
|
||||
include/ProjectionLib/EquidistantConicProjection.h
|
||||
include/ProjectionLib/EquirectangularProjection.h
|
||||
include/ProjectionLib/GeographicProjection.h
|
||||
include/ProjectionLib/GnomonicProjection.h
|
||||
include/ProjectionLib/HotineObliqueMercatorProjection.h
|
||||
include/ProjectionLib/LambertAzimuthalProjection.h
|
||||
include/ProjectionLib/LambertConformalConicProjection.h
|
||||
include/ProjectionLib/MercatorProjection.h
|
||||
include/ProjectionLib/MillerCylindricalProjection.h
|
||||
include/ProjectionLib/OrthographicProjection.h
|
||||
include/ProjectionLib/PolarStereographicProjection.h
|
||||
include/ProjectionLib/PolyconicProjection.h
|
||||
include/ProjectionLib/Projection.h
|
||||
include/ProjectionLib/ProjectionTypes.h
|
||||
include/ProjectionLib/PseudocylindricalProjection.h
|
||||
include/ProjectionLib/RobinsonProjection.h
|
||||
include/ProjectionLib/SinusoidalProjection.h
|
||||
include/ProjectionLib/StatePlaneProjection.h
|
||||
include/ProjectionLib/StereographicProjection.h
|
||||
include/ProjectionLib/TransverseMercatorProjection.h
|
||||
include/ProjectionLib/UTMProjection.h
|
||||
include/ProjectionLib/UnknownProjection.h
|
||||
include/ProjectionLib/VanDerGrintenProjection.h
|
||||
include/ProjectionLib/ZonedProjection.h
|
||||
lib/libprojection.a
|
||||
lib/libprojection.so
|
||||
lib/libprojection.so.1
|
||||
@dirrm include/ProjectionLib
|
Loading…
Reference in a new issue