- Update of irc/ircd-ratbox port from ircd-ratbox-2.2.6 to ircd-ratbox-2.2.8 to fix a few very minor bugs.
- Included ircd-shortcut.pl in ircd-ratbox tarball. - Added port support for configuring services names and parameters within the ircd-shortcut.pl build script (requested by ratbox users and makes things a bit nicer). - Fixed a pkg-plist inconsistency when compiling old port and building with support for services. - Added perl5 build requirement for ircd-shortcut.pl. PR: ports/119784 Submitted by: Lewis <moggie@elasticmind.net> (maintainer) Approved by: linimon (mentor)
This commit is contained in:
parent
7c522afbf5
commit
480a524421
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=205819
5 changed files with 72 additions and 13 deletions
|
@ -7,8 +7,7 @@
|
|||
# ex: ts=8
|
||||
|
||||
PORTNAME= ircd-ratbox
|
||||
PORTVERSION= 2.2.6
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.2.8
|
||||
CATEGORIES= irc ipv6
|
||||
MASTER_SITES= ftp://ftp.ircd-ratbox.org/pub/ircd-ratbox/ \
|
||||
ftp://ftp.demon.co.uk/pub/mirrors/ircd-ratbox/ \
|
||||
|
@ -24,6 +23,7 @@ CONFLICTS= ircd-ratbox-devel-[0-9]*
|
|||
|
||||
MAN8= ircd.8
|
||||
USE_RC_SUBR= ircd-ratbox.sh
|
||||
USE_PERL5_BUILD= yes
|
||||
|
||||
LOGDIR= /var/log/${PORTNAME}
|
||||
RUNDIR= /var/run/${PORTNAME}
|
||||
|
@ -111,18 +111,71 @@ pre-configure:
|
|||
@${ECHO_MSG} " NICKLEN [default 9, max 50] - Max nick length on server"
|
||||
@${ECHO_MSG} " TOPICLEN [default 160, max 390] - Max topic length"
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} " SERVER_NAME [default 'services.ircd-ratbox.org'] - Name of services"
|
||||
@${ECHO_MSG} " USER_SERV [default 'USERSERV'] - Name of user registration service"
|
||||
@${ECHO_MSG} " CHAN_SERV [default 'CHANSERV'] - Name of channel registration serv'"
|
||||
@${ECHO_MSG} " NICK_SERV [default 'NICKSERV'] - Name of nickname registration serv'"
|
||||
@${ECHO_MSG} " ALIS_SERV [default 'ALIS'] - Name of channel list service"
|
||||
@${ECHO_MSG} " OPER_BOT [default 'OPERBOT'] - Name of operbot service"
|
||||
@${ECHO_MSG} " OPER_SERV [default 'OPERSERV'] - Name of oper command service"
|
||||
@${ECHO_MSG} " JUPE_SERV [default 'JUPESERV'] - Name of jupe service"
|
||||
@${ECHO_MSG} " GLOBAL_SERV [default 'GLOBAL'] - Name of global announce service"
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} "Press CTRL+C now if you wish to set them."
|
||||
@${ECHO_MSG} ""
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s#-O2##" ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e "s#%%PREFIX%%#${PREFIX}#g" \
|
||||
${WRKSRC}/doc/example.conf \
|
||||
${WRKSRC}/doc/example.efnet.conf
|
||||
${WRKSRC}/doc/example.conf \
|
||||
${WRKSRC}/doc/example.efnet.conf
|
||||
@${REINPLACE_CMD} -e "s#%%LOGDIR%%#${LOGDIR}#g" \
|
||||
${WRKSRC}/doc/example.conf \
|
||||
${WRKSRC}/doc/example.efnet.conf
|
||||
@${REINPLACE_CMD} -e "s#%%RUNDIR%%#${RUNDIR}#g" ${WRKSRC}/include/config.h
|
||||
@${REINPLACE_CMD} -e "s#%%WRKSRC%%#${WRKSRC}#g" ${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
|
||||
#-- ircd-shortcut.pl ratbox-services commands --------------------------------------
|
||||
|
||||
.if defined(SERVER_NAME)
|
||||
@${REINPLACE_CMD} -e "s#services.ircd-ratbox.org#${SERVER_NAME}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(USER_SERV)
|
||||
@${REINPLACE_CMD} -e "s#USERSERV#${USER_SERV}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(CHAN_SERV)
|
||||
@${REINPLACE_CMD} -e "s#CHANSERV#${CHAN_SERV}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(NICK_SERV)
|
||||
@${REINPLACE_CMD} -e "s#NICKSERV#${NICK_SERV}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(ALIS_SERV)
|
||||
@${REINPLACE_CMD} -e "s#ALIS#${ALIS_SERV}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(OPER_BOT)
|
||||
@${REINPLACE_CMD} -e "s#OPERBOT#${OPER_BOT}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(OPER_SERV)
|
||||
@${REINPLACE_CMD} -e "s#OPERSERV#${OPER_SERV}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(JUPE_SERV)
|
||||
@${REINPLACE_CMD} -e "s#JUPESERV#${JUPE_SERV}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
.if defined(GLOBAL_SERV)
|
||||
@${REINPLACE_CMD} -e "s#GLOBAL#${GLOBAL_SERV}#" \
|
||||
${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
.endif
|
||||
|
||||
#-- execute ircd-shortcut perl script to generate the .c file. -----
|
||||
${PERL} ${WRKSRC}/contrib/ircd-shortcut.pl
|
||||
|
||||
pre-su-install:
|
||||
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (ircd-ratbox-2.2.6.tgz) = d288f8169e08d9031a115814a8a88033
|
||||
SHA256 (ircd-ratbox-2.2.6.tgz) = b6dd01a15d13f29c0a87f507a63b212b3fe7a62bcd101ac123ec75fcca847c35
|
||||
SIZE (ircd-ratbox-2.2.6.tgz) = 713577
|
||||
MD5 (ircd-ratbox-2.2.8.tgz) = d4cccf7dd1523e362b5c38c1a20884e2
|
||||
SHA256 (ircd-ratbox-2.2.8.tgz) = f5d53e4821437f7d196af6a89f44edc2a1c39afed33a640c42c99f4f76c7b787
|
||||
SIZE (ircd-ratbox-2.2.8.tgz) = 730097
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
--- contrib/Makefile.in.orig Thu Jun 17 23:19:00 2004
|
||||
+++ contrib/Makefile.in Mon Jan 23 17:17:00 2006
|
||||
@@ -43,8 +43,7 @@
|
||||
--- contrib/Makefile.in.orig Sun Jan 13 02:35:03 2008
|
||||
+++ contrib/Makefile.in Sun Jan 13 02:38:59 2008
|
||||
@@ -44,7 +44,7 @@
|
||||
spy_stats_p_notice.c \
|
||||
spy_trace_notice.c \
|
||||
spy_whois_notice.c \
|
||||
- spy_whois_notice_global.c \
|
||||
spy_whois_notice_global.c \
|
||||
- example_module.c
|
||||
+ spy_whois_notice_global.c
|
||||
+ m_rsshortcut.c
|
||||
|
||||
OBJS = ${SRCS:.c=.so}
|
||||
|
||||
|
|
|
@ -12,5 +12,10 @@ server can be started by running:
|
|||
|
||||
%%PREFIX%%/etc/rc.d/ircd-ratbox start
|
||||
|
||||
If you specified options for ircd-shortcut commands, these will have
|
||||
been added and the module included in the contrib module directory.
|
||||
You may wish to add an entry to your ircd.conf file for this module to
|
||||
be loaded when your IRCD starts.
|
||||
|
||||
Be sure to check out 'ratbox-services' if you need a services package.
|
||||
------------------------------------------------------------------------
|
||||
|
|
|
@ -61,6 +61,7 @@ lib/ircd-ratbox/modules/autoload/m_who.so
|
|||
lib/ircd-ratbox/modules/autoload/m_whois.so
|
||||
lib/ircd-ratbox/modules/autoload/m_whowas.so
|
||||
lib/ircd-ratbox/modules/autoload/m_xline.so
|
||||
@unexec f="%D/lib/ircd-ratbox/modules/autoload/m_services.so"; if [ -f "$f" ]; then rm -f "$f"; fi
|
||||
lib/ircd-ratbox/modules/contrib/m_clearchan.so
|
||||
lib/ircd-ratbox/modules/contrib/m_flags.so
|
||||
lib/ircd-ratbox/modules/contrib/m_force.so
|
||||
|
@ -78,6 +79,7 @@ lib/ircd-ratbox/modules/contrib/spy_stats_notice.so
|
|||
lib/ircd-ratbox/modules/contrib/spy_stats_p_notice.so
|
||||
lib/ircd-ratbox/modules/contrib/spy_whois_notice.so
|
||||
lib/ircd-ratbox/modules/contrib/spy_whois_notice_global.so
|
||||
lib/ircd-ratbox/modules/contrib/m_rsshortcut.so
|
||||
lib/ircd-ratbox/modules/m_die.so
|
||||
lib/ircd-ratbox/modules/m_error.so
|
||||
lib/ircd-ratbox/modules/m_join.so
|
||||
|
|
Loading…
Reference in a new issue