- Update to 1.1.1
- Pass maintainship to submitter Submitted by: Anatoly Borodin (anatoly.borodin@gmail.com) via mail Approved by: miwi (mentor)
This commit is contained in:
parent
9e158d6a0d
commit
489e0e1737
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=213975
16 changed files with 283 additions and 275 deletions
|
@ -6,27 +6,28 @@
|
|||
#
|
||||
|
||||
PORTNAME= directfb
|
||||
PORTVERSION= 0.9.16
|
||||
PORTREVISION= 8
|
||||
PORTVERSION= 1.1.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.directfb.org/downloads/Old/
|
||||
MASTER_SITES= http://www.directfb.org/downloads/Core/ \
|
||||
http://www.directfb.org/downloads/Old/
|
||||
DISTNAME= DirectFB-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= anatoly.borodin@gmail.com
|
||||
COMMENT= Graphic development lightweight API
|
||||
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="${PTHREAD_LIBS}"
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_SDL= sdl
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack
|
||||
USE_LDCONFIG= yes
|
||||
USE_PERL5= yes
|
||||
PLIST_SUB+= DIRECTFB_VERSION=${PORTVERSION}
|
||||
PLIST_SUB+= DIRECTFB_VERSION=${PORTVERSION} DIRECTFB_VER=1.1-0
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libfreetype.so.9)
|
||||
WITH_FREETYPE2= yes
|
||||
|
@ -35,10 +36,35 @@ WITH_FREETYPE2= yes
|
|||
.if defined(WITH_FREETYPE2)
|
||||
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
|
||||
CONFIGURE_ARGS+= --enable-freetype
|
||||
PLIST_SUB+= WITH_FREETYPE2=""
|
||||
PLIST_SUB+= FREETYPE2=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-freetype
|
||||
PLIST_SUB+= WITH_FREETYPE2="@comment "
|
||||
PLIST_SUB+= FREETYPE2="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_X11)
|
||||
USE_XORG+= x11 xproto
|
||||
CONFIGURE_ARGS+= --enable-x11
|
||||
PLIST_SUB+= X11=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-x11
|
||||
PLIST_SUB+= X11="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SDL)
|
||||
USE_SDL+= sdl
|
||||
CONFIGURE_ARGS+= --enable-sdl
|
||||
PLIST_SUB+= SDL="" GFXDRIVERS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-sdl
|
||||
PLIST_SUB+= SDL="@comment " GFXDRIVERS="@comment "
|
||||
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SDL) || defined(WITH_X11)
|
||||
PLIST_SUB+= INPUTDRIVERS=""
|
||||
.else
|
||||
PLIST_SUB+= INPUTDRIVERS="@comment "
|
||||
.endif
|
||||
|
||||
MAN1= directfb-csource.1 dfbg.1
|
||||
|
@ -50,9 +76,12 @@ MAN5= directfbrc.5
|
|||
BROKEN= Does not compile on alpha
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 600000
|
||||
BROKEN= 5.x not supported
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
|
||||
${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure.in
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (DirectFB-0.9.16.tar.gz) = 7a33720caed3f179d4f558821b2fff91
|
||||
SHA256 (DirectFB-0.9.16.tar.gz) = 1b3d56f6c6d29e09b77a8b08678fa71b91363e856c17742bb1f8a7b11639938d
|
||||
SIZE (DirectFB-0.9.16.tar.gz) = 915045
|
||||
MD5 (DirectFB-1.1.1.tar.gz) = c75255049ca8d5c69afe4db58f603028
|
||||
SHA256 (DirectFB-1.1.1.tar.gz) = f12ec5f0864d85268a8d67e4919cb7f3d7f0e06ed6cc278c952f6c342673d931
|
||||
SIZE (DirectFB-1.1.1.tar.gz) = 2614203
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.orig Mon Jan 13 23:25:30 2003
|
||||
+++ configure Sun Jan 19 22:10:41 2003
|
||||
@@ -5500,7 +5500,8 @@
|
||||
--- configure.orig 2008-03-12 17:28:51.000000000 +0200
|
||||
+++ configure 2008-03-12 17:32:16.000000000 +0200
|
||||
@@ -19439,7 +19439,8 @@
|
||||
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
|
@ -10,21 +10,12 @@
|
|||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -6153,7 +6154,7 @@
|
||||
|
||||
@@ -22065,7 +22066,7 @@
|
||||
fi
|
||||
|
||||
|
||||
-THREADFLAGS="-D_REENTRANT"
|
||||
+THREADFLAGS="-D_REENTRANT -pthread"
|
||||
|
||||
if test x$need_libc_r = xyes; then
|
||||
echo $ac_n "checking for pthread_attr_init in -lc_r""... $ac_c" 1>&6
|
||||
@@ -6391,7 +6392,7 @@
|
||||
DFB_INTERNAL_CFLAGS="$DFB_INTERNAL_CFLAGS -DDFB_DEBUG"
|
||||
DFB_CFLAGS="$DFB_CFLAGS -O3 -g3 -fno-inline"
|
||||
else
|
||||
- DFB_CFLAGS="$DFB_CFLAGS -O3 -g"
|
||||
+ DFB_CFLAGS="$DFB_CFLAGS -O"
|
||||
if test "x$enable_profiling" = xno; then
|
||||
DFB_CFLAGS_OMIT_FRAME_POINTER="-fomit-frame-pointer"
|
||||
fi
|
||||
if test "$have_kos" = "no"; then
|
||||
if test "$need_libc_r" = "yes"; then
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- interfaces/IDirectFBImageProvider/idirectfbimageprovider_jpeg.c.orig 2007-11-02 12:40:44.000000000 +0100
|
||||
+++ interfaces/IDirectFBImageProvider/idirectfbimageprovider_jpeg.c 2007-11-02 12:42:20.000000000 +0100
|
||||
@@ -464,7 +464,7 @@
|
||||
BUG("unsupported format not filtered before");
|
||||
return DFB_BUG;
|
||||
}
|
||||
- (__u8*)row_ptr += pitch;
|
||||
+ row_ptr = (__u8*)row_ptr + pitch;
|
||||
}
|
||||
}
|
||||
else { /* image must be scaled */
|
||||
@@ -474,7 +474,7 @@
|
||||
while (cinfo.output_scanline < cinfo.output_height) {
|
||||
jpeg_read_scanlines(&cinfo, buffer, 1);
|
||||
copy_line32( (__u32*)row_ptr, *buffer, cinfo.output_width);
|
||||
- (__u32*)row_ptr += cinfo.output_width;
|
||||
+ row_ptr = (__u32*)row_ptr + cinfo.output_width;
|
||||
}
|
||||
dfb_scale_linear_32( dst, image_data, cinfo.output_width,
|
||||
cinfo.output_height, rect.w, rect.h,
|
11
devel/directfb/files/patch-lib-direct-conf.c
Normal file
11
devel/directfb/files/patch-lib-direct-conf.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- lib/direct/conf.c.orig 2007-12-15 14:30:28.000000000 +0200
|
||||
+++ lib/direct/conf.c 2008-03-16 14:31:28.000000000 +0200
|
||||
@@ -31,6 +31,8 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
|
||||
+#include <signal.h>
|
||||
+
|
||||
#include <direct/conf.h>
|
||||
#include <direct/mem.h>
|
||||
#include <direct/util.h>
|
17
devel/directfb/files/patch-lib-direct-log.c
Normal file
17
devel/directfb/files/patch-lib-direct-log.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- lib/direct/log.c.orig 2007-03-03 22:29:45.000000000 +0200
|
||||
+++ lib/direct/log.c 2008-03-12 12:49:22.000000000 +0200
|
||||
@@ -49,6 +49,14 @@
|
||||
#include <direct/util.h>
|
||||
|
||||
|
||||
+#ifndef EAI_ADDRFAMILY
|
||||
+#define EAI_ADDRFAMILY 1
|
||||
+#endif
|
||||
+#ifndef EAI_NODATA
|
||||
+#define EAI_NODATA 7
|
||||
+#endif
|
||||
+
|
||||
+
|
||||
struct __D_DirectLog {
|
||||
int magic;
|
||||
|
11
devel/directfb/files/patch-lib-direct-stream.c
Normal file
11
devel/directfb/files/patch-lib-direct-stream.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- lib/direct/stream.c.orig 2007-12-15 14:30:28.000000000 +0200
|
||||
+++ lib/direct/stream.c 2008-03-16 14:51:44.000000000 +0200
|
||||
@@ -429,7 +429,7 @@
|
||||
req.imr_multiaddr.s_addr = saddr->sin_addr.s_addr;
|
||||
req.imr_interface.s_addr = 0;
|
||||
|
||||
- err = setsockopt( fd, SOL_IP, IP_ADD_MEMBERSHIP, &req, sizeof(req) );
|
||||
+ err = setsockopt( fd, IPPROTO_IP, IP_ADD_MEMBERSHIP, &req, sizeof(req) );
|
||||
if (err < 0) {
|
||||
ret = errno2result( errno );
|
||||
D_PERROR( "Direct/Stream: Could not join multicast group (%u.%u.%u.%u)!\n",
|
11
devel/directfb/files/patch-lib-voodoo-manager.c
Normal file
11
devel/directfb/files/patch-lib-voodoo-manager.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- lib/voodoo/manager.c.orig 2007-12-15 14:30:28.000000000 +0200
|
||||
+++ lib/voodoo/manager.c 2008-03-16 14:51:33.000000000 +0200
|
||||
@@ -186,7 +186,7 @@
|
||||
|
||||
D_DEBUG( "Voodoo/Manager: Creating manager at %p.\n", manager );
|
||||
|
||||
- if (setsockopt( fd, SOL_IP, IP_TOS, &tos, sizeof(tos) ) < 0)
|
||||
+ if (setsockopt( fd, IPPROTO_IP, IP_TOS, &tos, sizeof(tos) ) < 0)
|
||||
D_PERROR( "Voodoo/Manager: Could not set IP_TOS!\n" );
|
||||
|
||||
if (setsockopt( fd, SOL_TCP, TCP_NODELAY, &one, sizeof(one) ) < 0)
|
|
@ -1,11 +0,0 @@
|
|||
--- src/core/input.c.orig 2002-12-29 01:17:06.000000000 +0100
|
||||
+++ src/core/input.c 2007-11-02 12:17:48.000000000 +0100
|
||||
@@ -1312,7 +1312,7 @@
|
||||
|
||||
write( fd, buf24, surface->width * 3 );
|
||||
|
||||
- ((__u8*)data) += pitch;
|
||||
+ data = (__u8*)data + pitch;
|
||||
}
|
||||
|
||||
dfb_surface_unlock( surface, (surface->caps & DSCAPS_FLIPPING) );
|
|
@ -1,15 +1,10 @@
|
|||
--- src/display/idirectfbsurface.c.orig 2007-11-02 12:19:20.000000000 +0100
|
||||
+++ src/display/idirectfbsurface.c 2007-11-02 12:27:33.000000000 +0100
|
||||
@@ -298,9 +298,9 @@
|
||||
if (ret)
|
||||
return ret;
|
||||
--- src/display/idirectfbsurface.c.orig 2007-03-03 22:19:36.000000000 +0200
|
||||
+++ src/display/idirectfbsurface.c 2008-03-12 12:56:41.000000000 +0200
|
||||
@@ -32,7 +32,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
-#include <alloca.h>
|
||||
|
||||
- (__u8*)(*ptr) += data->area.current.y * (*pitch) +
|
||||
- data->area.current.x *
|
||||
- DFB_BYTES_PER_PIXEL(data->surface->format);
|
||||
+ *ptr = (__u8 *)(*ptr) + (data->area.current.y * (*pitch) +
|
||||
+ data->area.current.x *
|
||||
+ DFB_BYTES_PER_PIXEL(data->surface->format));
|
||||
|
||||
data->locked = front + 1;
|
||||
#include <math.h>
|
||||
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- src/gfx/generic/generic.c.orig 2007-11-02 12:36:17.000000000 +0100
|
||||
+++ src/gfx/generic/generic.c 2007-11-02 12:40:03.000000000 +0100
|
||||
@@ -555,7 +555,8 @@
|
||||
__u16 *S = (__u16*)Bop;
|
||||
|
||||
if (((long)D)&2) {
|
||||
- *(((__u16*)D)++) = *S;
|
||||
+ D = (__u16*)D++;
|
||||
+ *D = *S;
|
||||
i += SperD;
|
||||
w--;
|
||||
}
|
12
devel/directfb/files/patch-src-misc-conf.h
Normal file
12
devel/directfb/files/patch-src-misc-conf.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/misc/conf.h.orig 2007-12-15 15:16:37.000000000 +0200
|
||||
+++ src/misc/conf.h 2008-03-16 16:43:14.000000000 +0200
|
||||
@@ -38,6 +38,9 @@
|
||||
#include <core/coredefs.h>
|
||||
|
||||
|
||||
+typedef unsigned long ulong;
|
||||
+
|
||||
+
|
||||
typedef struct {
|
||||
bool init;
|
||||
|
|
@ -1,71 +0,0 @@
|
|||
--- src/misc/gfx_util.c.orig 2007-11-02 12:28:22.000000000 +0100
|
||||
+++ src/misc/gfx_util.c 2007-11-02 12:32:42.000000000 +0100
|
||||
@@ -138,14 +138,14 @@
|
||||
*(__u8 *)dst++ = *src >> 24;
|
||||
src++;
|
||||
}
|
||||
- (__u8 *)dst += dskip;
|
||||
+ dst = (__u8 *)dst + dskip;
|
||||
}
|
||||
break;
|
||||
|
||||
case DSPF_ARGB:
|
||||
for (y = 0; y < h; y++) {
|
||||
dfb_memcpy (dst, src, w * 4);
|
||||
- (__u8 *)dst += w * 4 + dskip;
|
||||
+ dst = (__u8 *)dst + (w * 3 + dskip);
|
||||
src += w;
|
||||
}
|
||||
break;
|
||||
@@ -174,10 +174,10 @@
|
||||
a, dst_format, palette);
|
||||
break;
|
||||
}
|
||||
- (__u8 *)dst += DFB_BYTES_PER_PIXEL (dst_format);
|
||||
+ dst = (__u8 *)dst + (DFB_BYTES_PER_PIXEL (dst_format));
|
||||
src++;
|
||||
}
|
||||
- (__u8 *)dst += dskip;
|
||||
+ dst = (__u8 *)dst + dskip;
|
||||
}
|
||||
break;
|
||||
}
|
||||
@@ -380,7 +380,7 @@
|
||||
x += x_step;
|
||||
}
|
||||
|
||||
- return dst;
|
||||
+ return (char *)dst;
|
||||
}
|
||||
|
||||
void dfb_scale_linear_32( void *dst, __u32 *src, int sw, int sh,
|
||||
@@ -446,9 +446,9 @@
|
||||
y_start++;
|
||||
}
|
||||
|
||||
- (__u8 *)outbuf =
|
||||
+ outbuf =
|
||||
dst + i * (DFB_BYTES_PER_PIXEL (dst_format) * dw + dskip);
|
||||
- (__u8 *)outbuf_end = outbuf + DFB_BYTES_PER_PIXEL (dst_format) * dw;
|
||||
+ outbuf_end = outbuf + DFB_BYTES_PER_PIXEL (dst_format) * dw;
|
||||
x = scaled_x_offset;
|
||||
x_start = x >> SCALE_SHIFT;
|
||||
dest_x = 0;
|
||||
@@ -462,7 +462,7 @@
|
||||
x += x_step;
|
||||
x_start = x >> SCALE_SHIFT;
|
||||
dest_x++;
|
||||
- (__u8 *)outbuf += DFB_BYTES_PER_PIXEL (dst_format);
|
||||
+ outbuf = (__u8 *)outbuf + DFB_BYTES_PER_PIXEL (dst_format);
|
||||
}
|
||||
|
||||
new_outbuf = scale_line (run_weights, filter.n_x, filter.n_y, outbuf,
|
||||
@@ -480,7 +480,7 @@
|
||||
x >> SCALE_SHIFT, sw, dst_format, palette);
|
||||
|
||||
x += x_step;
|
||||
- (__u8 *)outbuf += DFB_BYTES_PER_PIXEL (dst_format);
|
||||
+ outbuf = (__u8 *)outbuf + DFB_BYTES_PER_PIXEL (dst_format);
|
||||
}
|
||||
|
||||
y += y_step;
|
|
@ -1,46 +0,0 @@
|
|||
--- src/misc/memcpy.c.orig 2007-11-02 12:33:04.000000000 +0100
|
||||
+++ src/misc/memcpy.c 2007-11-02 12:35:27.000000000 +0100
|
||||
@@ -226,8 +226,8 @@
|
||||
"movq %%mm6, 48(%1)\n"
|
||||
"movq %%mm7, 56(%1)\n"
|
||||
:: "r" (from), "r" (to) : "memory");
|
||||
- ((const unsigned char *)from)+=64;
|
||||
- ((unsigned char *)to)+=64;
|
||||
+ from = (const unsigned char *)from + 64;
|
||||
+ to = (unsigned char *)to + 64;
|
||||
}
|
||||
__asm__ __volatile__ ("emms":::"memory");
|
||||
}
|
||||
@@ -288,8 +288,8 @@
|
||||
"movntq %%mm6, 48(%1)\n"
|
||||
"movntq %%mm7, 56(%1)\n"
|
||||
:: "r" (from), "r" (to) : "memory");
|
||||
- ((const unsigned char *)from)+=64;
|
||||
- ((unsigned char *)to)+=64;
|
||||
+ from = (const unsigned char *)from + 64;
|
||||
+ to = (unsigned char *)to + 64;
|
||||
}
|
||||
/* since movntq is weakly-ordered, a "sfence"
|
||||
* is needed to become ordered again. */
|
||||
@@ -346,8 +346,8 @@
|
||||
"movntps %%xmm2, 32(%1)\n"
|
||||
"movntps %%xmm3, 48(%1)\n"
|
||||
:: "r" (from), "r" (to) : "memory");
|
||||
- ((const unsigned char *)from)+=64;
|
||||
- ((unsigned char *)to)+=64;
|
||||
+ from = (const unsigned char *)from + 64;
|
||||
+ to = (unsigned char *)to + 64;
|
||||
}
|
||||
else
|
||||
/*
|
||||
@@ -368,8 +368,8 @@
|
||||
"movntps %%xmm2, 32(%1)\n"
|
||||
"movntps %%xmm3, 48(%1)\n"
|
||||
:: "r" (from), "r" (to) : "memory");
|
||||
- ((const unsigned char *)from)+=64;
|
||||
- ((unsigned char *)to)+=64;
|
||||
+ from = (const unsigned char *)from + 64;
|
||||
+ to = (unsigned char *)to + 64;
|
||||
}
|
||||
/* since movntq is weakly-ordered, a "sfence"
|
||||
* is needed to become ordered again. */
|
|
@ -1,11 +0,0 @@
|
|||
--- tools/Makefile.in.orig Wed Jan 15 21:06:35 2003
|
||||
+++ tools/Makefile.in Sun Jan 19 19:17:52 2003
|
||||
@@ -157,7 +157,7 @@
|
||||
@DIRECTFB_CSOURCE_TRUE@dfbg$(EXEEXT)
|
||||
@DIRECTFB_CSOURCE_FALSE@bin_PROGRAMS = dfbg$(EXEEXT)
|
||||
noinst_PROGRAMS = dfbdump$(EXEEXT) dfbsummon$(EXEEXT) \
|
||||
-fusion_bench$(EXEEXT) raw15toraw24$(EXEEXT) raw16toraw24$(EXEEXT) \
|
||||
+raw15toraw24$(EXEEXT) raw16toraw24$(EXEEXT) \
|
||||
raw32toraw24$(EXEEXT)
|
||||
PROGRAMS = $(bin_PROGRAMS) $(noinst_PROGRAMS)
|
||||
|
|
@ -1,106 +1,208 @@
|
|||
bin/dfbdump
|
||||
bin/dfbfx
|
||||
bin/dfbg
|
||||
bin/dfbinfo
|
||||
bin/dfbinput
|
||||
bin/dfblayer
|
||||
bin/dfbpenmount
|
||||
bin/dfbscreen
|
||||
bin/directfb-config
|
||||
bin/directfb-csource
|
||||
include/directfb/dfb_types.h
|
||||
include/directfb/directfb.h
|
||||
include/directfb/directfb_keyboard.h
|
||||
include/directfb/directfb_keynames.h
|
||||
include/directfb-internal/directfb_internals.h
|
||||
include/directfb-internal/directfb_version.h
|
||||
include/directfb-internal/core/coretypes.h
|
||||
bin/mkdfiff
|
||||
%%FREETYPE2%%bin/mkdgiff
|
||||
include/directfb-internal/core/clipboard.h
|
||||
include/directfb-internal/core/colorhash.h
|
||||
include/directfb-internal/core/core.h
|
||||
include/directfb-internal/core/core_parts.h
|
||||
include/directfb-internal/core/core_system.h
|
||||
include/directfb-internal/core/coredefs.h
|
||||
include/directfb-internal/core/coretypes.h
|
||||
include/directfb-internal/core/fonts.h
|
||||
include/directfb-internal/core/fusion/arena.h
|
||||
include/directfb-internal/core/fusion/fusion.h
|
||||
include/directfb-internal/core/fusion/list.h
|
||||
include/directfb-internal/core/fusion/lock.h
|
||||
include/directfb-internal/core/fusion/object.h
|
||||
include/directfb-internal/core/fusion/property.h
|
||||
include/directfb-internal/core/fusion/reactor.h
|
||||
include/directfb-internal/core/fusion/ref.h
|
||||
include/directfb-internal/core/fusion/shmalloc.h
|
||||
include/directfb-internal/core/fusion/fusion_types.h
|
||||
include/directfb-internal/core/gfxcard.h
|
||||
include/directfb-internal/core/graphics_driver.h
|
||||
include/directfb-internal/core/input.h
|
||||
include/directfb-internal/core/input_driver.h
|
||||
include/directfb-internal/core/layer_context.h
|
||||
include/directfb-internal/core/layer_control.h
|
||||
include/directfb-internal/core/layer_region.h
|
||||
include/directfb-internal/core/layers.h
|
||||
include/directfb-internal/core/modules.h
|
||||
include/directfb-internal/core/layers_internal.h
|
||||
include/directfb-internal/core/palette.h
|
||||
include/directfb-internal/core/sig.h
|
||||
include/directfb-internal/core/screen.h
|
||||
include/directfb-internal/core/screens.h
|
||||
include/directfb-internal/core/screens_internal.h
|
||||
include/directfb-internal/core/state.h
|
||||
include/directfb-internal/core/surfaces.h
|
||||
include/directfb-internal/core/surfacemanager.h
|
||||
include/directfb-internal/core/surface.h
|
||||
include/directfb-internal/core/surface_buffer.h
|
||||
include/directfb-internal/core/surface_pool.h
|
||||
include/directfb-internal/core/system.h
|
||||
include/directfb-internal/core/thread.h
|
||||
include/directfb-internal/core/windows.h
|
||||
include/directfb-internal/core/windows_internal.h
|
||||
include/directfb-internal/core/windowstack.h
|
||||
include/directfb-internal/core/wm.h
|
||||
include/directfb-internal/core/wm_module.h
|
||||
include/directfb-internal/devmem/devmem.h
|
||||
include/directfb-internal/devmem/surfacemanager.h
|
||||
include/directfb-internal/display/idirectfbdisplaylayer.h
|
||||
include/directfb-internal/display/idirectfbpalette.h
|
||||
include/directfb-internal/display/idirectfbscreen.h
|
||||
include/directfb-internal/display/idirectfbsurface.h
|
||||
include/directfb-internal/display/idirectfbsurface_layer.h
|
||||
include/directfb-internal/display/idirectfbsurface_window.h
|
||||
include/directfb-internal/display/idirectfbdisplaylayer.h
|
||||
include/directfb-internal/gfx/clip.h
|
||||
include/directfb-internal/gfx/convert.h
|
||||
include/directfb-internal/gfx/generic/generic.h
|
||||
include/directfb-internal/gfx/util.h
|
||||
include/directfb-internal/idirectfb.h
|
||||
include/directfb-internal/input/idirectfbinputdevice.h
|
||||
include/directfb-internal/input/idirectfbinputbuffer.h
|
||||
include/directfb-internal/interface_implementation.h
|
||||
include/directfb-internal/input/idirectfbinputdevice.h
|
||||
include/directfb-internal/media/idirectfbdatabuffer.h
|
||||
include/directfb-internal/media/idirectfbfont.h
|
||||
include/directfb-internal/media/idirectfbimageprovider.h
|
||||
include/directfb-internal/media/idirectfbvideoprovider.h
|
||||
include/directfb-internal/misc/conf.h
|
||||
include/directfb-internal/misc/cpu_accel.h
|
||||
include/directfb-internal/misc/gfx_util.h
|
||||
include/directfb-internal/misc/mem.h
|
||||
include/directfb-internal/misc/memcpy.h
|
||||
include/directfb-internal/misc/tree.h
|
||||
include/directfb-internal/misc/utf8.h
|
||||
include/directfb-internal/misc/util.h
|
||||
include/directfb-internal/windows/idirectfbwindow.h
|
||||
lib/libdirectfb-0.9.so
|
||||
lib/libdirectfb-0.9.so.16
|
||||
include/directfb/dfb_types.h
|
||||
include/directfb/dfiff.h
|
||||
include/directfb/dgiff.h
|
||||
include/directfb/direct/build.h
|
||||
include/directfb/direct/clock.h
|
||||
include/directfb/direct/conf.h
|
||||
include/directfb/direct/debug.h
|
||||
include/directfb/direct/direct.h
|
||||
include/directfb/direct/hash.h
|
||||
include/directfb/direct/interface.h
|
||||
include/directfb/direct/interface_implementation.h
|
||||
include/directfb/direct/list.h
|
||||
include/directfb/direct/log.h
|
||||
include/directfb/direct/mem.h
|
||||
include/directfb/direct/memcpy.h
|
||||
include/directfb/direct/messages.h
|
||||
include/directfb/direct/modules.h
|
||||
include/directfb/direct/serial.h
|
||||
include/directfb/direct/signals.h
|
||||
include/directfb/direct/stream.h
|
||||
include/directfb/direct/system.h
|
||||
include/directfb/direct/thread.h
|
||||
include/directfb/direct/trace.h
|
||||
include/directfb/direct/tree.h
|
||||
include/directfb/direct/types.h
|
||||
include/directfb/direct/utf8.h
|
||||
include/directfb/direct/util.h
|
||||
include/directfb/directfb.h
|
||||
include/directfb/directfb_keyboard.h
|
||||
include/directfb/directfb_keynames.h
|
||||
include/directfb/directfb_strings.h
|
||||
include/directfb/directfb_util.h
|
||||
include/directfb/directfb_version.h
|
||||
include/directfb/directfbgl.h
|
||||
include/directfb/fusion/arena.h
|
||||
include/directfb/fusion/build.h
|
||||
include/directfb/fusion/call.h
|
||||
include/directfb/fusion/conf.h
|
||||
include/directfb/fusion/fusion.h
|
||||
include/directfb/fusion/fusion_internal.h
|
||||
include/directfb/fusion/hash.h
|
||||
include/directfb/fusion/lock.h
|
||||
include/directfb/fusion/object.h
|
||||
include/directfb/fusion/property.h
|
||||
include/directfb/fusion/protocol.h
|
||||
include/directfb/fusion/reactor.h
|
||||
include/directfb/fusion/ref.h
|
||||
include/directfb/fusion/shm/pool.h
|
||||
include/directfb/fusion/shm/shm.h
|
||||
include/directfb/fusion/shm/shm_internal.h
|
||||
include/directfb/fusion/shmalloc.h
|
||||
include/directfb/fusion/types.h
|
||||
include/directfb/fusion/vector.h
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/gfxdrivers/libdirectfb_sdlgraphics.a
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/gfxdrivers/libdirectfb_sdlgraphics.la
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/gfxdrivers/libdirectfb_sdlgraphics.so
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/inputdrivers/libdirectfb_sdlinput.a
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/inputdrivers/libdirectfb_sdlinput.la
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/inputdrivers/libdirectfb_sdlinput.so
|
||||
%%X11%%lib/directfb-%%DIRECTFB_VER%%/inputdrivers/libdirectfb_x11input.a
|
||||
%%X11%%lib/directfb-%%DIRECTFB_VER%%/inputdrivers/libdirectfb_x11input.la
|
||||
%%X11%%lib/directfb-%%DIRECTFB_VER%%/inputdrivers/libdirectfb_x11input.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBFont/libidirectfbfont_default.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBFont/libidirectfbfont_default.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBFont/libidirectfbfont_default.so
|
||||
%%FREETYPE2%%lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBFont/libidirectfbfont_ft2.a
|
||||
%%FREETYPE2%%lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBFont/libidirectfbfont_ft2.la
|
||||
%%FREETYPE2%%lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dfiff.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dfiff.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dfiff.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_gif.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_gif.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_gif.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_devmem.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_devmem.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_devmem.so
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_sdl.a
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_sdl.la
|
||||
%%SDL%%lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_sdl.so
|
||||
%%X11%%lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_x11.a
|
||||
%%X11%%lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_x11.la
|
||||
%%X11%%lib/directfb-%%DIRECTFB_VER%%/systems/libdirectfb_x11.so
|
||||
lib/directfb-%%DIRECTFB_VER%%/wm/libdirectfbwm_default.a
|
||||
lib/directfb-%%DIRECTFB_VER%%/wm/libdirectfbwm_default.la
|
||||
lib/directfb-%%DIRECTFB_VER%%/wm/libdirectfbwm_default.so
|
||||
lib/libdirect-1.1.so
|
||||
lib/libdirect-1.1.so.1
|
||||
lib/libdirect.a
|
||||
lib/libdirect.la
|
||||
lib/libdirect.so
|
||||
lib/libdirectfb-1.1.so
|
||||
lib/libdirectfb-1.1.so.1
|
||||
lib/libdirectfb.a
|
||||
lib/libdirectfb.la
|
||||
lib/libdirectfb.so
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBFont/libidirectfbfont_default.a
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBFont/libidirectfbfont_default.la
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBFont/libidirectfbfont_default.so
|
||||
%%WITH_FREETYPE2%%lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBFont/libidirectfbfont_ft2.a
|
||||
%%WITH_FREETYPE2%%lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBFont/libidirectfbfont_ft2.la
|
||||
%%WITH_FREETYPE2%%lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.a
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.la
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.a
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.la
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.a
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.la
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.a
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.la
|
||||
lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
|
||||
libdata/pkgconfig/directfb.pc
|
||||
lib/libfusion-1.1.so
|
||||
lib/libfusion-1.1.so.1
|
||||
lib/libfusion.a
|
||||
lib/libfusion.la
|
||||
lib/libfusion.so
|
||||
libdata/pkgconfig/direct.pc
|
||||
libdata/pkgconfig/directfb-internal.pc
|
||||
share/directfb-%%DIRECTFB_VERSION%%/cursor.dat
|
||||
share/directfb-%%DIRECTFB_VERSION%%/font.data
|
||||
@dirrm share/directfb-%%DIRECTFB_VERSION%%
|
||||
@dirrm lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBVideoProvider
|
||||
@dirrm lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBImageProvider
|
||||
@dirrm lib/directfb-%%DIRECTFB_VERSION%%/interfaces/IDirectFBFont
|
||||
@dirrm lib/directfb-%%DIRECTFB_VERSION%%/interfaces
|
||||
@dirrm lib/directfb-%%DIRECTFB_VERSION%%
|
||||
libdata/pkgconfig/directfb.pc
|
||||
libdata/pkgconfig/fusion.pc
|
||||
%%DATADIR%%-%%DIRECTFB_VERSION%%/cursor.dat
|
||||
@dirrm %%DATADIR%%-%%DIRECTFB_VERSION%%
|
||||
@dirrm lib/directfb-%%DIRECTFB_VER%%/wm
|
||||
@dirrm lib/directfb-%%DIRECTFB_VER%%/systems
|
||||
@dirrm lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBVideoProvider
|
||||
@dirrm lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBImageProvider
|
||||
@dirrm lib/directfb-%%DIRECTFB_VER%%/interfaces/IDirectFBFont
|
||||
@dirrm lib/directfb-%%DIRECTFB_VER%%/interfaces
|
||||
%%INPUTDRIVERS%%@dirrm lib/directfb-%%DIRECTFB_VER%%/inputdrivers
|
||||
%%GFXDRIVERS%%@dirrm lib/directfb-%%DIRECTFB_VER%%/gfxdrivers
|
||||
@dirrm lib/directfb-%%DIRECTFB_VER%%
|
||||
@dirrm include/directfb/fusion/shm
|
||||
@dirrm include/directfb/fusion
|
||||
@dirrm include/directfb/direct
|
||||
@dirrm include/directfb-internal/windows
|
||||
@dirrm include/directfb-internal/misc
|
||||
@dirrm include/directfb-internal/media
|
||||
@dirrm include/directfb-internal/input
|
||||
@dirrm include/directfb-internal/gfx/generic
|
||||
@dirrm include/directfb-internal/gfx
|
||||
@dirrm include/directfb-internal/display
|
||||
@dirrm include/directfb-internal/core/fusion
|
||||
@dirrm include/directfb-internal/devmem
|
||||
@dirrm include/directfb-internal/core
|
||||
@dirrm include/directfb-internal
|
||||
@dirrm include/directfb
|
||||
|
|
Loading…
Reference in a new issue