Repocopied to www/eaccelerator.

This commit is contained in:
Alex Dupre 2005-01-19 07:20:58 +00:00
parent bb62d5f6ea
commit 48d72f0295
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=126771
6 changed files with 0 additions and 135 deletions

View file

@ -1,50 +0,0 @@
# New ports collection makefile for: turck-mmcache
# Date created: Sat Mar 1 13:55:55 CET 2003
# Whom: Alex Dupre <sysadmin@alexdupre.com>
#
# $FreeBSD$
#
PORTNAME= turck-mmcache
PORTVERSION= 2.4.6
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ale@FreeBSD.org
COMMENT= An opcode cache for PHP with encoder and loader
USE_BZIP2= yes
USE_REINPLACE= yes
USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-mmcache=shared
PKGMESSAGE= ${WRKDIR}/pkg-message
post-patch:
@${REINPLACE_CMD} 's|ALIGN|MMALIGN|g' ${WRKSRC}/mm.c ${WRKSRC}/mmcache.c
post-build:
@${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/encoder.php > ${WRKSRC}/encoder
@${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
do-install:
@${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
@${INSTALL_DATA} ${WRKSRC}/modules/mmcache.so \
${PREFIX}/lib/php/${PHP_EXT_DIR}
@${INSTALL_SCRIPT} ${WRKSRC}/encoder ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/mmcache.php ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/mmcache_password.php ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
MD5 (turck-mmcache-2.4.6.tar.bz2) = 8edaf6cd647e7c521b5360f4e2d4ee6f
SIZE (turck-mmcache-2.4.6.tar.bz2) = 96103

View file

@ -1,33 +0,0 @@
--- encoder.php.orig Fri Jul 25 10:21:09 2003
+++ encoder.php Mon Jul 28 13:04:19 2003
@@ -1,10 +1,12 @@
+#!%%LOCALBASE%%/bin/php -f
+
<?php
$web_error = "";
function mmcache_encoder_usage() {
- echo "Usage:\tphp -q encoder.php [options] source_file_name\n";
- echo "\tphp -q encoder.php [options] source_file_name...\n";
- echo "\tphp -q encoder.php [options] source_directory_name...\n\n";
+ echo "Usage:\tencoder [options] source_file_name\n";
+ echo "\tencoder [options] source_file_name...\n";
+ echo "\tencoder [options] source_directory_name...\n\n";
echo "Options:\n";
echo "\t-s suffix\n\t\tencode files only with following suffix (default is \"php\")\n";
echo "\t-a\n\t\tencode all files (no by default)\n";
@@ -16,10 +18,10 @@
echo "\t\tfile name. If you encode directory or several files at once\n";
echo "\t\tthen 'target' specifyes an output directory name.\n";
echo "\nExamples:\n";
- echo "\tphp -q encoder.php some_file.php\n";
- echo "\tphp -q encoder.php some_file.php -o some_encoded_file.php\n";
- echo "\tphp -q encoder.php *.php -o some_dir\n";
- echo "\tphp -q encoder.php ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
+ echo "\tencoder some_file.php\n";
+ echo "\tencoder some_file.php -o some_encoded_file.php\n";
+ echo "\tencoder *.php -o some_dir\n";
+ echo "\tencoder ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
echo "\n";
exit();
}

View file

@ -1,17 +0,0 @@
Turck MMCache is a opcode cache for PHP. It increases
performance of PHP scripts by caching them in compiled state,
so that the overhead of compiling is almost completely eliminated.
Also it uses some optimizations for speed up of PHP scripts execution.
Turck MMCache typically reduces server load and increases
the speed of your PHP code by 1-10 times.
Turck MMCache contains PHP encoder and loader. You can encode any PHP
scripts with encoder to distribute them without sources. Encoded files
can be run on any site which runs PHP with Turck MMCache. The sources
of encoded script can't be restored because they are stored in a compiled
form and the encoded version doesn't contain the source.
WWW: http://turck-mmcache.sourceforge.net/
- Alex Dupre
ale@FreeBSD.org

View file

@ -1,25 +0,0 @@
*****************************************************************************
You have installed the turck-mmcache package.
Edit %%LOCALBASE%%/etc/php.ini and add:
[mmcache]
zend_extension="%%PREFIX%%/lib/php/%%PHP_EXT_DIR%%/mmcache.so"
mmcache.shm_size="16"
mmcache.cache_dir="/tmp"
mmcache.enable="1"
mmcache.optimizer="1"
mmcache.check_mtime="1"
mmcache.debug="0"
mmcache.filter=""
mmcache.shm_max="0"
mmcache.shm_ttl="0"
mmcache.shm_prune_period="0"
mmcache.shm_only="0"
mmcache.compress="1"
mmcache.keys="shm_and_disk"
mmcache.sessions="shm_and_disk"
mmcache.content="shm_and_disk"
*****************************************************************************

View file

@ -1,8 +0,0 @@
bin/encoder
lib/php/%%PHP_EXT_DIR%%/mmcache.so
%%PORTDOCS%%%%DOCSDIR%%/README
@unexec rmdir %D/lib/php/%%PHP_EXT_DIR%% 2> /dev/null || true
%%EXAMPLESDIR%%/mmcache.php
%%EXAMPLESDIR%%/mmcache_password.php
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%