biology/bowtie2: Add support for powerpc64le
PR: 255092 Submitted by: pkubaj
This commit is contained in:
parent
e4ca154bd2
commit
48ddc73c58
3 changed files with 17 additions and 4 deletions
|
@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
|
||||
# Requires a 64-bit processor and depends on hard-coded SSE instructions
|
||||
# Experimental support for AARCH64 as of 2.3.5
|
||||
ONLY_FOR_ARCHS= aarch64 amd64
|
||||
ONLY_FOR_ARCHS= aarch64 amd64 powerpc64le
|
||||
LIB_DEPENDS= libtbb.so:devel/onetbb
|
||||
RUN_DEPENDS= bash:shells/bash
|
||||
|
||||
|
@ -23,11 +23,22 @@ USE_GITHUB= yes
|
|||
SHEBANG_FILES= bowtie2 bowtie2-build bowtie2-inspect \
|
||||
scripts/bowtie2-hbb.sh scripts/*.pl
|
||||
GH_ACCOUNT= BenLangmead
|
||||
GH_TUPLE= nemequ:simde:422ed9c:simde
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
SUB_FILES= bowtie2-test
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${ARCH} != amd64
|
||||
post-extract:
|
||||
(cd ${WRKSRC_simde}; \
|
||||
${COPYTREE_SHARE} . ${WRKSRC}/third_party/simde/)
|
||||
|
||||
MAKE_ENV= POPCNT_CAPABILITY=0
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|^RELEASE_FLAGS|# RELEASE_FLAGS|' \
|
||||
|
|
|
@ -1,3 +1,5 @@
|
|||
TIMESTAMP = 1604617529
|
||||
TIMESTAMP = 1618499065
|
||||
SHA256 (BenLangmead-bowtie2-v2.4.2_GH0.tar.gz) = ea33a1562faf759b21b3a905e20b87a3524ac4e53af8cd723d9a9f31ee159c8a
|
||||
SIZE (BenLangmead-bowtie2-v2.4.2_GH0.tar.gz) = 10590144
|
||||
SHA256 (nemequ-simde-422ed9c_GH0.tar.gz) = 3e7e962b499212cdddcaeca973d1c15d71a4b620afb46113d936ce5c3a8236ba
|
||||
SIZE (nemequ-simde-422ed9c_GH0.tar.gz) = 332230
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- Makefile.orig 2020-11-05 23:04:50 UTC
|
||||
--- Makefile.orig 2020-10-06 03:46:41 UTC
|
||||
+++ Makefile
|
||||
@@ -24,7 +24,7 @@
|
||||
PREFIX := /usr/local
|
||||
|
@ -33,7 +33,7 @@
|
|||
CPPFLAGS += -Ithird_party/simde
|
||||
SANITIZER_FLAGS :=
|
||||
-else ifeq (ppc64le,$(shell uname -m))
|
||||
+else ifeq (ppc64le,$(shell uname -p))
|
||||
+else ifeq (powerpc64le,$(shell uname -p))
|
||||
BITS := 64
|
||||
SSE_FLAG :=
|
||||
CXXFLAGS += -fopenmp-simd
|
||||
|
|
Loading…
Reference in a new issue