- Update to 1.13.
- Mark IGNORE on < 7 versions. PR: ports/121892 Submitted by: Geoffrey Mainland <mainland@apeiron.net> Approved by: araujo (mentor), Geoffrey Mainland <mainland@apeiron.net> (maintainer)
This commit is contained in:
parent
e64fd617ff
commit
48e36c30ec
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=212958
8 changed files with 158 additions and 40 deletions
|
@ -7,8 +7,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= lhs2tex
|
PORTNAME= lhs2tex
|
||||||
PORTVERSION= 1.12
|
PORTVERSION= 1.13
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= devel haskell
|
CATEGORIES= devel haskell
|
||||||
MASTER_SITES= http://people.cs.uu.nl/andres/${PORTNAME}/
|
MASTER_SITES= http://people.cs.uu.nl/andres/${PORTNAME}/
|
||||||
|
|
||||||
|
@ -18,7 +17,6 @@ COMMENT= A preprocessor to generate LaTeX code from literate Haskell sources
|
||||||
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||||
mktexlsr:${PORTSDIR}/print/teTeX-base
|
mktexlsr:${PORTSDIR}/print/teTeX-base
|
||||||
|
|
||||||
USE_BZIP2= yes
|
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
HAS_CONFIGURE= yes
|
HAS_CONFIGURE= yes
|
||||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||||
|
@ -26,6 +24,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||||
--docdir=${DOCSDIR} \
|
--docdir=${DOCSDIR} \
|
||||||
--mandir=${MANPREFIX}/man
|
--mandir=${MANPREFIX}/man
|
||||||
|
|
||||||
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
.if defined(NOPORTDOCS)
|
.if defined(NOPORTDOCS)
|
||||||
INSTALL_TARGET=install
|
INSTALL_TARGET=install
|
||||||
.else
|
.else
|
||||||
|
@ -34,4 +34,8 @@ INSTALL_TARGET=install install-doc
|
||||||
|
|
||||||
MAN1= lhs2TeX.1
|
MAN1= lhs2TeX.1
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.if ${OSVERSION} < 700042
|
||||||
|
IGNORE= has a broken dependency
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.post.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (lhs2tex-1.12.tar.bz2) = 1bc982e96f19201aaf1c39c1d4b5e358
|
MD5 (lhs2tex-1.13.tar.gz) = 1173dbe6440f24918f3dc80d776e1f18
|
||||||
SHA256 (lhs2tex-1.12.tar.bz2) = af3440b8d5dda73ad43660fa496f5e1c04a3d3105961847963d0105c69a03447
|
SHA256 (lhs2tex-1.13.tar.gz) = 28282cb4afcc71785b092d358ffb33f5ec7585e50b392ae4fb6391d495a0836b
|
||||||
SIZE (lhs2tex-1.12.tar.bz2) = 582250
|
SIZE (lhs2tex-1.13.tar.gz) = 601072
|
||||||
|
|
|
@ -1,11 +1,66 @@
|
||||||
--- ./configure.orig Wed Apr 25 22:41:37 2007
|
--- configure.orig 2008-02-19 01:11:52.000000000 -0500
|
||||||
+++ ./configure Wed Apr 25 22:41:55 2007
|
+++ configure 2008-02-19 01:42:57.000000000 -0500
|
||||||
@@ -2726,7 +2726,7 @@
|
@@ -2637,54 +2637,6 @@
|
||||||
|
POLYTABLE_INSTALL=yes
|
||||||
|
fi
|
||||||
|
|
||||||
|
-if test "z$POLYTABLE_INSTALL" = "zyes"; then
|
||||||
|
-
|
||||||
|
-{ echo "$as_me:$LINENO: checking for the polytable package" >&5
|
||||||
|
-echo $ECHO_N "checking for the polytable package... $ECHO_C" >&6; }
|
||||||
|
-if test -x "$KPSEWHICH"; then
|
||||||
|
- POLYTABLE="`$KPSEWHICH polytable.sty`"
|
||||||
|
-fi
|
||||||
|
-if test -f "$POLYTABLE"; then
|
||||||
|
- { echo "$as_me:$LINENO: result: $POLYTABLE" >&5
|
||||||
|
-echo "${ECHO_T}$POLYTABLE" >&6; }
|
||||||
|
- { echo "$as_me:$LINENO: checking for version of polytable" >&5
|
||||||
|
-echo $ECHO_N "checking for version of polytable... $ECHO_C" >&6; }
|
||||||
|
- POLYTABLE_VERSION=`$GREP " v.* .polytable. package" $POLYTABLE | $SED -e "s/^.*v\(.*\) .polytable. package.*$/\1/"`
|
||||||
|
- { echo "$as_me:$LINENO: result: $POLYTABLE_VERSION" >&5
|
||||||
|
-echo "${ECHO_T}$POLYTABLE_VERSION" >&6; }
|
||||||
|
-else
|
||||||
|
- { echo "$as_me:$LINENO: result: no" >&5
|
||||||
|
-echo "${ECHO_T}no" >&6; }
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
- # does polytable need to be installed?
|
||||||
|
- { echo "$as_me:$LINENO: checking whether polytable needs to be installed" >&5
|
||||||
|
-echo $ECHO_N "checking whether polytable needs to be installed... $ECHO_C" >&6; }
|
||||||
|
- POLYTABLE_INSTALL=no
|
||||||
|
- if test -n $POLYTABLE; then
|
||||||
|
- if ( IFS=".";
|
||||||
|
- a="$POLYTABLE_VERSION"; b="0.8.2";
|
||||||
|
- while test -n "$a$b"
|
||||||
|
- do
|
||||||
|
- set -- $a; h1="$1"; shift 2>/dev/null; a="$*"
|
||||||
|
- set -- $b; h2="$1"; shift 2>/dev/null; b="$*"
|
||||||
|
- test -n "$h1" || h1=0; test -n "$h2" || h2=0
|
||||||
|
- test ${h1} -eq ${h2} || break
|
||||||
|
- done
|
||||||
|
- test ${h1} -lt ${h2}
|
||||||
|
- )
|
||||||
|
-then
|
||||||
|
- POLYTABLE_INSTALL=yes
|
||||||
|
-
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
- else
|
||||||
|
- POLYTABLE_INSTALL=yes
|
||||||
|
- fi
|
||||||
|
- { echo "$as_me:$LINENO: result: $POLYTABLE_INSTALL" >&5
|
||||||
|
-echo "${ECHO_T}$POLYTABLE_INSTALL" >&6; }
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
# Extract the first word of "mktexlsr", so it can be a program name with args.
|
||||||
|
set dummy mktexlsr; ac_word=$2
|
||||||
|
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
|
||||||
|
@@ -2727,7 +2679,7 @@
|
||||||
|
|
||||||
|
|
||||||
# docdir and expansion
|
# docdir and expansion
|
||||||
-docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
-docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
||||||
+#docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
+#docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
||||||
|
|
||||||
|
stydir="$datadir/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
||||||
|
|
||||||
# lhs2TeX binary path relative to docdir
|
|
||||||
|
|
|
@ -2,15 +2,15 @@ bin/lhs2TeX
|
||||||
share/texmf-local/tex/latex/polytable/lazylist.sty
|
share/texmf-local/tex/latex/polytable/lazylist.sty
|
||||||
share/texmf-local/tex/latex/polytable/polytable.sty
|
share/texmf-local/tex/latex/polytable/polytable.sty
|
||||||
@dirrm share/texmf-local/tex/latex/polytable
|
@dirrm share/texmf-local/tex/latex/polytable
|
||||||
%%DATADIR%%/lhs2tex/colorcode.fmt
|
%%DATADIR%%/lhs2tex-1.13/colorcode.fmt
|
||||||
%%DATADIR%%/lhs2tex/forall.fmt
|
%%DATADIR%%/lhs2tex-1.13/forall.fmt
|
||||||
%%DATADIR%%/lhs2tex/greek.fmt
|
%%DATADIR%%/lhs2tex-1.13/greek.fmt
|
||||||
%%DATADIR%%/lhs2tex/jfpcompat.fmt
|
%%DATADIR%%/lhs2tex-1.13/jfpcompat.fmt
|
||||||
%%DATADIR%%/lhs2tex/lhs2TeX.fmt
|
%%DATADIR%%/lhs2tex-1.13/lhs2TeX.fmt
|
||||||
%%DATADIR%%/lhs2tex/lhs2TeX.sty
|
%%DATADIR%%/lhs2tex-1.13/lhs2TeX.sty
|
||||||
%%DATADIR%%/lhs2tex/polycode.fmt
|
%%DATADIR%%/lhs2tex-1.13/polycode.fmt
|
||||||
%%DATADIR%%/lhs2tex/spacing.fmt
|
%%DATADIR%%/lhs2tex-1.13/spacing.fmt
|
||||||
@dirrm %%DATADIR%%/lhs2tex
|
@dirrm %%DATADIR%%/lhs2tex-1.13
|
||||||
@dirrm %%DATADIR%%
|
@dirrm %%DATADIR%%
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/Guide2.pdf
|
%%PORTDOCS%%%%DOCSDIR%%/Guide2.pdf
|
||||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||||
|
|
|
@ -7,8 +7,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= lhs2tex
|
PORTNAME= lhs2tex
|
||||||
PORTVERSION= 1.12
|
PORTVERSION= 1.13
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= devel haskell
|
CATEGORIES= devel haskell
|
||||||
MASTER_SITES= http://people.cs.uu.nl/andres/${PORTNAME}/
|
MASTER_SITES= http://people.cs.uu.nl/andres/${PORTNAME}/
|
||||||
|
|
||||||
|
@ -18,7 +17,6 @@ COMMENT= A preprocessor to generate LaTeX code from literate Haskell sources
|
||||||
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||||
mktexlsr:${PORTSDIR}/print/teTeX-base
|
mktexlsr:${PORTSDIR}/print/teTeX-base
|
||||||
|
|
||||||
USE_BZIP2= yes
|
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
HAS_CONFIGURE= yes
|
HAS_CONFIGURE= yes
|
||||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||||
|
@ -26,6 +24,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||||
--docdir=${DOCSDIR} \
|
--docdir=${DOCSDIR} \
|
||||||
--mandir=${MANPREFIX}/man
|
--mandir=${MANPREFIX}/man
|
||||||
|
|
||||||
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
.if defined(NOPORTDOCS)
|
.if defined(NOPORTDOCS)
|
||||||
INSTALL_TARGET=install
|
INSTALL_TARGET=install
|
||||||
.else
|
.else
|
||||||
|
@ -34,4 +34,8 @@ INSTALL_TARGET=install install-doc
|
||||||
|
|
||||||
MAN1= lhs2TeX.1
|
MAN1= lhs2TeX.1
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.if ${OSVERSION} < 700042
|
||||||
|
IGNORE= has a broken dependency
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.post.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (lhs2tex-1.12.tar.bz2) = 1bc982e96f19201aaf1c39c1d4b5e358
|
MD5 (lhs2tex-1.13.tar.gz) = 1173dbe6440f24918f3dc80d776e1f18
|
||||||
SHA256 (lhs2tex-1.12.tar.bz2) = af3440b8d5dda73ad43660fa496f5e1c04a3d3105961847963d0105c69a03447
|
SHA256 (lhs2tex-1.13.tar.gz) = 28282cb4afcc71785b092d358ffb33f5ec7585e50b392ae4fb6391d495a0836b
|
||||||
SIZE (lhs2tex-1.12.tar.bz2) = 582250
|
SIZE (lhs2tex-1.13.tar.gz) = 601072
|
||||||
|
|
|
@ -1,11 +1,66 @@
|
||||||
--- ./configure.orig Wed Apr 25 22:41:37 2007
|
--- configure.orig 2008-02-19 01:11:52.000000000 -0500
|
||||||
+++ ./configure Wed Apr 25 22:41:55 2007
|
+++ configure 2008-02-19 01:42:57.000000000 -0500
|
||||||
@@ -2726,7 +2726,7 @@
|
@@ -2637,54 +2637,6 @@
|
||||||
|
POLYTABLE_INSTALL=yes
|
||||||
|
fi
|
||||||
|
|
||||||
|
-if test "z$POLYTABLE_INSTALL" = "zyes"; then
|
||||||
|
-
|
||||||
|
-{ echo "$as_me:$LINENO: checking for the polytable package" >&5
|
||||||
|
-echo $ECHO_N "checking for the polytable package... $ECHO_C" >&6; }
|
||||||
|
-if test -x "$KPSEWHICH"; then
|
||||||
|
- POLYTABLE="`$KPSEWHICH polytable.sty`"
|
||||||
|
-fi
|
||||||
|
-if test -f "$POLYTABLE"; then
|
||||||
|
- { echo "$as_me:$LINENO: result: $POLYTABLE" >&5
|
||||||
|
-echo "${ECHO_T}$POLYTABLE" >&6; }
|
||||||
|
- { echo "$as_me:$LINENO: checking for version of polytable" >&5
|
||||||
|
-echo $ECHO_N "checking for version of polytable... $ECHO_C" >&6; }
|
||||||
|
- POLYTABLE_VERSION=`$GREP " v.* .polytable. package" $POLYTABLE | $SED -e "s/^.*v\(.*\) .polytable. package.*$/\1/"`
|
||||||
|
- { echo "$as_me:$LINENO: result: $POLYTABLE_VERSION" >&5
|
||||||
|
-echo "${ECHO_T}$POLYTABLE_VERSION" >&6; }
|
||||||
|
-else
|
||||||
|
- { echo "$as_me:$LINENO: result: no" >&5
|
||||||
|
-echo "${ECHO_T}no" >&6; }
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
- # does polytable need to be installed?
|
||||||
|
- { echo "$as_me:$LINENO: checking whether polytable needs to be installed" >&5
|
||||||
|
-echo $ECHO_N "checking whether polytable needs to be installed... $ECHO_C" >&6; }
|
||||||
|
- POLYTABLE_INSTALL=no
|
||||||
|
- if test -n $POLYTABLE; then
|
||||||
|
- if ( IFS=".";
|
||||||
|
- a="$POLYTABLE_VERSION"; b="0.8.2";
|
||||||
|
- while test -n "$a$b"
|
||||||
|
- do
|
||||||
|
- set -- $a; h1="$1"; shift 2>/dev/null; a="$*"
|
||||||
|
- set -- $b; h2="$1"; shift 2>/dev/null; b="$*"
|
||||||
|
- test -n "$h1" || h1=0; test -n "$h2" || h2=0
|
||||||
|
- test ${h1} -eq ${h2} || break
|
||||||
|
- done
|
||||||
|
- test ${h1} -lt ${h2}
|
||||||
|
- )
|
||||||
|
-then
|
||||||
|
- POLYTABLE_INSTALL=yes
|
||||||
|
-
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
- else
|
||||||
|
- POLYTABLE_INSTALL=yes
|
||||||
|
- fi
|
||||||
|
- { echo "$as_me:$LINENO: result: $POLYTABLE_INSTALL" >&5
|
||||||
|
-echo "${ECHO_T}$POLYTABLE_INSTALL" >&6; }
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
# Extract the first word of "mktexlsr", so it can be a program name with args.
|
||||||
|
set dummy mktexlsr; ac_word=$2
|
||||||
|
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
|
||||||
|
@@ -2727,7 +2679,7 @@
|
||||||
|
|
||||||
|
|
||||||
# docdir and expansion
|
# docdir and expansion
|
||||||
-docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
-docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
||||||
+#docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
+#docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
||||||
|
|
||||||
|
stydir="$datadir/$PACKAGE_TARNAME-$PACKAGE_VERSION"
|
||||||
|
|
||||||
# lhs2TeX binary path relative to docdir
|
|
||||||
|
|
|
@ -2,15 +2,15 @@ bin/lhs2TeX
|
||||||
share/texmf-local/tex/latex/polytable/lazylist.sty
|
share/texmf-local/tex/latex/polytable/lazylist.sty
|
||||||
share/texmf-local/tex/latex/polytable/polytable.sty
|
share/texmf-local/tex/latex/polytable/polytable.sty
|
||||||
@dirrm share/texmf-local/tex/latex/polytable
|
@dirrm share/texmf-local/tex/latex/polytable
|
||||||
%%DATADIR%%/lhs2tex/colorcode.fmt
|
%%DATADIR%%/lhs2tex-1.13/colorcode.fmt
|
||||||
%%DATADIR%%/lhs2tex/forall.fmt
|
%%DATADIR%%/lhs2tex-1.13/forall.fmt
|
||||||
%%DATADIR%%/lhs2tex/greek.fmt
|
%%DATADIR%%/lhs2tex-1.13/greek.fmt
|
||||||
%%DATADIR%%/lhs2tex/jfpcompat.fmt
|
%%DATADIR%%/lhs2tex-1.13/jfpcompat.fmt
|
||||||
%%DATADIR%%/lhs2tex/lhs2TeX.fmt
|
%%DATADIR%%/lhs2tex-1.13/lhs2TeX.fmt
|
||||||
%%DATADIR%%/lhs2tex/lhs2TeX.sty
|
%%DATADIR%%/lhs2tex-1.13/lhs2TeX.sty
|
||||||
%%DATADIR%%/lhs2tex/polycode.fmt
|
%%DATADIR%%/lhs2tex-1.13/polycode.fmt
|
||||||
%%DATADIR%%/lhs2tex/spacing.fmt
|
%%DATADIR%%/lhs2tex-1.13/spacing.fmt
|
||||||
@dirrm %%DATADIR%%/lhs2tex
|
@dirrm %%DATADIR%%/lhs2tex-1.13
|
||||||
@dirrm %%DATADIR%%
|
@dirrm %%DATADIR%%
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/Guide2.pdf
|
%%PORTDOCS%%%%DOCSDIR%%/Guide2.pdf
|
||||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||||
|
|
Loading…
Reference in a new issue