Add openexr_ctl 1.0.0, is a simplified OpenEXR interface to CTL.

This commit is contained in:
Norikatsu Shigemura 2007-10-08 16:37:46 +00:00
parent 8a135bfc6b
commit 4914453bd2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=201104
6 changed files with 81 additions and 0 deletions

View file

@ -447,6 +447,7 @@
SUBDIR += opencv
SUBDIR += opendis
SUBDIR += opendx
SUBDIR += openexr_ctl
SUBDIR += opengl-man
SUBDIR += openjpeg
SUBDIR += openproducer

View file

@ -0,0 +1,32 @@
# New ports collection makefile for: openexr_ctl
# Date created: 2007-10-09
# Whom: nork@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= openexr_ctl
PORTVERSION= 1.0.0
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= openexr
MAINTAINER= nork@FreeBSD.org
COMMENT= Simplified OpenEXR interface to CTL
LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
IlmCtl.2:${PORTSDIR}/graphics/ampasCTL
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
test check: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
.if defined(PACKAGE_BUILDING)
pre-install: test
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (openexr_ctl-1.0.0.tar.gz) = 48b0f2d247117a46962a0983da511759
SHA256 (openexr_ctl-1.0.0.tar.gz) = bfa28d626201f6b29e794b9ab54a01ec4b1153ec99160b492adabf0ae082f304
SIZE (openexr_ctl-1.0.0.tar.gz) = 367164

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig 2007-08-04 09:13:15.000000000 +0900
+++ Makefile.in 2007-10-09 01:15:31.000000000 +0900
@@ -209,7 +209,7 @@
AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS \
README README.CVS README.OSX README.win32 bootstrap
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = OpenEXR_CTL.pc
all: all-recursive

View file

@ -0,0 +1,19 @@
* IlmImfCtl provides a simplified OpenEXR interface to CTL.
* exrdpx is an initial version of a CTL-driven file converter
that translates DPX files into OpenEXR files and vice versa.
The conversion between the DPX and OpenEXR color spaces is
handled by CTL transforms.
* exr_ctl_exr is an initial version of a program that can bake
the effect of a series of CTL transforms into the pixels of
an OpenEXR file.
WARNING: the exrdpx file converter and the exr_ctl_exr program are
still under development. They are good enough for experimentation,
but they are not ready for production use. The programs are slow,
and the DPX file I/O capabilities of exrdpx are minimal; most DPX
header fields and most OpenEXR attributes are lost during file
conversion.
WWW: http://www.openexr.com/

View file

@ -0,0 +1,15 @@
bin/exr_ctl_exr
bin/exrdpx
lib/libIlmImfCtl.a
lib/libIlmImfCtl.la
lib/libIlmImfCtl.so
lib/libIlmImfCtl.so.2
lib/CTL/change_saturation.ctl
lib/CTL/transform_DPX_EXR.ctl
lib/CTL/transform_EXR_DPX.ctl
lib/CTL/transform_RRT.ctl
lib/CTL/transform_display_video.ctl
lib/CTL/utilities.ctl
libdata/pkgconfig/OpenEXR_CTL.pc
include/OpenEXR/ImfCtlApplyTransforms.h
@dirrm lib/CTL