Add MasqMail is a mail server designed for hosts that do not have a permanent
internet connection eg. a home network or a single host at home. It has special support for connections to different ISPs. It replaces sendmail or other MTAs such as qmail or exim. This is development unstable version (quite stable in fact). PR: ports/66116 Submitted by: Andrey Slusar <vasallia@ukr.net>
This commit is contained in:
parent
dabf5e1b03
commit
4931ba8bee
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108205
8 changed files with 215 additions and 0 deletions
|
@ -156,6 +156,7 @@
|
|||
SUBDIR += majorcool
|
||||
SUBDIR += majordomo
|
||||
SUBDIR += masqmail
|
||||
SUBDIR += masqmail-devel
|
||||
SUBDIR += mavbiff
|
||||
SUBDIR += mb2md
|
||||
SUBDIR += mboxcheck-applet
|
||||
|
|
73
mail/masqmail-devel/Makefile
Normal file
73
mail/masqmail-devel/Makefile
Normal file
|
@ -0,0 +1,73 @@
|
|||
# Ports collection makefile for: masqmail-devel
|
||||
# Date created: 4 Apr 2004
|
||||
# Whom: Andrey Slusar <vasallia@ukr.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= masqmail
|
||||
PORTVERSION= 0.2.20
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://innominate.org/kurth/masqmail/download/
|
||||
|
||||
MAINTAINER= vasallia@ukr.net
|
||||
COMMENT= Mail server for hosts, not permanently connected to the internet
|
||||
|
||||
MAN5= masqmail.aliases.5 masqmail.conf.5 masqmail.get.5 masqmail.route.5
|
||||
MAN8= masqmail.8 mservdetect.8
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --mandir=${PREFIX}/man --with-user=mailnull --with-group=mail \
|
||||
--with-confdir=${PREFIX}/etc/masqmail --with-logdir=/var/log/masqmail
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
.if defined(WITH_LIBCRYPTO)
|
||||
CONFIGURE_ARGS+= --with-libcrypto
|
||||
.endif
|
||||
.if defined(WITHOUT_POP3)
|
||||
CONFIGURE_ARGS+= --disable-pop3
|
||||
.endif
|
||||
.if defined(WITHOUT_SMTP)
|
||||
CONFIGURE_ARGS+= --disable-smtp-server
|
||||
.endif
|
||||
.if defined(WITHOUT_RESOLVER)
|
||||
CONFIGURE_ARGS+= --disable-resolver
|
||||
.endif
|
||||
.if defined(WITH_MAILDIR)
|
||||
CONFIGURE_ARGS+= --enable-maildir
|
||||
.endif
|
||||
.if defined(WITH_MSERVER)
|
||||
CONFIGURE_ARGS+= --enable-mserver
|
||||
.endif
|
||||
.if defined(WITH_AUTH)
|
||||
CONFIGURE_ARGS+= --enable-auth
|
||||
.endif
|
||||
.if defined(WITH_IDENT)
|
||||
CONFIGURE_ARGS+= --enable-ident
|
||||
.endif
|
||||
|
||||
USE_GNOME= glib12
|
||||
USE_RC_SUBR= yes
|
||||
NO_LATEST_LINK= yes
|
||||
|
||||
post-build:
|
||||
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
|
||||
-e 's,%%RC_SUBR%%,${RC_SUBR},g' \
|
||||
${FILESDIR}/masqmail.sh > ${WRKDIR}/masqmail.sh
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/masqmail.sh ${PREFIX}/etc/rc.d/masqmail.sh
|
||||
${MKDIR} ${PREFIX}/etc/masqmail
|
||||
${CHOWN} mailnull:mail ${PREFIX}/etc/masqmail
|
||||
${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/masqmail.conf ${PREFIX}/etc/masqmail/masqmail.conf-dist
|
||||
${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/example.get ${PREFIX}/etc/masqmail/masqmail.get-dist
|
||||
${INSTALL_DATA} -o mailnull -g mail ${WRKSRC}/examples/example.route ${PREFIX}/etc/masqmail/masqmail.route-dist
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for i in AUTHORS COPYING INSTALL NEWS README TODO
|
||||
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
mail/masqmail-devel/distinfo
Normal file
2
mail/masqmail-devel/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (masqmail-0.2.20.tar.gz) = 74540980ecde45783e888d1da80cb318
|
||||
SIZE (masqmail-0.2.20.tar.gz) = 243171
|
63
mail/masqmail-devel/files/masqmail.sh
Normal file
63
mail/masqmail-devel/files/masqmail.sh
Normal file
|
@ -0,0 +1,63 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
# PROVIDE: mail
|
||||
# REQUIRE: LOGIN
|
||||
# KEYWORD: FreeBSD shutdown
|
||||
# we make mail start late, so that things like .forward's are not
|
||||
# processed until the system is fully operational
|
||||
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf to enable masqmail:
|
||||
#
|
||||
#masqmail_enable="YES"
|
||||
#
|
||||
# See masqmail(8) for flags
|
||||
#
|
||||
|
||||
. %%RC_SUBR%%
|
||||
|
||||
name=masqmail
|
||||
rcvar=`set_rcvar`
|
||||
|
||||
command=%%PREFIX%%/sbin/masqmail
|
||||
required_dirs=/var/log/masqmail
|
||||
required_files=%%PREFIX%%/etc/masqmail/masqmail.conf
|
||||
|
||||
start_precmd=start_precmd
|
||||
stop_postcmd=stop_postcmd
|
||||
|
||||
extra_commands="reload"
|
||||
|
||||
start_precmd()
|
||||
{
|
||||
case $sendmail_enable in
|
||||
[Yy][Ee][Ss]|[Tt][Rr][Uu][Ee]|[Oo][Nn]|1)
|
||||
warn "sendmail_enable should be set to NONE"
|
||||
;;
|
||||
[Nn][Oo]|[Ff][Aa][Ll][Ss][Ee]|[Oo][Ff][Ff]|0)
|
||||
case $sendmail_submit_enable in
|
||||
[Yy][Ee][Ss]|[Tt][Rr][Uu][Ee]|[Oo][Nn]|1)
|
||||
warn "sendmail_submit_enable should be set to NO"
|
||||
;;
|
||||
esac
|
||||
;;
|
||||
[Nn][Oo][Nn][Ee])
|
||||
;;
|
||||
esac
|
||||
}
|
||||
|
||||
stop_postcmd()
|
||||
{
|
||||
rm -f $pidfile
|
||||
}
|
||||
|
||||
# set defaults
|
||||
|
||||
masqmail_enable=${masqmail_enable:-"NO"}
|
||||
masqmail_flags=${masqmail_flags:-"-bd -q30m"}
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
17
mail/masqmail-devel/files/patch-Makefile.in
Normal file
17
mail/masqmail-devel/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- Makefile.in.old Sun Apr 4 23:36:26 2004
|
||||
+++ Makefile.in Sun Apr 4 23:38:38 2004
|
||||
@@ -377,9 +377,12 @@
|
||||
$(DESTDIR)@datadir@/tpl: conf_dir
|
||||
install -d $(DESTDIR)@datadir@/masqmail/tpl
|
||||
install -m 644 tpl/failmsg.tpl $(DESTDIR)@datadir@/masqmail/tpl
|
||||
- install -m 644 tpl/failmsg.tpl.{de,fr,it} $(DESTDIR)@datadir@/masqmail/tpl
|
||||
+ install -m 644 tpl/failmsg.tpl.de $(DESTDIR)@datadir@/masqmail/tpl
|
||||
+ install -m 644 tpl/failmsg.tpl.fr $(DESTDIR)@datadir@/masqmail/tpl
|
||||
+ install -m 644 tpl/failmsg.tpl.it $(DESTDIR)@datadir@/masqmail/tpl
|
||||
install -m 644 tpl/warnmsg.tpl $(DESTDIR)@datadir@/masqmail/tpl
|
||||
- install -m 644 tpl/warnmsg.tpl.{de,fr} $(DESTDIR)@datadir@/masqmail/tpl
|
||||
+ install -m 644 tpl/warnmsg.tpl.de $(DESTDIR)@datadir@/masqmail/tpl
|
||||
+ install -m 644 tpl/warnmsg.tpl.fr $(DESTDIR)@datadir@/masqmail/tpl
|
||||
|
||||
log_dir: $(DESTDIR)@with_logdir@
|
||||
|
12
mail/masqmail-devel/files/patch-local.c
Normal file
12
mail/masqmail-devel/files/patch-local.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/local.c.old Fri Apr 30 15:32:04 2004
|
||||
+++ src/local.c Fri Apr 30 15:34:23 2004
|
||||
@@ -19,6 +19,9 @@
|
||||
#include "masqmail.h"
|
||||
#include "peopen.h"
|
||||
#include <sys/wait.h>
|
||||
+#ifdef ENABLE_MAILDIR
|
||||
+#include <sys/stat.h>
|
||||
+#endif
|
||||
|
||||
static
|
||||
void message_stream(FILE *out, message *msg, GList *hdr_list, guint flags)
|
23
mail/masqmail-devel/pkg-descr
Normal file
23
mail/masqmail-devel/pkg-descr
Normal file
|
@ -0,0 +1,23 @@
|
|||
MasqMail is a mail server designed for hosts that do not have a permanent
|
||||
internet connection eg. a home network or a single host at home. It has
|
||||
special support for connections to different ISPs. It replaces sendmail or
|
||||
other MTAs such as qmail or exim.
|
||||
|
||||
Features
|
||||
|
||||
* Delivers only when online to a destination 'outside' your LAN
|
||||
* Support for multiple Providers (ie. Mail Servers, or direct delivery)
|
||||
* Rewriting of Return addresses (Return-Path:, From:, Reply-To:),
|
||||
configurable for each Provider separately
|
||||
* can also be used as a Mail Server on a LAN
|
||||
* alias support
|
||||
* delivery to pipes
|
||||
* delivery to MDAs (eg. procmail)
|
||||
* Maildir support (version >= 0.2.5)
|
||||
* routing depending on sender
|
||||
* AUTH (RFC 2554) support (as client, since version 0.1.0)
|
||||
* SMTP-after-POP
|
||||
* POP3 client
|
||||
* POP3 client daemon (fetch mail in regular intervals if online)
|
||||
|
||||
WWW: http://innominate.org/kurth/masqmail/
|
24
mail/masqmail-devel/pkg-plist
Normal file
24
mail/masqmail-devel/pkg-plist
Normal file
|
@ -0,0 +1,24 @@
|
|||
bin/mservdetect
|
||||
etc/masqmail/masqmail.conf-dist
|
||||
etc/masqmail/masqmail.get-dist
|
||||
etc/masqmail/masqmail.route-dist
|
||||
etc/rc.d/masqmail.sh
|
||||
sbin/masqmail
|
||||
share/masqmail/tpl/failmsg.tpl
|
||||
share/masqmail/tpl/failmsg.tpl.de
|
||||
share/masqmail/tpl/failmsg.tpl.fr
|
||||
share/masqmail/tpl/failmsg.tpl.it
|
||||
share/masqmail/tpl/warnmsg.tpl
|
||||
share/masqmail/tpl/warnmsg.tpl.de
|
||||
share/masqmail/tpl/warnmsg.tpl.fr
|
||||
%%DOCSDIR%%/AUTHORS
|
||||
%%DOCSDIR%%/COPYING
|
||||
%%DOCSDIR%%/INSTALL
|
||||
%%DOCSDIR%%/NEWS
|
||||
%%DOCSDIR%%/README
|
||||
%%DOCSDIR%%/TODO
|
||||
@dirrm share/masqmail/tpl
|
||||
@dirrm share/masqmail
|
||||
@dirrm etc/masqmail
|
||||
@dirrm %%DOCSDIR%%
|
||||
@unexec rmdir /var/log/masqmail 2>/dev/null || true
|
Loading…
Reference in a new issue