Remove gswitchit_applet after a repo move to gswitchit.

This commit is contained in:
Joe Marcus Clarke 2003-06-02 22:05:43 +00:00
parent 8bda45d50b
commit 493f233dcf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82056
7 changed files with 0 additions and 189 deletions

View file

@ -1,35 +0,0 @@
# Ports collection Makefile for: gswitchit_applet
# Date created: 5 June 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gswitchit_applet
PORTVERSION= 0.92
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gswitchit
MAINTAINER= sobomax@FreeBSD.org
COMMENT= A simple keyboard state indicator and switcher for GNOME Desktop
LIB_DEPENDS= xklavier.0:${PORTSDIR}/x11/libxklavier
RUN_DEPENDS= ${X11BASE}/lib/X11/xkb/rules/xfree86.xml:${PORTSDIR}/x11/xfree86_xkb_xml
USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gswitchit_applet.1
pre-patch:
@${PERL} -pi -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>

View file

@ -1 +0,0 @@
MD5 (gswitchit_applet-0.92.tar.gz) = 5a14ce9a6ed42997882b5e34c8e00647

View file

@ -1,22 +0,0 @@
$FreeBSD$
--- capplet/Makefile.in.orig Fri May 31 14:39:19 2002
+++ capplet/Makefile.in Fri May 31 14:58:45 2002
@@ -169,6 +169,7 @@
../src/gswitchit_config.o \
-lxklavier \
-lxkbfile \
+ -lxml2 \
$(GDK_PIXBUF_LIBS) \
$(GCONF_LIBS) \
$(BONOBO_LIBS) \
@@ -195,7 +196,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I..
-CPPFLAGS = @CPPFLAGS@
+CPPFLAGS = $(GDK_PIXBUF_CFLAGS) @CPPFLAGS@
LIBS = @LIBS@
gswitchit_properties_capplet_OBJECTS = gswitchit_capplet.$(OBJEXT)
gswitchit_properties_capplet_DEPENDENCIES = ../src/gswitchit_config.o

View file

@ -1,62 +0,0 @@
$FreeBSD$
--- configure.orig Fri May 31 14:03:58 2002
+++ configure Fri May 31 14:04:45 2002
@@ -5925,6 +5925,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -8524,10 +8525,10 @@
#include "confdefs.h"
#include <libintl.h>
extern int _nl_msg_cat_cntr;
-extern int *_nl_domain_bindings;
+extern int *_nl_domain_bindings__;
int main() {
bindtextdomain ("", "");
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
+return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings__
; return 0; }
EOF
if { (eval echo configure:8534: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
@@ -8913,7 +8914,7 @@
#include "confdefs.h"
#include <libintl.h>
extern int _nl_msg_cat_cntr;
-extern int *_nl_domain_bindings;
+extern int *_nl_domain_bindings__;
extern
#ifdef __cplusplus
"C"
@@ -8921,7 +8922,7 @@
const char *_nl_expand_alias ();
int main() {
bindtextdomain ("", "");
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
+return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings__ + *_nl_expand_alias (0)
; return 0; }
EOF
if { (eval echo configure:8928: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
@@ -8941,7 +8942,7 @@
#include "confdefs.h"
#include <libintl.h>
extern int _nl_msg_cat_cntr;
-extern int *_nl_domain_bindings;
+extern int *_nl_domain_bindings__;
extern
#ifdef __cplusplus
"C"
@@ -8949,7 +8950,7 @@
const char *_nl_expand_alias ();
int main() {
bindtextdomain ("", "");
-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)
+return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings__ + *_nl_expand_alias (0)
; return 0; }
EOF
if { (eval echo configure:8956: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then

View file

@ -1,13 +0,0 @@
$FreeBSD$
--- src/Makefile.in 2002/05/31 11:13:42 1.1
+++ src/Makefile.in 2002/05/31 11:14:13
@@ -176,6 +176,7 @@
$(GDK_PIXBUF_LIBS) \
$(GCONF_LIBS) \
-lxklavier \
+ -lxkbfile \
-lgconf-gtk-1
gswitchit_applet_MANS = ../man/gswitchit_applet.1

View file

@ -1,12 +0,0 @@
GSwitchIt is just a simple keyboard state indicator and switcher for GNOME
panel.
Features:
---------
o Support up to 4 keyboard groups.
o Customizable images for each group.
o Switching using the applet menu or by double-click.
o Audible bell on layout switching (BTW, it can be turned off!).
o Support for "secondary" layouts (i.e. layouts reachable only from popup menu).
WWW: http://gswitchit.sourceforge.net/

View file

@ -1,44 +0,0 @@
bin/gswitchit-properties_capplet
bin/gswitchit_applet
bin/xkb-properties_capplet
etc/CORBA/servers/gswitchit_applet.gnorba
etc/gconf/gconf.xml.defaults/apps/gswitchit_applet/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/gswitchit_applet/General/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/gswitchit_applet/XKB/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit_applet/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit_applet/General/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit_applet/XKB/%gconf.xml
etc/gconf/schemas/gswitchit_applet.schemas
share/gnome/applets/Utility/gswitchit_applet.desktop
share/gnome/apps/Settings/XKB/.directory
share/gnome/apps/Settings/XKB/gswitchit-properties.desktop
share/gnome/apps/Settings/XKB/xkb-properties.desktop
share/gnome/control-center/capplets/XKB/.directory
share/gnome/control-center/capplets/XKB/gswitchit-properties.desktop
share/gnome/control-center/capplets/XKB/xkb-properties.desktop
share/gnome/gswitchit_applet/interfaces/gswitchit_applet.glade
share/gnome/pixmaps/gswitchit/III.xpm
share/gnome/pixmaps/gswitchit/IV.xpm
share/gnome/pixmaps/gswitchit/bg.xpm
share/gnome/pixmaps/gswitchit/el.xpm
share/gnome/pixmaps/gswitchit/gswitchit.png
share/gnome/pixmaps/gswitchit/ru.xpm
share/gnome/pixmaps/gswitchit/th.xpm
share/gnome/pixmaps/gswitchit/us.xpm
share/gnome/pixmaps/gswitchit/xkb.png
share/locale/bg/LC_MESSAGES/gswitchit_applet.mo
share/locale/de/LC_MESSAGES/gswitchit_applet.mo
share/locale/el/LC_MESSAGES/gswitchit_applet.mo
share/locale/ru/LC_MESSAGES/gswitchit_applet.mo
share/locale/sv/LC_MESSAGES/gswitchit_applet.mo
@dirrm share/gnome/pixmaps/gswitchit
@dirrm share/gnome/gswitchit_applet/interfaces
@dirrm share/gnome/gswitchit_applet
@dirrm share/gnome/control-center/capplets/XKB
@dirrm share/gnome/apps/Settings/XKB
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit_applet/XKB
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit_applet/General
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gswitchit_applet
@dirrm etc/gconf/gconf.xml.defaults/apps/gswitchit_applet/XKB
@dirrm etc/gconf/gconf.xml.defaults/apps/gswitchit_applet/General
@dirrm etc/gconf/gconf.xml.defaults/apps/gswitchit_applet