Update to 4.0. Unfortunately I have not heard from the maintainer, while 4.3

freeze is coming today, so I decided to force things a little. Among other
things this release supports TLS/SSL, previously available in the Qualcomms's
commercial package "Qpopper LX".
This commit is contained in:
Maxim Sobolev 2001-04-17 07:53:49 +00:00
parent 2f4b6bde6b
commit 496f0ea974
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41503
5 changed files with 83 additions and 55 deletions

View file

@ -6,8 +6,7 @@
# #
PORTNAME= qpopper PORTNAME= qpopper
PORTVERSION= 3.1.2 PORTVERSION= 4.0
PORTREVISION= 1
CATEGORIES= mail ipv6 CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/ \ MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/ \
ftp://sunsite.doc.ic.ac.uk/Mirrors/ftp.qualcomm.com/eudora/servers/unix/popper/ ftp://sunsite.doc.ic.ac.uk/Mirrors/ftp.qualcomm.com/eudora/servers/unix/popper/
@ -15,11 +14,11 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400014 #.if ${OSVERSION} >= 400014
PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/ #PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
PATCHFILES= qpopper3.1.2-ipv6-20001214.diff.gz #PATCHFILES= qpopper3.1.2-ipv6-20001214.diff.gz
PATCH_DIST_STRIP= -p1 #PATCH_DIST_STRIP= -p1
.endif #.endif
MAINTAINER= lioux@FreeBSD.org MAINTAINER= lioux@FreeBSD.org
@ -45,6 +44,14 @@ OS_DEFS+= -DAPOP_ONLY
CONFIGURE_ARGS+= --enable-debugging CONFIGURE_ARGS+= --enable-debugging
.endif .endif
.if exists(/usr/lib/libssl.a) && exists(/usr/lib/libcrypto.a)
CONFIGURE_ARGS+= --with-openssl=/usr
.elif exists(${LOCALBASE}/lib/libssl.a) && exists(${LOCALBASE}/lib/libcrypto.a)
LIB_DEPENDS+= ssl.1:${PORTSDIR}/security/openssl
CONFIGURE_ARGS+= -with-includes=${LOCALBASE}/include/openssl --with-openssl=${LOCALBASE}
CONFIGURE_ENV+= RSAGLUE=-lRSAglue
.endif
post-patch: post-patch:
@${RM} -f ${WRKSRC}/popper/md5.h @${RM} -f ${WRKSRC}/popper/md5.h
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/man/* @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/man/*

View file

@ -1,2 +1 @@
MD5 (qpopper3.1.2.tar.gz) = b7776c45b94bd1b937ae8ad3559da45d MD5 (qpopper4.0.tar.gz) = 05a199b41bf6e8b3bfaf5f762d4e35d9
MD5 (qpopper3.1.2-ipv6-20001214.diff.gz) = 3404b42da1e119728cb7a460f545d5ea

View file

@ -1,45 +1,50 @@
--- popper/Makefile.in.orig Thu Aug 17 01:36:14 2000
+++ popper/Makefile.in Wed Nov 1 11:37:31 2000 $FreeBSD$
@@ -74,9 +74,9 @@
pop_msg.o pop_parse.o pop_pass.o pop_quit.o \ --- popper/Makefile.in.orig Wed Apr 4 03:23:22 2001
pop_rset.o pop_send.o pop_stat.o pop_updt.o \ +++ popper/Makefile.in Fri Apr 13 19:03:27 2001
pop_user.o pop_xtnd.o pop_xmit.o popper.o \ @@ -106,9 +106,9 @@
- pop_bull.o xtnd_xlst.o pop_uidl.o mktemp.o \ pop_msg.o pop_parse.o pop_pass.o pop_quit.o \
- pop_rpop.o pop_apop.o md5.o pop_auth.o pop_pope.o \ pop_rset.o pop_send.o pop_stat.o pop_updt.o \
- pop_extend.o scram.o hmac.o base64.o pop_util.o \ pop_user.o pop_xtnd.o pop_xmit.o popper.o \
+ pop_bull.o xtnd_xlst.o pop_uidl.o \ - pop_bull.o xtnd_xlst.o pop_uidl.o mktemp.o \
+ pop_rpop.o pop_apop.o pop_auth.o pop_pope.o \ - pop_rpop.o pop_apop.o md5.o pop_auth.o pop_pope.o \
+ pop_extend.o scram.o hmac.o pop_util.o \ - pop_extend.o scram.o hmac.o base64.o pop_util.o \
get_sub_opt.o msg_ptr.o drac.o pop_config.o main.o + pop_bull.o xtnd_xlst.o pop_uidl.o \
+ pop_rpop.o pop_apop.o pop_auth.o pop_pope.o \
+ pop_extend.o scram.o hmac.o pop_util.o \
get_sub_opt.o msg_ptr.o drac.o pop_config.o pop_tls.o \
pop_tls_openssl.o pop_tls_sslplus.o sslplus_utils.o \
main.o pop_cache.o genpath.o
@@ -119,17 +119,17 @@
pop_msg.c pop_parse.c pop_pass.c pop_quit.c \
pop_rset.c pop_send.c pop_stat.c pop_updt.c \
pop_user.c pop_xtnd.c pop_xmit.c popper.c \
- pop_bull.c xtnd_xlst.c pop_uidl.c mktemp.c \
- pop_rpop.c pop_apop.c md5.c pop_auth.c pop_pope.c \
- pop_extend.c scram.c hmac.c base64.c pop_util.c \
+ pop_bull.c xtnd_xlst.c pop_uidl.c \
+ pop_rpop.c pop_apop.c pop_auth.c pop_pope.c \
+ pop_extend.c scram.c hmac.c pop_util.c \
get_sub_opt.c msg_ptr.c drac.c pop_config.c pop_tls.c \
pop_tls_openssl.c pop_tls_sslplus.c sslplus_utils.c \
main.c pop_cache.c genpath.c
SRCS = pop_dele.c pop_dropcopy.c \ -POPAUTHOBJS = base64.o scram.o md5.o \
@@ -85,15 +85,15 @@ +POPAUTHOBJS = scram.o \
pop_msg.c pop_parse.c pop_pass.c pop_quit.c \ hmac.o popauth.o
pop_rset.c pop_send.c pop_stat.c pop_updt.c \
pop_user.c pop_xtnd.c pop_xmit.c popper.c \
- pop_bull.c xtnd_xlst.c pop_uidl.c mktemp.c \
- pop_rpop.c pop_apop.c md5.c pop_auth.c pop_pope.c \
- pop_extend.c scram.c hmac.c base64.c pop_util.c \
+ pop_bull.c xtnd_xlst.c pop_uidl.c \
+ pop_rpop.c pop_apop.c pop_auth.c pop_pope.c \
+ pop_extend.c scram.c hmac.c pop_util.c \
get_sub_opt.c msg_ptr.c drac.c pop_config.c main.c
-POPAUTHOBJS = base64.o scram.o md5.o \ -POPAUTHSRCS = base64.c scram.c md5.c \
+POPAUTHOBJS = scram.o \ +POPAUTHSRCS = scram.c \
hmac.o popauth.o hmac.c popauth.c
-POPAUTHSRCS = base64.c scram.c md5.c \ INCLUDES = ${srcdir}/popper.h \
+POPAUTHSRCS = scram.c \ @@ -180,7 +180,7 @@
hmac.c popauth.c ${LIBS}
INCLUDES = ${srcdir}/popper.h ${srcdir}/version.h \
@@ -133,7 +133,7 @@
-I${common_srcdir} ${common_dir}/libcommon.a
popauth: ${POPAUTHOBJS} popauth: ${POPAUTHOBJS}
- ${CC} -o popauth ${POPAUTHOBJS} ${NETWORK_LIBS} ${DBM_LIBS} \ - ${CC} -o popauth ${POPAUTHOBJS} ${NETWORK_LIBS} ${DBM_LIBS} \
+ ${CC} -o popauth ${POPAUTHOBJS} ${LIBS} ${NETWORK_LIBS} ${DBM_LIBS} \ + ${CC} -o popauth ${POPAUTHOBJS} ${LIBS} ${NETWORK_LIBS} ${DBM_LIBS} \
${common_dir}/libcommon.a ${common_dir}/libcommon.a
.c.o: poppassd: common_library

View file

@ -1,5 +1,8 @@
--- man/popauth.8.orig Mon Aug 21 00:18:08 2000
+++ man/popauth.8 Wed Nov 1 11:50:18 2000 $FreeBSD$
--- man/popauth.8.orig Wed Apr 4 03:23:13 2001
+++ man/popauth.8 Fri Apr 13 19:05:06 2001
@@ -7,11 +7,11 @@ @@ -7,11 +7,11 @@
.\" See License.txt file for terms and conditions for modification and .\" See License.txt file for terms and conditions for modification and
.\" redistribution. .\" redistribution.
@ -15,16 +18,16 @@
[ [
.BI \-trace " tracefile" .BI \-trace " tracefile"
] [ ] [
@@ -43,18 +43,18 @@ @@ -46,18 +46,18 @@
] ]
.SH DESCRIPTION .SH DESCRIPTION
-The \fIpopauth\fR program allows a POP-subscribers to add or change the secret -The \fIpopauth\fR program allows POP subscribers to add or change the secret
+The \fIqpopauth\fR program allows a POP-subscribers to add or change the secret +The \fIqpopauth\fR program allows POP subscribers to add or change the secret
values used to generate their authentication credentials, or to verify the values used to generate their authentication credentials, or to verify the
existance of their records. existance of their records.
In addition,the super\-user or master POP user can add, delete, or reset In addition, the super\-user or master POP user can add, delete, or reset
credential data for a user, or list which records exist. Only the credential data for a user, or list which records exist. Only the
-super\-user may initialize the database. \fIpopauth\fR is useful only when -super\-user may initialize the database. \fIpopauth\fR is useful only when
+super\-user may initialize the database. \fIqpopauth\fR is useful only when +super\-user may initialize the database. \fIqpopauth\fR is useful only when
@ -36,9 +39,9 @@
+\fIqpopauth\fR prompts for a new secret, +\fIqpopauth\fR prompts for a new secret,
just like the \fIpasswd\fR program. It then updates the authorization DB. just like the \fIpasswd\fR program. It then updates the authorization DB.
With the `\-user' switch, With the
@@ -74,8 +74,8 @@ @@ -85,8 +85,8 @@
With the `\-delete' switch, the super-user or master POP user can remove switch, the super-user or master POP user can remove
a user entry from the authorization DB. a user entry from the authorization DB.
.SH FILES .SH FILES
-/etc/pop.auth.* POP authorization DB -/etc/pop.auth.* POP authorization DB
@ -46,5 +49,5 @@
.SH ACKNOWLEDGEMENTS .SH ACKNOWLEDGEMENTS
This program was derived from MH 6.8.3 This program was derived from MH 6.8.3
.SH SEE ALSO .SH SEE ALSO
-popper(8) -popper(8), poppassd(8)
+qpopper(8) +qpopper(8)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- configure.orig Wed Apr 4 03:28:30 2001
+++ configure Fri Apr 13 19:20:14 2001
@@ -2559,7 +2559,7 @@
EOF
SSL_DIR_INC="-I${openssl}/include"
- SSL_LIBS="-L${openssl}/lib -lssl -lcrypto"
+ SSL_LIBS="-L${openssl}/lib -lrsaref -lssl -lcrypto ${RSAGLUE}"
fi