- Support staging
- Convert USE_GMAKE to USES - Fix build on 10.x
This commit is contained in:
parent
a15a756e39
commit
4971f35855
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=336041
4 changed files with 29 additions and 4755 deletions
|
@ -15,11 +15,9 @@ COMMENT= Free real-time Worms game
|
|||
|
||||
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
|
||||
|
||||
USES= gmake
|
||||
USE_BZIP2= yes
|
||||
USE_SDL= sdl net mixer ttf image
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAKE_ENV= "CXX=${CXX}"
|
||||
|
||||
DATAVERSION= 2005-12-21
|
||||
DESKTOP_ENTRIES="Worms of Prey" \
|
||||
|
@ -29,8 +27,10 @@ DESKTOP_ENTRIES="Worms of Prey" \
|
|||
"Game;ActionGame;" \
|
||||
false
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
PORTDOCS= *
|
||||
PORTDATA= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|__va_copy|va_copy|g' ${WRKSRC}/src/string.cpp
|
||||
|
@ -42,22 +42,13 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e '/stdint.h/ d' ${WRKSRC}/src/attachableobject.cpp
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/wop ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/woprc ${PREFIX}/etc/woprc.sample
|
||||
if [ ! -f ${PREFIX}/etc/woprc ]; then \
|
||||
${INSTALL_DATA} ${WRKSRC}/woprc ${PREFIX}/etc; \
|
||||
fi
|
||||
|
||||
@echo "Installing data files..."
|
||||
@cd ${WRKDIR}/${PORTNAME}data-${DATAVERSION}; \
|
||||
${FIND} . -type d -exec ${MKDIR} ${DATADIR}/{} \; ; \
|
||||
${FIND} . -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/wop ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/woprc ${STAGEDIR}${PREFIX}/etc/woprc.sample
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
cd ${WRKDIR}/${PORTNAME}data-${DATAVERSION} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in AUTHORS COPYING ChangeLog README README-COMMAND-LINE-OPTIONS.txt
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
10
games/wop/files/patch-src-serverlistwindow.cpp
Normal file
10
games/wop/files/patch-src-serverlistwindow.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/serverlistwindow.cpp.orig 2005-07-17 21:27:31.000000000 +0400
|
||||
+++ src/serverlistwindow.cpp 2013-05-30 22:08:15.521112163 +0400
|
||||
@@ -94,7 +94,6 @@
|
||||
}
|
||||
|
||||
ServerListWindow::~ServerListWindow() {
|
||||
- delete m_header;
|
||||
}
|
||||
|
||||
void ServerListWindow::clearEntries() {
|
8
games/wop/files/patch-src-spriteset.cpp
Normal file
8
games/wop/files/patch-src-spriteset.cpp
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- src/spriteset.cpp.orig 2006-03-27 14:27:53.000000000 +0400
|
||||
+++ src/spriteset.cpp 2013-09-12 04:56:04.339229318 +0400
|
||||
@@ -618,3 +618,5 @@
|
||||
}
|
||||
|
||||
/**********************************************************/
|
||||
+#include "sprite.hpp"
|
||||
+template class SpriteSet<Sprite>;
|
4735
games/wop/pkg-plist
4735
games/wop/pkg-plist
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue