- Update to version 1.10.0

PR:		165004
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2012-02-20 00:06:48 +00:00
parent 2bb12a9788
commit 4995e4a28e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=291888
13 changed files with 6783 additions and 2373 deletions

View file

@ -6,50 +6,92 @@
#
PORTNAME= mixxx
PORTVERSION= 1.7.0
PORTREVISION= 2
PORTVERSION= 1.10.0
DISTVERSIONSUFFIX= -src
CATEGORIES= audio
MASTER_SITES= http://downloads.mixxx.org/%SUBDIR%/
MASTER_SITES= http://mixxx.rasant-records.de/downloads/%SUBDIR%/ \
http://moo.glines.org/mixxx/%SUBDIR%/ \
http://web.mit.edu/rryan/www/downloads.mixxx.org/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= A DJ mixing application
LICENSE= GPLv2 # (or later)
LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
id3tag.0:${PORTSDIR}/audio/libid3tag \
mad.2:${PORTSDIR}/audio/libmad \
sndfile.1:${PORTSDIR}/audio/libsndfile \
vorbis.4:${PORTSDIR}/audio/libvorbis \
portaudio.2:${PORTSDIR}/audio/portaudio2
portaudio.2:${PORTSDIR}/audio/portaudio2 \
tag.1:${PORTSDIR}/audio/taglib
OPTIONS= LAME "LAME MP3 audio encoder support" off \
SHOUTCAST "Shoutcast Broadcasting" off \
FAAD "FAAD AAC audio decoder plugin" off \
WAVPACK "WavPack audio support plugin" off
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_QT_VER= 4
QT_COMPONENTS= corelib gui opengl qt3support script svg xml \
linguist_build moc_build qmake_build uic_build \
moc_build rcc_build
QT_COMPONENTS= corelib gui network opengl script sql svg webkit xml \
xmlpatterns linguist_build moc_build qmake_build rcc_build \
uic_build
USE_SCONS= yes
SCONS_BUILDENV= ${SCONS_ENV}
SCONS_ARGS= qtdir="${QT_PREFIX}"
SCONS_ARGS= qtdir="${QT_PREFIX}" optimize=0
MAKE_JOBS_SAFE= yes
CCFLAGS= `pkg-config --cflags portaudio-2.0 \
QtCore QtGui QtOpenGL Qt3Support QtScript QtSvg QtXml`
LINKFLAGS= -L${LOCALBASE}/lib/portaudio2 -L${QT_LIBDIR} \
-Wl,-rpath,${LOCALBASE}/lib/portaudio2 -Wl,-rpath,${QT_LIBDIR} \
${PTHREAD_LIBS}
.include <bsd.port.options.mk>
.if defined(WITH_LAME)
RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
.if defined(WITH_SHOUTCAST)
LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
SCONS_ARGS+= shoutcast=1
.else
SCONS_ARGS+= shoutcast=0
.endif
.if defined(WITH_FAAD)
LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad \
mp4v2.10:${PORTSDIR}/multimedia/mp4v2
SCONS_ARGS+= faad=1
PLIST_SUB+= FAAD=""
.else
SCONS_ARGS+= faad=0
PLIST_SUB+= FAAD="@comment "
.endif
.if defined(WITH_WAVPACK)
LIB_DEPENDS+= wavpack.2:${PORTSDIR}/audio/wavpack
SCONS_ARGS+= wv=1
PLIST_SUB+= WAVPACK=""
.else
SCONS_ARGS+= wv=0
PLIST_SUB+= WAVPACK="@comment "
.endif
post-patch:
.for FILE in build/depends.py src/soundsourceproxy.cpp src/recording/encodermp3.cpp
@${REINPLACE_CMD} -e \
'/pthread/d ; \
/X11R6/d ; \
/-pipe -Wall -W -g/d' ${WRKSRC}/src/SConscript
"s|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${FILE}
.endfor
@${REINPLACE_CMD} -e \
"/('install', docs)/d" ${WRKSRC}/src/SConscript
@${REINPLACE_CMD} -e \
"s|^Exec=.*|Exec=mixxx|" ${WRKSRC}/src/mixxx.desktop
post-install:
@${STRIP_CMD} ${PREFIX}/bin/mixxx
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in Mixxx-Manual.pdf README
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.for FILE in Mixxx-Manual.pdf README
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
.endif

View file

@ -1,2 +1,2 @@
SHA256 (mixxx-1.7.0-src.tar.gz) = e1304935736da032f0395b2d2abce4336f6022b06a06e95cf42be5ec85d917a4
SIZE (mixxx-1.7.0-src.tar.gz) = 8775170
SHA256 (mixxx-1.10.0-src.tar.gz) = 9135f814262bf42eb05bf5d56c760ab462329c06785271d570be6a9d14ab1e97
SIZE (mixxx-1.10.0-src.tar.gz) = 15852338

View file

@ -0,0 +1,120 @@
--- build/depends.py.orig 2012-01-16 06:02:51.000000000 +0900
+++ build/depends.py 2012-01-16 06:04:08.000000000 +0900
@@ -99,7 +99,7 @@
class Qt(Dependence):
DEFAULT_QTDIRS = {'linux': '/usr/share/qt4',
- 'bsd': '/usr/local/lib/qt4',
+ 'bsd': '%%LOCALBASE%%/lib/qt4',
'osx': '/Library/Frameworks',
'windows': 'C:\\qt\\4.6.0'}
@@ -145,6 +145,8 @@
# Setup Qt library includes for non-OSX
if build.platform_is_linux or build.platform_is_bsd:
build.env.Append(LIBS = 'QtXml')
+ build.env.Append(LIBS = 'QtXmlPatterns')
+ build.env.Append(LIBS = 'QtSql')
build.env.Append(LIBS = 'QtGui')
build.env.Append(LIBS = 'QtCore')
build.env.Append(LIBS = 'QtNetwork')
@@ -164,14 +166,14 @@
# Set Qt include paths for non-OSX
if not build.platform_is_osx:
- build.env.Append(CPPPATH=['$QTDIR/include/QtCore',
- '$QTDIR/include/QtGui',
- '$QTDIR/include/QtXml',
- '$QTDIR/include/QtNetwork',
- '$QTDIR/include/QtSql',
- '$QTDIR/include/QtOpenGL',
- '$QTDIR/include/QtWebKit',
- '$QTDIR/include/Qt'])
+ build.env.Append(CPPPATH=['$QTDIR/include/qt4/QtCore',
+ '$QTDIR/include/qt4/QtGui',
+ '$QTDIR/include/qt4/QtXml',
+ '$QTDIR/include/qt4/QtNetwork',
+ '$QTDIR/include/qt4/QtSql',
+ '$QTDIR/include/qt4/QtOpenGL',
+ '$QTDIR/include/qt4/QtWebKit',
+ '$QTDIR/include/qt4/Qt'])
# Set the rpath for linux/bsd/osx.
# This is not support on OS X before the 10.5 SDK.
@@ -179,8 +181,6 @@
compiling_on_104 = False
if build.platform_is_osx:
compiling_on_104 = (os.popen('sw_vers').readlines()[1].find('10.4') >= 0)
- if not build.platform_is_windows and not (using_104_sdk or compiling_on_104):
- build.env.Append(LINKFLAGS = "-Wl,-rpath,$QTDIR/lib")
#QtSQLite DLL
if build.platform_is_windows:
@@ -298,7 +298,7 @@
# the files correctly. Adding this folder ot the include path should fix
# it, though might cause issues. This is safe to remove once we
# deprecate Karmic support. rryan 2/2011
- build.env.Append(CPPPATH='/usr/include/taglib/')
+ build.env.Append(CPPPATH='%%LOCALBASE%%/include/taglib/')
class MixxxCore(Feature):
def description(self):
@@ -623,10 +623,8 @@
if build.toolchain_is_gnu:
# Default GNU Options
# TODO(XXX) always generate debugging info?
- build.env.Append(CCFLAGS = '-pipe')
build.env.Append(CCFLAGS = '-Wall')
build.env.Append(CCFLAGS = '-Wextra')
- build.env.Append(CCFLAGS = '-g')
# Check that g++ is present (yeah, SCONS is a bit dumb here)
if os.system("which g++ > /dev/null"): #Checks for non-zero return code
@@ -676,8 +674,8 @@
elif build.platform_is_osx:
#Stuff you may have compiled by hand
- build.env.Append(LIBPATH = ['/usr/local/lib'])
- build.env.Append(CPPPATH = ['/usr/local/include'])
+ build.env.Append(LIBPATH = ['%%LOCALBASE%%/lib'])
+ build.env.Append(CPPPATH = ['%%LOCALBASE%%/include'])
#Non-standard libpaths for fink and certain (most?) darwin ports
build.env.Append(LIBPATH = ['/sw/lib'])
@@ -689,13 +687,15 @@
elif build.platform_is_bsd:
build.env.Append(CPPDEFINES='__BSD__')
- build.env.Append(CPPPATH=['/usr/include',
- '/usr/local/include',
- '/usr/X11R6/include/'])
- build.env.Append(LIBPATH=['/usr/lib/',
- '/usr/local/lib',
- '/usr/X11R6/lib'])
- build.env.Append(LIBS='pthread')
+ build.env.Append(CPPPATH=['%%LOCALBASE%%/include/portaudio2',
+ '%%LOCALBASE%%/include/qt4',
+ '%%LOCALBASE%%/include'])
+ build.env.Append(LIBPATH=['%%LOCALBASE%%/lib/portaudio2',
+ '%%LOCALBASE%%/lib/qt4',
+ '%%LOCALBASE%%/lib'])
+ build.env.Append(LINKFLAGS=['-Wl,-rpath,%%LOCALBASE%%/lib/portaudio2',
+ '-Wl,-rpath,%%LOCALBASE%%/lib/qt4',
+ '-Wl,-rpath,%%LOCALBASE%%/lib'])
# why do we need to do this on OpenBSD and not on Linux? if we
# don't then CheckLib("vorbisfile") fails
build.env.Append(LIBS=['ogg', 'vorbis'])
@@ -735,11 +735,11 @@
# Say where to find resources on Unix. TODO(XXX) replace this with a
# RESOURCE_PATH that covers Win and OSX too:
if build.platform_is_linux or build.platform_is_bsd:
- share_path = os.path.join(SCons.ARGUMENTS.get('prefix', '/usr/local'), 'share/mixxx')
+ share_path = os.path.join(SCons.ARGUMENTS.get('prefix', '%%PREFIX%%'), 'share/mixxx')
build.env.Append(CPPDEFINES=('UNIX_SHARE_PATH', r'\"%s\"' % share_path))
def depends(self, build):
- return [SoundTouch, KissFFT, ReplayGain, PortAudio, PortMIDI, Qt,
+ return [SoundTouch, KissFFT, ReplayGain, PortAudio, Qt,
FidLib, SndFile, FLAC, OggVorbis, OpenGL, TagLib,]
def post_dependency_check_configure(self, build, conf):

View file

@ -0,0 +1,13 @@
--- build/qt4.py.orig 2011-12-24 11:53:19.000000000 +0900
+++ build/qt4.py 2012-01-16 06:10:09.000000000 +0900
@@ -245,8 +245,8 @@
env.Replace(
# QTDIR = _detect(env),
QT4_BINPATH = os.path.join('$QTDIR', 'bin'),
- QT4_CPPPATH = os.path.join('$QTDIR', 'include'),
- QT4_LIBPATH = os.path.join('$QTDIR', 'lib'),
+ QT4_CPPPATH = os.path.join('$QTDIR', 'include', 'qt4'),
+ QT4_LIBPATH = os.path.join('$QTDIR', 'lib', 'qt4'),
# TODO: This is not reliable to QTDIR value changes but needed in order to support '-qt4' variants
QT4_MOC = locateQt4Command(env,'moc', env['QTDIR']),
QT4_UIC = locateQt4Command(env,'uic', env['QTDIR']),

View file

@ -1,5 +1,5 @@
--- lib/kissfft/kiss_fft.h.orig 2009-08-06 16:11:34.000000000 +0900
+++ lib/kissfft/kiss_fft.h 2009-10-09 01:36:38.000000000 +0900
--- lib/kissfft/kiss_fft.h.orig 2011-12-24 11:53:19.000000000 +0900
+++ lib/kissfft/kiss_fft.h 2012-01-16 06:10:09.000000000 +0900
@@ -5,9 +5,6 @@
#include <stdio.h>
#include <math.h>

View file

@ -0,0 +1,32 @@
--- src/midi/mididevicemanager.cpp.orig 2011-12-24 11:53:19.000000000 +0900
+++ src/midi/mididevicemanager.cpp 2012-01-16 06:08:07.000000000 +0900
@@ -28,7 +28,9 @@
{
m_pConfig = pConfig;
+#ifdef __PORTMIDI__
m_pPMEnumerator = new PortMidiEnumerator();
+#endif
#ifdef __HSS1394__
m_pHSSEnumerator = new Hss1394Enumerator();
#endif
@@ -37,7 +39,9 @@
MidiDeviceManager::~MidiDeviceManager()
{
//Delete enumerators and they'll delete their Devices
+#ifdef __PORTMIDI__
delete m_pPMEnumerator;
+#endif
#ifdef __HSS1394__
delete m_pHSSEnumerator;
#endif
@@ -78,7 +82,9 @@
bool bMatchedCriteria = false; //Whether or not the current device matched the filtering criteria
if (m_devices.empty()) {
+#ifdef __PORTMIDI__
m_devices = m_pPMEnumerator->queryDevices();
+#endif
#ifdef __HSS1394__
m_devices.append(m_pHSSEnumerator->queryDevices());
#endif

View file

@ -0,0 +1,22 @@
--- src/recording/encodermp3.cpp.orig 2011-12-24 11:53:18.000000000 +0900
+++ src/recording/encodermp3.cpp 2012-01-16 06:10:09.000000000 +0900
@@ -85,7 +85,9 @@
*/
QStringList libnames;
QString libname = "";
-#ifdef __LINUX__
+#ifdef __BSD__
+ libnames << "%%LOCALBASE%%/lib/libmp3lame.so";
+#elif __LINUX__
libnames << "/usr/lib/libmp3lame.so.0";
libnames << "/usr/lib/libmp3lame.so";
#elif __WINDOWS__
@@ -109,7 +111,7 @@
props->setType(DLG_WARNING);
props->setTitle(tr("Encoder"));
QString key = "";
-#ifdef __LINUX__
+#if defined(__BSD__) || defined(__LINUX__)
key = tr("<html>Mixxx cannot record or stream in MP3 without the MP3 encoder &quot;lame&quot;. Due to licensing issues, we cannot include this with Mixxx. To record or stream in MP3, you must download <b>libmp3lame</b> and install it on your system. <p>See <a href='http://mixxx.org/wiki/doku.php/internet_broadcasting#linux'>Mixxx Wiki</a> for more information. </html>");
props->setText(key);
#elif __WINDOWS__

View file

@ -0,0 +1,15 @@
--- src/sounddeviceportaudio.cpp.orig 2011-12-24 11:53:20.000000000 +0900
+++ src/sounddeviceportaudio.cpp 2012-01-16 06:10:09.000000000 +0900
@@ -182,10 +182,10 @@
qDebug() << "Opened PortAudio stream successfully... starting";
}
-#ifdef __LINUX__
+#if defined(__BSD__) || defined(__LINUX__)
//Attempt to dynamically load and resolve stuff in the PortAudio library
//in order to enable RT priority with ALSA.
- QLibrary portaudio("libportaudio.so.2");
+ QLibrary portaudio("libportaudio.so");
if (!portaudio.load())
qWarning() << "Failed to dynamically load PortAudio library";
else

View file

@ -0,0 +1,23 @@
--- src/soundmanager.cpp.orig 2011-12-24 11:53:20.000000000 +0900
+++ src/soundmanager.cpp 2012-01-16 06:10:09.000000000 +0900
@@ -309,7 +309,7 @@
#ifdef __PORTAUDIO__
PaError err = paNoError;
if (!m_paInitialized) {
-#ifdef Q_OS_LINUX
+#if defined(__BSD__) || defined(Q_OS_LINUX)
setJACKName();
#endif
err = Pa_Initialize();
@@ -702,9 +702,9 @@
void SoundManager::setJACKName() const {
#ifdef __PORTAUDIO__
-#ifdef Q_OS_LINUX
+#if defined(__BSD__) || defined(Q_OS_LINUX)
typedef PaError (*SetJackClientName)(const char *name);
- QLibrary portaudio("libportaudio.so.2");
+ QLibrary portaudio("libportaudio.so");
if (portaudio.load()) {
SetJackClientName func(
reinterpret_cast<SetJackClientName>(

View file

@ -0,0 +1,11 @@
--- src/soundmanagerconfig.cpp.orig 2011-12-24 11:53:20.000000000 +0900
+++ src/soundmanagerconfig.cpp 2012-01-16 06:10:09.000000000 +0900
@@ -290,7 +290,7 @@
if (flags & SoundManagerConfig::API) {
QList<QString> apiList = soundManager->getHostAPIList();
if (!apiList.isEmpty()) {
-#ifdef __LINUX__
+#if defined(__BSD__) || defined(__LINUX__)
//Check for JACK and use that if it's available, otherwise use ALSA
if (apiList.contains(MIXXX_PORTAUDIO_JACK_STRING)) {
m_api = MIXXX_PORTAUDIO_JACK_STRING;

View file

@ -0,0 +1,18 @@
--- src/soundsourceoggvorbis.cpp.orig 2011-12-24 11:53:20.000000000 +0900
+++ src/soundsourceoggvorbis.cpp 2012-01-16 06:10:09.000000000 +0900
@@ -32,6 +32,15 @@
#endif
#endif
+#ifdef __BSD__
+#include <sys/endian.h>
+#if _BYTE_ORDER == _LITTLE_ENDIAN
+#define OV_ENDIAN_ARG 0
+#else
+#define OV_ENDIAN_ARG 1
+#endif
+#endif
+
#ifdef __LINUX__
#include <endian.h>
#if __BYTE_ORDER == __LITTLE_ENDIAN

View file

@ -0,0 +1,14 @@
--- src/soundsourceproxy.cpp.orig 2011-12-24 11:53:20.000000000 +0900
+++ src/soundsourceproxy.cpp 2012-01-16 06:10:09.000000000 +0900
@@ -80,7 +80,10 @@
qDebug() << "Adding plugin path from commandline arg:" << clArgs.at(pluginPath + 1);
pluginDirs.append(QDir(clArgs.at(pluginPath + 1)));
}
-#ifdef __LINUX__
+#ifdef __BSD__
+ pluginDirs.append(QDir("%%PREFIX%%/lib/mixxx/plugins/soundsource/"));
+ pluginDirs.append(QDir(QDesktopServices::storageLocation(QDesktopServices::HomeLocation) + "/.mixxx/plugins/soundsource/"));
+#elif __LINUX__
pluginDirs.append(QDir("/usr/local/lib/mixxx/plugins/soundsource/"));
pluginDirs.append(QDir("/usr/lib/mixxx/plugins/soundsource/"));
pluginDirs.append(QDir(QDesktopServices::storageLocation(QDesktopServices::HomeLocation) + "/.mixxx/plugins/soundsource/"));

File diff suppressed because it is too large Load diff