- Fix build on 32-bit platforms (temporary quick & dirty fix)

PR:		137028
Submitted by:	Charlie Kester <corky1951@comcast.net>
This commit is contained in:
Pietro Cerutti 2009-07-23 09:51:27 +00:00
parent 7688ca3ba6
commit 49abc368d3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=238236
2 changed files with 32 additions and 1 deletions

View file

@ -21,6 +21,12 @@ GNU_CONFIGURE= yes
MAN1= task.1
MAN5= taskrc.5 task-tutorial.5
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
EXTRA_PATCHES= ${PATCHDIR}/extra-32bit
.endif
post-patch:
${REINPLACE_CMD} -e 's|%%DOCSDIR%%|${DOCSDIR}|; s|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/Makefile.in
@ -28,4 +34,4 @@ post-patch:
${REINPLACE_CMD} -e '341,348d' ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -0,0 +1,25 @@
--- src/Duration.h.orig 2009-07-23 11:41:40.000000000 +0200
+++ src/Duration.h 2009-07-23 11:51:08.000000000 +0200
@@ -40,7 +40,6 @@
bool operator> (const Duration&);
~Duration (); // Destructor
- operator int ();
operator time_t ();
operator std::string ();
--- src/Duration.cpp.orig 2009-07-23 11:41:44.000000000 +0200
+++ src/Duration.cpp 2009-07-23 11:51:28.000000000 +0200
@@ -52,12 +52,6 @@
}
////////////////////////////////////////////////////////////////////////////////
-Duration::operator int ()
-{
- return (int) mDays;
-}
-
-////////////////////////////////////////////////////////////////////////////////
Duration::operator time_t ()
{
return mDays;