JOVE defines a getline function that collides with getline(3).
r419275 tried to fix it by renaming it to get_line, but a few renames were missed leading to crashes when trying to run JOVE. Finish the previous work and also add LICENSE while here. PR: 217516 Submitted by: crahman@gmail.com (based on) Reviewed by: crahman@gmail.com Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9881
This commit is contained in:
parent
2dee12c1fe
commit
49aeb93155
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=435376
5 changed files with 10 additions and 51 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= jove
|
||||
PORTVERSION= 4.16
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/moraes/jove/ \
|
||||
LOCAL/simon
|
||||
|
@ -11,8 +11,17 @@ MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/moraes/jove/ \
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Jonathan's Own Version of Emacs
|
||||
|
||||
LICENSE= JOVE
|
||||
LICENSE_NAME= JOVE License
|
||||
LICENSE_FILE= ${WRKSRC}/README
|
||||
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
USES= ncurses
|
||||
MAKE_ARGS= LIBS="${LDFLAGS} -lncurses"
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
# Fix collisions with getline(3)
|
||||
@${REINPLACE_CMD} 's|[[:<:]]getline[[:>:]]|get_line|g' ${WRKSRC}/*.c ${WRKSRC}/*.h
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -17,15 +17,3 @@
|
|||
#else /* MSFILESYSTEM */
|
||||
tmpfd = open(tfname, O_CREAT|O_EXCL|O_BINARY|O_RDWR, S_IWRITE|S_IREAD);
|
||||
#endif /* MSFILESYSTEM */
|
||||
@@ -1240,9 +1246,9 @@ int Jr_Len; /* length of Just Read Line
|
||||
|
||||
void
|
||||
#ifdef USE_PROTOTYPES
|
||||
-getline proto((daddr addr, register char *buf))
|
||||
+get_line proto((daddr addr, register char *buf))
|
||||
#else
|
||||
-getline(addr, buf)
|
||||
+get_line(addr, buf)
|
||||
daddr addr;
|
||||
register char *buf;
|
||||
#endif
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- io.h.orig 1996-03-07 17:34:42 UTC
|
||||
+++ io.h
|
||||
@@ -37,7 +37,7 @@ extern void
|
||||
close_file proto((File *fp)),
|
||||
d_cache_init proto((void)),
|
||||
file_write proto((char *fname, bool app)),
|
||||
- getline proto((daddr addr,char *buf)),
|
||||
+ get_line proto((daddr addr,char *buf)),
|
||||
lsave proto((void)),
|
||||
putreg proto((File *fp,LinePtr line1,int char1,LinePtr line2,int char2,bool makesure)),
|
||||
read_file proto((char *file, bool is_insert)),
|
|
@ -1,20 +0,0 @@
|
|||
--- recover.c.orig 1996-03-07 17:34:43 UTC
|
||||
+++ recover.c
|
||||
@@ -160,7 +160,7 @@ size_t n;
|
||||
private char *getblock proto((daddr atl));
|
||||
|
||||
void
|
||||
-getline(tl, buf)
|
||||
+get_line(tl, buf)
|
||||
daddr tl;
|
||||
char *buf;
|
||||
{
|
||||
@@ -561,7 +561,7 @@ FILE *out;
|
||||
Nchars = Nlines = 0L;
|
||||
while (--nlines >= 0) {
|
||||
addr = getaddr(ptrs_fp);
|
||||
- getline(addr, buf);
|
||||
+ get_line(addr, buf);
|
||||
Nlines += 1;
|
||||
Nchars += 1 + strlen(buf);
|
||||
fputs(buf, out);
|
|
@ -1,10 +1,3 @@
|
|||
###########################################################################
|
||||
# This program is Copyright (C) 1986, 1987, 1988 by Jonathan Payne. JOVE #
|
||||
# is provided to you without charge, and with no warranty. You may give #
|
||||
# away copies of JOVE, including sources, provided that this notice is #
|
||||
# included in all the files. #
|
||||
###########################################################################
|
||||
|
||||
Jove is a simple text editor in the spirit of GNU emacs, but somewhat
|
||||
smaller and faster to start up.
|
||||
|
||||
|
|
Loading…
Reference in a new issue