Remove expired port finance/emma
This commit is contained in:
parent
ab1f5b5a2a
commit
4a0991ad9d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155562
10 changed files with 1 additions and 181 deletions
1
MOVED
1
MOVED
|
@ -2168,3 +2168,4 @@ www/jakarta-tomcat55|www/tomcat55|2006-02-07|Renamed (no longer a Jakarta projec
|
|||
comms/qtpcr||2006-02-08|Remove expired port
|
||||
www/amyc||2006-02-08|Remove expired port
|
||||
science/glens||2006-02-08|Remove expired port
|
||||
finance/emma||2006-02-09|Remove expired port
|
||||
|
|
|
@ -7,7 +7,6 @@
|
|||
SUBDIR += aqmoney
|
||||
SUBDIR += cbb
|
||||
SUBDIR += ccard
|
||||
SUBDIR += emma
|
||||
SUBDIR += gnofin
|
||||
SUBDIR += gnomepm
|
||||
SUBDIR += gnucash
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
# New ports collection makefile for: emma
|
||||
# Date created: 7 November 2000
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= emma
|
||||
PORTVERSION= 0.8.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= finance gnome python
|
||||
MASTER_SITES= http://rainbow.mimuw.edu.pl/~la181249/emma/packages/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A personal finance manager for Gnome
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/DateTime/DateTime.py:${PORTSDIR}/lang/py-mx-base
|
||||
|
||||
DEPRECATED= mastersite disappeared, no longer maintained by author
|
||||
EXPIRATION_DATE= 2006-01-28
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_PYTHON= yes
|
||||
USE_GNOME= gnomehack gnomelibs gnomeprefix
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_REINPLACE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
pre-configure:
|
||||
@${RM} -f ${WRKSRC}/config.cache
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (emma-0.8.2.tar.gz) = 1ccdcc70f57f256d08b35714e0540e96
|
||||
SHA256 (emma-0.8.2.tar.gz) = 72ae5f47fa64ec1651e9876dc1c585322cee7f8bba19aca08514dbace5f23ac2
|
||||
SIZE (emma-0.8.2.tar.gz) = 649264
|
|
@ -1,11 +0,0 @@
|
|||
--- src/Makefile.in.orig Tue Nov 7 15:25:26 2000
|
||||
+++ src/Makefile.in Tue Nov 7 15:19:32 2000
|
||||
@@ -140,7 +140,7 @@
|
||||
|
||||
|
||||
DEFS = @DEFS@ -I. -I$(srcdir) -I..
|
||||
-CPPFLAGS = @CPPFLAGS@
|
||||
+CPPFLAGS = @CPPFLAGS@ -DPREFIX=\"@prefix@\"
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
emma_OBJECTS = acc_entry.o account_dlg.o actions.o data.o date_entry.o \
|
|
@ -1,20 +0,0 @@
|
|||
--- data/standard.py 2000/11/07 14:27:11 1.1
|
||||
+++ data/standard.py 2000/11/07 14:27:48
|
||||
@@ -48,7 +48,7 @@
|
||||
"Example : CurDay()");
|
||||
|
||||
A = NormalisedTime()
|
||||
-FirstDayOfMonth = time.mktime(A[0], A[1], 1, A[3], A[4], A[5], A[6], A[7], A[8]);
|
||||
+FirstDayOfMonth = time.mktime((A[0], A[1], 1, A[3], A[4], A[5], A[6], A[7], A[8]));
|
||||
|
||||
def CurMonth():
|
||||
return emma.date() >= FirstDayOfMonth
|
||||
@@ -59,7 +59,7 @@
|
||||
"Example : CurMonth()");
|
||||
|
||||
A = NormalisedTime()
|
||||
-FirstDayOfYear = time.mktime(A[0], 1, 1, A[3], A[4], A[5], A[6], A[7], A[8]);
|
||||
+FirstDayOfYear = time.mktime((A[0], 1, 1, A[3], A[4], A[5], A[6], A[7], A[8]));
|
||||
|
||||
def CurYear():
|
||||
return emma.date() >= FirstDayOfYear
|
|
@ -1,20 +0,0 @@
|
|||
--- data/date.py 2000/11/07 14:34:00 1.1
|
||||
+++ data/date.py 2000/11/07 14:36:28
|
||||
@@ -57,7 +57,7 @@
|
||||
return emma.date() >= this.ticks() and emma.date() < next.ticks()
|
||||
|
||||
emma.register_func("MonthExt",\
|
||||
- "Args: numMonths, offset\n\n",\
|
||||
+ "Args: numMonths, offset\n\n"\
|
||||
"Returns True if the transaction happened\n"\
|
||||
"in the next <numMonths> months offset by\n"\
|
||||
"<offset> weeks.\n\n"\
|
||||
@@ -72,7 +72,7 @@
|
||||
return emma.date() >= this.ticks() and emma.date() < next.ticks()
|
||||
|
||||
emma.register_func("YearExt",\
|
||||
- "Args: numYears, offset\n\n",\
|
||||
+ "Args: numYears, offset\n\n"\
|
||||
"Returns True if the transaction happened in\n"\
|
||||
"the next <numYears> year offset by <offset>\n"\
|
||||
"years.\n\n"\
|
|
@ -1,11 +0,0 @@
|
|||
--- data/Makefile.in 2000/11/07 14:57:10 1.1
|
||||
+++ data/Makefile.in 2000/11/07 14:57:34
|
||||
@@ -125,7 +125,7 @@
|
||||
EXTRA_DIST = emma.py
|
||||
|
||||
|
||||
-pkgdata_DATA = $(LIMIT_EXTENSION) $(REPORT_FILTERS)
|
||||
+pkgdata_DATA = $(LIMIT_EXTENSIONS) $(REPORT_FILTERS)
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
||||
CONFIG_CLEAN_FILES =
|
|
@ -1,22 +0,0 @@
|
|||
Emma is an Easy Money Management program for Gnome / Gtk+ similar to
|
||||
X-accountant, Quicken and MsMoney (these are registered trademarks of their
|
||||
respective owners).
|
||||
|
||||
Emma allows you to keep track of your incomes and expenses. You can easily
|
||||
analyse where all your money came from or why your wallet is empty. Using
|
||||
embedded python interface you can extend Emma functions to make it even more
|
||||
useful.
|
||||
|
||||
Features
|
||||
--------
|
||||
o Hierarchical accounts
|
||||
o Double-entry accounting
|
||||
o Scheduled transactions
|
||||
o Sorting of transactions
|
||||
o Easy analysis of accounts through python interface
|
||||
o Graphical charts to make analysis more fun
|
||||
o Extendable through python interface
|
||||
o Special dialog to edit python expressions
|
||||
o Consistent look&feel of Gnome/Gtk+
|
||||
|
||||
WWW: http://rainbow.mimuw.edu.pl/~la181249/emma/home.php
|
|
@ -1,55 +0,0 @@
|
|||
bin/emma
|
||||
share/gnome/apps/Applications/emma.desktop
|
||||
share/gnome/emma/date.py
|
||||
share/gnome/emma/emma.py
|
||||
share/gnome/emma/report_gnuplot.py
|
||||
share/gnome/emma/report_grace.py
|
||||
share/gnome/emma/standard.py
|
||||
share/gnome/help/emma/C/accounts.html
|
||||
share/gnome/help/emma/C/book1.html
|
||||
share/gnome/help/emma/C/c21.html
|
||||
share/gnome/help/emma/C/c26.html
|
||||
share/gnome/help/emma/C/c61.html
|
||||
share/gnome/help/emma/C/docbook.css
|
||||
share/gnome/help/emma/C/files.html
|
||||
share/gnome/help/emma/C/images/acc_axis_dlg.gif
|
||||
share/gnome/help/emma/C/images/accountdlg.gif
|
||||
share/gnome/help/emma/C/images/filedlg.gif
|
||||
share/gnome/help/emma/C/images/grp_axis_dlg.gif
|
||||
share/gnome/help/emma/C/images/newfile.gif
|
||||
share/gnome/help/emma/C/images/transactiondlg.gif
|
||||
share/gnome/help/emma/C/limits.html
|
||||
share/gnome/help/emma/C/ln14.html
|
||||
share/gnome/help/emma/C/reports.html
|
||||
share/gnome/help/emma/C/scheduled-transactions.html
|
||||
share/gnome/help/emma/C/topic.dat
|
||||
share/gnome/help/emma/C/transactions.html
|
||||
share/gnome/help/emma/C/x44.html
|
||||
share/gnome/help/emma/ja/accounts.html
|
||||
share/gnome/help/emma/ja/book1.html
|
||||
share/gnome/help/emma/ja/c21.html
|
||||
share/gnome/help/emma/ja/c26.html
|
||||
share/gnome/help/emma/ja/c58.html
|
||||
share/gnome/help/emma/ja/docbook.css
|
||||
share/gnome/help/emma/ja/files.html
|
||||
share/gnome/help/emma/ja/images/accountdlg.gif
|
||||
share/gnome/help/emma/ja/images/filedlg.gif
|
||||
share/gnome/help/emma/ja/images/newfile.gif
|
||||
share/gnome/help/emma/ja/images/transactiondlg.gif
|
||||
share/gnome/help/emma/ja/limits.html
|
||||
share/gnome/help/emma/ja/ln14.html
|
||||
share/gnome/help/emma/ja/scheduled-transactions.html
|
||||
share/gnome/help/emma/ja/topic.dat
|
||||
share/gnome/help/emma/ja/transactions.html
|
||||
share/gnome/help/emma/ja/x44.html
|
||||
share/locale/de/LC_MESSAGES/emma.mo
|
||||
share/locale/fr/LC_MESSAGES/emma.mo
|
||||
share/locale/ja/LC_MESSAGES/emma.mo
|
||||
share/locale/pl/LC_MESSAGES/emma.mo
|
||||
share/locale/sv/LC_MESSAGES/emma.mo
|
||||
@dirrm share/gnome/help/emma/ja/images
|
||||
@dirrm share/gnome/help/emma/ja
|
||||
@dirrm share/gnome/help/emma/C/images
|
||||
@dirrm share/gnome/help/emma/C
|
||||
@dirrm share/gnome/help/emma
|
||||
@dirrm share/gnome/emma
|
Loading…
Reference in a new issue